データ ソースとして XML ファイルを追加する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

組織に XML ファイルとその他の詳細データを保存します。サイトでこのデータをより使いやすくデータ ソースとして XML ファイルを使用します。Microsoft Office SharePoint Designer 2007で簡単に追加できます接続データ ソース ライブラリに XML ファイルにデータ ソースとして。XML ファイルに接続した後、XML ファイルのデータ ビューを作成してデータのビューを作成できます。データ ビューの詳細については、「データ ビューを作成する」を参照してください。

XML ファイルをデータ ソースとしてサイトに追加する場合、3 とおりの方法があります。この 3 つの方法を次に示します。

  • Office SharePoint Designer 2007の XML ファイルを作成し、Web サイトの一部として保存します。

  • XML ファイルを、ローカル コンピュータやネットワーク上のファイルまたはフォルダからインポートする。

  • 外部のサーバーに置かれた XML ファイルに接続する。

新しい XML ファイルを作成またはインポートすると、対応する接続がデータ ソース ライブラリに自動的に表示されます。データ ソース ライブラリには、サイト内のすべての XML ファイルについて、対応するデータ ソース接続が既定で割り当てられます。

目的に合ったトピックをクリックしてください

XML ファイルを作成します。

コンピューターまたはネットワーク上に置かれた XML ファイルをインポートします。

外部サーバー上に置かれた XML ファイルに接続します。

XML ファイルを作成する

Office SharePoint Designer 2007の XML ファイルを作成して、Web サイトの一部として保存すると、データ ソース ライブラリに自動的に対応するデータ ソース接続が表示されます。

  1. [ファイル] メニューの [新規作成] をクリックします。

  2. [新規作成] ダイアログ ボックスの [ページ] タブで、[全般] をクリックし、[XML] をクリックします。

  3. [OK] をクリックします。

    XML の使用宣言 (<?xml version="1.0" encoding="utf-8">) での新しい XML ファイルは、Web サイトで開きます。

  4. Office SharePoint Designer 2007] では、XML の使用の宣言の後にカーソルを置き、enter キーを押して、XML ファイルを開始するします。XML ファイルを作成した後、以下のことを確認、</xml > 終了タグが含まれています。

  5. [ファイル] メニューの [名前を付けて保存] をクリックします。

  6. [ファイル名] ボックスに XML ファイルの名前を入力し、[保存] をクリックします。

注: 

  • データ ソースとして使用する XML ファイルは、整形式の XML であることが必要です。無効なマークアップが含まれていると、エラーが発生します。

  • さらに、XML ファイルにスキーマが存在していて、そのスキーマに準拠しているか、スキーマを推測できるようなデータが XML ファイルに格納されている必要があります。

ページの先頭へ

ローカル コンピュータまたはネットワーク上の XML ファイルをインポートする

XML ファイルをサイトにインポートすると、対応する接続がデータ ソース ライブラリに自動的に表示されます。

  1. [作業ウィンドウ] メニューの [データ ソース ライブラリ] をクリックします。

  2. [データ ソース ライブラリ] 作業ウィンドウの [XML ファイル] で、[XML ファイルの追加] をクリックします。

    [XML ファイル] という見出しが折りたたんで表示されている場合は、正符号 (+) をクリックして展開します。

  3. [データ ソースのプロパティ] ダイアログ ボックスの [ソース] タブにある [場所] ボックスに、目的の XML ファイルのパスを入力するか、[参照] をクリックして選択します。

    必要な XML ファイルの URL を入力するか、[参照] ボタンをクリックして探す

  4. ファイルをインポートするかどうかを確認するメッセージが表示されたら、[OK] をクリックします。[OK] をもう一度クリックします。

注: 

  • データ ソースとして使用する XML ファイルは、整形式の XML であることが必要です。無効なマークアップが含まれていると、エラーが発生します。

  • さらに、XML ファイルにスキーマが存在していて、そのスキーマに準拠しているか、スキーマを推測できるようなデータが XML ファイルに格納されている必要があります。

ページの先頭へ

外部サーバー上の XML ファイルに接続する

ローカル コンピュータやネットワーク上の XML ファイルをインポートするときとは異なり、外部のサーバーに格納された XML ファイルに接続する場合、サイトに対してファイルをインポートすることはしません。外部の XML ファイルに対し、URL を使って直接リンクを設定します。

  1. [作業ウィンドウ] メニューの [データ ソース ライブラリ] をクリックします。

  2. [データ ソース ライブラリ] 作業ウィンドウの [XML ファイル] で、[XML ファイルの追加] をクリックします。

    [XML ファイル] という見出しが折りたたんで表示されている場合は、正符号 (+) をクリックして展開します。

  3. [データ ソースのプロパティ] ダイアログ ボックスの [ソース] タブにある [場所] ボックスに、目的の XML ファイルの URL を入力するか、[参照] をクリックして選択します。

  4. [OK] をクリックします。

    XML ファイルが、ユーザー名とパスワードを必要とするサイトに置かれている場合、資格情報の入力を求めるメッセージが表示されます。

  5. 現在の Microsoft SharePoint サイトに対する資格情報のほかに、XML ファイルそのもののログオン資格情報が要求される場合もあります。たとえば、ユーザー名とパスワードがないと、プロパティを変更したり、データにアクセスしたりできないことがあります。XML ファイルに対する資格情報が必要な場合は、[ログイン] をクリックして、次のいずれかのオプションをクリックします。

    • 認証しようとしていません。    このオプションは、匿名接続しようとするか、現在のチーム メンバーの資格情報を提供します。XML ファイルがパスワードで保護されていない場合、またはチームのメンバー、保護されたファイルにアクセスするユーザー名とパスワードを使用する必要がある場合は、このオプションを選択します。

    • このユーザー名とデータ接続のパスワードを保存します。    このオプションは、ファイルにアクセスできるように、指定したユーザー名とパスワードを保存します。対応するボックスにユーザー名とパスワードを入力して、既存のパスワード保護を省略する場合は、このオプションを使用します。

    • Windows 認証を使用    このオプションは、現在のチーム メンバーのユーザー名とパスワードを使用します。このオプションは、同じサーバーにWindows SharePoint Services 3.0と XML ファイルがある場合にのみ機能します。

    • シングル サインオン認証を使用する ( Microsoft Office SharePoint Server 2007が必要)    サイトOffice SharePoint Server 2007を使用して、管理者が有効にし、シングル サインオン認証を構成するときに作成されたポータル サイトの一部である場合、このオプションを使用できます。シングル サインオン認証を使用する場合は、このオプションを選択し、[設定] をクリックします。シングル サインオンの設定] ダイアログ ボックスで、次の操作を行います。

      • [アプリケーション名] ボックスに、データベースのアプリケーション名を入力します。

      • [ユーザー名として使用するアプリケーションのフィールド] ボックスに、ユーザー名が格納されているフィールドの名前を入力します。

      • アプリケーションのフィールドで、パスワードを使用する] ボックスで、パスワードが保存されているフィールドの名前を入力します。

        必要な情報がない場合は、サーバー管理者に問い合わせてください。

注: 

  • データ ソースとして使用する XML ファイルは、整形式の XML であることが必要です。無効なマークアップが含まれていると、エラーが発生します。

  • さらに、XML ファイルにスキーマが存在していて、そのスキーマに準拠しているか、スキーマを推測できるようなデータが XML ファイルに格納されている必要があります。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×