データ接続 (インポート) の概要

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

この参照記事では、インポートして、データの接続について説明します。タスクをインポートする、更新、保護するには、Excel 2007 ワークシートのデータの管理などについて学習します。

この記事の内容

外部データ接続を操作します。

データを更新します。

データ ソースからデータをインポートします。

データへのアクセスのセキュリティを強化します。

データへの接続に関する問題

外部データ接続を操作する

ここでは、外部データ接続の動作方法と、接続情報の検索、編集、管理、および接続情報を他のアプリケーションやユーザーと共有する方法について説明します。

ページの先頭へ

データ接続の基本について

Excel ブック内のデータは、2 つの異なる場所から取り込むことができます。データは、ブック内に直接格納されているか、または、テキスト ファイル、データベース、オンライン分析処理 (OLAP) キューブなどの外部データ ソースに格納されています。この外部データ ソースは、データ接続を通じてブックに接続されます。データ接続とは、外部データ ソースを検出、ログイン、およびアクセスする方法を記述する情報のセットです。

外部データに接続する重要な利点は、データのコピーを繰り返すことなく、そのデータを定期的に分析できることです。データのコピーを繰り返すことは、時間がかかり、エラーも発生しやすい作業です。外部データに接続した後、元のデータ ソースに新しい情報が追加されて更新されるたびに、そのデータ ソースから Excel ブックを自動的に更新することもできます。

接続情報はブックに格納されますが、Office データ接続 (ODC) ファイル (.odc) またはデータ ソース名ファイル (.dsn) に格納することもできます。

外部データを Excel に取り込むには、データにアクセスできる必要があります。アクセスする外部データ ソースがローカル コンピュータにない場合は、必要に応じて、データベースの管理者に、パスワードやユーザー アクセス許可などの接続情報を問い合わせます。データ ソースがデータベースの場合は、そのデータベースが排他的モードで開いていないことを確認します。データ ソースがテキスト ファイルまたはスプレッドシートの場合は、他のユーザーが排他的アクセスでそのファイルを開いていないことを確認します。

多くのデータ ソースでは、Excel、接続ファイル、およびデータ ソース間のデータのフローを調整するために、ODBC ドライバまたは OLE DB プロバイダも必要です。

次の図は、データ接続に関する重要なポイントを示しています。

外部データ ソースへの接続

1. Analysis Services、SQL Server、Microsoft Office Access、他の OLAP およびリレーショナル データベース、スプレッドシート、テキスト ファイルなど、接続できるデータ ソースの種類は多岐にわたります。

2. 多くのデータ ソースには、関連する ODBC ドライバまたは OLE DB プロバイダが用意されています。

3. 接続ファイルは、データ ソースにアクセスし、データを取得するために必要なすべての情報を定義します。

4. 接続ファイルの接続情報は、ブックにコピーして編集することができます。

5. ブックにコピーされたデータは、ブックに直接格納されているデータと同じように使用できます。

ページの先頭へ

接続を見つける

接続ファイルを見つけるには、[既存の接続] ダイアログ ボックスを使用します ([データ] タブの [外部データの取り込み] で [既存の接続] をクリック)。このダイアログ ボックスには、次の種類の接続が表示されます。

  • ブックの接続   

    このリストには、ブック内の現在の接続がすべて表示されます。リストは、定義済みの接続、データ接続ウィザードの [データ ソースの選択] ダイアログ ボックスを使って作成した接続、またはこのダイアログ ボックスで以前に接続として選択した接続に基づいて作成されます。

  • お使いのコンピューター上の接続ファイル   

    このリストは、通常は [マイ ドキュメント] フォルダー (Windows XP) または [ドキュメント] フォルダー (Windows Vista) に格納されている [My Data Sources] フォルダーに基づいて作成されます。

  • ネットワーク上の接続ファイル   

    このリストは、次の情報に基づいて作成されます。

    • ローカル ネットワーク上の一連のフォルダ。その位置は、Microsoft Office グループ ポリシーの配置の一部としてネットワーク全体にわたります。

    • Excel ServicesMicrosoft Office SharePoint Server 2007サイト上のデータ接続ライブラリ (DCL)。Dcl の詳細については、 Excel Services に発行を参照してください。

ページの先頭へ

接続プロパティを編集する

Excel を接続ファイル エディタとして使用し、ブックまたは接続ファイルに格納されている外部データ ソースへの接続を作成および編集することもできます。目的の接続が見つからない場合は、[参照] をクリックして [データ ソースの選択] ダイアログ ボックスを表示し、[新しいソース] をクリックしてデータ接続ウィザードを開始することによって、接続を作成できます。

接続を作成したら、[接続のプロパティ] ダイアログ ボックス ([データ] タブの [外部データの取り込み] で [プロパティ] をクリック) を使って、外部データ ソースへの接続の各種設定を管理したり、接続ファイルの使用、再使用、または切り替えを行ったりできます。

接続ファイルを使ってデータ ソースに接続する場合は、接続ファイルから Excel ブックへ接続情報がコピーされます。[接続のプロパティ] ダイアログ ボックスを使って変更を加えると、[定義] タブの [接続ファイル] プロパティに表示されるファイル名で識別される、接続を作成するために使用された元のデータ接続ファイルではなく、現在の Excel ブックに格納されているデータ接続情報が編集されます。接続情報 ([接続名] プロパティと [接続の設定] プロパティを除く) を編集すると、接続ファイルへのリンクは削除され、[接続ファイル] プロパティがクリアされます。

データ ソースを更新するときに接続ファイルが常に使用されるようにするには、[定義] タブの [常にこのファイルを使用してデータを更新する] をオンにします。このチェック ボックスをオンにすると、その接続ファイルを使用するすべてのブックは、接続ファイルに対する更新を常に使用するようになります。ただし、このプロパティが設定されている必要があります。

ページの先頭へ

接続を管理する

[ブックの接続] ダイアログ ボックスを使用すると、接続の作成、編集、削除など、接続を簡単に管理できます ([データ] タブの [接続] で [接続] をクリック)。このダイアログ ボックスでは、次の操作を行います。

  • ブックで使用される接続を作成、編集、更新、および削除します。

  • 外部データの取得先を確認できます (他のユーザーが接続を定義した場合など)。

  • 現在のブック内で各接続が使用されている場所を表示します。

  • 外部データへの接続に関するエラー メッセージを診断します。

  • 接続を別のサーバーまたはデータ ソースにリダイレクトします。または、既存の接続の接続ファイルを置換します。

  • 接続ファイルの作成およびユーザーとの共有を簡単に行います。

ページの先頭へ

接続を共有する

接続ファイルは、一貫した基準での接続の共有、検出可能な状態の実現、セキュリティの向上、およびデータ ソース管理の促進に特に役立ちます。接続ファイルを共有する場合は、ユーザーがファイルを読み取ることはできるが、ファイルを変更できるのは指定されたユーザーに限られるネットワーク フォルダや SharePoint ライブラリなど、安全で信頼できる場所に格納するのが最適です。

ODC ファイルを使用する

Office データ接続 (ODC) ファイル (.odc) を作成するには、[データ ソースの選択] ダイアログ ボックスを使って外部データに接続するか、またはデータ接続ウィザードを使って新しいデータ ソースに接続します。ODC ファイルは、カスタム HTML タグおよび XML タグを使って接続情報を格納しています。ファイルの内容は、Office Excel で簡単に表示および編集できます。

他のユーザーと接続ファイルを共有することで、自分が外部データ ソースに対して所有しているアクセス許可と同じアクセス許可を付与できます。他のユーザーは、接続ファイルを開くためにデータ ソースを設定する必要はありませんが、場合によっては、コンピュータ上で外部データにアクセスするために必要な ODBC ドライバまたは OLE DB プロバイダをインストールする必要があります。

データへの接続およびデータの共有を行う上で、ODC ファイルは推奨される方法です。従来の他の接続ファイル (DSN、UDL、およびクエリ ファイル) は、ODC ファイルに簡単に変換できます。このためには、接続ファイルを開き、[接続のプロパティ] ダイアログ ボックスの [定義] タブの [接続ファイルのエクスポート] をクリックします。

クエリ ファイルを使用する

クエリ ファイルは、データ ソースに関する情報が記録されたテキスト ファイルであり、データベース サーバーの名前や、データ ソースの作成時に指定する接続に関する情報などが記述されています。クエリ ファイルは、クエリを他の Excel ユーザーと共有するための従来の方法です。

クエリ ファイル .dqy を使用する     Microsoft Query を使って、リレーショナル データベースやテキスト ファイルのデータに対するクエリ情報が記述された .dqy ファイルを保存できます。これらのファイルを Microsoft Query で開くと、クエリ内のデータを表示でき、異なるデータを選択して取り出すことができます。作成したクエリの .dqy ファイルを保存するには、クエリ ウィザードを使用するか、または直接 Microsoft Query を使用します。

クエリ ファイル .oqy を使用する     サーバー上またはオフライン キューブ ファイル (.cub) の OLAP データベースのデータに接続するには、.oqy ファイルを作成します。Microsoft Query の Multi-Dimensional Connection ウィザードを使って OLAP データベースまたは OLAP キューブのデータ ソースを作成すると、.oqy ファイルが自動的に作成されます。OLAP データベースはレコードまたはテーブル形式では構成されないので、このデータベースにアクセスするクエリまたは .dqy ファイルを作成することはできません。

クエリ ファイル .rqy を使用する     Excel では、.rqy 形式のクエリ ファイルを開いて OLE DB データ ソース ドライバをサポートできます。詳細については、ドライバのマニュアルを参照してください。

クエリ ファイル .qry を使用する     Microsoft Query では、.qry 形式のクエリ ファイルを開いて保存することで、.dqy ファイルを開くことができない旧バージョンの Microsoft Query で使用できるようにすることができます。.qry 形式のクエリ ファイルを Excel で使用する場合は、Microsoft Query でファイルを開いてから .dqy 形式で保存します。.dqy ファイルの保存の詳細については、Microsoft Query のヘルプを参照してください。

Web クエリ ファイル .iqy を使用する     Excel では、Web クエリ ファイル .iqy を開いて Web からデータを取得できます。

ページの先頭へ

外部データ範囲とプロパティを使用する

外部データ範囲 (クエリ テーブルとも呼ばれる) は、ワークシートに取り込まれるデータの場所を定義する定義名またはテーブル名です。外部データに接続すると、外部データ範囲が自動的に作成されます。データ ソースに接続されたピボットテーブル レポートだけは例外であり、外部データ範囲は作成されません。Excel では、他のデータと同じように、外部データ範囲の書式およびレイアウトを設定したり、計算で使用したりできます。

外部データ範囲の名前は、自動的に次のように設定されます。

  • Office データ接続 (ODC) ファイルからの外部データ範囲には、ファイル名と同じ名前が付けられます。

  • データベースからの外部データ範囲には、クエリの名前を使った名前が付けられます。既定では、Query_from_ソース名が、クエリの作成に使用したデータ ソースの名前になります。

  • テキスト ファイルからの外部データ範囲には、そのテキスト ファイル名を使った名前が付けられます。

  • Web クエリから外部データ範囲は、データの取得元となる Web ページの名前を持つ名前付き。

ワークシートに、同じソースからの外部データ範囲が複数ある場合、それぞれの範囲には番号が付けられます。たとえば、MyText、MyText_1、MyText_2、などになります。

外部データ範囲は、セルの書式や列幅の保持など、データの制御に使用できる追加のプロパティを備えています (接続のプロパティと混同しないでください)。このような外部データ範囲のプロパティを変更するには、[データ] タブの [接続] で [プロパティ] をクリックし、[外部データ範囲のプロパティ] ダイアログ ボックスまたは [外部データのプロパティ] ダイアログ ボックスで変更を加えます。

注: 外部データに基づいた集計やレポートを共有する場合は、外部データ範囲が含まれているブックを他のユーザーに提供するか、レポートのテンプレートを作成します。レポート テンプレートを使用すると、外部データを保存せずに集計やレポートを保存できるので、ファイルのサイズが小さくなります。外部データは、ユーザーがレポート テンプレートを開いたときに取得されます。

ページの先頭へ

Excel および Excel Services のデータ ソース サポートについて

各種のデータ オブジェクト (外部データ範囲やピボットテーブル レポートなど) を使って、さまざまなデータ ソースに接続できます。ただし、接続できるデータ ソースの種類は、データ オブジェクトごとにそれぞれ異なります。Excel Services で接続データを使用したり更新することもできますが、いくつかの制限事項があり、対処には注意が必要です。

Excel データ オブジェクトとデータ ソースのサポート

次の表は、Excel の各データ オブジェクトに対してサポートされるデータ ソースを示します。

サポートされるデータ ソース

Excel
データ
オブジェクト

外部
データ
範囲を
作成する

OLE
DB

ODBC

テキスト
ファイル

HTML
ファイル

XML
ファイル

Share-
Point
リスト

テキスト ファイル ウィザード

はい

いいえ

いいえ

はい

いいえ

いいえ

いいえ

ピボットテーブル レポート
(非 OLAP)

いいえ

はい

はい

はい

いいえ

いいえ

はい

ピボットテーブル レポート
(OLAP)

いいえ

はい

いいえ

いいえ

いいえ

いいえ

いいえ

Excel のテーブル

はい

はい

はい

いいえ

いいえ

はい

はい

XML の対応付け

はい

いいえ

いいえ

いいえ

いいえ

はい

いいえ

Web クエリ

はい

いいえ

いいえ

いいえ

はい

はい

いいえ

データ接続ウィザード

はい

はい

はい

はい

はい

はい

はい

Microsoft Query

はい

いいえ

はい

はい

いいえ

いいえ

いいえ

注: テキスト ファイル ウィザードを使ってインポートしたテキスト ファイル、XML の対応付けを使ってインポートした XML ファイル、および Web クエリを使ってインポートした HTML ファイルや XML ファイルは、データ ソースへの接続を確立するのに、ODBC ドライバまたは OLE DB プロバイダを使用しません。

Excel Services とデータ ソースのサポート

Excel Services で Excel ブックを表示する場合、データに接続し、更新することはできますが、ピボットテーブル レポートを使用する必要があります。Excel Services は、外部データ範囲をサポートしていません。つまり、Excel Services では、データ ソース、Web クエリ、XML の対応付け、または Microsoft Query に接続した Excel のテーブルはサポートされません。

ただし、この制限を回避に接続するデータ ソースと、[デザインとレイアウトのピボット テーブル レベル、グループ、または小計せずに 2 次元をテーブルとして目的のすべての行と列の値が表示されるように、ピボット テーブルを使用して操作できます。詳細については、外部テーブルのデータが Excel Services で利用できるようにするピボット テーブル レポートを使用するを参照してください。

ページの先頭へ

Microsoft Data Access Components について

データ アクセス コンポーネント (MDAC) 2.8 は、Microsoft Windows Server 2003、Windows Vista、Windows XP SP2 と含まれています。MDAC に接続でき、さまざまなリレーショナルとそれ以外のデータ ソースからデータを使用します。開いているデータベース Connectivity (ODBC) ドライバーまたはが組み込まれていると Microsoft 製またはさまざまなサードパーティが開発したOLE DBプロバイダーを使用して、さまざまなデータ ソースに接続することができます。Microsoft Office のインストール時に、その他の ODBC ドライバーと OLE DB プロバイダーは、お使いのコンピューターに追加されます。

コンピュータにインストールされている OLE DB プロバイダの一覧を表示するには、データ リンク ファイルから [データ リンク プロパティ] ダイアログ ボックスを開き、[プロバイダ] タブをクリックします。

コンピュータにインストールされている ODBC ドライバの一覧を表示するには、[ODBC データソース アドミニストレータ] ダイアログ ボックスを表示し、[ドライバ] タブをクリックします。

他のメーカーの ODBC ドライバと OLE DB プロバイダを使って、Microsoft データ ソース以外の、他の種類の ODBC データベースや OLE DB データベースなどのソースから情報を取得することもできます。このような ODBC ドライバや OLE DB プロバイダのインストールの詳細については、データベースのマニュアルを参照するか、データベースのベンダに問い合わせてください。

ページの先頭へ

ODBC を使ってデータ ソースに接続する

ここでは、Open Database Connectivity (ODBC) について詳しく説明します。

ODBC アーキテクチャ

ODBC アーキテクチャでは、アプリケーション (Excel など) が ODBC ドライバ マネージャに接続し、次にこれが固有の ODBC ドライバ (Microsoft SQL ODBC ドライバなど) を使ってデータ ソース (Microsoft SQL Server データベースなど) に接続します。

接続情報を定義する

ODBC データ ソースに接続するには、次の操作を行います。

  1. データ ソースが格納されているコンピュータに適切な ODBC ドライバがインストールされていることを確認します。

  2. [ODBC データ ソース アドミニストレーター] を使用してレジストリまたは DSN ファイルに接続情報を格納するか、Microsoft Visual Basic コードで接続文字列を使用して ODBC ドライバー マネージャーに接続情報を直接渡すことにより、データ ソース名 (DSN) を定義します。

    データ ソースを定義するには、Windows Vista の [スタート] ボタンをクリックし、[コントロール パネル] をクリックします。次に、[システムとメンテナンス] をクリックし、[管理ツール] をクリックします。Windows XP および Windows Server では、[スタート] ボタンをクリックし、[コントロール パネル] をクリックします。次に、[パフォーマンスとメンテナンス] をクリックし、[管理ツール] をクリックして、[データ ソース (ODBC)] をクリックします。他のオプションの詳細については、各ダイアログ ボックスの [ヘルプ] をクリックしてください。

コンピューター データ ソース

コンピューターのデータ ソースは、ユーザー定義の名前で、特定のコンピューターで、レジストリに接続情報を格納します。データ ソースのコンピューターで定義されているコンピューターにのみ使用できます。コンピューターのデータ ソースの 2 種類があります: ユーザーとシステムします。ユーザーのデータ ソースでは、現在のユーザーのみで使用できるし、そのユーザーにのみ表示されます。システムのデータ ソースは、コンピューター上のすべてのユーザーによって利用されるされ、コンピューター上のすべてのユーザーに表示されます。

コンピュータ データ ソースは、ログオンしたユーザーだけが表示でき、リモート ユーザーが別のコンピュータにコピーできないため、セキュリティを強化する場合に特に効果的です。

ファイル データ ソース

ファイル データ ソース (DSN ファイルとも呼ばれます) は、レジストリではなくテキスト ファイルに接続情報を格納し、一般にはコンピューター データ ソースより柔軟に使用できます。たとえば、適切な ODBC ドライバーがインストールされているコンピューターにファイル データ ソースをコピーすることにより、アプリケーションでは、使用するすべてのコンピューターに対して一貫性のある正確な接続情報を使用できます。または、ファイル データ ソースを 1 つのサーバーに配置し、ネットワーク上の複数のコンピューターで共有すると、接続情報を 1 つの場所で簡単に管理できます。

ファイル データ ソースは、共有可能でない場合もあります。共有可能でないファイル データ ソースは 1 台のコンピューター上に配置され、コンピューター データ ソースをポイントします。共有可能でないファイル データ ソースを使って、ファイル データ ソースから既存のコンピューター データ ソースにアクセスできます。

ページの先頭へ

OLE DB を使ってデータ ソースに接続する

ここでは、Object Linking and Embedding Database (OLE DB) について詳しく説明します。

OLE DB アーキテクチャ

OLE DB アーキテクチャでは、データにアクセスするアプリケーションはデータ コンシューマと呼ばれ (Excel など)、データへのネイティブ アクセスを許可するプログラムはデータベース プロバイダと呼ばれます (SQL Server の Microsoft OLE DB プロバイダなど)。

接続情報を定義する

データ コンシューマが、データ ソースの OLE DB プロバイダを通じてデータ ソースにアクセスするときに使用する接続情報は、ユニバーサル データ リンク ファイル (.udl) に格納されています。接続情報を作成するには、次のいずれかの操作を行います。

  • データ接続ウィザードでは、OLE DB プロバイダーのデータのリンクを定義するのにデータ リンク プロパティ] ダイアログ ボックスを使用します。詳細については、データ接続ウィザードを使用してデータのインポートを参照してください。

  • 空白のテキスト ファイルを作成してファイルの種類に .udl を指定し、そのファイルを編集します。[データ リンク プロパティ] ダイアログ ボックスが表示されます。

ページの先頭へ

データを更新する

外部データ ソースに接続すると、更新操作を実行して最新のデータを取得することができます。データを更新するたびに、前回の更新後に加えられた変更をすべて含む最新のデータが表示されます。

次の図は、外部データ ソースに接続しているデータを更新したときに実行される基本的な処理を示しています。

外部データを更新する基本的なプロセス

1. 更新処理によって、最新のデータが取得されます。

2. 接続ファイルには、外部データ ソースにアクセスし、データを取得するために必要なすべての情報が定義されています。

3. 更新できるデータ ソースは、OLAP、SQL Server、Access、OLE DB、ODBC、スプレッドシート、テキスト ファイルなど、多岐にわたります。

4. 最新データは、現在のブックに追加されます。

Excel には、インポートされたデータの更新に関して、ブックを開くときにデータを更新する、一定の間隔でデータを自動的に更新するなど、多くのオプションが用意されています。データの更新中も Excel での作業はそのまま続行でき、データの更新中に更新の状態を確認することもできます。

外部データ ソースが、データにアクセスするためのパスワードを要求する場合は、外部データ範囲が更新されるたびにパスワードを入力するように要求できます。

ページの先頭へ

データ ソースからデータをインポートする

Windows XP、Windows vista の場合、および Microsoft Office は、ODBC ドライバーと次の一般的なデータ ソースからデータを取得するために使用できる OLE DB プロバイダーを指定します。 [Microsoft Office Access、World Wide Web 上の HTML ファイル、テキスト ファイル、Microsoft SQL Server、Microsoft SQL Server Analysis Services、および XML ファイル。Microsoft Query、データ接続ウィザードを使用すると、該当する OLE DB プロバイダーとその他の Excel のワークシート、Microsoft FoxPro、dBASE、Paradox、Oracle、および DB2 などの ODBC ドライバーを持つその他の多くのデータ ソースにもアクセスできます。

ページの先頭へ

Access データベースからデータをインポートする

Microsoft Office Access と Microsoft Office Excel の間でデータを交換するには、いくつかの方法があります。

  • Access から Excel にデータを移動するには、Access データシートからデータをコピーして Excel のワークシートに貼り付ける、Excel ワークシートから Access データベースに接続する、または Access のデータを Excel ワークシートにエクスポートする方法があります。

  • Excel から Access にデータを移動するには、Excel ワークシートからデータをコピーして Access データシートに貼り付ける、Excel ワークシートを Access のテーブルにインポートする、または Access のテーブルから Excel ワークシートにリンクする方法があります。

注: インポートという用語には、Excel と Access で 2 つの異なる意味があります。インポートとは、Excel では更新可能なデータに永続的な接続を行うことを意味します。Access では、Access にデータを 1 回移動し、データ接続は行わないことを意味します。

Excel で Access データを操作する

Excel で Access データを操作することによって、データの分析機能とグラフ化機能、柔軟なデータの配置とレイアウト、または Access では使用できない機能を利用できます。

Excel から Access データに接続する

更新可能な Access データを Excel に取り込むには、Access データベースへの接続を作成し、テーブルまたはクエリからすべてのデータを取得します。たとえば、毎月配布する Excel 総括予算報告を更新して、今月のデータを格納できます。

Access データを Excel にエクスポートする

Access のエクスポート ウィザードを使って、テーブル、クエリ、フォーム、ビュー内の選択レコードなどの Access データベース オブジェクトを、Excel ワークシートにエクスポートできます。エクスポート処理を実行する場合は、今後の使用に備えて詳細情報を保存したり、指定の間隔でエクスポート処理が自動的に実行されるようにスケジュールしたりできます。

Access から Excel にデータをエクスポートする一般的なシナリオを次に示します。

  • 部門またはワークグループでは、Access および Excel の両方を使ってデータを操作している。データは Access データベースに保存しているが、データを分析し、分析結果を配布するために Excel を使用している。現在、チームは必要なときにデータを Excel にエクスポートしているが、この処理をより効率的にしたい。

  • 自分は Access を長期間使用しているが、上司は Excel でレポートを表示することを望んでいる。そのために、定期的にデータを Excel にコピーしているが、この手順を自動化して時間を節約したい。

Access から Excel へのデータのエクスポートの詳細については、Access のヘルプを参照してください。

Access で Excel データを操作する

Excel データを Access データベースで操作することによって、Access のデータ管理、セキュリティ、またはマルチユーザー機能を利用できます。Access には多くの役立つ機能がありますが、Excel データを扱う上で、次の 2 つの機能は特に役立ちます。

  • レポート     Access レポートの設計に精通しており、この種類のレポートで Excel データを集計および設定する場合は、Access レポートを作成します。たとえば、グループ レポート、概要レポート、見出し、グラフ レポートなど、柔軟なレポートを作成できます。

  • フォーム     フォームを使って Excel のデータを検索または表示する場合は、Access フォームを作成します。たとえば、Access フォームを作成して、ワークシート内の列の順序とは異なる順序でフィールドを表示したり、大量のデータ行を 1 画面で簡単に表示したりできます。

Access のフォームとレポートの詳細については、Access のヘルプを参照してください。

Access から Excel データにリンクする

Excel 範囲をテーブルとして Access データベースにリンクできます。この方法は、範囲の更新は Excel で行い、同じ範囲を Access でも使用する場合に使います。 この種類のリンクは、Excel ではなく、Access のデータベース上で作成します。

Excel ワークシートまたは名前付き範囲にリンクすると、元のセルにリンクされた新しいテーブルが作成されます。Excel で元のセルに対して行う変更は、リンクされたテーブルに反映されます。ただし、対応する表の内容を Access で編集することはできません。データを追加、編集、または削除する場合は、元のファイルで変更を行う必要があります。

Access から Excel ワークシートにリンクする一般的なシナリオを次に示します。

  • データは Excel ワークシートで管理し続けたいのですが、Access の強力なクエリ機能、レポート作成機能を利用したいとします。

  • 所属の部署またはワークグループでは Access を使用していますが、操作する外部ソースのデータは Excel ワークシートに含まれています。外部データのコピーを保持するのではなく、これを Access で操作することが望まれます。

Access から Excel へのデータのリンクの詳細については、Access のヘルプを参照してください。

Excel データを Access にインポートする

Access データベースに Excel からデータを保存し、それ以降は Access でデータを使用および維持するには、データをインポートします。データをインポートするときに、Excel のデータを変更することなく、そのデータが新しいテーブルまたは既存のテーブルに保存されます。インポート操作中には、一度に 1 つのワークシートのみをインポートできます。複数のワークシートからデータをインポートするには、各ワークシートでインポート操作を繰り返します。

Excel のデータを Access にインポートする一般的なシナリオを次に示します。

  • 長期間、Excel でデータを管理してきましたが、今後のことを考え、Access でデータを管理することに決めました。新規の Access データベースを 1 つまたは複数作成し、そこに Excel ワークシートのデータを格納したいとします。

  • 所属部署では Access を使用していますが、Excel 形式のデータを受け取ることもあります。その場合、Excel 形式のデータを Access データベースに結合しなければなりません。このような Excel ワークシートを、簡単に Access データベースにインポートできるようにしたいとします。

  • Access を使ってデータを管理しているが、チームから受け取る週報は Excel ブック形式である。このインポート手順を合理化し、毎週特定の時間にデータがデータベースにインポートされるようにしたい。

Excel から Access へのデータのインポートの詳細については、Access のヘルプを参照してください。

ページの先頭へ

Web からデータをインポートする

Web ページには、Excel での解析に最適な情報が含まれていることがあります。たとえば、Web ページにある情報を直接利用して、Excel で株価を解析することができます。必要に応じて、更新可能なデータ (Web ページに掲載された最新データを利用して Excel のデータを更新できる) を取得したり、Web ページからデータを取得して、ワークシート上で静的に保存したりすることができます。

Web クエリを使用して、Web ページ上にある 1 つのテーブルや複数のテーブル、すべてのテキストなど、イントラネットやインターネットに格納されているデータを取得し、Excel に用意されているツールや機能を利用して解析することができます。ボタンをクリックするだけで、データを Web ページに掲載されている最新情報に更新することが可能になります。たとえば、公開された Web ページからは株価情報を、企業の Web ページからは売上一覧を取り出して、データを更新することができます。

新しい Web クエリ] ダイアログ ボックスを使用して Web ページからデータをインポートできます。([データ] タブの [外部データの取り込み] で、 [Web から] をクリックします。)会社のイントラネットや、コンピューターまたはネットワーク上のモデムを通じて World Wide Web へのアクセスをか、またはローカルの HTML または XML ファイルに対するクエリを行うことができます。

ページの先頭へ

テキスト ファイルをインポートする

Excel を使って、テキスト ファイルのデータをワークシートにインポートできます ([データ] タブの [外部データの取り込み] で [テキスト ファイル] をクリック)。テキスト ファイル ウィザードは、インポートしているファイルを調べて、データが予期されたとおりにインポートされたことを確認します。

Excel を使ってテキスト ファイルのデータをインポートするには、2 種類の方法があります。それは、Excel でテキスト ファイルを開く方法 (テキスト ファイルへの接続は作成されない) と、テキスト ファイルを外部データ ソースとしてインポートする方法 (テキスト ファイルへの接続が作成される) です。

一般的に使用されるテキスト ファイルの形式は、次の 2 種類です。

  • 区切りテキスト ファイル (.txt)。通常はタブ文字 (ASCII 文字コード 009) で各テキスト フィールドが区切られています。

  • コンマ区切り (CSV) のテキスト ファイル (.csv)。通常はコンマ (,) で各テキスト フィールドが区切られています。

区切りテキスト ファイルおよび .csv テキスト ファイルで使用される区切り文字は、変更することもできます。この場合、インポート処理またはエクスポート処理が予期されるように動作することを必要に応じて確認します。

ページの先頭へ

Microsoft SQL Server からデータをインポートする

Microsoft SQL Server は、最適なパフォーマンス、可用性、スケーラビリティ、およびセキュリティが要求されるエンタープライズ データ ソリューション用に設計された多機能なリレーショナル データベースです。Excel では、Microsoft SQL Server データベースに簡単に接続できます ([データ] タブの [外部データの取り込み] で [その他のデータ ソース] をクリックし、[SQL Server] をクリック)。

Microsoft SQL Server データベースに接続すると、データ接続ウィザードから次の 3 つのページが表示されます。

  • ページ 1: データベース サーバーへの接続     このページでは、サーバーと、データベース サーバーにログオンする方法を指定します。

  • ページ 2: データベースとテーブルの選択     このページでは、データベースと、テーブルまたはクエリを指定します。

  • ページ 3: データ ファイルと接続の保存     このページでは、接続ファイルと、ファイルを検索するための検索語句を指定および記述します。

ページの先頭へ

Microsoft SQL Server Analysis Services からデータをインポートする

Analysis Services (Microsoft SQL Server のコンポーネント) のビジネス インテリジェンスをサポートしているし、オンライン分析処理 (OLAP) 分析システム、キー業績評価指標 (KPI) のスコアカード、データ マイニング、およびレポート システム ダッシュ ボードの基盤します。Excel では、簡単に接続できますが、OLAP プロバイダーを使用して、Analysis Services OLAP データベース。[データ] タブの [外部データの取り込み] で、その他のソース] をクリックしてなどAnalysis Services] をクリックします。OLAP プロバイダーは、特定の種類の OLAP データベースへのアクセスを提供するソフトウェアのセットです。本ソフトウェアは、データ ソース ドライバーとデータベースに接続する必要があるその他のクライアント ソフトウェアを含めることができます。ピボット テーブル レポートを使用して、OLAP プロバイダーに接続する必要があります。

OLAP データ ソースから切断しているときは、OLAP データもアクセスできます。オフライン キューブ ファイルには、OLAP サーバー データベースからソース データの一部を格納するキューブ拡張子のファイルです。オフライン キューブ ファイルを使用して、サーバーが利用できない場合、またはネットワークから切断しているときに、ピボット テーブルとピボット グラフ レポートに変更を加えるにできます。

Microsoft SQL Server Analysis Services に接続すると、データ接続ウィザードから次の 3 つのページが表示されます。

  • ページ 1: データベース サーバーへの接続     このページでは、サーバーと、データベース サーバーにログオンする方法を指定します。

  • ページ 2: データベースとテーブルの選択     このページでは、データベースとキューブを指定します。

  • ページ 3: データ ファイルと接続の保存     このページでは、接続ファイルと、ファイルを検索するための検索語句を指定および記述します。

ページの先頭へ

XML データをインポートする

Office Excel では、簡単に他のデータベースやアプリケーションから作成された拡張マークアップ言語 (XML) のデータをインポートする、ワークシートのセルに XML スキーマを XML 要素を対応付けるおよび他のデータベースやアプリケーションとのやり取りの変更後の XML データをエクスポートします。Excel で使い慣れたユーザー インターフェイスの XML データ ファイル ジェネレーターに変えるとして、これらの新しい XML 機能のものと考えます。

XML の対応付けを使用すると、Excel ドキュメントに特定のビジネス データを追加したり、Excel ドキュメントから特定のビジネス データを検索し、抽出できます。たとえば、顧客の名前と住所が書かれた納品書や、直前の四半期の財務状況を記したレポートは、静的なレポートではなくなります。データベースとアプリケーションからこの情報を簡単にインポートして変更し、同じデータベースとアプリケーションまたは別のデータベースとアプリケーションに変更後のデータをエクスポートできます。

主な XML のシナリオ

次に、XML 機能を使って対処する主なシナリオを示します。

  • XML 要素を既存のセルに対応付けることによって、既存の Excel テンプレートの機能を拡張する。この方法によって、テンプレートのデザインを最初からやり直すことなく、テンプレートとの間で XML データを簡単にやり取りできます。

  • XML 要素を既存のスプレッドシートに対応付けて、XML データを既存の計算モデルの入力として使用する。

  • 新しいブックに XML データ ファイルをインポートする。

  • Web サービスからの XML データを Excel ワークシートにインポートする。

  • 対応付けられたセル内のデータを、ブック内の他のデータに依存しない XML データ ファイルにエクスポートする。

Excel で XML データを使用する場合の基本の処理

次の図は、Excel で XML を使用する場合の、各種ファイルと処理の関係を示しています。基本的に、この処理は 5 段階に分かれています。

Excel と XML データの連動の概要

コールアウト 1 ブックに XML スキーマ ファイル (.xsd) を追加します。

吹き出し 2 個々 のセルまたは XML に XML スキーマ要素をマップに一覧表示します。

吹き出し 3 XML データ ファイル (.xml) をインポートして、XML 要素をマップされたセルに結合します。

吹き出し 4 データを入力し、マップされたセルを移動し、XML の構造と定義を保持しながら Excel の機能を活用します。

吹き出し 5 マップされたセルから XML データ ファイルに変更されたデータをエクスポートします。

XML データを使用する

XML データ ファイルの内容を、ブック内の既存の XML の対応付けにインポートすると、ファイルのデータが、ブックに格納されている XML の対応付けにバインドされます。つまり、XML データ ファイル内の各データ要素は、XML スキーマ ファイルから対応付けた XML スキーマまたは推定されるスキーマ内の要素に対応します。XML の対応付けはそれぞれ 1 つの XML データ バインドを持ち、XML データのバインドは、1 つの XML の対応付けから作成されたすべての対応付けに適用されます。

[XML の対応付けのプロパティ] ダイアログ ボックス ([開発者用] タブの [XML] で [対応付けのプロパティ] をクリック) の 3 つのオプションは既定ですべてオンになっていますが、これをオンまたはオフにすることで、XML データのバインドの動作を管理できます。

  • インポートまたはエクスポート時にスキーマに対してデータを検証する     Excel がデータのインポート時に XML の対応付けについてデータを検証するかどうかを指定します。インポートする XML データが XML スキーマに準拠することを確認するには、このオプションをオンにします。

  • 既存のデータを新規データで上書きする     データのインポート時にデータを上書きするかどうかを指定します。新しい XML データ ファイルに最新のデータが格納されている場合などのように、現在のデータを新しいデータで置換する場合は、このオプションをオンにします。

  • 既存の XML リストに新規データを追加する     データ ソースの内容が、ワークシートの既存のデータに追加されるかどうかを指定します。たとえば、複数の類似の XML データ ファイルを XML リストにまとめている場合、または、関数が含まれるセルの内容を上書きしたくない場合などは、このオプションをオンにします。

ページの先頭へ

データ接続ウィザードを使ってデータをインポートする

データ接続ウィザードを使って、既に定義されている OLE DB および ODBC 外部データ ソースに接続できます。データ接続ウィザードを開くには、[データ] タブの [外部データの取り込み] で [その他のデータ ソース] をクリックし、[データ接続ウィザード] をクリックします。

データ接続ウィザードの [その他/詳細] データ ソース オプションを選択すると、[データ リンク プロパティ] ダイアログ ボックスに、有効な OLE DB プロバイダの一覧が表示されます。また、ODBC ドライバの Microsoft OLE DB プロバイダを使用すると、ODBC データ ソースにアクセスすることもできます。このダイアログ ボックスの各タブの使用方法については、[データ リンク プロパティ] ダイアログ ボックスの [ヘルプ] をクリックしてください。

通常、[データ リンク プロパティ] ダイアログ ボックスで接続情報を定義するには、次の操作を行います。

  • [プロバイダ] タブをクリックし、OLE DB プロバイダを選択します。次に、[次へ] をクリックして [接続] タブを表示し、その OLE DB プロバイダ固有の接続情報を入力します。

    各 OLE DB プロバイダは、固有の接続情報を定義します。たとえば、SQL Server の Microsoft OLE DB プロバイダでは、サーバー名、サーバーの場所、およびユーザー名が必要です。パスワードや、Microsoft Windows 統合セキュリティを使用するかどうかなどの追加情報を定義することもあります。

  • [詳細設定] タブをクリックして、ネットワーク設定やアクセス許可などの追加情報を指定します。

  • [すべて] タブをクリックして、その OLE DB プロバイダの初期プロパティを定義します。

注: データ接続ウィザードでは、データの抽出や結合はできません。

ページの先頭へ

Microsoft Query を使ってデータをインポートする

Microsoft Query を使ってデータをインポートすることもできます ([データ] タブの [外部データの取り込み] で [その他のデータ ソース] をクリックし、[Microsoft Query] をクリック)。Microsoft Query を使って、データを取得する ODBC データ ソースを設定します。Microsoft Query では、クエリ ウィザードを使って簡単なクエリを作成したり、Query の詳細な検索条件を使って、さらに複雑なクエリを作成したり、次の操作を行ったりできます。

  • Excel に取り込む前にデータの行や列を抽出する

  • パラメーター クエリを作成する

  • Excel に取り込む前にデータを並べ替える

  • 複数のテーブルを結合する

Microsoft Query には、Excel から簡単に利用できるツールが用意されており、これを使ってデータの抽出を行うことができます。

ページの先頭へ

プログラムと関数を使ってデータをインポートする

開発者の場合は、データをインポートするのに Excel のさまざまな方法を利用できます。

  • アプリケーションの Visual Basic を使用するには、外部データ ソースにアクセスできるようにします。データ ソースによってデータを取得するのにには、ActiveX データ オブジェクトまたはデータ アクセス オブジェクトのいずれかを使用できます。接続情報を指定する、コードの接続文字列を定義することもできます。接続文字列を使って役に立ちます、たとえば、システム管理者またはユーザーは、最初に、接続ファイルを作成するのには、またはアプリケーションのインストールをシンプルを必須にしないようにする場合。

  • SQL Server データベースからデータをインポートする場合は、SQL Native Client の使用を検討してください。これは、OLE DB と ODBC の両方で使用される、スタンドアロンのデータアクセス アプリケーション プログラミング インターフェイス (API) です。SQL OLE DB プロバイダと SQL ODBC ドライバが、1 つのネイティブなダイナミック リンク ライブラリ (DLL) に結合されており、Microsoft Data Access Components (MDAC) とは別の新しい機能も提供されています。SQL Native Client を使用すると、複数のアクティブな結果セット (MARS)、ユーザー定義型 (UDT)、XML データ型などの新しい SQL Server 2005 機能を利用する新しいアプリケーションを作成したり、既存のアプリケーションを強化したりできます。

  • RTD 関数は、COM オートメーションに対応するプログラムからリアルタイムのデータを取得します。RTD COM オートメーション アドインの作成し、ローカル コンピューターに登録します。

  • SQL します。要求関数では、外部データ ソースに接続し、ワークシートからクエリを実行します。SQL します。要求は、マクロ プログラミングの必要はありません。 配列として結果を返します。この関数を使用できない場合は、Microsoft Excel の ODBC アドイン プログラム (XLODBC をインストールする必要があります。XLA)。Microsoft Office Online Web サイトからアドインをインストールできます。

Visual Basic for Applications の作成の詳細については、Visual Basic のヘルプを参照してください。

ページの先頭へ

データ アクセスを保護する

外部データに接続する場合、またはデータを更新する場合は、潜在的なセキュリティの問題に留意し、このようなセキュリティの問題の対策を理解しておくことが重要です。データを保護するには、次のガイドラインと方法を使用します。

ページの先頭へ

データ接続を信頼できる場所に格納する

データ接続ファイルには、外部データを更新するときに使用する 1 つまたは複数のクエリが含まれていることがあります。悪意のあるユーザーは、このファイルを置換することによって、機密情報にアクセスしてこれを他のユーザーに配布したり、問題を起こす処理を実行したりするクエリを設計できます。このため、次の条件を確認することが重要です。

  • 接続ファイルは、信頼できる人によって作成されたものである。

  • 接続ファイルはセキュリティで保護されており、信頼できる場所に格納されていたものである。

セキュリティを強化するには、お使いのコンピューターで外部データへの接続を無効にすることがあります。ブックを開いたときに、データに接続するには、セキュリティ センター] バーを使用するか、信頼できる場所にブックを配置してデータ接続がアクティブにする必要があります。詳細については、作成、削除、またはファイルに対して信頼できる場所を変更するには追加、削除、または信頼できる発行元を表示、およびセキュリティ センターのセキュリティ設定を表示するを参照してください。

ページの先頭へ

資格情報を安全に使用する

外部データ ソースにアクセスする場合は、通常、ユーザーの認証に使用される資格情報 (ユーザー名やパスワードなど) が必要です。このような資格情報は安全に提供される必要があり、この資格情報を不用意に他人に教えないように注意してください。

パスワードには、大文字、小文字、数字、記号を組み合わせた複雑なものを使用してください。これらの文字を混在させたものになっていないパスワードは強力とは言えません。たとえば、House27 は Y6dh!et5 に比べ、推測されやすいパスワードと言えます。長さは 8 文字以上にする必要があり、理想は 14 文字以上のパス フレーズです。

パスワードは忘れないようにしてください。パスワードを忘れた場合、マイクロソフトでパスワードを回復することはできません。紙に記録したパスワードを、保護する必要がある情報から離れた安全な場所に保管してください。

データ ソースに接続するときに、ログオン情報を保存しないでください。この情報はブックおよび接続ファイルにテキスト形式で格納されるため、悪意のあるユーザーが情報にアクセスして、データ ソースのセキュリティを侵害できます。

可能な場合は、Windows 認証 (セキュリティ接続とも呼ばれる) を使用します。Windows 認証では、Windows ユーザー アカウントを使って SQL Server に接続します。ユーザーが Windows ユーザー アカウントを通じて接続すると、SQL Server は Windows オペレーティング システム内の情報を使ってアカウント名とパスワードを検証します。Windows 認証を使用するには、サーバー管理者が、この認証モードを使用するように SQL Server を構成する必要があります。Windows 認証を使用できない場合は、ユーザーのログオン情報を保存しないようにします。ユーザーがログオンするたびにログオン情報を入力する方が安全です。

ページの先頭へ

Excel Services に安全に発行する

データ ソースに接続する場合は、[Excel Services の認証の設定] ダイアログ ボックスを使って、Excel Services のデータ ソースにアクセスするときの認証方法を選択できます。次のいずれかのオプションを選択して、データ ソースにログオンできます。

  • Windows 認証     このオプションを選択すると、現在のユーザーの Windows ユーザー名とパスワードが使用されます。安全性は最も高いのですが、ユーザー数が多いとパフォーマンスに影響する場合があります。

  • SSO     シングル サインオンを使用するには、このオプションを選択します。次に、[SSO ID] ボックスに適切な識別文字列を入力します。サイト管理者は SharePoint サイトを構成して、ユーザー名とパスワードが格納されるシングル サインオン データベースを使用するようにできます。この方法は、ユーザー数が多い場合に最も効率的な方法です。

  • なし     ユーザー名とパスワードを接続ファイルに保存するには、このオプションを選択します。

注: この認証設定は Excel Services でのみ使用され、Microsoft Office Excel では使用されません。ブックを Excel または Excel Services のどちらで開いても同じデータにアクセスするようにするには、Excel で同じ認証設定が使用されていることを確認してください。

接続のセキュリティを強化するには、データ接続ライブラリ (DCL) を使用します。DCL は特別な SharePoint ドキュメント ライブラリであり、信頼できる場所のライブラリとして定義され、ODC ファイルを簡単に格納、保護、共有、および管理できます。たとえば、管理者が、テスト サーバーから運用サーバーにデータベースを移動する必要がある、またはデータにアクセスするクエリを更新する必要があるものとします。DCL に保存されている 1 つの ODC ファイルを使用することによって、この接続情報の管理は非常に簡単になり、データへのユーザー アクセスも便利になります。これは、すべてのブックが同じ接続ファイルを使用し、更新処理 (クライアント コンピュータまたはサーバー コンピュータで実行) はその接続ファイルへの最新の変更を取得するためです。Office SharePoint サーバーおよびユーザーのクライアント コンピュータを設定して、接続ファイルへの変更を自動的に検出し、接続ファイルの最新バージョンを使用することもできます。詳細については、Office SharePoint Server 2007 のサーバー管理のヘルプを参照してください。

ページの先頭へ

データ接続に関するトラブルシューティング

ここでは、外部データに接続するときに発生することがあるさまざまな問題について説明します。

ページの先頭へ

トラブルシューティング: データをインポートするときにディスクの空き領域が足りない

外部データに接続するときにディスクの空き領域が足りない場合は、次の操作を検討します。

ディスク領域をチェックし、使用可能な向上    ハード_ディスク上にいくつかの領域を解放するには、[ごみ箱を空にすると、不要なファイルをバックアップして、ハード ディスクから削除するまたは使わない Windows コンポーネントを削除するしてみてください。ハード_ディスクの容量を解放する方法の詳細については、Windows のヘルプを参照してください。

ディスク領域が限られている場合の対策     使用できるハード ディスクの領域が限られている場合は、次の操作を行います。

Microsoft Query     次のいずれかの操作を行います。

  • クエリを単純化    テーブルおよびクエリのために必要なフィールドのみを含めることを確認します。クエリには、不要なテーブルまたはフィールドが含まれている場合、は、一時的なクエリ ファイルのサイズを小さくためにクエリから削除します。

  • 条件を使って結果セットのサイズを小さくする     すべてのレコードではなく、特定のレコードがデータベースから取り出されるように検索条件を設定します。詳細については、Microsoft Query のヘルプを参照してください。

  • クエリで返されるレコードの数を制限する     クエリから返されるレコードの数を制限します。Microsoft Query で、[編集] メニューの [オプション] をクリックし、[ユーザー設定] の [返すレコード数の上限] チェック ボックスをオンにします。次に、[レコード] ボックスに、返されるレコードの最大数を入力します。

データ接続ウィザード     データ接続ウィザードを使ってデータを制限することはできませんが、データ ソースにクエリを定義することによって、データ ソースからのデータを制限できます。データ ソースでクエリを定義できない場合、またはそのアクセス許可が付与されていない場合は、データ管理者に問い合わせてください。

ページの先頭へ

トラブルシューティング: OLAP キューブ ウィザードが見つからない

Jet データベースから OLAP キューブを作成した Microsoft Query の OLAP キューブ ウィザードは、Office Excel には用意されていません。

ページの先頭へ

トラブルシューティング: データ取得サービスが動作しない

Microsoft Office 2003 で導入されたデータ取得サービスでは、ユニバーサル データ接続 (UDC) ファイル (.udcx) を使って Web サービスにアクセスし、さまざまなデータ ソースに対してクエリを実行します。

データ接続ウィザードへようこそ] ページで [データ接続ウィザードでは、 Microsoft Business Solutionsまたはデータ取得サービスのデータ ソース オプションを選択できます。データ取得サービス] オプションでは、次の 2 つのデータ取得サービスを選択することができます: Windows SharePoint Services リストがリストとWindows SharePoint Servicesを実行しているサーバー上のドキュメント ライブラリからデータを取得、およびMicrosoft SQL Serverから Microsoft SQL Server 2000 以降のデータを取得します。

データ接続ウィザードでは UDC 接続ファイルの編集はサポートされなくなりましたが、Excel では引き続き既存のデータ取得サービス接続がサポートされており、このような接続を更新できます。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×