データ接続ウィザードを使用して Office Publisher、Office Visio、または Office Word にデータをインポートする

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Microsoft Office Publisher、Microsoft Office Visio、または Microsoft Office Word の各プログラムでは、さまざまな外部データを使用できます。しかし、データをインポートして保護するにはどうすればよいでしょうか。そのためには、適切な接続を確立することが何よりも重要です。

目的に合ったトピックをクリックしてください

Office データ接続の概要

データへのアクセスを強化します。

作成または Excel を使って Office データ接続ファイルを編集します。

Office Publisher: データ接続ウィザードを使用して外部データをインポートします。

Visio: データ接続ウィザードを使用して外部データをインポートします。

Office Word: データ接続ウィザードを使用して外部データをインポートします。

Office データ接続の概要

ここでは、外部データ接続の動作と、接続情報を他のアプリケーションおよびユーザーと共有する方法について説明します。

データ接続の基本について

プログラムで使用するデータは、テキスト ファイル、ブック、データベースなどの外部データ ソースから取り込むことができます。この外部データ ソースは、データ接続を通じてプログラムに接続されます。データ接続とは、外部データ ソースを検出し、外部データ ソースにログインおよびアクセスする方法を記述した情報のセットです。

外部データに接続する主な利点は、データのコピーを繰り返すことなく、そのデータを定期的に分析できることです。データのコピーを繰り返すことは、時間がかかり、エラーも発生しやすい作業です。

接続情報はブックに格納されますが、Office データ接続 (ODC) ファイル (.odc) またはデータ ソース名 (DSN) ファイル (.dsn) に格納することもできます。

外部データをプログラムに取り込むには、データにアクセスできる必要があります。アクセスする外部データ ソースがローカル コンピュータにない場合は、必要に応じて、パスワードやユーザー権限、その他の接続情報をデータベースの管理者に問い合わせます。データ ソースがデータベースの場合は、そのデータベースが排他モードで開かれていないことを確認します。データ ソースがテキスト ファイルやブックの場合は、そのテキスト ファイルまたはブックが他のユーザーによって排他的に開かれていないことを確認します。

多くのデータ ソースでは、プログラム、接続ファイル、およびデータ ソース間のデータのフローを調整するために、ODBC ドライバまたは OLE DB プロバイダも必要です。

次の図は、データ接続に関する重要なポイントを示しています。

外部データへの接続

1. Microsoft SQL Server、Microsoft Office Access、Microsoft Office Excel、テキスト ファイルなど、接続できるデータ ソースの種類はさまざまです。

2. 各データ ソースには、関連する ODBC ドライバまたは OLE DB プロバイダが用意されています。

3. 接続ファイルは、データ ソースにアクセスし、データを取得するために必要なすべての情報を定義します。

4. 接続ファイルからプログラムに接続情報がコピーされます。

接続を共有する

接続ファイルは、一貫した基準で接続を共有する場合、接続を検出しやすくする場合、セキュリティを強化する場合、およびデータ ソースの管理を容易にする場合に特に役立ちます。接続ファイルを共有する最適な方法は、安全で信頼できる場所に接続ファイルを配置することです。たとえば、ファイルの読み取りは任意のユーザーに許可され、ファイルの変更は指定したユーザーのみに限られているネットワーク フォルダや Microsoft Office SharePoint Designer ライブラリに接続ファイルを配置します。

新しいデータ ソースに接続するには、Excel またはデータ接続ウィザードを使用して Office データ接続 (ODC) ファイル (.odc) を作成します。.odc ファイルでは、カスタム HTML タグおよび XML タグを使用して接続情報が格納されます。ファイルの内容は、Excel で簡単に表示または編集できます。

接続ファイルを他のユーザーと共有すると、自分が外部データ ソースに対して所有しているのと同じアクセス権を他のユーザーに与えることができます。他のユーザーは、接続ファイルを開くためにデータ ソースを設定する必要はありませんが、コンピュータから外部データにアクセスするために必要な ODBC ドライバまたは OLE DB プロバイダをインストールしなければならない場合があります。

Microsoft Data Access Components について

Microsoft Data Access Components (MDAC) 2.8 は、Microsoft Windows Server 2003 および Microsoft Windows XP SP2 以降に付属しています。MDAC を使用すると、さまざまなリレーショナル データ ソースや非リレーショナル データ ソースに接続して、そのデータを使用できます。Open Database Connectivity (ODBC) ドライバまたは OLE DB プロバイダを使用することにより、多くの異なるデータ ソースに接続できます。ODBC ドライバと OLE DB プロバイダは、Microsoft によって組み込まれているものもあれば、さまざまなサード パーティによって開発されているものもあります。Microsoft Office をインストールすると、いくつかの ODBC ドライバと OLE DB プロバイダがコンピュータに追加されます。

コンピュータにインストールされている OLE DB プロバイダの一覧を表示するには、データ リンク ファイルから [データ リンク プロパティ] ダイアログ ボックスを開き、[プロバイダ] タブをクリックします。

コンピュータにインストールされている ODBC ドライバの一覧を表示するには、[ODBC データ ソース アドミニストレータ] ダイアログ ボックスを表示し、[ドライバ] タブをクリックします。

他のメーカーの ODBC ドライバと OLE DB プロバイダを使って、Microsoft データ ソース以外の、他の種類の ODBC データベースや OLE DB データベースなどのソースから情報を取得することもできます。このような ODBC ドライバや OLE DB プロバイダのインストールの詳細については、データベースのマニュアルを参照するか、データベースのベンダに問い合わせてください。

ODBC を使ってデータ ソースに接続する

ここでは、Open Database Connectivity (ODBC) について詳しく説明します。

ODBC アーキテクチャ

ODBC アーキテクチャでは、アプリケーション (使用しているプログラムなど) が ODBC ドライバ マネージャに接続し、次にこれが特定の ODBC ドライバ (Microsoft SQL ODBC ドライバなど) を使用してデータ ソース (Microsoft SQL Server データベースなど) に接続します。

接続情報を定義する

ODBC データ ソースに接続するには、次の操作を行います。

  1. データ ソースが格納されているコンピュータに適切な ODBC ドライバがインストールされていることを確認します。

  2. [ODBC データ ソース アドミニストレータ] を使用して Microsoft Windows レジストリまたは .dsn ファイルに接続情報を格納するか、Microsoft Visual Basic コードで接続文字列を使用して ODBC ドライバ マネージャに接続情報を直接渡すことにより、データ ソース名 (DSN) を定義します。

    データ ソースを定義するには、Microsoft Windows のコントロール パネルを開き、[管理ツール] アイコンをダブルクリックして、[データ ソース (ODBC)] アイコンをダブルクリックします。

    各種のオプションの詳細については、それぞれのダイアログ ボックスで [ヘルプ] をクリックしてください。

コンピュータ データ ソース

コンピュータ データ ソースでは、特定のコンピュータの Windows レジストリに、ユーザー定義名を使用して接続情報が格納されます。コンピュータ データ ソースは、それが定義されているコンピュータ上でのみ使用できます。コンピュータ データ ソースには、ユーザーとシステムの 2 種類があります。ユーザー データ ソースは、現在のユーザーだけが使用でき、そのユーザーに対してのみ表示されます。システム データ ソースは、コンピュータ上のすべてのユーザーが使用でき、コンピュータ上のすべてのユーザーに対して表示されます。コンピュータ データ ソースは、ログオンしたユーザーだけが表示でき、リモート ユーザーが別のコンピュータにコピーすることはできないため、セキュリティを強化する場合に特に効果的です。

ファイル データ ソース

ファイル データ ソース (DSN ファイルとも呼ばれます) は、Windows レジストリではなくテキスト ファイルに接続情報を格納し、一般にはコンピュータ データ ソースより柔軟に使用できます。たとえば、適切な ODBC ドライバがインストールされているコンピュータにファイル データ ソースをコピーすることにより、アプリケーションでは、使用するすべてのコンピュータに対して一貫性のある正確な接続情報を使用できます。または、ファイル データ ソースを 1 つのサーバーに配置し、ネットワーク上の複数のコンピュータで共有すると、接続情報を 1 つの場所で簡単に管理できます。

ファイル データ ソースは、共有不可能にすることもできます。共有不可能なファイル データ ソースは 1 台のコンピュータ上に配置され、コンピュータ データ ソースを参照します。共有不可能なファイル データ ソースを使用すると、ファイル データ ソースから既存のコンピュータ データ ソースにアクセスできます。

OLE DB を使ってデータ ソースに接続する

ここでは、Object Linking and Embedding Database (OLE DB) について詳しく説明します。

OLE DB アーキテクチャ

OLE DB アーキテクチャでは、データにアクセスするアプリケーションはデータ コンシューマと呼ばれ (Publisher など)、データへのネイティブ アクセスを許可するプログラムはデータベース プロバイダと呼ばれます (Microsoft OLE DB Provider for SQL Server など)。

接続情報を定義する

データ コンシューマがデータ ソースの OLE DB プロバイダを通じてデータ ソースにアクセスするときに使用する接続情報は、ユニバーサル データ リンク ファイル (.udl) に格納されます。接続情報を作成するには、次のいずれかの操作を行います。

  • データ接続ウィザードで、[データ リンク プロパティ] ダイアログ ボックスを使用して、OLE DB プロバイダのデータ リンクを定義します。

  • 空白のテキスト ファイルを作成し、ファイルの種類を .udl にして、そのファイルを編集します。この操作により、[データ リンク プロパティ] ダイアログ ボックスが表示されます。

ページの先頭へ

データ アクセスのセキュリティを強化する

外部データに接続する場合、またはデータを更新する場合は、潜在的なセキュリティの問題を認識し、このようなセキュリティの問題への対策を理解しておくことが重要です。データを保護するには、次のガイドラインと方法を使用します。

データ接続を信頼できる場所に格納する

データ接続ファイルには、データ ソースに対する 1 つまたは複数のクエリが含まれていることがあります。悪意のあるユーザーは、このファイルを置き換えることによって、機密情報にアクセスして他のユーザーに配布するクエリや、その他の有害な処理を実行するクエリを作成する可能性があります。このため、次の点を確認することが重要です。

  • 接続ファイルが、信頼できる人によって作成されている。

  • 接続ファイルが安全で、信頼できる場所から入手されている。

セキュリティを強化するために、コンピュータで外部データへの接続が無効にされる場合があります。ブックを開いたときにデータに接続するには、セキュリティ センター バーを使用するか、ブックを信頼できる場所に配置して、データ接続をアクティブ化する必要があります。

詳細については、作成、削除、またはファイルに対して信頼できる場所を変更するには追加、削除、または信頼できる発行元を表示、およびセキュリティ センターのセキュリティ設定を表示するを参照してください。

資格情報を安全に使用する

外部データ ソースへのアクセスには、通常、ユーザーの認証に使用される資格情報 (ユーザー名やパスワードなど) が必要になります。このような資格情報が安全な方法で提供されることを確認し、この資格情報を間違って他人に教えないように注意してください。

パスワードには、大文字、小文字、数字、記号を組み合わせたものを使用してください。これらの文字を混在させていないパスワードのセキュリティは強固ではありません。たとえば、セキュリティ度の高いパスワードとは「Y6dh!et5」で、反対にセキュリティ度の低いパスワードとは「House27」になります。パスワードの長さは 8 文字以上にする必要があり、14 文字以上のパスフレーズになるとさらにセキュリティ強度が高まります。

パスワードは忘れないようにしてください。パスワードを忘れた場合、マイクロソフトでパスワードを回復することはできません。紙に記録したパスワードを、保護する必要がある情報から離れた安全な場所に保管してください。

データ ソースに接続するときは、ログオン情報を保存しないでください。この情報はブックおよび接続ファイルにテキスト形式で格納されるため、悪意のあるユーザーが情報にアクセスして、データ ソースのセキュリティを侵害するおそれがあります。

可能な場合は、Windows 認証 (セキュリティ接続とも呼ばれます) を使用します。Windows 認証では、Windows ユーザー アカウントを使用して SQL Server に接続します。ユーザーが Windows ユーザー アカウントを通じて接続すると、SQL Server は Windows オペレーティング システム内の情報を使用してアカウント名とパスワードを検証します。Windows 認証を使用するには、サーバー管理者が、この認証モードを使用するように SQL Server を構成する必要があります。Windows 認証を使用できない場合は、ユーザーのログオン情報を保存しないようにします。ユーザーがログオンするたびにログオン情報を入力する方が安全です。

ページの先頭へ

Excel を使用して Office データ接続ファイルを作成または編集する

他のユーザーや異なるプログラムとの間で、Office データ接続 (ODC) ファイル (.odc) を共有すると便利な場合があります。.odc ファイルを作成または編集するには、Excel を使用します。

Excel を使用して新しい ODC ファイルを作成する

  1. コンピュータ上の [My Data Sources] フォルダに移動します。

  2. 次のいずれかを実行します。

    • 任意の種類の接続ファイルを作成するには、[+新しいデータ ソースへの接続.odc] ファイルを右クリックし、ショートカット メニューの [Excel で開く] をクリックします。

      Excel が起動します。"Microsoft Office Excel のセキュリティに関する通知" というメッセージが表示される場合は、[有効にする] をクリックします。

      データ接続ウィザードの [データ接続ウィザードへようこそ] ページが表示されます。ウィザードに表示される指示に従って操作します。

    • SQL Server 接続ファイルを作成するには、[+新しい SQL Server 接続.odc] ファイルを右クリックし、ショートカット メニューの [Excel で開く] をクリックします。

      Excel が起動し、データ接続ウィザードの [データベース サーバーに接続] ページが表示されます。

Excel を使用して既存の ODC ファイルを編集する

  1. コンピュータ上の [My Data Sources] フォルダや信頼できるネットワーク フォルダなど、.odc ファイルが格納されているフォルダに移動します。

  2. .odc ファイルを右クリックし、ショートカット メニューの [Excel で開く] をクリックします。

  3. "Microsoft Office Excel のセキュリティに関する通知" というメッセージが表示される場合があります。データ ソースが信頼できる場合は、[有効にする] をクリックします。

    .odc ファイルによって取得されたデータが新しいブックの最初のワークシートに表示され、正しい接続が確立されたことを確認できます。

  4. [データ] タブの [接続] で [接続] をクリックします。

  5. [ブックの接続] ダイアログ ボックスで、接続を選択し、[プロパティ] をクリックします。

  6. [接続のプロパティ] ダイアログ ボックスで、必要な変更を行います。

    接続ファイルの情報を変更する方法の詳細については、Excel のヘルプ システムを参照してください。

  7. すべての変更を指定したら、[定義] タブをクリックし、[接続ファイルのエクスポート] をクリックします。

  8. [名前を付けて保存] ダイアログ ボックスの [保存] をクリックします。

  9. [接続のプロパティ] ダイアログ ボックスと [ブックの接続] ダイアログ ボックスを閉じ、新しいブックを保存せずに Excel を終了します。

ページの先頭へ

Office Publisher: データ接続ウィザードを使用して外部データをインポートする

Microsoft Office Publisher では、差し込み印刷を使用して外部データをインポートします。多数の内容がほぼ同じドキュメントを作成するが、製品のお知らせを上位 100 の顧客に送信するなど、固有の情報を含めるには、差し込み印刷を使用します。接続ファイルを使用しないでテキスト ファイル、Excel ワークシートと Access のテーブルまたはクエリを直接もインポートできます。詳細については、差し込み印刷を作成するを参照してください。

目的に合ったトピックをクリックしてください。

OLE DB プロバイダーを使用してテキスト ファイルをインポートします。

ODBC ドライバーを使用してテキスト ファイルをインポートします。

OLE DB プロバイダーを使用して Excel 97-2003、2007 ブックからデータをインポートします。

ODBC ドライバーを使用して、Excel 97-2003、2007 のブックからデータをインポートします。

OLE DB プロバイダーを使用して Access 2000、2003、または 2007 データベースからデータをインポートします。

ODBC ドライバーを使用して Access 2000、2003、または 2007 データベースからデータをインポートします。

OLE DB プロバイダーを使用して、SQL Server 2000 または 2005年データベースからデータをインポートします。

ODBC ドライバーを使用して、SQL Server 2000 または 2005年データベースからデータをインポートします。

OLE DB プロバイダを使用してテキスト ファイルをインポートする

コンマ区切り値 (CSV) テキスト ファイル (.csv) をインポートするのは簡単です。インポートするテキスト ファイルが、コンピュータで定義されていない区切り記号を使用した .csv ファイルである場合、または .csv ファイル以外のテキスト ファイルである場合は、Schema.ini ファイルを使用して適切なファイル形式を指定できます。

ファイルをインポートする

  1. [ツール] メニューの [宛名/カタログ] をポイントし、[宛名の差し込み]、[電子メールの宛名差し込み]、または [カタログ データの差し込み] をクリックします。

  2. 次のいずれかを実行します。

    • [差し込み印刷] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [電子メールの宛名差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [カタログ データの差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

  3. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  4. [データ接続ウィザードへようこそ] ページで、[その他/詳細] をクリックします。

    [データ リンク プロパティ] ダイアログ ボックスが表示されます。

    さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

  5. [プロバイダ] タブで、[Microsoft Jet 4.0 OLE DB Provider] を選択し、[次へ] をクリックします。

  6. [接続] タブの [データベース名を選択または入力します] ボックスに、テキスト ファイルのあるフォルダへの完全なパスを入力します。

    フォルダを参照するには、ボックスの横の [参照] ボタンをクリックします。

  7. [すべて] タブをクリックし、[Extended Properties] を選択して、[値の編集] をクリックします。

  8. [プロパティの値] ボックスに、次のいずれかの値を入力します。

    • テキスト ファイルに列見出しがある場合は、のテキストを入力します。HDR = はいします。

    • テキスト ファイルには、列見出しがない、のテキストを入力してください。HDR = なしします。

  9. [OK] をクリックします。

  10. 適切な情報を入力したかどうかを確認するには、[接続] タブをクリックし、[接続のテスト] をクリックします。

  11. 次のいずれかを実行します。

    • エラー メッセージが表示された場合は、前の手順で入力した値を再確認します。

    • "接続のテストに成功しました" というメッセージが表示されたら、[OK] をクリックします。

  12. [OK] をクリックします。

    データ接続ウィザードが再び表示されます。

  13. [データベースとテーブルの選択] ページの [名前] 列で、インポートするテキスト ファイルを選択し、[次へ] をクリックします。

  14. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  15. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

Schema.ini ファイルを使用して別の区切り記号またはテキスト ファイル形式を指定する

Schema.ini ファイルは、Windows レジストリの既定のテキスト ドライバの設定を上書きするエントリが記述されたテキスト ファイルです。一般に、Schema.ini ファイルを使用するには、次の操作を行う必要があります。

  • インポートするテキスト ファイルと同じフォルダに Schema.ini ファイルを保存します。

  • Schema.iniファイルの名前を付けます。

  • Schema.ini ファイルの 1 行目に、関連付けるテキスト ファイルの名前を角かっこで囲んで入力します。

  • 別のテキスト ファイル形式を指定するには、追加の情報を入力します。

Schema.ini ファイルの一般的な使用例を以下に示します。

例: 区切り記号としてセミコロン文字 (;) を指定する

[Categories.txt] Format=Delimited(;)

Ex 十分: タブ文字を指定する区切り記号として

[Products.txt] Format=TabDelimited

例: 固定長ファイルを指定する

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

ページの先頭へ セクションの先頭へ

ODBC ドライバを使用してテキスト ファイルをインポートする

ODBC ドライバを使用してテキスト ファイルをインポートするには、少なくとも 2 つの手順を実行する必要があります。最初に、必要に応じて、コンピュータで ODBC テキスト ドライバ用のユーザー DSN を定義します。次に、ユーザー DSN を使用してテキスト ファイルをインポートします。インポートするテキスト ファイルが、コンピュータで定義されていない区切り記号を使用したコンマ区切り値 (CSV) ファイルである場合、または .csv ファイル以外のテキスト ファイルである場合は、Schema.ini ファイルを使用して適切なファイル形式を指定できます。

ユーザー DSN を定義する

  1. コントロール パネルを開き、[管理ツール] アイコンをダブルクリックして、[データ ソース (ODBC)] アイコンをダブルクリックします。

  2. [ODBC データ ソース アドミニストレータ] ダイアログ ボックスで、[ユーザー DSN] タブの [追加] をクリックします。

  3. [データ ソースの新規作成] ダイアログ ボックスで、[Microsoft Text Driver (*.txt; *.csv)] を選択し、[完了] をクリックします。

    [ODBC テキスト セットアップ] ダイアログ ボックスが表示されます。

  4. [データ ソース名] に名前を入力します。

  5. [現在のフォルダを使用する] チェック ボックスをオフにします。

  6. [フォルダの選択] をクリックします。

  7. [フォルダの選択] ダイアログ ボックスで、インポートするテキスト ファイルのあるフォルダに移動します。[ファイル名] ボックスの下の一覧にテキスト ファイルが表示されていることを確認し、[OK] をクリックします。

  8. [OK] をクリックし、もう一度 [OK] をクリックします。

さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

ファイルをインポートする

  1. [ツール] メニューの [宛名/カタログ] をポイントし、[宛名の差し込み]、[電子メールの宛名差し込み]、または [カタログ データの差し込み] をクリックします。

  2. 次のいずれかを実行します。

    • [差し込み印刷] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [電子メールの宛名差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [カタログ データの差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

  3. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  4. [データ接続ウィザードへようこそ] ページで、[ODBC DSN] をクリックします。

  5. [ODBC データ ソースに接続] ページで、先ほど作成したユーザー DSN を選択し、[次へ] をクリックします。

  6. [データベースとテーブルの選択] ページの [名前] 列で、テキスト ファイルを選択し、[次へ] をクリックします。

  7. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  8. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

Schema.ini ファイルを使用して別の区切り記号またはテキスト ファイル形式を指定する

Schema.ini ファイルは、Windows レジストリの既定のテキスト ドライバの設定を上書きするエントリが記述されたテキスト ファイルです。一般に、Schema.ini ファイルを使用するには、次の操作を行う必要があります。

  • インポートするテキスト ファイルと同じフォルダに Schema.ini ファイルを保存します。

  • Schema.iniファイルの名前を付けます。

  • Schema.ini ファイルの 1 行目に、関連付けるテキスト ファイルの名前を角かっこで囲んで入力します。

  • 別のテキスト ファイル形式を指定するには、追加の情報を入力します。

Schema.ini ファイルの一般的な使用例を以下に示します。

例: 列見出しを指定する

[Categories.txt] ColNameHeader=True

例: 区切り記号としてセミコロン文字 (;) を指定する

[Categories.txt] Format=Delimited(;)

例: 区切り記号としてタブ文字を指定する

[Products.txt] Format=TabDelimited

例: 固定長ファイルを指定する

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

ページの先頭へ セクションの先頭へ

OLE DB プロバイダを使用して Excel 97-2003 または 2007 ブックからデータをインポートする

  1. [ツール] メニューの [宛名/カタログ] をポイントし、[宛名の差し込み]、[電子メールの宛名差し込み]、または [カタログ データの差し込み] をクリックします。

  2. 次のいずれかを実行します。

    • [差し込み印刷] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [電子メールの宛名差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [カタログ データの差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

  3. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  4. [データ接続ウィザードへようこそ] ページで、[その他/詳細] をクリックします。

    [データ リンク プロパティ] ダイアログ ボックスが表示されます。

    さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

  5. [プロバイダ] タブで、[Microsoft Office 12.0 Access Database Engine OLE DB Provider] を選択し、[次へ] をクリックします。

  6. [接続] タブの [データ ソース] ボックスに、Excel ブックの完全なパスとファイル名を入力します。

  7. [すべて] タブをクリックし、[Extended Properties] を選択して、[値の編集] をクリックします。

  8. [プロパティの値] ボックスに、次のいずれかの値を入力します。

    • ブック内のデータに列見出しがある場合は、 Excel 8.0; を入力してください。HDR = はいします。

    • ブック内のデータには、列見出しがない場合、は、Excel 8.0;を入力します。HDR = いいえします。

  9. [OK] をクリックします。

  10. 適切な情報を入力したかどうかを確認するには、[接続] タブをクリックし、[接続のテスト] をクリックします。

  11. 次のいずれかを実行します。

    • エラー メッセージが表示された場合は、前の手順で入力した値を再確認します。

    • "接続のテストに成功しました" というメッセージが表示されたら、[OK] をクリックします。

  12. [データベースとテーブルの選択] ページの [名前] 列で、ワークシートを選択し、[次へ] をクリックします。

  13. [OK] をクリックします。

    データ接続ウィザードが再び表示されます。

  14. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  15. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

ページの先頭へ セクションの先頭へ

ODBC ドライバを使用して Excel 97-2003 または 2007 ブックからデータをインポートする

  1. [ツール] メニューの [宛名/カタログ] をポイントし、[宛名の差し込み]、[電子メールの宛名差し込み]、または [カタログ データの差し込み] をクリックします。

  2. 次のいずれかを実行します。

    • [差し込み印刷] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [電子メールの宛名差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [カタログ データの差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

  3. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  4. [データ接続ウィザードへようこそ] ページで、[ODBC DSN] をクリックします。

  5. [ODBC データ ソースに接続] ページで、[Excel Files] を選択し、[次へ] をクリックします。

  6. [ブックの選択] ダイアログ ボックスで、[データベース名] ボックスに Excel ブックのあるフォルダを入力し、一覧でブックを選択して、[OK] をクリックします。

  7. [データベースとテーブルの選択] ページの [名前] 列で、インポートするワークシートを選択し、[次へ] をクリックします。

  8. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  9. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

ページの先頭へ セクションの先頭へ

OLE DB プロバイダを使用して Access 2000、2003、または 2007 データベースからデータをインポートする

  1. [ツール] メニューの [宛名/カタログ] をポイントし、[宛名の差し込み]、[電子メールの宛名差し込み]、または [カタログ データの差し込み] をクリックします。

  2. 次のいずれかを実行します。

    • [差し込み印刷] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [電子メールの宛名差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [カタログ データの差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

  3. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  4. [データ接続ウィザードへようこそ] ページで、[その他/詳細] をクリックします。

    [データ リンク プロパティ] ダイアログ ボックスが表示されます。

    さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

  5. [プロバイダ] タブで、次のいずれかの操作を行います。

    • データベースが Microsoft Access 2000 データベースまたは Microsoft Office Access 2003 データベースである場合は、[Microsoft Jet 4.0 OLE DB Provider] を選択します。

    • データベースが Microsoft Office Access 2007 データベースである場合は、[Microsoft Office 12.0 Access Database Engine OLE DB Provider] を選択します。

  6. [次へ] をクリックします。

  7. [接続] タブの [データベース名を選択または入力します] ボックスに、Access データベースの完全なパスとファイル名を入力します。

    [プロバイダ] タブで [Microsoft Jet 4.0 OLE DB Provider] を選択した場合は、ボックスの横の [参照] ボタンをクリックしてデータベースを指定できます。

  8. 適切な情報を入力したかどうかを確認するには、[接続] タブをクリックし、[接続のテスト] をクリックします。

  9. 次のいずれかを実行します。

    • エラー メッセージが表示された場合は、前の手順で入力した値を再確認します。

    • "接続のテストに成功しました" というメッセージが表示されたら、[OK] をクリックします。

  10. [データベースとテーブルの選択] ページの [名前] 列で、テーブルまたはクエリを選択し、[次へ] をクリックします。

    注: この一覧にはリンク テーブルは表示されません。リンク テーブルをインポートする場合は、インポート操作を実行する前に、Access データベースでリンク テーブルに対するクエリを作成します。

  11. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  12. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

ページの先頭へ セクションの先頭へ

ODBC ドライバを使用して Access 2000、2003、または 2007 データベースからデータをインポートする

  1. [ツール] メニューの [宛名/カタログ] をポイントし、[宛名の差し込み]、[電子メールの宛名差し込み]、または [カタログ データの差し込み] をクリックします。

  2. 次のいずれかを実行します。

    • [差し込み印刷] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [電子メールの宛名差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [カタログ データの差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

  3. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  4. [データ接続ウィザードへようこそ] ページで、[ODBC DSN] をクリックします。

  5. [ODBC データ ソースに接続] ページで、[MS Access Database] を選択し、[次へ] をクリックします。

    [データベースの選択] ダイアログ ボックスが表示されます。

  6. [フォルダの選択] ダイアログ ボックスで、インポートする Access データベースのあるフォルダに移動します。[ファイル名] ボックスの下の一覧に Access データベースが表示されていることを確認し、[OK] をクリックします。

    データ接続ウィザードが再び表示されます。

  7. [データベースとテーブルの選択] ページの [名前] 列で、テーブルまたはクエリを選択し、[次へ] をクリックします。

  8. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  9. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

ページの先頭へ セクションの先頭へ

OLE DB プロバイダを使用して SQL Server 2000 または 2005 データベースからデータをインポートする

  1. [ツール] メニューの [宛名/カタログ] をポイントし、[宛名の差し込み]、[電子メールの宛名差し込み]、または [カタログ データの差し込み] をクリックします。

  2. 次のいずれかを実行します。

    • [差し込み印刷] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [電子メールの宛名差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [カタログ データの差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

  3. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  4. [データ接続ウィザードへようこそ] ページで、[Microsoft SQL Server] をクリックします。

  5. [データベース サーバーに接続] ページで、次の操作を行います。

    • [サーバー名] ボックスにデータベース サーバーの名前を入力します。

      データベースがローカル コンピュータ上にある場合は、「(local)」と入力します。

    • [ログオン時の資格情報] で、次のいずれかの操作を行います。

      • Windows のユーザー名とパスワードを使用するには、[Windows 認証を使用する] をクリックします。

      • データベースのユーザー名とパスワードを使用するには、[以下のユーザー名とパスワードを使用する] をクリックし、適切なボックスにデータベースのユーザー名とパスワードを入力します。

  6. [次へ] をクリックします。

  7. [データベースとテーブルの選択] ページの [データベース] ボックスで、データベースを選択します。次に、[名前] 列でテーブル、ビュー、またはユーザー定義関数を選択し、[次へ] をクリックします。

  8. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  9. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

ページの先頭へ セクションの先頭へ

ODBC ドライバを使用して SQL Server 2000 または 2005 データベースからデータをインポートする

ODBC ドライバを使用して SQL Server データベースからデータをインポートするには、2 つの手順を実行します。最初に、必要に応じて、コンピュータで ODBC ドライバ用のユーザー DSN を定義します。次に、SQL Server データベースからデータをインポートします。

ユーザー DSN を定義する

  1. コントロール パネルを開き、[管理ツール] アイコンをダブルクリックして、[データ ソース (ODBC)] アイコンをダブルクリックします。

  2. [ODBC データ ソース アドミニストレータ] ダイアログ ボックスで、[ユーザー DSN] タブをクリックし、[追加] をクリックします。

  3. [データ ソースの新規作成] ダイアログ ボックスで、[SQL Server] を選択し、[完了] をクリックします。

    [SQL Server に接続するための新規データ ソースを作成する] ダイアログ ボックスが表示されます。

  4. [名前] ボックスにデータ ソース名を入力します。

  5. 必要に応じて、データ ソースの説明を [説明] ボックスに入力します。

  6. [サーバー] ボックスにデータベース サーバー名を入力します。

    データベースがローカル コンピュータ上にある場合は、「(local)」と入力します。

  7. [次へ] をクリックします。

  8. [SQL Server が、ログイン ID の権限の確認を行う方法は?] で、次のいずれかの操作を行います。

    • Windows のユーザー名とパスワードを使用するには、[ネットワークへのログイン ID で、Windows NT の認証メカニズムを使う] をクリックします。

    • データベースのユーザー名とパスワードを使用するには、[ユーザーが入力する SQL Server 用のログイン ID とパスワードを使う] をクリックし、適切なボックスにデータベースのログイン ID とパスワードを入力します。

  9. [次へ] を 2 回クリックし、[完了] をクリックします。

  10. 適切な情報を入力したかどうかを確認するには、[データ ソースのテスト] をクリックします。

  11. 次のいずれかを実行します。

    • エラー メッセージが表示された場合は、前の手順で入力した値を再確認します。

    • "テストは無事に完了しました。" というメッセージが表示されたら、[OK] をクリックします。

  12. [OK] をクリックし、もう一度 [OK] をクリックします。

さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

SQL Server データベースからデータをインポートする

  1. [ツール] メニューの [宛名/カタログ] をポイントし、[宛名の差し込み]、[電子メールの宛名差し込み]、または [カタログ データの差し込み] をクリックします。

  2. 次のいずれかを実行します。

    • [差し込み印刷] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [電子メールの宛名差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

    • [カタログ データの差し込み] 作業ウィンドウで、[アドレス帳の作成、またはアドレス帳に接続] をクリックします。

  3. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  4. [データ接続ウィザードへようこそ] ページで、[ODBC DSN] をクリックします。

  5. [ODBC データ ソースに接続] ページで、前のセクションで定義したデータ ソース名を選択し、[次へ] をクリックします。

  6. [データベースとテーブルの選択] ページの [データベース] ボックスで、データベースを選択します。次に、[名前] 列でテーブル、ビュー、または関数を選択し、[次へ] をクリックします。

  7. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  8. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

ページの先頭へ セクションの先頭へ

ページの先頭へ

Office Visio: データ接続ウィザードを使用して外部データをインポートする

Microsoft Office Visio で図面内の図形を直接追加できるように外部データをインポートします。ダウンタイム統計情報を表示するネットワーク ダイアグラム] または [進行状況バーとプロジェクト タスクを集計するのにメーターが表示されたフローチャートなど、視覚的に情報を監視するのにには、図面を使用します。次の手順では、テキスト ファイル、および SQL Server データ ソース向けです。Excel ワークシート、Access のテーブルまたはクエリをインポートすることもし、SharePoint がファイルに直接接続ファイルを使用せずに一覧表示します。詳細については、 Excel、SQL Server、SharePoint サイト、およびその他の外部ソースからのデータのインポートを参照してください。

目的に合ったトピックをクリックしてください。

OLE DB プロバイダーを使用してテキスト ファイルをインポートします。

ODBC ドライバーを使用してテキスト ファイルをインポートします。

OLE DB プロバイダーを使用して、SQL Server 2000 または 2005年データベースからデータをインポートします。

ODBC ドライバーを使用して、SQL Server 2000 または 2005年データベースからデータをインポートします。

OLE DB プロバイダを使用してテキスト ファイルをインポートする

コンマ区切り値 (CSV) テキスト ファイル (.csv) をインポートするのは簡単です。インポートするテキスト ファイルが、コンピュータで定義されていない区切り記号を使用した .csv ファイルである場合、または .csv ファイル以外のテキスト ファイルである場合は、Schema.ini ファイルを使用して適切なファイル形式を指定できます。

ファイルをインポートする

  1. [データ] メニューの [図形にデータをリンク] をクリックします。

  2. データ選択ウィザードの最初のページで、[他の OLE DB または ODBC データ ソース] をクリックします。

    データ接続ウィザードが表示されます。

  3. [その他/詳細] をクリックします。

    [データ リンク プロパティ] ダイアログ ボックスが表示されます。

    さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

  4. [プロバイダ] タブで、[Microsoft Jet 4.0 OLE DB Provider] を選択し、[次へ] をクリックします。

  5. [接続] タブの [データベース名を選択または入力します] ボックスに、テキスト ファイルのあるフォルダへの完全なパスを入力します。

    フォルダを参照するには、ボックスの横の [参照] ボタンをクリックします。

  6. [すべて] タブをクリックし、[Extended Properties] を選択して、[値の編集] をクリックします。

  7. [プロパティの値] ボックスに、次のいずれかの値を入力します。

    • テキスト ファイルに列見出しがある場合は、のテキストを入力します。HDR = はいします。

    • テキスト ファイルには、列見出しがない、のテキストを入力してください。HDR = なしします。

  8. [OK] をクリックします。

  9. 適切な情報を入力したかどうかを確認するには、[接続] タブをクリックし、[接続のテスト] をクリックします。

  10. 次のいずれかを実行します。

    • エラー メッセージが表示された場合は、前の手順で入力した値を再確認します。

    • "接続のテストに成功しました" というメッセージが表示されたら、[OK] をクリックします。

  11. [OK] をクリックします。

    データ接続ウィザードが再び表示されます。

  12. [データベースとテーブルの選択] ページの [名前] 列で、インポートするテキスト ファイルを選択し、[次へ] をクリックします。

  13. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  14. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

  15. [完了] をクリックします。

    データ選択ウィザードが再び表示されます。

  16. [データ接続の選択] ページで、次のいずれかの操作を行います。

    • 作成した .odc ファイルを使用し、データ ソースのすべての行と列を取り込むには、[完了] をクリックします。

    • 引き続きデータ選択ウィザードを使用して、特定の列と行を選択し、一意の識別子を作成するには、[次へ] をクリックします。

      データ選択ウィザードの各ページの詳細については、F1 キーを押してください。

Schema.ini ファイルを使用して別の区切り記号またはテキスト ファイル形式を指定する

Schema.ini ファイルは、Windows レジストリの既定のテキスト ドライバの設定を上書きするエントリが記述されたテキスト ファイルです。一般に、Schema.ini ファイルを使用するには、次の操作を行う必要があります。

  • インポートするテキスト ファイルと同じフォルダに Schema.ini ファイルを保存します。

  • Schema.iniファイルの名前を付けます。

  • Schema.ini ファイルの 1 行目に、関連付けるテキスト ファイルの名前を角かっこで囲んで入力します。

  • 別のテキスト ファイル形式を指定するには、追加の情報を入力します。

Schema.ini ファイルの一般的な使用例を以下に示します。

例: 区切り記号としてセミコロン文字 (;) を指定する

[Categories.txt] Format=Delimited(;)

例: 区切り記号としてタブ文字を指定する

[Products.txt] Format=TabDelimited

例: 固定長ファイルを指定する

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

ページの先頭へ セクションの先頭へ

ODBC ドライバを使用してテキスト ファイルをインポートする

ODBC ドライバを使用してテキスト ファイルをインポートするには、少なくとも 2 つの手順を実行する必要があります。最初に、必要に応じて、コンピュータで ODBC テキスト ドライバ用のユーザー DSN を定義します。次に、ユーザー DSN を使用してテキスト ファイルをインポートします。インポートするテキスト ファイルが、コンピュータで定義されていない区切り記号を使用したコンマ区切り値 (CSV) ファイルである場合、または .csv ファイル以外のテキスト ファイルである場合は、Schema.ini ファイルを使用して適切なファイル形式を指定できます。

ユーザー DSN を定義する

  1. コントロール パネルを開き、[管理ツール] アイコンをダブルクリックして、[データ ソース (ODBC)] アイコンをダブルクリックします。

  2. [ODBC データ ソース アドミニストレータ] ダイアログ ボックスで、[ユーザー DSN] タブの [追加] をクリックします。

  3. [データ ソースの新規作成] ダイアログ ボックスで、[Microsoft Text Driver (*.txt; *.csv)] を選択し、[完了] をクリックします。

    [ODBC テキスト セットアップ] ダイアログ ボックスが表示されます。

  4. [データ ソース名] に名前を入力します。

  5. [現在のフォルダを使用する] チェック ボックスをオフにします。

  6. [フォルダの選択] をクリックします。

  7. [フォルダの選択] ダイアログ ボックスで、インポートするテキスト ファイルのあるフォルダに移動します。[ファイル名] ボックスの下の一覧にテキスト ファイルが表示されていることを確認し、[OK] をクリックします。

  8. [OK] をクリックし、もう一度 [OK] をクリックします。

さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

ファイルをインポートする

  1. [データ] メニューの [図形にデータをリンク] をクリックします。

  2. データ選択ウィザードの最初のページで、[他の OLE DB または ODBC データ ソース] をクリックします。

    データ接続ウィザードが表示されます。

  3. [データ接続ウィザードへようこそ] ページで、[ODBC DSN] をクリックします。

  4. [ODBC データ ソースに接続] ページで、先ほど作成したユーザー DSN を選択し、[次へ] をクリックします。

  5. [データベースとテーブルの選択] ページの [名前] 列で、テキスト ファイルを選択し、[次へ] をクリックします。

  6. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  7. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

  8. [完了] をクリックします。

    データ選択ウィザードが再び表示されます。

  9. [データ接続の選択] ページで、次のいずれかの操作を行います。

    • 作成した .odc ファイルを使用し、データ ソースのすべての行と列を取り込むには、[完了] をクリックします。

    • 引き続きデータ選択ウィザードを使用して、特定の列と行を選択し、一意の識別子を作成するには、[次へ] をクリックします。

      データ選択ウィザードの各ページの詳細については、F1 キーを押してください。

Schema.ini ファイルを使用して別の区切り記号またはテキスト ファイル形式を指定する

Schema.ini ファイルは、Windows レジストリの既定のテキスト ドライバの設定を上書きするエントリが記述されたテキスト ファイルです。一般に、Schema.ini ファイルを使用するには、次の操作を行う必要があります。

  • インポートするテキスト ファイルと同じフォルダに Schema.ini ファイルを保存します。

  • Schema.iniファイルの名前を付けます。

  • Schema.ini ファイルの 1 行目に、関連付けるテキスト ファイルの名前を角かっこで囲んで入力します。

  • 別のテキスト ファイル形式を指定するには、追加の情報を入力します。

Schema.ini ファイルの一般的な使用例を以下に示します。

例: 列見出しを指定する

[Categories.txt] ColNameHeader=True

例: 区切り記号としてセミコロン文字 (;) を指定する

[Categories.txt] Format=Delimited(;)

例: 区切り記号としてタブ文字を指定する

[Products.txt] Format=TabDelimited

例: 固定長ファイルを指定する

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

ページの先頭へ セクションの先頭へ

OLE DB プロバイダを使用して SQL Server 2000 または 2005 データベースからデータをインポートする

  1. [データ] メニューの [図形にデータをリンク] をクリックします。

  2. データ選択ウィザードの最初のページで、[Microsoft SQL Server 2000 or 2005 database] をクリックします。

    データ接続ウィザードが表示されます。

  3. [データベース サーバーに接続] ページで、次の操作を行います。

    • [サーバー名] ボックスにデータベース サーバーの名前を入力します。

      データベースがローカル コンピュータ上にある場合は、「(local)」と入力します。

    • [ログオン時の資格情報] で、次のいずれかの操作を行います。

      • Windows のユーザー名とパスワードを使用するには、[Windows 認証を使用する] をクリックします。

      • データベースのユーザー名とパスワードを使用するには、[以下のユーザー名とパスワードを使用する] をクリックし、適切なボックスにデータベースのユーザー名とパスワードを入力します。

  4. [次へ] をクリックします。

  5. [データベースとテーブルの選択] ページの [データベース] ボックスで、データベースを選択します。次に、[名前] 列でテーブル、ビュー、またはユーザー定義関数を選択し、[次へ] をクリックします。

  6. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  7. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

  8. [完了] をクリックします。

    データ選択ウィザードが再び表示されます。

  9. [データ接続の選択] ページで、次のいずれかの操作を行います。

    • 作成した .odc ファイルを使用し、データ ソースのすべての行と列を取り込むには、[完了] をクリックします。

    • 引き続きデータ選択ウィザードを使用して、特定の列と行を選択し、一意の識別子を作成するには、[次へ] をクリックします。

      データ選択ウィザードの各ページの詳細については、F1 キーを押してください。

ページの先頭へ セクションの先頭へ

ODBC ドライバを使用して SQL Server 2000 または 2005 データベースからデータをインポートする

ODBC ドライバを使用して SQL Server データベースからデータをインポートするには、2 つの手順を実行します。最初に、必要に応じて、コンピュータで ODBC ドライバ用のユーザー DSN を定義します。次に、SQL Server データベースからデータをインポートします。

ユーザー DSN を定義する

  1. コントロール パネルを開き、[管理ツール] アイコンをダブルクリックして、[データ ソース (ODBC)] アイコンをダブルクリックします。

  2. [ODBC データ ソース アドミニストレータ] ダイアログ ボックスで、[ユーザー DSN] タブをクリックし、[追加] をクリックします。

  3. [データ ソースの新規作成] ダイアログ ボックスで、[SQL Server] を選択し、[完了] をクリックします。

    [SQL Server に接続するための新規データ ソースを作成する] ダイアログ ボックスが表示されます。

  4. [名前] ボックスにデータ ソース名を入力します。

  5. 必要に応じて、データ ソースの説明を [説明] ボックスに入力します。

  6. [サーバー] ボックスにデータベース サーバー名を入力します。

    データベースがローカル コンピュータ上にある場合は、「(local)」と入力します。

  7. [次へ] をクリックします。

  8. [SQL Server が、ログイン ID の権限の確認を行う方法は?] で、次のいずれかの操作を行います。

    • Windows のユーザー名とパスワードを使用するには、[ネットワークへのログイン ID で、Windows NT の認証メカニズムを使う] をクリックします。

    • データベースのユーザー名とパスワードを使用するには、[ユーザーが入力する SQL Server 用のログイン ID とパスワードを使う] をクリックし、適切なボックスにデータベースのログイン ID とパスワードを入力します。

  9. [次へ] を 2 回クリックし、[完了] をクリックします。

  10. 適切な情報を入力したかどうかを確認するには、[データ ソースのテスト] をクリックします。

  11. 次のいずれかを実行します。

    • エラー メッセージが表示された場合は、前の手順で入力した値を再確認します。

    • "テストは無事に完了しました。" というメッセージが表示されたら、[OK] をクリックします。

  12. [OK] をクリックし、もう一度 [OK] をクリックします。

さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

SQL Server データベースからデータをインポートする

  1. [データ] メニューの [図形にデータをリンク] をクリックします。

  2. データ選択ウィザードの最初のページで、[他の OLE DB または ODBC データ ソース] をクリックします。

    データ接続ウィザードが表示されます。

  3. [データ接続ウィザードへようこそ] ページで、[ODBC DSN] をクリックします。

  4. [ODBC データ ソースに接続] ページで、前のセクションで定義したデータ ソース名を選択し、[次へ] をクリックします。

  5. [データベースとテーブルの選択] ページの [データベース] ボックスで、データベースを選択します。次に、[名前] 列でテーブル、ビュー、または関数を選択し、[次へ] をクリックします。

  6. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  7. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

  8. [完了] をクリックします。

    データ選択ウィザードが再び表示されます。

  9. [データ接続の選択] ページで、次のいずれかの操作を行います。

    • 作成した .odc ファイルを使用し、データ ソースのすべての行と列を取り込むには、[完了] をクリックします。

    • 引き続きデータ選択ウィザードを使用して、特定の列と行を選択し、一意の識別子を作成するには、[次へ] をクリックします。

      データ選択ウィザードの各ページの詳細については、F1 キーを押してください。

ページの先頭へ セクションの先頭へ

ページの先頭へ

Office Word: データ接続ウィザードを使用して外部データをインポートする

Microsoft Office Word で差し込み印刷を使用して外部データをインポートします。多数の顧客や休日カードの宛先の宛名ラベルのシートに送信された定型書簡など、ドキュメントのセットを作成するのにには、差し込み印刷を使用します。接続ファイルを使用しないでテキスト ファイル、Excel ワークシートと Access のテーブルまたはクエリを直接もインポートできます。詳細については、差し込み印刷を作成するを参照してください。

目的に合ったトピックをクリックしてください。

OLE DB プロバイダーを使用してテキスト ファイルをインポートします。

ODBC ドライバーを使用してテキスト ファイルをインポートします。

OLE DB プロバイダーを使用して Excel 97-2003、2007 ブックからデータをインポートします。

ODBC ドライバーを使用して、Excel 97-2003、2007 のブックからデータをインポートします。

OLE DB プロバイダーを使用して Access 2000、2003、または 2007 データベースからデータをインポートします。

ODBC ドライバーを使用して Access 2000、2003、または 2007 データベースからデータをインポートします。

OLE DB プロバイダーを使用して、SQL Server 2000 または 2005年データベースからデータをインポートします。

ODBC ドライバーを使用して、SQL Server 2000 または 2005年データベースからデータをインポートします。

OLE DB プロバイダを使用してテキスト ファイルをインポートする

コンマ区切り値 (CSV) テキスト ファイル (.csv) をインポートするのは簡単です。インポートするテキスト ファイルが、コンピュータで定義されていない区切り記号を使用した .csv ファイルである場合、または .csv ファイル以外のテキスト ファイルである場合は、Schema.ini ファイルを使用して適切なファイル形式を指定できます。

ファイルをインポートする

  1. [差し込み文書] タブの [差し込み印刷の開始] で [宛先の選択] をクリックし、[既存のリストを使用] をクリックします。

    Word のリボンの画像

  2. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  3. [データ接続ウィザードへようこそ] ページで、[その他/詳細] をクリックします。

    [データ リンク プロパティ] ダイアログ ボックスが表示されます。

    さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

  4. [プロバイダ] タブで、[Microsoft Jet 4.0 OLE DB Provider] を選択し、[次へ] をクリックします。

  5. [接続] タブの [データベース名を選択または入力します] ボックスに、テキスト ファイルのあるフォルダへの完全なパスを入力します。

    フォルダを参照するには、ボックスの横の [参照] ボタンをクリックします。

  6. [すべて] タブをクリックし、[Extended Properties] を選択して、[値の編集] をクリックします。

  7. [プロパティの値] ボックスに、次のいずれかの値を入力します。

    • テキスト ファイルに列見出しがある場合は、のテキストを入力します。HDR = はいします。

    • テキスト ファイルには、列見出しがない、のテキストを入力してください。HDR = なしします。

  8. [OK] をクリックします。

  9. 適切な情報を入力したかどうかを確認するには、[接続] タブをクリックし、[接続のテスト] をクリックします。

  10. 次のいずれかを実行します。

    • エラー メッセージが表示された場合は、前の手順で入力した値を再確認します。

    • "接続のテストに成功しました" というメッセージが表示されたら、[OK] をクリックします。

  11. [OK] をクリックします。

    データ接続ウィザードが再び表示されます。

  12. [データベースとテーブルの選択] ページの [名前] 列で、インポートするテキスト ファイルを選択し、[次へ] をクリックします。

  13. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  14. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

Schema.ini ファイルを使用して別の区切り記号またはテキスト ファイル形式を指定する

Schema.ini ファイルは、Windows レジストリの既定のテキスト ドライバの設定を上書きするエントリが記述されたテキスト ファイルです。一般に、Schema.ini ファイルを使用するには、次の操作を行う必要があります。

  • インポートするテキスト ファイルと同じフォルダに Schema.ini ファイルを保存します。

  • Schema.iniファイルの名前を付けます。

  • Schema.ini ファイルの 1 行目に、関連付けるテキスト ファイルの名前を角かっこで囲んで入力します。

  • 別のテキスト ファイル形式を指定するには、追加の情報を入力します。

Schema.ini ファイルの一般的な使用例を以下に示します。

例: 区切り記号としてセミコロン文字 (;) を指定する

[Categories.txt] Format=Delimited(;)

例: 区切り記号としてタブ文字を指定する

[Products.txt] Format=TabDelimited

例: 固定長ファイルを指定する

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

ページの先頭へ セクションの先頭へ

ODBC ドライバを使用してテキスト ファイルをインポートする

ODBC ドライバを使用してテキスト ファイルをインポートするには、少なくとも 2 つの手順を実行する必要があります。最初に、必要に応じて、コンピュータで ODBC テキスト ドライバ用のユーザー DSN を定義します。次に、ユーザー DSN を使用してテキスト ファイルをインポートします。インポートするテキスト ファイルが、コンピュータで定義されていない区切り記号を使用したコンマ区切り値 (CSV) ファイルである場合、または .csv ファイル以外のテキスト ファイルである場合は、Schema.ini ファイルを使用して適切なファイル形式を指定できます。

ユーザー DSN を定義する

  1. コントロール パネルを開き、[管理ツール] アイコンをダブルクリックして、[データ ソース (ODBC)] アイコンをダブルクリックします。

  2. [ODBC データ ソース アドミニストレータ] ダイアログ ボックスで、[ユーザー DSN] タブの [追加] をクリックします。

  3. [データ ソースの新規作成] ダイアログ ボックスで、[Microsoft Text Driver (*.txt; *.csv)] を選択し、[完了] をクリックします。

    [ODBC テキスト セットアップ] ダイアログ ボックスが表示されます。

  4. [データ ソース名] に名前を入力します。

  5. [現在のフォルダを使用する] チェック ボックスをオフにします。

  6. [フォルダの選択] をクリックします。

  7. [フォルダの選択] ダイアログ ボックスで、インポートするテキスト ファイルのあるフォルダに移動します。[ファイル名] ボックスの下の一覧にテキスト ファイルが表示されていることを確認し、[OK] をクリックします。

  8. [OK] をクリックし、もう一度 [OK] をクリックします。

さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

ファイルをインポートする

  1. [差し込み文書] タブの [差し込み印刷の開始] で [宛先の選択] をクリックし、[既存のリストを使用] をクリックします。

    Word のリボンの画像

  2. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  3. [データ接続ウィザードへようこそ] ページで、[ODBC DSN] をクリックします。

  4. [ODBC データ ソースに接続] ページで、先ほど作成したユーザー DSN を選択し、[次へ] をクリックします。

  5. [データベースとテーブルの選択] ページの [名前] 列で、テキスト ファイルを選択し、[次へ] をクリックします。

  6. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  7. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

Schema.ini ファイルを使用して別の区切り記号またはテキスト ファイル形式を指定する

Schema.ini ファイルは、Windows レジストリの既定のテキスト ドライバの設定を上書きするエントリが記述されたテキスト ファイルです。一般に、Schema.ini ファイルを使用するには、次の操作を行う必要があります。

  • インポートするテキスト ファイルと同じフォルダに Schema.ini ファイルを保存します。

  • ファイルに Schema.ini という名前を付けます。

  • Schema.ini ファイルの 1 行目に、関連付けるテキスト ファイルの名前を角かっこで囲んで入力します。

  • 別のテキスト ファイル形式を指定するには、追加の情報を入力します。

Schema.ini ファイルの一般的な使用例を以下に示します。

例: 列見出しを指定する

[Categories.txt] ColNameHeader=True

例: セミコロンを指定する 文字 (;) の区切り記号として

[Categories.txt] Format=Delimited(;)

例: 区切り記号としてタブ文字を指定する

[Products.txt] Format=TabDelimited

例: 固定長ファイルを指定する

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

ページの先頭へ セクションの先頭へ

OLE DB プロバイダを使用して Excel 97-2003 または 2007 ブックからデータをインポートする

  1. [差し込み文書] タブの [差し込み印刷の開始] で [宛先の選択] をクリックし、[既存のリストを使用] をクリックします。

    Word のリボンの画像

  2. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  3. [データ接続ウィザードへようこそ] ページで、[その他/詳細] をクリックします。

    [データ リンク プロパティ] ダイアログ ボックスが表示されます。

    さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

  4. [プロバイダ] タブで、[Microsoft Office 12.0 Access Database Engine OLE DB Provider] を選択し、[次へ] をクリックします。

  5. [接続] タブの [データ ソース] ボックスに、Excel ブックの完全なパスとファイル名を入力します。

  6. [すべて] タブをクリックし、[Extended Properties] を選択して、[値の編集] をクリックします。

  7. [プロパティの値] ボックスに、次のいずれかの値を入力します。

    • ブック内のデータに列見出しがある場合は、 Excel 8.0; を入力してください。HDR = はいします。

    • ブック内のデータには、列見出しがない場合、は、Excel 8.0;を入力します。HDR = なしします。

  8. [OK] をクリックします。

  9. 適切な情報を入力したかどうかを確認するには、[接続] タブをクリックし、[接続のテスト] をクリックします。

  10. 次のいずれかを実行します。

    • エラー メッセージが表示された場合は、前の手順で入力した値を再確認します。

    • "接続のテストに成功しました" というメッセージが表示されたら、[OK] をクリックします。

  11. [データベースとテーブルの選択] ページの [名前] 列で、ワークシートを選択し、[次へ] をクリックします。

  12. [OK] をクリックします。

    データ接続ウィザードが再び表示されます。

  13. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  14. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

ページの先頭へ セクションの先頭へ

ODBC ドライバを使用して Excel 97-2003 または 2007 ブックからデータをインポートする

  1. [差し込み文書] タブの [差し込み印刷の開始] で [宛先の選択] をクリックし、[既存のリストを使用] をクリックします。

    Word のリボンの画像

  2. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  3. [データ接続ウィザードへようこそ] ページで、[ODBC DSN] をクリックします。

  4. [ODBC データ ソースに接続] ページで、[Excel Files] を選択し、[次へ] をクリックします。

  5. [ブックの選択] ダイアログ ボックスで、[データベース名] ボックスに Excel ブックのあるフォルダを入力し、一覧でブックを選択して、[OK] をクリックします。

  6. [データベースとテーブルの選択] ページの [名前] 列で、インポートするワークシートを選択し、[次へ] をクリックします。

  7. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  8. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

ページの先頭へ セクションの先頭へ

OLE DB プロバイダを使用して Access 2000、2003、または 2007 データベースからデータをインポートする

  1. [差し込み文書] タブの [差し込み印刷の開始] で [宛先の選択] をクリックし、[既存のリストを使用] をクリックします。

    Word のリボンの画像

  2. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  3. [データ接続ウィザードへようこそ] ページで、[その他/詳細] をクリックします。

    [データ リンク プロパティ] ダイアログ ボックスが表示されます。

    さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

  4. [プロバイダ] タブで、次のいずれかの操作を行います。

    • データベースが Access 2000 データベースまたは Access 2003 データベースである場合は、[Microsoft Jet 4.0 OLE DB Provider] を選択します。

    • データベースが Office Access 2007 データベースである場合は、[Microsoft Office 12.0 Access Database Engine OLE DB Provider] を選択します。

  5. [次へ] をクリックします。

  6. [接続] タブの [データベース名を選択または入力します] ボックスに、Access データベースの完全なパスとファイル名を入力します。

    [プロバイダ] タブで [Microsoft Jet 4.0 OLE DB Provider] を選択した場合は、ボックスの横の [参照] ボタンをクリックしてデータベースを指定できます。

  7. 適切な情報を入力したかどうかを確認するには、[接続] タブをクリックし、[接続のテスト] をクリックします。

  8. 次のいずれかを実行します。

    • エラー メッセージが表示された場合は、前の手順で入力した値を再確認します。

    • "接続のテストに成功しました" というメッセージが表示されたら、[OK] をクリックします。

  9. [データベースとテーブルの選択] ページの [名前] 列で、テーブルまたはクエリを選択し、[次へ] をクリックします。

    注: この一覧にはリンク テーブルは表示されません。リンク テーブルをインポートする場合は、インポート操作を実行する前に、Access データベースでリンク テーブルに対するクエリを作成します。

  10. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  11. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

ページの先頭へ セクションの先頭へ

ODBC ドライバを使用して Access 2000、2003、または 2007 データベースからデータをインポートする

  1. [差し込み文書] タブの [差し込み印刷の開始] で [宛先の選択] をクリックし、[既存のリストを使用] をクリックします。

    Word のリボンの画像

  2. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  3. [データ接続ウィザードへようこそ] ページで、[ODBC DSN] をクリックします。

  4. [ODBC データ ソースに接続] ページで、[MS Access Database] を選択し、[次へ] をクリックします。

    [データベースの選択] ダイアログ ボックスが表示されます。

  5. [フォルダの選択] ダイアログ ボックスで、インポートする Access データベースのあるフォルダに移動します。[ファイル名] ボックスの下の一覧に Access データベースが表示されていることを確認し、[OK] をクリックします。

    データ接続ウィザードが再び表示されます。

  6. [データベースとテーブルの選択] ページの [名前] 列で、テーブルまたはクエリを選択し、[次へ] をクリックします。

  7. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  8. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

ページの先頭へ セクションの先頭へ

OLE DB プロバイダを使用して SQL Server 2000 または 2005 データベースからデータをインポートする

  1. [差し込み文書] タブの [差し込み印刷の開始] で [宛先の選択] をクリックし、[既存のリストを使用] をクリックします。

    Word のリボンの画像

  2. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  3. [データ接続ウィザードへようこそ] ページで、[Microsoft SQL Server] をクリックします。

  4. [データベース サーバーに接続] ページで、次の操作を行います。

    • [サーバー名] ボックスにデータベース サーバーの名前を入力します。

      データベースがローカル コンピュータ上にある場合は、「(local)」と入力します。

    • [ログオン時の資格情報] で、次のいずれかの操作を行います。

      • Windows のユーザー名とパスワードを使用するには、[Windows 認証を使用する] をクリックします。

      • データベースのユーザー名とパスワードを使用するには、[以下のユーザー名とパスワードを使用する] をクリックし、適切なボックスにデータベースのユーザー名とパスワードを入力します。

  5. [次へ] をクリックします。

  6. [データベースとテーブルの選択] ページの [データベース] ボックスで、データベースを選択します。次に、[名前] 列でテーブル、ビュー、またはユーザー定義関数を選択し、[次へ] をクリックします。

  7. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  8. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

ページの先頭へ セクションの先頭へ

ODBC ドライバを使用して SQL Server 2000 または 2005 データベースからデータをインポートする

ODBC ドライバを使用して SQL Server データベースからデータをインポートするには、2 つの手順を実行します。最初に、必要に応じて、コンピュータで ODBC ドライバ用のユーザー DSN を定義します。次に、SQL Server データベースからデータをインポートします。

ユーザー DSN を定義する

  1. コントロール パネルを開き、[管理ツール] アイコンをダブルクリックして、[データ ソース (ODBC)] アイコンをダブルクリックします。

  2. [ODBC データ ソース アドミニストレータ] ダイアログ ボックスで、[ユーザー DSN] タブをクリックし、[追加] をクリックします。

  3. [データ ソースの新規作成] ダイアログ ボックスで、[SQL Server] を選択し、[完了] をクリックします。

    [SQL Server に接続するための新規データ ソースを作成する] ダイアログ ボックスが表示されます。

  4. [名前] ボックスにデータ ソース名を入力します。

  5. 必要に応じて、データ ソースの説明を [説明] ボックスに入力します。

  6. [サーバー] ボックスにデータベース サーバー名を入力します。

    データベースがローカル コンピュータ上にある場合は、「(local)」と入力します。

  7. [次へ] をクリックします。

  8. [SQL Server が、ログイン ID の権限の確認を行う方法は?] で、次のいずれかの操作を行います。

    • Windows のユーザー名とパスワードを使用するには、[ネットワークへのログイン ID で、Windows NT の認証メカニズムを使う] をクリックします。

    • データベースのユーザー名とパスワードを使用するには、[ユーザーが入力する SQL Server 用のログイン ID とパスワードを使う] をクリックし、適切なボックスにデータベースのログイン ID とパスワードを入力します。

  9. [次へ] を 2 回クリックし、[完了] をクリックします。

  10. 適切な情報を入力したかどうかを確認するには、[データ ソースのテスト] をクリックします。

  11. 次のいずれかを実行します。

    • エラー メッセージが表示された場合は、前の手順で入力した値を再確認します。

    • "テストは無事に完了しました。" というメッセージが表示されたら、[OK] をクリックします。

  12. [OK] をクリックし、もう一度 [OK] をクリックします。

さまざまなダイアログ ボックスの各種のオプションの詳細については、[ヘルプ] をクリックしてください。

SQL Server データベースからデータをインポートする

  1. [差し込み文書] タブの [差し込み印刷の開始] で [宛先の選択] をクリックし、[既存のリストを使用] をクリックします。

    Word のリボンの画像

  2. [データ ファイルの選択] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 既存の .odc ファイルを使用するには、.odc ファイルをダブルクリックします。データがインポートされたら操作は完了です。

    • 新しい .odc ファイルを作成するには、[新しいソース] をクリックし、表示される手順に従います。

      データ接続ウィザードが表示されます。

  3. [データ接続ウィザードへようこそ] ページで、[ODBC DSN] をクリックします。

  4. [ODBC データ ソースに接続] ページで、前のセクションで定義したデータ ソース名を選択し、[次へ] をクリックします。

  5. [データベースとテーブルの選択] ページの [データベース] ボックスで、データベースを選択します。次に、[名前] 列でテーブル、ビュー、または関数を選択し、[次へ] をクリックします。

  6. [データ接続ファイルを保存して終了] ページで、[ファイル名] ボックスに .odc ファイルの名前を入力し、[完了] をクリックします。

    フォルダの場所を既定の [My Data Sources] フォルダから変更するには、[参照] をクリックします。

  7. 必要に応じて、接続ファイルを見つけやすくするために、[説明]、[フレンドリ名]、[キーワード検索] の各ボックスに追加情報を入力できます。

ページの先頭へ セクションの先頭へ

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×