データベース モデル図のビューを作成または編集する

ビューは保存したクエリとして考えることができます。複数のテーブルから同じ情報にアクセスする必要がある場合、または実際のテーブルを変更することなく、ユーザーにデータを公開する必要がある場合、ビューは特に便利です。

注: データベース モデル図は、特定のバージョンの Visio のみで提供されています。詳細については、「データベース モデリング機能が見つかりません」を参照してください。

データベース モデル図にビューを追加する

  • [エンティティ関係] または [オブジェクト リレーショナル] ステンシルから [ビュー] 図形を図面ページにドラッグします。

テーブルの列をビューに割り当てる

  1. 列を追加するビューが含まれているデータベース モデル図を開きます。

  2. ビューをダブルクリックし、[データベース プロパティ] ウィンドウの [カテゴリ] リストで [] をクリックします。

  3. 次のいずれかの操作を行います。

    • 空白行の [物理名] フィールドをクリックし、列の名前を入力します。ビューに追加するすべての列で繰り返します。

    • [追加] をクリックします。新しい列の既定の名前は、[モデリングのプリファレンス] ダイアログ ボックスで指定した命名規則に従います。列の名前を変更するには、既定の列名をクリックし、新しい名前を入力します。ビューに追加するすべての列で繰り返します。

  4. 定義するプロパティの列の名前をクリックして、[編集] をクリックします。

  5. [カラム プロパティを表示] ダイアログ ボックスの [ソース] タブで [別のテーブルまたはビューの既知のカラム] をクリックして、[変更] をクリックします。

  6. [カラムを指定] ダイアログ ボックスで、データベース モデル図のテーブルとビューのリストから列を選択し、[OK] をクリックします。

  7. 設定に問題がなければ、[OK] をクリックします。

  8. 手順 3 で追加した各列で、手順 4 から 7 を繰り返します。

ビューの列のプロパティを編集する

  1. データベース モデル図を開きます。

  2. 変更する列を含むビューをダブルクリックして、[データベース プロパティ] ウィンドウの [カテゴリ] リストの [] をクリックします。

  3. 変更する列の名前をクリックして、[編集] をクリックします。

  4. [カラム プロパティを表示] ダイアログ ボックスで、編集する情報を含むタブをクリックし、変更を行います。

  5. 設定に問題がなければ、[OK] をクリックします。

ビューのプロパティを編集する

  1. データベース モデル図を開きます。

  2. 編集するプロパティのビューをダブルクリックして、[データベース プロパティ] ウィンドウを開きます。

  3. [データベース プロパティ] ウィンドウで、編集する情報を含むカテゴリをクリックし、変更を行います。

データベース モデル図が自動的に更新されます。

ビューを削除する

  1. データベース モデル図を開きます。

  2. 図面のページで、削除するビューをクリックし、Del キーを押します。

  3. [オブジェクトの削除] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 図面のページだけでなく、モデルと [テーブルとビュー] ウィンドウからもビューを削除する場合は [はい] をクリックします。

    • ビューを図面のページから削除し、モデルまたは [テーブルとビュー] ウィンドウからは削除しない場合は [いいえ] をクリックします。

注: 図からオブジェクトを削除するときに [オブジェクトの削除] ダイアログ ボックスが表示されない場合は、[データベース] メニューで [オプション] をポイントし、[モデリング] をクリックして、[図表からオブジェクトを削除する場合の処理] にある [データベース モデリングの設定] ダイアログ ボックスの [論理図] タブで [確認する] をクリックします。または、モデルからビューを削除する場合は、[テーブルとビュー] ウィンドウでビューをクリックしてから、Del キーを押します。

コード ウィンドウのビューを並べ替える

  1. [コード] ウィンドウがまだ開いていない場合は、[データベース] メニューで [ビュー] をポイントし、[コード] をクリックしてウィンドウを開きます。

    注: このコマンドは、データベース モデル図テンプレートでのみ使用できます。

  2. 並べ替えるビューをウィンドウ内の新しい位置にドラッグします。

エンティティまたはビューの名前空間の値を定義する

  1. データベース モデル図を開きます。

  2. 設定する名前空間のエンティティまたはビューをダブルクリックして、[データベース プロパティ] ウィンドウを開きます。

  3. [カテゴリ] リストで [定義] をクリックし、[名前空間] ボックスにわかりやすい文字列を入力します。

データベース モデルが自動的に更新されます。

ビューのコードを作成する

  1. [エンティティ関係] または [オブジェクト リレーショナル] ステンシルから [ビュー] 図形をドラッグします。

  2. 図形をダブルクリックして、[データベース プロパティ] ウィンドウを開きます。

  3. [カテゴリ] の [SQL] をクリックします。

  4. SQL ウィンドウに、コードを入力します。

データベース モデリング機能が見つかりません

ご利用中のエディションの Visio にその機能が含まれていない可能性があります。ご利用中の Visio のエディションを確認するには、[ヘルプ] メニューの [バージョン情報] をクリックしてください。ダイアログ ボックスの一番上のテキスト行にエディションの名前が表示されます。

Visio Standard には、データベース モデル図テンプレートがありません。

Visio Professional エディションおよび Premium エディションの場合、データベース モデル図テンプレートのリバース エンジニアリング (つまり、既存のデータベースを利用し、Visio でモデルを作成する) 機能を備えていますが、フォワード エンジニアリング (つまり、Visio データベース モデルを利用し、SQL コードを生成すること) には対応していません。詳細については、既存のデータベースのリバース エンジニアリングに関するトピックを参照してください。

Visio Online Plan 2 で既存のデータベースを基にデータベース モデルを設計する方法については、既存のデータベースのリバース エンジニアリングに関するトピックを参照してください。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×