データベース モデル図にテーブルと列を追加する

データベース モデル図のテーブルは、テーブル名、列名、主キー、およびデータ型を含む、データベース内のテーブルの構造を示します。データベース モデル図 テンプレートを使用すると、新しいテーブルの作成、既存のテーブルの変更、または既存のデータベースからのテーブルのリバース エンジニアリングが行えます。

重要: データベース モデル図は、特定のバージョンの Visio のみで提供されています。詳細については、「データベース モデリング機能が見つかりません」を参照してください。

注: Visio for Enterprise Architects の場合、完全なデータベース モデリング機能をご利用いただけます。リバース エンジニアリングとフォワード エンジニアリングの両方が含まれています。Visio for Enterprise Architects は MSDN Premium Subscription に含まれています。このサブスクリプションは Visual Studio Professional エディションと Visual Studio Team System ロールベース エディションでご利用いただけます。

データベース モデル図でテーブルを作成する

  1. 対象となるデータベース モデル図を開きます。

  2. [エンティティ関係] または [オブジェクト リレーショナル] ステンシルのいずれかから [エンティティ] 図形を図面にドラッグします。

  3. 図形をダブルクリックして、[データベース プロパティ] ウィンドウを開きます。

  4. [カテゴリ] の下で [定義] をクリックし、テーブルの名前を入力します。

  5. [カテゴリ] の [] をクリックし、名前を入力してデータ型を選択します。

  6. Null 値にすることができない列については [必須] を選択します。

  7. データベース テーブルの各行を一意に識別する列については [PK] (主キー) を選択します。

  8. [カテゴリ] の下で [インデックス]、[トリガー]、[チェック]、または [拡張] をクリックしてこれらのオプションの要素を作成します。

ヒント: 図にエンティティ図形をドラッグすると、既定の名前が付きます。既定値を変更するには、[データベース] メニューで [オプション] をポイントし、[モデリング] をクリックし、[その他の論理] タブに移動します。

テーブルに列を追加する

テーブルを作成したら、列を追加し、データ型や主キーなどの列のプロパティを定義する必要があります。

  1. 図のテーブルをダブルクリックします。

  2. [データベース プロパティ] ウィンドウの [カテゴリ] の下で [] をクリックします。

  3. 最初の空の [物理名] セルをクリックして、名前を入力します。

  4. 列のデータ型を変更するには、列の [データ型] フィールドをクリックしてリストからデータ型を選択するか、リストにデータ型を入力します。たとえば、「decimal(8,2)」や「char(30)」と入力できます。

  5. Null 値を回避するには、[必須] チェック ボックスをオンにします。

  6. 列が主キーであることを指定するには、[PK] チェック ボックスをオンにします。

主キーを設定する

リレーションシップは、主キーと外部キーを使用して、あるテーブルの行を別のテーブルの対応する行にマップします。リレーションシップを築くには、リレーションシップ内の少なくとも 1 つのテーブルに主キーが設定されている必要があります。

  1. 図のテーブルをダブルクリックします。

  2. [データベース プロパティ] ウィンドウの [カテゴリ] の下で [] をクリックします。

  3. 主キーを使用する列の [PK] ボックスを選択します。複合キーを作成する場合は、複数のチェック ボックスを選択します。

注: 型は、主キーとして使用できません。

テーブルを削除する

データベース モデル図からテーブルを削除する場合、図面からのみテーブルを削除、または図面と基になるモデルの両方からテーブルを削除できます。いろいろなシナリオを試す際に、図面からのみテーブルを削除するようにすると便利です。

  1. モデルのテーブルをクリックし、キーボードの Delete キーを押します。

  2. [オブジェクトの削除] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 図面と基のモデルの両方からテーブルを削除する場合は、[はい] をクリックします。

    • 図面からのみテーブルを削除する場合は、[いいえ] をクリックします。

      注: [いいえ] をクリックした後でも、[テーブルとビュー] ウィンドウからテーブルを図面にドラッグすると、テーブルを図面に戻すことができます。

ヒント: 削除したリレーションシップは、基になるモデルから常に削除するか、削除しないかを選べます。[データベース] メニューで [オプション] をポイントし、[モデリング] をクリックし、[論理図] タブで希望するオプションを選択します。

テーブルの情報を表示する

図面では、主キー (PK)、外部キー (FKn)、代替キー (AKn)、一意 (UN)、インデックス (In)、データ型などのテーブルに関する情報を表示することができます。

  1. [データベース] メニューで [オプション] をポイントし、[ドキュメント] をクリックします。

  2. [テーブル] タブで、図に表示するアイテムを選択します。

    表記法をリレーショナルに設定すると、左側の列に注釈が表示されます。表記法に Idef1x を使用している場合、注釈は列名の横のかっこ内に表示されます。

データベース モデリング機能が見つかりません

ご利用中のエディションの Visio にその機能が含まれていない可能性があります。ご利用中の Visio のエディションを確認するには、[ヘルプ] メニューの [バージョン情報] をクリックしてください。ダイアログ ボックスの一番上のテキスト行にエディションの名前が表示されます。

Visio Standard には、データベース モデル図テンプレートがありません。

Visio Professional エディションおよび Premium エディションの場合、データベース モデル図テンプレートのリバース エンジニアリング (つまり、既存のデータベースを利用し、Visio でモデルを作成する) 機能はサポートしていますが、フォワード エンジニアリング (つまり、Visio データベース モデルを利用し、SQL コードを生成すること) はサポートしていません。

注: Visio for Enterprise Architects の場合、完全なデータベース モデリング機能をご利用いただけます。リバース エンジニアリングとフォワード エンジニアリングの両方が含まれています。Visio for Enterprise Architects は MSDN Premium Subscription に含まれています。このサブスクリプションは Visual Studio Professional エディションと Visual Studio Team System ロールベース エディションでご利用いただけます。

Visio Online Plan 2 で既存のデータベースを基にデータベース モデルを設計する方法については、既存のデータベースのリバース エンジニアリングに関するトピックを参照してください。

関連項目

データベース モデル (エンティティ関係図とも呼ぶ) を作成する

データベース モデル図でリレーションシップを定義する

データベース モデル図でデータ型を設定および編集する

既存のデータベースのリバース エンジニアリング

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×