データベース モデル図でリレーションシップを定義します。

注:  最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに 英語の記事 があります。

データのコレクションを作成するには 1 つ以上のテーブルからキーと外部キーを使用してVisioでリレーションシップを定義します。

注: Visio Pro for Office 365を使用しているしてデータベース モデルへの既存のデータベースを設計する方法の詳細を知りたい場合は、リバース エンジニア リング既存のデータベース、トピックを参照してください。

目的に合ったトピックをクリックしてください

データベース モデル図でリレーションシップを作成します。

データベース モデルからリレーションシップを削除します。

一対一と一対多リレーションシップを定義します。

図でリレーションシップとそのプロパティを表示します。

データベース モデリング機能が見つかりません

最も一般的なVisioのエディションに探している機能が含まれていないことはできます。Visioのエディションがあるかを検索するには、[ヘルプ] メニューについては、Microsoft Office Visioをクリックします。エディションの名前が] ダイアログ ボックスのテキストの上部にある行であります。

Microsoft Office Visio Standardは、データベース モデル図テンプレートは含まれません。

Microsoft Office Visio Professional ( Visioでモデルを作成するのには、既存のデータベースを使用して、) をデータベース モデル図テンプレートのリバース エンジニア リングの機能をサポートしていますが、転送エンジニア リングをサポートしていない (つまり、使用します。Visioデータベース モデル SQL コードを生成する)。

注: データベースのスイートは、エンタープライズ設計者には、Visio でリバース エンジニア リングと転送のエンジニア リングの両方を含む、モデリング機能を検索できます。エンタープライズ設計者には、Visio は、Visual Studio Professional および Visual Studio チーム システムの役割ベースのエディションで提供されるMSDN Premium サブスクリプションに含まれています。

データベース モデル図でリレーションシップを作成します。

  1. 両方のテーブルは、図面に表示することを確認します。リバース エンジニア リング モデルを既存のデータベースから] の場合は、図面ページにテーブルとビューのウィンドウから 1 つまたは両方のテーブルをドラッグする必要があります。

  2. リレーションシップの主キー側のテーブルをダブルクリックします。

  3. データベースのプロパティウィンドウで、[カテゴリ] の [] をクリックします。

  4. グリッドで、列を使用して一意にテーブル内の各行を確認し、主キーとして設定するには、[主キー ] チェック ボックスを選択する] をクリックします。

  5. オブジェクト リレーショナル] または [エンティティ関係図] ステンシルから図形をドラッグし、ページ上の空白の領域にドロップします。

  6. 上端を親テーブルとテーブルに接続します。

  7. その他の端を子テーブルに接続します。

    2 番目のテーブル、主キーと同じ名前の列に含まれていない、モデル追加 2 番目のテーブルに外部キーとしてされます。

注: リレーションシップ ラインが表示されない、[データベース] メニューのオプション] をポイントし、ドキュメントをクリックします。[リレーションシップ] タブの [表示]、[リレーションシップ] チェック ボックスを選択します。

ページの先頭へ

データベース モデルからリレーションシップを削除します。

  1. 自分のモデルとキーを押して削除のリレーションシップ] をクリックします。

  2. [オブジェクトの削除] ダイアログ ボックスで、次のいずれかの操作を行います。

    • [はい図面と、基になるモデルの両方からリレーションシップを削除する] をクリックします。

    • 図面上の行のみを削除するのには[いいえ] をクリックします。

      注: [なし] をクリックして後で図面に行を追加すること [リレーションシップでテーブルのいずれかを選択し、[データベース] メニューの [関連テーブルの表示] をクリックします。

ヒント: か、基になるモデルから削除のリレーションシップを削除することができます。データベース] メニューで、オプションをポイントし、[モデリングをクリックして、[論理図] タブに移動します。

ページの先頭へ

一対一と一対多リレーションシップを定義します。

リレーションシップのカーディナリティでは、1 つのテーブルの行の数が別のテーブルの行の数に関連付けることができるについて説明します。たとえば、1 つの部門が、多くの従業員を持つことができますが、従業員が所属できる 1 つだけ部門。一対一、一対多、多対多カーディナリティは通常します。

  1. リレーションシップをダブルクリックします。

  2. データベースのプロパティウィンドウで、[カテゴリ] の [その他] をクリックします。

  3. [カーディナリティリレーションシップに最も適したカーディナリティを選択します。1 つまたは複数、または0 以上になる 1 対多のリレーションシップです。[ 0 または 1 つまたは1 つだけになる一対一リレーションシップです。

ページの先頭へ

図でリレーションシップとそのプロパティを表示します。

または図面でのリレーションシップに関する情報を非表示にすることができます。

  1. データベース] メニューで、[オプション] をポイントし、[ドキュメント] をクリックします。

  2. [リレーションシップ] タブで、図面を表示する情報を確認してください。

    表示したり、非表示にします。

    • リレーションシップ

    • カーディナリティ

    • クロウズ フット表記法

    • [動詞句

    • 参照動作

ページの先頭へ

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×