データベース モデル図でビューを作成または編集する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

ビューは保存されたクエリのようなものと考えることができます。ビューは、複数のテーブルに含まれる同じ情報にアクセスする場合や、ユーザーからは実際のテーブルを変更できないようにして、ユーザーにデータを公開する場合に、特に便利です。

目的に合ったトピックをクリックしてください

データベース モデル図に、ビューを追加します。

テーブルから列をビューに割り当てる

ビュー内の列のプロパティを編集します。

ビューのプロパティを編集します。

ビューを削除します。

コード ウィンドウで、ビューを並べ替え

エンティティまたはビューの名前空間を定義します。

ビューのコードを作成します。

データベース モデリング機能が見つかりませんか。

使用しているエディションの Microsoft Office Visio には、お探しの機能が含まれていないことが考えられます。Visio のエディションを確認するには、[ヘルプ] メニューの [バージョン情報] をクリックします。エディション名がダイアログ ボックスの一番上の行に表示されます。

Microsoft Office Visio Standard には、データベース モデル図テンプレートはありません。

Microsoft Office Visio Professional は、データベース モデル図テンプレートのリバース エンジニアリング機能 (既存のデータベースを使用して Visio のモデルを作成すること) はサポートしていますが、フォワード エンジニアリング (Visio データベース モデルを使用して SQL コードを生成すること) はサポートしていません。

注: リバース エンジニアリングおよびフォワード エンジニアリングを含む完全なデータベース モデリング機能は、Visio for Enterprise Architects に搭載されています。Visio for Enterprise Architects は、Visual Studio Professional および Visual Studio Team System の業務別各エディションで提供される MSDN プレミアム サブスクリプションのもとで提供されています。

データベース モデル図にビューを追加する

  • [エンティティ関係図] または [オブジェクト リレーショナル] ステンシルから図面ページに [ビュー] 図形をドラッグします。

ページの先頭へ

テーブルのカラムをビューに割り当てる

  1. カラムを追加するビューが格納されているデータベース モデル図を開きます。

  2. ビューをダブルクリックし、[データベース プロパティ] ウィンドウの [カテゴリ] ボックスの一覧の [カラム] をクリックします。

  3. 次のいずれかを実行します。

    • 空白行の [物理名] フィールドをクリックして、カラムの名前を入力します。ビューに追加するカラムごとに、この手順を繰り返します。

    • [追加] をクリックします。新しいカラムの既定の名前は、[データベース モデリングのプリファレンス] ダイアログ ボックスで指定した命名規則に従います。カラムの名前を変更するには、既定のカラム名をクリックして新しい名前を入力します。ビューに追加するカラムごとに、この手順を繰り返します。

  4. 定義するプロパティを持つカラムの名前をクリックし、次に [編集] をクリックします。

  5. ['%s' のカラム プロパティを表示] ダイアログ ボックスの [ソース] タブで、[別のテーブルまたはビューの既知のカラム] をクリックして、[変更] をクリックします。

  6. [カラムを指定] ダイアログ ボックスで、データベース モデル図のテーブルとビューの一覧からカラムを選択して、[OK] をクリックします。

  7. 設定が終了したら、[OK] をクリックします。

  8. 手順 3. で追加したカラムごとに手順 4. ~ 7. を繰り返します。

ページの先頭へ

ビューのカラムのプロパティを編集する

  1. データベース モデル図を開きます。

  2. 変更するカラムが格納されているビューをダブルクリックして、[データベース プロパティ] ウィンドウの [カテゴリ] ボックスの一覧の [カラム] をクリックします。

  3. 変更するカラムの名前をクリックし、次に [編集] をクリックします。

  4. ['%s' のカラム プロパティを表示] ダイアログ ボックスで、編集する情報を含むタブをクリックして変更を行います。

  5. 設定が終了したら、[OK] をクリックします。

ページの先頭へ

ビューのプロパティを編集する

  1. データベース モデル図を開きます。

  2. プロパティを編集するビューをダブルクリックして [データベース プロパティ] ウィンドウを開きます。

  3. [データベース プロパティ] ウィンドウで、編集する情報を含むカテゴリをクリックして変更を行います。

データベース モデル図は自動的に更新されます。

ページの先頭へ

ビューを削除する

  1. データベース モデル図を開きます。

  2. 図面ページで、削除するビューをクリックし、Del キーを押します。

  3. [オブジェクトの削除] ダイアログ ボックスで、次のいずれかの操作を行います。

    • 図面ページからだけでなく、モデルや [テーブルとビュー] ウィンドウからもビューを削除する場合は、[はい] をクリックします。

    • 図面ページからビューを削除して、モデルや [テーブルとビュー] ウィンドウから削除しない場合は、[いいえ] をクリックします。

注: 図表からオブジェクトを削除したときに [オブジェクトの削除] ダイアログ ボックスが表示されない場合は、[データベース] メニューの [オプション] をポイントし、[モデリング] をクリックします。次に、[データベース モデリングのプリファレンス] ダイアログ ボックスの [論理図] タブにある [図表からオブジェクトを削除する場合の処理] で [確認する] をクリックします。または、ビューをモデルから削除する場合は、[テーブルとビュー] ウィンドウでビューをクリックして Del キーを押します。

ページの先頭へ

[コード] ウィンドウのビューを並べ替える

  1. [コード] ウィンドウが開いていない場合は、[データベース] メニューの [表示] をポイントし、[コード] をクリックして、このウィンドウを開きます。

    注: このコマンドを使用できるのは、[データベース モデル図] テンプレートのみです。

  2. 並べ替えるビューをウィンドウ内の新しい位置にドラッグします。

ページの先頭へ

エンティティまたはビューに名前空間を定義する

  1. データベース モデル図を開きます。

  2. 名前空間を設定するエンティティまたはビューをダブルクリックして、[データベース プロパティ] ウィンドウを開きます。

  3. [カテゴリ] ボックスの一覧の [定義] をクリックして、[名前空間] ボックスに識別用のテキストを入力します。

データベース モデルは自動的に更新されます。

ページの先頭へ

ビューのコードを作成する

  1. [エンティティ関係図] または [オブジェクト リレーショナル] ステンシルから [ ビュー] 図形をドラッグします。

  2. この図形をダブルクリックして [データベース プロパティ] ウィンドウを開きます。

  3. [カテゴリ] の [SQL] をクリックします。

  4. [SQL] ウィンドウにコードを入力します。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×