スキップしてメイン コンテンツへ
スクリーンリーダーを使用して Access テーブルを Excel ブックにエクスポートする

スクリーンリーダーを使用して Access テーブルを Excel ブックにエクスポートする

[スクリーン リーダー コンテンツ] というラベルが表示された、読み上げの記号。 このトピックでは、Office でスクリーン リーダーを使用する方法について説明します。

この記事は、Office アクセシビリティ コンテンツ セットの一部であり、Office 製品でスクリーン リーダー プログラムを使用する、視覚に障碍のある方を対象としています。 一般的なヘルプについては、Office サポート ホームをご覧ください。

キーボードとスクリーンリーダーを使用して Access_1st_NoVer を使って Excel_generic 読み取り可能なファイル形式でデータをエクスポートします。 ここでは、ナレーター、JAWS、および NVDA でテストしていますが、他のスクリーンリーダーと共に使用できるのは、一般的なアクセシビリティ標準と手法に準拠しているためです。 エクスポートウィザードを使用して、テーブル、クエリ、フォーム、レポート、選択したレコードなどのデータを複数のレコードビューでエクスポートする方法について説明します。たとえば、 Excel_generic 対応のファイルにデータシートなどがあります。

注: 

この記事の内容

エクスポート用のデータを準備する

データをエクスポートする前に、データを確認し、エクスポートする方法を決定してください。

  • データにエラーインジケーターまたはエラー値が含まれていないことを確認します。 そうしないと、エクスポート時に問題が発生し、null 値が Excel_generic ワークシートのセルに挿入されることがあります。 トラブルシューティング情報については、「 Excel にデータをエクスポートする」の「存在しない値または正しくない値のトラブルシューティング」を参照してください。

  • テーブルまたはクエリの書式設定を使用するかどうかを指定します。 この決定は、エクスポートされるデータの量と、データの表示形式に影響します。 書式設定されたデータをエクスポートする場合の詳細については、「 Excel にデータをエクスポートする」の「エクスポート操作の準備」を参照してください。

  • Choose the destination workbook and file format. 書式が設定されたテーブル、クエリ、フォーム、またはレポートを既存のブックにエクスポートすると、ブックは上書きされます。

    注: レポートは、新しい * .xlsx ファイル形式ではなく、古い * .xls ファイル形式でのみエクスポートできます。

データをエクスポートする

サブフォーム、サブレポート、またはサブデータシートが含まれているフォーム、レポート、またはデータシートをエクスポートすると、メインのフォーム、レポート、またはデータシートのみがエクスポートされます。 Excel_genericにエクスポートするサブフォーム、サブレポート、サブデータシートごとにエクスポート操作を繰り返す必要があります。

1 回のエクスポート操作でエクスポートできるのは、1 つのデータベース オブジェクトのみです。 ただし、個々のエクスポート操作を完了した後で Excel_generic に複数のワークシートを結合できます。

準備ができていないブックは、エクスポート時に作成されます。 データは、常に新しいワークシートに追加されます。

現在Access_1st_NoVer は、 Excel_genericへのマクロまたはモジュールのエクスポートをサポートしていません。

  1. 保存先の Excel_generic ブックがある場合は、それを閉じます。

  2. ソースデータベースに移動し、エクスポートするオブジェクトを選択します。

    オブジェクトがテーブル、クエリ、またはフォームで、データの一部のみをエクスポートする場合は、データシートビューでオブジェクトを開き、必要なレコードを選択します。 手順については、「データシートビューでオブジェクトを開く」を参照してください。

    注: レポートの一部をエクスポートすることはできません。 ただし、レポートの基になっているテーブルまたはクエリを選択するか開いて、そのオブジェクトのデータの一部をエクスポートすることができます。

  3. エクスポートウィザードで Excel_generic のエクスポートを開始するには、Alt キーを押しながら X、X キーを押します。[エクスポート-Excel スプレッドシート] ダイアログボックスが開きます。

  4. 次のいずれかの操作を行います。

    • エクスポート中に新しいスプレッドシートを作成する場合は、Alt キーを押しながら F キーを押して、[ファイル名] テキストフィールドにフォーカスを移動します。 [Access_1st_NoVer は、エクスポートされたファイルのファイル名としてソースオブジェクトの名前を提示します。 名前を変更するには、提案された名前を削除し、新しい名前を入力します。

    • データをエクスポートする既存の Excel_generic ファイルがある場合は、Alt キーを押しながら R キーを押して [ファイルの保存] ダイアログボックスを開き、目的のファイルを参照します。 ファイルが表示されたら、Enter キーを押して選択します。 ダイアログボックスが閉じ、フォーカスが [エクスポート-Excel スプレッドシート] ダイアログボックスに戻ります。

  5. Alt キーを押しながら T キーを押して、[ファイル形式] の一覧にフォーカスを移動します。 現在の形式が読み上げられます。 目的のファイル形式を選択するには、Space キーを押して一覧を展開し、目的の形式が読み上げられるまで上方向キーまたは下方向キーを押してから、Enter キーを押して選択します。

  6. テーブルまたはクエリをエクスポートするときに、書式設定されたデータをエクスポートするには、Alt キーを押しながら W キーを押して、[書式設定とレイアウトを使用してデータをエクスポートする] オプションを選択します。

    注: フォームまたはレポートをエクスポートする場合、このオプションは既定でオンになっています。選択を解除することはできません。

  7. エクスポート後にエクスポート Excel_generic 先のブックを自動的に開くようにするには、Alt キーを押しながら A キーを押して移動し、[エクスポートの完了後にエクスポート先のファイルを開く] オプションを選択します。

  8. ソースオブジェクトが開いていて、エクスポートを開始する前にビューで1つ以上のレコードを選んでいて、エクスポートするレコードである場合は、Alt キーを押しながら S キーを押して移動し、[選択したレコードのみをエクスポートする] オプションを選択します。 ビューに表示されているすべてのレコードをエクスポートする場合は、このオプションを選択しないでください。

    注: レコードが選択されていない場合、このオプションは使用できません。

  9. エクスポートを開始するには、Tab キーを押して[OK ] ボタンに移動し、enter キーを押します。

  10. エクスポートが正常に完了すると、エクスポート手順を保存するように求めるメッセージが表示され、エクスポートウィザードを使わずにそれらをすばやく繰り返すことが Access_1st_NoVer ます。 このオプションを選択するには、Alt キーを押しながら V キーを押します。 ファイルに名前を指定するには、Alt キーを押しながら A キーを押して、ファイル名を入力します。 手順ファイルを保存するには、Alt キーを押しながら S キーを押します。

    エラーが原因でエクスポートに失敗した場合は、エラーの原因を説明するメッセージが Access_1st_NoVer に表示されます。

    エクスポート Excel_generic 先のブックを自動的に開くように選択した場合、ブックの名前が読み上げられるまで Alt キーを押しながら Tab キーを押し、その内容を確認します。

データシートビューでオブジェクトを開く

エクスポートするオブジェクトがテーブル、クエリ、またはフォームで、データの一部のみをエクスポートする場合は、データシートビューでオブジェクトを開いて、必要なレコードを選択する必要があります。

  1. ナビゲーションツリー内のオブジェクトに移動します。

  2. オブジェクトで、Shift キーを押しながら F10 キーを押してコンテキストメニューを開きます。

  3. メニューで、[データシートビュー ] オプションに移動するまで tab キーを押し、enter キーを押して選択します。 オブジェクトがデータシートビューに表示されます。

    [データシートビュー ] オプションを使用できない場合は、オブジェクトのビューを有効にする必要があります。 手順については、「オブジェクトのデータシートビューを有効にする」を参照してください。

オブジェクトのデータシートビューを有効にする

  1. ナビゲーションツリーのオブジェクトで、Shift キーを押しながら F10 キーを押してコンテキストメニューを開きます。

  2. メニューで、D キーを押してデザインビューを開きます。

  3. デザインビューで、F4 キーを押して、[プロパティシート] ウィンドウを開きます。

  4. F6 キーを1回押します。 フォーカスが [プロパティシート] ウィンドウのプロパティ行に移動します。 行番号と、その後にプロパティセルの内容が読み上げられます。

  5. フォーカスを [選択の種類] ドロップダウンリストに移動するには、"フィールド全体" の後に現在の値が読み上げられるまで Shift キーを押しながら tab キーを押し、その後に現在の値を入力して、"コンボエディット" と読み上げられます。 現在の値がフォームの場合は、次の手順に進むことができます。 または、Alt キーを押しながら下方向キーを押してリストを展開し、"フォーム" と読み上げられるまで上方向キーまたは下方向キーを押してから、Enter キーを押して選択します。

  6. [プロパティシート] ウィンドウで、現在選択されているタブアイテム (たとえば、"データタブアイテム、選択されています") が読み上げられるまで、tab キーを押します。 現在のタブが [書式] タブの場合は、次の手順に進むことができます。 "書式タブ項目" と読み上げられるまで左方向キーまたは右方向キーを押します。 [書式] タブのプロパティが表示されます。

  7. [書式] タブで、"行4、いいえ、折りたたまれています" と読み上げられるまで、tab キーを押します。 フォーカスは "データシートビューの許可" プロパティにあります。 プロパティを[はい]に設定するには、Alt キーを押しながら下方向キーを押し、上方向キーを1回押してから、enter キーを押して新しい値を選びます。

  8. [プロパティシート] ウィンドウを閉じるには、F4 キーを押します。

  9. 選択したオブジェクトをデータシートビューで開くには、Alt + J、D、W、H キーの順に押します。

関連項目

Access デスクトップ データベースでスクリーン リーダーを使ってテーブルを作成する

Access デスクトップ データベースでスクリーン リーダーを使ってクエリを作成する

Access デスクトップデータベースでスクリーンリーダーを使用してフォームを作成する

スクリーンリーダーを使用して Access のテーブルをテキストファイルにエクスポートする

Access のキーボード ショートカット

スクリーンリーダーを使用して Access を検索および移動する

障碍のある方向けのテクニカル サポート

Microsoft は、すべてのお客様に最適な操作性を提供することを目指しています。 障碍のある方、およびアクセシビリティに関してご質問がある方が技術サポートをご希望の場合は、Microsoft Disability Answer Desk までご連絡ください。 Disability Answer Desk サポート チームは、一般的なユーザー補助技術を駆使するトレーニングを受けており、英語、スペイン語、フランス語、および米語の手話でサポートを提供することができます。 お住まいの地域での連絡先の詳細については、Microsoft Disability Answer Desk サイトを参照してください。

政府機関、商用、または法人ユーザーの場合は、法人向け Disability Answer Desk までお問い合わせください。

注:  このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 情報が役に立ったかどうか、ご意見をお寄せください。 参考までに、こちらから英語の記事をお読みいただけます。

サポートを受ける
お問い合わせ
Office のスキルを磨く
トレーニングの探索

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×