コネクタの線、矢印、ポイントを編集する

コネクタの線、矢印、ポイントを編集する

Visio では、非常に柔軟にコネクタを編集したり操作したりすることができます。線の太さ、スタイル、曲がり具合を編集し、端点と矢印の外観を制御し、コネクタを曲線、直角、直線にして、さまざまな方法で接続ポイントを管理することができます。

ヒント    [ホーム] タブの [ツール] グループのコマンドを使うと、Visio が異なる状態やモードになり、わかりにくい場合があります。オブジェクト選択ツール オブジェクトを選ぶ (Ctrl + 1 キー) とコネクタ ボタン イメージ (Ctrl + 3 キー) ツールを簡単に切り替えるには、キーボードを使ってください。テキスト ブロック接続ポイントなど、どのツールを使っていても、Esc キーを数回押すとオブジェクト選択ツールに戻ります (Visio 2010 を除く)。

この記事の大部分は、他の図形の周囲に自動的に経路を変更できる、既定の動的コネクタ図形に関係があります。自動的に経路を変更しないコネクタには、いくつかの種類があります。これらのほとんどは、[その他の図形]、[Visio エキストラ]、[コネクタ] ステンシルから利用できます。

目的に合ったトピックをクリックしてください   

コネクタを曲線、直角、または直線にする

矢印や他の線の端点をコネクタに追加する

コネクタの太さ、スタイル、曲率を変更する

コネクタの矢印の向きを反転する

コネクタの経路を変更したり交差させたりする

接続ポイントの他の操作方法

関連項目

コネクタを曲線、直角、または直線にする

コネクタを変更したり、新しいコネクタの既定値を変更したりすることができます。

コネクタを変更する

  1. コネクタを選びます。

  2. [デザイン] タブの [レイアウト] グループで [コネクタ] を選択し、希望する迂回方法を [直角コネクタ]、[直線コネクタ]、または [曲線コネクタ] から選択します。

  3. また、マウスの右クリックで表示されるコネクタ図形のアクション メニューにも、コネクタの迂回方法を変更するオプションがあります。

新しいコネクタの既定値を変更する

  • 既定のコネクタを直角、直線、または曲線にするには:

    • Visio Online プラン 2、2016、2013    ページを選択してすべての図形を選択解除します。[デザイン] タブを選択し、[レイアウト] グループの [コネクタ] ドロップダウン メニューを選択します。次に、[直角]、[直線]、または [曲線] を選択します。

    • または、[ファイル] タブ、[印刷]、[ページ設定]、[レイアウトと経路] タブの順に選択し、[外観] の一覧で [直線] または [曲線] を選択します。

    • 2010    [ファイル] タブ、[印刷]、[印刷​​プレビュー]、[ページ設定]、[レイアウトと経路] タブの順に選び、[外観] の一覧で [直線] または [曲線] を選びます。

ページの先頭へ

矢印や他の線の端点をコネクタに追加する

矢印やポイントなどの線の端点をコネクタに追加することができます。

  1. コネクタを選びます。

  2. 次のいずれかの操作を行います。

    • Visio Online プラン 2、2016、2013    マウスの右クリックのアクション メニューから [図形の書式設定] オプションを選択します。または、[ホーム] タブの [図形のスタイル] グループで、[] を選択し、[線のオプション] を選択します。

    • 2010    [ホーム] タブの [図形] グループで、[] を選び、[矢印] を選びます。

  3. 次のいずれかの操作を行います。

    • Visio Online プラン 2、2016、2013    [図形の書式設定] ウィンドウの [] で、[実践] が選ばれていることを確認し、種類、サイズ、キャップの種類を選びます。

      コネクタの端の設定
    • 2010    [その他の矢印] を選び、[] ウィンドウで種類、サイズ、キャップの種類を選んで、[OK] をクリックします。

      矢印の端

ページの先頭へ

コネクタの太さ、スタイル、曲率を変更する

  1. コネクタを選びます。

  2. 次のいずれかの操作を行います。

    • Visio Online プラン 2、2016、2013    マウスの右クリックのアクション メニューから [図形の書式設定] オプションを選択します。または、[ホーム] タブの [図形のスタイル] グループで、[] を選択し、[線のオプション] を選択します。

    • 2010    [ホーム] タブの [図形] グループで、[] を選び、[線のオプション] を選びます。

  3. 次のいずれかの操作を行います。

    • Visio Online プラン 2、2016、2013    [図形の書式設定] ウィンドウの [] で、太さ、スタイル、曲率を選びます。

      コネクタのスタイルの設定
    • 2010    [] ウィンドウで、太さ、スタイル、曲率を選び、[OK] をクリックします。

      線の太さおよび他の設定

ページの先頭へ

コネクタの矢印の向きを反転する

メモ:さまざまなプロセス フロー図など、図のいくつかの種類では、接続の方向が重要になります。そのため、これらのコネクタには、端の再フォーマットではなく、[上下左右反転] コマンドを使用する必要があります。[上下左右反転] コマンドは、[ファイル]、[オプション]、[リボンをカスタマイズする] 機能を使用すると、リボンに簡単に追加できます。このコマンドにより、選択したすべてのコネクタのフローを反転できます。

また、矢印がない端に新しい矢印を追加し、反対の端から既存の矢印を削除して、[上下左右反転] コマンドを使用せずにコネクタの方向を変更することもできます。

  1. コネクタを選びます。

  2. 次のいずれかの操作を行います。

    • Visio Online プラン 2、2016、2013    [ホーム] タブの [図形のスタイル] グループで、[] を選び、[線のオプション] を選びます。

    • 2010    [ホーム] タブの [図形] グループで、[] を選び、[線のオプション] を選びます。

  3. 次のいずれかの操作を行います。

    • Visio Online プラン 2、2016、2013    [図形の書式設定] ウィンドウの [] で、次のいずれかを行います。

      • [始点矢印の種類] を選び、手順 4 に進みます。

      • [終点矢印の種類] を選び、手順 4 に進みます。

      逆向き矢印の設定
    • 2010    [] ウィンドウで、次のいずれかを行います。

      • [始点矢印の種類] を選び、手順 4 に進みます。

      • [終点矢印の種類] を選び、手順 4 に進みます。

      開始と終了の矢印
  4. 選択したコネクタの始点または終点で矢印の追加、変更、削除を行うには、矢印のメニューで矢印を選択するか [なし] を選択します。

    矢印のスタイルのメニューで、矢印のスタイルまたは [なし] を選ぶ。

ページの先頭へ

コネクタの経路を変更したり交差させたりする

ほとんどの場合は、既定のコネクタの動作を利用できます。ただし、図のコネクタの経路や交差を細かく制御したい場合があります。

ヒント    ポイントを微調整できるように細部を確認する場合は、次の [ズーム] 機能、[拡大] (Alt + F6)、[縮小] (Alt + Shift + F6)、[ウィンドウに合わせる] (Ctrl + Shift + W) を使います。

  • 次の操作のいずれか、または複数の操作を行います。

    • コネクタを別のコネクタに接続するには、図形にコネクタを追加してから、コネクタを他のコネクタにドラッグします。

      コネクタへの接続
    • コネクタの経路を変更するには、コネクタを選んでから、中間点を新しい場所にドラッグします。

      コネクタの再ルーティング
    • コネクタをピクセル単位で調整するには、コネクタを選び、Shift キーを押しながら目的の方向の方向キーを押します。

      ピクセルを指定してコネクタを移動する

    ツリー図を作成する方法については、「ツリー図を作成する」をご覧ください。

ページの先頭へ

接続ポイントの他の操作方法

以下のセクションでは、接続ポイントを制御するさまざまな方法について説明します。

ヒント    ポイントを微調整できるように細部を確認する場合は、次の [ズーム] 機能、[拡大] (Alt + F6)、[縮小] (Alt + Shift + F6)、[ウィンドウに合わせる] (Ctrl + Shift + W) を使います。

接続ポイントの概要

接続ポイントとは、図形に含まれる特別なポイントで、コネクタやその他の図形を "接着" できます。コネクタまたは図形を接続ポイントに接着すると、図形の 1 つを移動しても、コネクタと図形は接続されたままです。

図形を別の図形に接続しようとすると接続ポイントが表示されます。たとえば、[コネクタ ツール] を含む図形の近くにポインターを移動したり、接続ポイントを含む図形の近くにコネクタや線の端点をドラッグしたりすると表示されます。

接続ポイントのある円の近くに表示されたコネクタ ツール

    接続ポイントだけが、コネクタを接着できる場所ではありません。コネクタ (および線) は、図形の頂点、図形のハンドル、および図形の辺にも接着できます。詳細については、「[スナップと接着] ダイアログ ボックス」をご覧ください。

ポイントまたは動的接続を使用する

(静的接続とも呼ばれる) ポイント接続と動的接続という 2 種類の接続により、コネクタで図形を接続できます。コネクタの両端に接続の種類のいずれかを指定することができます。オートコネクトまたは図形の接続コマンドを使用して図形を接続する場合、両端に動的接続があります。手動でコネクタを図形に接続する場所を選択する場合は、接続の種類を指定できます。

次の図では、図形 A に図形 C へのポイント接続があり、図形 C を移動するたびに、図形 A からのコネクタは図形 C の同じポイントに接続されたままになります。それとは対照的に、図形 B には図形 C への動的接続があり、図形 B からのコネクタは、図形 C で最も近い接続ポイントに移動します。

A には C へのポイント接続がありますが、B には C への動的接続があります。

ポイント接続を作成する   

ポイント接続は、図形の特定のポイントに接着されたコネクタを、その図形が移動または回転される場合でも、維持します。

  1. 最初の図形の接続ポイントを 2 番目の図形の接続ポイントにドラッグします。

  2. 図形が接続されると、コネクタの端点が緑色になります。

コネクタを図形の特定のポイントに接着して、コネクタをそのポイントに固定する。

動的な接続を作成する   

動的接続では、図形を移動または回転すると、コネクタは元のポイントに最も近い図形上の接続ポイントに移動します。

  1. コネクタ ツールを最初の図形の中央に置き、図形の周囲に緑色のボックスが表示されるようにします。

  2. マウス ボタンを押しながら、2 番目の図形の中央にドラッグします。

  3. 緑色のボックスが 2 番目の図形の周囲に表示されたら、マウス ボタンを離します。

コネクタを図形に接着して、コネクタを図形のポイントに動的に移動できるようにします。

接続ポイントを図形に追加する

コネクタを接着する図形で、目的の場所に接続ポイントがない場合は、接続ポイントを追加できます。

  1. 図形を選択します。

  2. [ホーム] タブの [ツール] グループで [接続ポイント ツール] ボタンの画像 をクリックします。

  3. 接続ポイントが表示されていない場合は、[表示] タブの [視覚補助] で [接続ポイント] チェック ボックスをオンにします。

  4. Ctrl キーを押して、接続ポイントを追加する場所をクリックします。配置した後、新しい接続ポイントが自動的に選択されます。

  5. [ホーム] タブの [ツール] で [オブジェクト選択ツール] ( オブジェクトを選ぶ ) をクリックして、通常の編集に戻ります。

接続ポイントを図形に追加する

図形の接続ポイントを移動する

接続ポイントの位置が不適切な場合は移動できます。

  1. 図形を選択します。

  2. [ホーム] タブの [ツール] グループで、[接続ポイント] ツール ボタンの画像 を選択します。

  3. 接続ポイントが表示されていない場合は、[表示] タブの [視覚補助] で [接続ポイント] チェック ボックスをオンにします。

  4. 移動する接続ポイントを、Ctrl キーを押しながらドラッグします。

  5. [ホーム] タブの [ツール] で [オブジェクト選択ツール] ( オブジェクトを選ぶ ) をクリックして、通常の編集に戻ります。

接続ポイントを目的の場所に正確に移動するのが困難な場合は、別のスナップ設定を試してください。詳細については、「スナップの強さを調整する、スナップをオフにする」をご覧ください。

接続ポイントを削除する

接続ポイントが不要になることがあります。そのような場合は、接続ポイントを削除できます。

  1. 接続ポイントを削除する図形を選びます。

  2. [ホーム] タブの [ツール] グループで [接続ポイント ツール] をクリックします。

  3. 接続ポイントが表示されていない場合は、[表示] タブの [視覚補助] で、[接続ポイント] チェック ボックスをオンにします。

  4. 削除する接続ポイントをクリックします。接続ポイントの色がマゼンタに変わります。

  5. Delete キーを押します。

  6. [ホーム] タブの [ツール] グループで、[オブジェクト選択ツール] オブジェクトを選ぶ をクリックして、通常の編集に戻ります。

接続ポイントを削除する

接続ポイントを非表示にする

図がよく見えるように、接続ポイントを非表示にしたいことがあります。

  • [表示] タブの [視覚補助] で [接続ポイント] チェック ボックスをオフにします。

接続ポイントの横にテキストを追加する

接続ポイントに直接テキストを追加することはできません。ただし、テキストを図形に追加した後で、そのテキストを接続ポイントの横に移動することはできます。

  1. テキストを追加する図形を選び、入力を始めます。入力したテキストが図形の中に表示されます。

  2. [ホーム]、[ツール]、[テキスト ブロック] ツール テキスト ブロック ツールのアイコン (Ctrl + Shift + 4 キー) の順に選択します

  3. これでテキスト ブロックは選択されます

    選択されているテキスト ブロック
  4. 必要に応じてテキスト ブロックをドラッグして移動したりサイズ変更したりする

    テキスト ブロックを移動してサイズ変更する

テキスト ​​ブロック ツールを終了する場合は、オブジェクト選択ツール オブジェクトを選ぶ (Ctrl + 1 キー) を選択します。

その他の方法として、それぞれに 1 つの接続ポイントがある一意にラベル付けされた複数の図形を作成し、それらをグループ化して、1 つの大きな図形を作成します。接続ポイントは引き続き使用できます。

複数の名前付き接続ポイントを作成する

接続ポイントを内向き、外向き、またはその両方にする

内向きと外向きの接続ポイントを使って、コネクタの端点を図形に引き付ける方法を制御できます。

  1. 図形を選択します。

  2. [ホーム] タブの [ツール] グループで [接続ポイント ツール] ボタンの画像 をクリックします。

  3. 接続ポイントが表示されていない場合は、[表示] タブの [視覚補助] で [接続ポイント] チェック ボックスをオンにします。

  4. 外向きの接続ポイントまたは内向きと外向きの接続ポイントが必要な場合は、接続ポイントを右クリックして、次のいずれかをクリックします。

    • [内向き]    多くの場合は、内向き接続ポイントが必要です。内向き接続ポイントには、コネクタの端点および 2 次元 (2-D) 図形の外向き接続ポイントおよび内向きと外向き接続ポイントが引き付けられます。

    • [外向き]    他の図形に接着する 2-D 図形がある場合は、外向き接続ポイントが必要です。外向き接続ポイントは、内向き接続ポイントに引き付けられます。

    • [内向きと外向き]    他の図形への接着方法が不明な図形の場合は、内向きと外向き接続ポイントが必要である可能性があります。

ページの先頭へ

接続ポイントを操作する

以下のセクションでは、接続ポイントを制御するさまざまな方法について説明します。

接続ポイントの概要

4 個の接続ポイントがある図形。

4 個の接続ポイントがある図形。

接続ポイントを追加する

コネクタや図形を接着する図形で、目的の場所に接続ポイントがない場合は、接続ポイントを簡単に追加できます。

  1. 接続ポイントが表示されない場合は、[表示] メニューの [接続ポイント] をクリックします。

  2. 図形を選びます。

    注: 最初に図形を選択しないと、接続ポイントを図形に追加することはできません。図形は、選択されると緑色の点線の枠線で囲まれます。

  3. [接続ポイント] ツール ボタンの画像 をクリックします。

    [接続ポイント] ツールが表示されない場合は、[コネクタ] ツール ボタン イメージ の隣の下向き矢印をクリックして、[接続​​ポイント] ツール ボタンの画像 をクリックします。

  4. Ctrl キーを押して、接続ポイントを追加する場所をクリックします。

  5. 外向き接続ポイントまたは内向き & 外向き接続ポイントが必要な場合は、接続ポイントを右クリックして、[内向き]、[外向き]、または [内向きと外向き] をクリックします。

    • 多くの場合は、"内向き"接続ポイントが必要です。内向き接続ポイントには、コネクタの端点および 2 次元 (2-D) 図形の外向き接続ポイントと内向き & 外向き接続ポイントが接着されます。

    • 他の図形に接着する 2-D 図形がある場合は、"外向き"接続ポイントが必要です。外向き接続ポイントには、内向き接続ポイントが接着されます。

    • 他の図形への接着方法が不明な図形の場合は、"内向きと外向き"接続ポイントが必要です。

  6. [ポインター] ツール [ポインター] ボタン をクリックすると、通常の編集に戻ります。

接続ポイントの横にテキストを追加する

残念ながら、接続ポイントに直接テキストを追加することはできません。ただし、テキストを図形に追加した後で、そのテキストを接続ポイントの横に移動することはできます。

  1. 図形を選択します。

  2. 入力を開始します。入力したテキストが図形の中に表示されます。

  3. [テキスト ブロック] ツール ボタンの画像 をクリックします。

    [テキスト ​​ブロック] ツールが表示されない場合は、[テキスト] ツール [テキスト ツール] ボタン の隣の下向き矢印をクリックし、[テキスト ​​ブロック] ツール ボタンの画像 をクリックします。

  4. テキストをドラッグします。

ヒント: 図形にコントロール ハンドル コントロール ハンドルの画像 - 黄色いひし形 がある場合、それをドラッグすると図形のテキストをすばやく移動することができます。

接続ポイントを移動する

接続ポイントの位置が不適切な場合は移動できます。

  1. 図形を選択します。

    注: 最初に図形を選択しないと、接続ポイントを移動することはできません。図形は、選択されると緑色の点線の枠線で囲まれます。

  2. [接続ポイント] ツール ボタンの画像 をクリックします。

    [接続ポイント] ツールが表示されない場合は、[コネクタ] ツール ボタン イメージ の隣の下向き矢印をクリックして、[接続​​ポイント] ツール ボタンの画像 をクリックします。

  3. 移動する接続ポイントをドラッグします。

    接続ポイントが表示されない場合は、[表示] メニューの [接続ポイント] をクリックします。

  4. [ポインター] ツール [ポインター] ボタン をクリックすると、通常の編集に戻ります。

接続ポイントを目的の場所に正確に移動するのが困難な場合は、別のスナップ設定を試してください。

  • [ツール] メニューの [スナップと接着] をクリックし、[全般] タブの [スナップ対象] で目的のオプションを選びます。

接続ポイントを削除または非表示にする

接続ポイントが邪魔になる場合があります。そのような場合は、接続ポイントを削除するか非表示にします。

図形の接続ポイントを削除するには

  1. 図形を選びます。

    注: 最初に図形を選択しないと、接続ポイントを削除することはできません。図形は、選択されると緑色の点線の枠線で囲まれます。

  2. [接続ポイント] ツール ボタンの画像 をクリックします。

    [接続ポイント] ツールが表示されない場合は、[コネクタ] ツール ボタン イメージ の隣の下向き矢印をクリックして、[接続​​ポイント] ツール ボタンの画像 をクリックします。

  3. 削除する接続ポイントをクリックします。接続ポイントの色がマゼンタに変わります。

    接続ポイントが表示されない場合は、[表示] メニューの [接続ポイント] をクリックします。

  4. Delete キーを押します。

  5. [ポインター] ツール [ポインター] ボタン をクリックすると、通常の編集に戻ります。

接続ポイントを削除するには

  • [表示] メニューの [接続ポイント] をクリックします。

ページの先頭へ

矢印や他の線の端点をコネクタに追加する

矢印、ポイント、その他の線の端点などの要素を、コネクタに追加することができます。

  1. コネクタを選びます。

  2. [形式] メニューの [] をクリックします。

  3. [線の端点] で、線の端点の種類とサイズを選びます。

  4. [OK] をクリックします。

ヒント: [線の端点] ツールは、[書式設定] ツール バーから使うこともできます。

コネクタを曲線、直角、または直線にする

図のコネクタを変更する

  1. コネクタを右クリックします。

  2. [直角コネクタ]、[直線コネクタ]、または [曲線コネクタ] をクリックします。

    直線コネクタまたは直角コネクタにハンドルを追加することはできませんが、[鉛筆] ツール ボタン イメージ を使用して曲線コネクタにハンドルを追加することはできます。

新しいコネクタの既定値を変更する

  • 既定のコネクタを直線または曲線にするには、[ファイル] メニューで [ページ​​設定] をクリックし、[レイアウトと経路] タブをクリックして、[外観] の一覧で [直線] または [曲線] をクリックします。

コネクタの矢印の向きを反転する

コネクタの方向を変更する場合は、矢印がない端に新しい矢印を追加して、既存の矢印を反対端から削除します。

  1. 変更するコネクタを選びます。

  2. [ホーム] タブの [図形] グループで [] をクリックし、[矢印] をポイントして [矢印] メニューを開きます。

    [図形のスタイル] の [線] をクリックしてメニューを開いて、[矢印] をクリックします。
  3. [矢印] メニューの下部にある [その他の矢印] をクリックします。

    [矢印] メニューの [その他の矢印] をクリックする。

    [図形の書式設定] 作業ウィンドウが表示され、[] が展開されます。

  4. 選択したコネクタの始点で矢印の追加、変更、削除を行うには、[始点矢印の種類] の矢印のメニューで矢印を選択するか [なし] を選択します。

    選んだコネクタの線で、矢印を追加、変更、または削除する。

    矢印のメニューには、選んだコネクタで現在選択されている矢印のスタイルまたは [なし] が表示されます。

    矢印のスタイルのメニューで、矢印のスタイルまたは [なし] を選ぶ。
  5. 選択したコネクタの終点で矢印の追加、変更、削除を行うには、[終点矢印の種類] の矢印のメニューで矢印を選択するか [なし] を選択します。

関連項目

コネクタのテキストを追加および編集する

図形間にコネクタを追加する

コネクタを接着または接着解除する

カスタム コネクタを作成する

コネクタの飛び越し点の追加または削除

Visio のトレーニング

Visio デスクトップ コネクタ について知っておく必要があること (Visio チームのブログ)

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×