グループ化レポートまたはサマリー レポートを作成する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

多くの場合、グループに分割 (グループ化)すると、情報の内容を把握しやすくなります。たとえば、売上高を地域別にグループ化してレポートにまとめると、見逃されがちな売上動向を読み取りやすくなります。さらに、このレポートの各グループの末尾に集計欄を設ければ、手作業で結果を計算する手間も省けます。

Microsoft Office Access 2007 では、グループ化されたレポートの操作が簡単です。ポート ウィザードを使用した基本的なグループ化されたレポートの作成、既存のレポートへのグループ化と並べ替えの追加、定義済みのグループ化と並べ替えのオプションの修正などを行うことができます。

この記事の内容

グループ化、レポート セクション、コントロールを理解する

レポート ウィザードを使って新しいグループ化レポートを作成する

レポートを微調整する

既存のレポートにフィールドやコントロールを追加する

既存のレポートにグループ化や並べ替えを追加する、または既存のレポートのグループ化や並べ替えを変更する

レポートを保存、印刷、または送信する

解説

グループ化、レポート セクション、コントロールを理解する

グループ化レポートを初めて使う場合は、さまざまなレポート セクションと各種コントロールについて確認した上、グループ化と並べ替えの概念についても学習することをお勧めします。 既にこれらの知識を持っている場合は、このセクションをスキップし、「レポート ウィザードを使って新しいグループ化レポートを作成する」に進んでください。

グループ化と並べ替えについて

レポートの印刷時には、通常、レコードを特定の順序で並べる必要があります。 たとえば、業者のリストを印刷するとき、会社名のアルファベット順でレコードを並べ替えることがあります。

多くの場合は、レコードを並べ替えるだけでは不十分です。 さらにグループに分割することができます。 グループとは、ひとまとまりのレコードに、これらのレコードと一緒に表示する紹介情報や要約情報 (ヘッダーなど) が付属したものです。 グループは、グループ ヘッダー、ネストされたグループ (存在する場合)、詳細レコード、グループ フッターで構成されます。

グループ化を行うと、各レコード グループを視覚的に区別し、各グループの紹介データや要約データを表示することができます。 たとえば、出荷日ごとに売上高をグループ化し、各日付の合計売上高を計算するレポートについて考えてみましょう。

合計でグループ化されたレポート

1. 日付ごとにグループ化します。

2. 各グループの合計を表示します。

グループ化のしくみは、カテゴリ別製品リスト レポート (図を参照) とその基になったクエリのデータシートを比較するとよくわかります。 製品がカテゴリ別に並べて表示される点は、レポートでもクエリでも同じです。レポートの特徴は、各グループの先頭にグループ ヘッダー行を挿入して別の行にカテゴリ名を表示し、末尾にグループ フッター行を挿入して別の行にそのカテゴリに分類される製品の個数を表示できる点です。

カテゴリごとの製品レポート

1. カテゴリ名は、データシートのすべての行に表示されます。

2. カテゴリ名は、レポートのグループごとに 1 つ表示されるグループ ヘッダーに表示されます。

3. カテゴリの合計は、各グループの末尾に表示されるグループ フッターに表示されます。

4. レコードは、1 つの大きいグループとしてデータシートに表示されます。

5. 各カテゴリのレコードは、レポートの個別のセクションとして表示され、前にグループ ヘッダー、後にグループ フッターが付きます。

グループ化は、並べ替えの基準として使用した任意のフィールドや式 (最大 10 個) を使って行うことができます。 同じフィールドまたは式を使って繰り返しグループ化を行うこともできます。 複数のフィールドまたは式を使ってグループ化を行う場合、Office Access 2007 では、グループ レベルに従ってグループがネストされます。 グループ化の基準として最初に使ったフィールドが最も上のグループ レベルになり、2 番目に使ったフィールドが次のグループ レベルになり、以降同様です。 次の図は、Office Access 2007 でグループがネストされる様子を示しています。

ヘッダーとフッターの履歴

1. それぞれのグループ ヘッダーがグループ フッターと対になっています。

通常、グループの先頭に独立したセクションとしてグループ ヘッダーを設けてグループを識別するデータを表示します。 グループの末尾に独立したセクションとしてグループ フッターを設けてグループ データの要約を表示します。

ページの先頭へ

レポート セクションについて

Access では、レポートのデザインはセクションに分割されます。 有用なレポートを作成するには、各セクションの働きを理解しておく必要があります。 たとえば、演算コントロールをどのセクションに配置するかで、結果の計算方法が決まります。 次の一覧は、セクションの種類とその使用方法を示しています。

  • レポート ヘッダー    レポートの先頭に 1 回表示されます。 ロゴ、タイトル、日付など、通常、表紙に表示される情報向けに使います。 レポート ヘッダーは、ページ ヘッダーの前に表示されます。 レポート ヘッダーに演算コントロールを配置すると、レポート全体の値が計算されます。 たとえば、SUM 集計関数を使用するコントロールをレポート ヘッダーに配置すると、レポート全体の合計が計算されます。

  • ページ ヘッダー    各ページの先頭に表示されます。 たとえば、各ページ上でレポートのタイトルを繰り返し表示します。

  • グループ ヘッダー    新しい各レコード グループの先頭に表示されます。グループ ヘッダーを使用してグループ名を表示します。たとえば、製品別にグループ化されたレポートでは、グループ ヘッダーを使って製品名を表示します。SUM 集計関数を使用する演算コントロールをグループ ヘッダーに配置すると、現在のグループの合計が計算されます。

  • 詳細    レコード ソースの各行に表示されます。 レポートの本文を構成するコントロールを配置します。

  • グループ フッター    各グループ レコードの末尾に印刷されます。 グループの集計情報を表示します。

  • ページ フッター    各ページの末尾に表示されます。 ページ番号またはページ単位の情報を表示します。

  • レポート フッター    レポートの末尾に 1 回表示されます。 レポート全体に関するレポートの合計またはその他の要約情報を表示します。

    注: デザイン ビューでは、レポート フッターはページ フッターの下に表示されます。ただし、レポートの印刷またはプレビュー時には、レポート フッターは、最後のページの最後のグループ フッターまたは詳細行の直後、ページ フッターのに表示されます。

ページの先頭へ

コントロールについて

コントロールは、データを表示したり操作を実行したりするオブジェクトです。コントロールを使って、ユーザー インターフェイスを拡張するラベルやイメージのような情報を表示したり、操作したりできます。 Access では、連結コントロール、非連結コントロール、演算コントロールの 3 種類を使用できます。 次の一覧で、これらのコントロールとその使用方法について簡単に説明します。

  • 連結コントロール    テーブルまたはクエリのフィールドをデータ ソースとするコントロール。 連結コントロールを使って、データベース内のフィールドの値を表示できます。 テキスト、日付、数値、Yes/No の値、画像、グラフなど、さまざまな値を表示できます。 連結コントロールの典型例として、テキスト ボックスがあります。 たとえば、フォームに社員の姓を表示するテキスト ボックスが含まれている場合、この情報は [社員] テーブルの [姓] フィールドから取得できます。

  • 非連結コントロール    データ ソースがないコントロール。 非連結コントロールを使って、情報、線、四角形、画像を表示できます。 たとえば、レポートのタイトルを表示するラベルは、非連結コントロールです。

  • 演算コントロール    フィールドではなく式をデータ ソースとするコントロール。 をコントロールのデータ ソースとして定義することにより、コントロール内に値を指定します。 式は、演算子 (=+ など)、コントロール名、フィールド名、単一の値を返す関数、定数の組み合わせです。 たとえば、次の式では、[単価] フィールドの値に定数 .75 を掛けて、25% 割引した品目価格を求めることができます。

= [Unit Price] * .75

式の中では、レポートの基になったテーブルやクエリのフィールドから、またはレポート上のコントロールから取得したデータを使用できます。

レポートを作成する場合、特にレポートのコントロールの大部分を連結コントロールで構成する場合は、最初にすべての連結コントロールを追加してから整理すると効率的です。 その後、[デザイン] タブにある [コントロール] のツールを使って非連結コントロールと演算コントロールを追加し、デザインをしあげることができます。

Access のリボンの画像

コントロールをフィールドに連結するには、コントロールのデータの取得元のフィールドを識別します。 選んだフィールドに連結されたコントロールを作成するには、[フィールド リスト] ウィンドウからレポートにフィールドをドラッグします。 ([フィールド リスト] ウィンドウには、レポートの基になったテーブルまたはクエリのフィールドが表示されています)。 [フィールド リスト] ウィンドウを表示するには、次のいずれかの操作を行います。

  • [デザイン] タブの [ツール] グループで [既存のフィールドの追加] をクリックします。 ボタンの画像

  • Alt キーを押しながら F8 キーを押します。

フィールドをダブルクリックするか、[フィールド リスト] ウィンドウからレポートにフィールドをドラッグすると、連結コントロールが作成されます。

フィールドをコントロールに連結するには、コントロール自体にフィールド名を入力するか、コントロールのプロパティ シートで、"ControlSource" のボックスに値を入力します。 プロパティ シートは、コントロールの名前、データのソース、書式など、コントロールの特性を定義します。 プロパティ シートを表示するには、F4 キーを押します。

次の 2 つの理由から、[フィールド リスト] ウィンドウを使って連結コントロールを作成する方法が最も効果的です。

  • 連結コントロールのラベルには、既定でフィールド名 (または基になったテーブルやクエリに定義された、そのフィールドを表す名前) が表示されるので、手動で名前を入力する必要がありません。

  • 連結コントロールは、基になったテーブルやクエリのフィールドの設定 ("Format"、"DecimalPlaces"、"InputMask" プロパティなど) の多くを継承します。 そのため、フィールドの連結コントロールをいつ作成しても、これらのフィールドのプロパティは変化しません。

既存の非連結コントロールをフィールドに連結するには、コントロールの "ControlSource" プロパティをそのフィールドの名前に設定します。

ページの先頭へ

レポート ウィザードを使って新しいグループ化レポートを作成する

レポート ウィザードには、一連の質問事項が表示されます。たとえば、どのフィールドに基づいてレポートのデータをグループ化するかなどの質問があります。これらの質問に回答していくと、その回答内容に基づいて自動的にレポートが生成されます。生成されたレポートは、そのままでも使用できますが、ユーザーのニーズによりよく対応できるように変更を加えることもできます。レポート ウィザードを開始する前に、データ ソースを決定する必要があります。

レコード ソースを選ぶ

レポートは、テーブルやクエリから取得した情報と、ラベル、見出し、グラフィックスなどのレポート デザインと共に保存された情報で構成されます。 基になるデータを提供するテーブルやクエリをレポートの "レコード ソース" とも呼びます。 レポートの作成を開始する前に、レポートにどのような情報を含めるかを考えてください。 選んだフィールドの中には、グループ化や要約が必要なものもあるでしょう。 レポートに含めるフィールドがすべて単一のテーブル内にある場合は、そのテーブルをレコード ソースにします。 複数のテーブルからフィールドを取得している場合は、クエリをレコード ソースとして使用します。 既にデータベース内に存在するクエリを使用できる場合もあれば、レポートのニーズに合わせたクエリの作成が必要な場合もあります。

クエリの詳細については、この記事の関連項目のセクションにあるリンクを参照してください。

レポート ウィザードを起動する

  1. [作成] タブの [レポート] グループの [レポート ウィザード] をクリックします。 ボタンの画像

    [レポート ウィザード] が起動します。

    レポート ウィザードでのフィールド選択

  2. [テーブル/クエリ] ボックスから、レポートに表示するフィールドが含まれているテーブルまたはクエリを選択します。

  3. 次に、[選択可能なフィールド] ボックス内のフィールドをダブルクリックして選択します。

    すると、選択したフィールドが [選択したフィールド] ボックスに追加されます。[選択可能なフィールド] ボックスと [選択したフィールド] ボックスの間にあるボタンをクリックして、選択したフィールドの追加または削除や、すべてのフィールドの追加または削除ができます。

  4. レポートに表示するフィールドが別のテーブルまたはクエリにも含まれている場合は、[テーブル/クエリ] ボックスの一覧を再度クリックして該当するテーブルまたはクエリを選択した後、フィールドを追加します。

  5. フィールドを追加し終わったら、[次へ] をクリックします。

レポート ウィザードのレコードをグループ化する

グループ化により、レコードを地域や販売担当者などのグループ別に分類して編成することができます。さらにグループをネストすると、グループ間の関係がわかりやすくなり、必要な情報をすばやく見つけられるようになります。グループ化により、データの合計値やパーセンテージなどの要約情報を計算することもできます。

レポートに複数のテーブルを含めると、ウィザードによりテーブル間の関係が吟味され、情報の表示方法が決定されます。

  1. レポート ウィザードの実行中、[グループ レベルを追加しますか?] というメッセージが表示されたら、リスト内のフィールド名を 1 つクリックし、[次へ] をクリックします。

  2. グループ レベルを追加するには、リスト内の任意のフィールド名をダブルクリックして、そのフィールドをレポートに追加します。

    ダイアログ ボックスの右側のページの表示をダブルクリックすると、グループ レベルを削除することもできます。方向ボタンを使用すると、グループ レベルを追加または削除したり、グループ レベルを選択して上下の優先度ボタンをクリックすることで優先度を調整したりできます。追加されたグループ レベルは、それぞれの親グループ レベル内にネストされた状態で表示されます。

    レポート ウィザードでのグループ レベルの追加

  3. [グループ化のオプション] をクリックして、[グループ間隔の設定] ダイアログ ボックスを表示します。

    レポート ウィザードでのグループ間隔

  4. 必要に応じて、グループ レベル フィールドごとにグループ間隔を選びます。

    グループ間隔により、好みの方法でレコードをグループ化することができます。たとえば上の図のレコードは、日付/時刻型の ShippedDate フィールドでグループ化されています。フィールドのデータ型は、レポート ウィザードの [グループ間隔の設定] ボックスの一覧から選択できます。たとえば ShippedDate は日付/時刻型なので、一定の値 (標準)、または、四半期時間、およびの各単位でグループ化することができます。フィールドのデータ型がテキスト型の場合は、フィールド全体 ([標準])、または最初の 1 ~ 5 文字でグループ化することができます。フィールドのデータ型が数値型の場合は、値 ([標準]) または選択したインクリメントの範囲でグループ化することができます。

    グループ化の間隔を選択したら、[OK] をクリックします。

  5. [次へ] をクリックし、次のウィザード画面に進みます。

レコードを並べ替える、要約する

最大 4 つのフィールドに基づいて、レコードを昇順または降順で並べ替えることができます。

  1. 最初のボックスをクリックし、並べ替えの基準にするフィールドを選択します。

    昇順/降順を切り替えるには、ボックスの右のボタンをクリックします (既定値は [昇順])。必要に応じて、2 番目、3 番目、4 番目のボックスをクリックして、並べ替えの基準にするフィールドを追加することもできます。

    レポート ウィザードの並べ替え順序

  2. 数値フィールドを要約する場合は、[集計のオプション] をクリックします。

    [集計のオプション] は、レポートの詳細セクションに数値フィールドがある場合にのみ表示されます。使用可能な数値フィールドが表示されます。

    レポート ウィザードの集計のオプション

  3. [合計]、[平均]、[最小]、または [最大] のチェック ボックスをオンにして、選択した計算をグループ フッターに追加します。

    詳細情報と要約の両方を表示するか、要約だけを表示するかを選択することもできます。たとえば [合計] チェック ボックスをオンにした状態で、要約だけを表示する設定にした場合、各 ShippedDate 値の合計が表示され、詳しい発注内容は省略されます。合計の全体に対するパーセンテージを表示することもできます。

  4. [OK] をクリックします。

  5. レポート ウィザードの残りのページの指示に従って作業を行います。最後のページで、レポートのタイトルを編集できます。このタイトルはレポートの最初のページに表示されるものであり、Access ではレポートはこのドキュメント名で保存されます。レポートのタイトルとドキュメント名は、後で編集できます。

  6. [完了] をクリックします。レポートが自動的に保存され、印刷プレビューに表示されます。

プレビュー ウィンドウの下部のナビゲーション ボタンを使って、レポートのページ順の表示や、任意のページへのジャンプができます。ナビゲーション ボタンをクリックするか、[ページ番号] ボックスにジャンプ先のページ番号を入力して、Enter キーを押します。

印刷プレビューでは、データを拡大して詳細を表示したり、縮小してページ内のデータの配置を確認したりできます。データを拡大/縮小するには、レポート内にマウス ポインターを置き、マウス ボタンを 1 回クリックします。もう 1 回クリックすると、拡大の場合は縮小、縮小の場合は拡大へ、ズーム効果が切り替わります。ステータス バーのズーム コントロールを使っても同じことができます。

ページの先頭へ

レポートを微調整する

レポート ウィザードの結果として必要なレポートが生成されない場合もあります。 たとえば、テキストの追加、列幅の調整、ロゴの追加などを行うことができます。Access には、レポートの変更用として、レイアウト ビューとデザイン ビューが用意されています。 ここでは、この 2 つのビューについて説明します。

レイアウト ビューについて

レイアウト ビューは、レポートの変更に最も適したビューであり、レポートを微調整するために必要なほとんどのツールが用意されています。 たとえば列の幅の変更、列の再配置、グループ レベルや合計の追加や変更などを実行できます。 レポート デザインに新しいフィールドを追加して、レポートとそのコントロールのプロパティを設定することもできます。 レイアウト ビューの利点として、データを確認しながらレポートの書式を変更できるので、その変更がデータの表示に与える影響を直ちに知ることができます。

レイアウト ビューでレポートを開くには、ナビゲーション ウィンドウでレポートを右クリックし、[レイアウト ビュー] ボタンの画像 をクリックします。

プロパティ シートを使用して、レポートやレポートのコントロールとセクションのプロパティを変更できます。 プロパティ シートを表示するには、F4 キーを押します。

[フィールド リスト] ウィンドウを使って、基になるテーブルやクエリからレポート デザインにフィールドを追加できます。 [フィールド リスト] ウィンドウを表示するには、次の操作を行います。

  1. [書式設定] タブの [コントロール] グループで [既存のフィールドの追加] をクリックします。 ボタンの画像

    ヒント:  Access 2010 には、レポートの読みやすさを大幅に改善できる新しい条件付き書式設定機能があります。

デザイン ビューについて

レイアウト ビューでレポートの特定の変更を実行できない場合は、デザイン ビューで変更を試みます。 デザイン ビューでは、レポートの基になる構造が表示され、レイアウト ビューより多くのデザイン ツールやデザイン機能を利用できます。 たとえば、レポートに配置できるコントロールの種類や設定可能なプロパティの種類がレイアウト ビューより多く、コントロールの配置もより正確に行うことができます。

デザイン ビューでレポートを開くには、ナビゲーション ウィンドウでレポートを右クリックし、[デザイン ビュー] ボタンの画像 をクリックします。

ページの先頭へ

既存のレポートにフィールドやコントロールを追加する

レポートに表示されるフィールド、ラベル、線、画像は、すべていずれかのコントロールを使って作成されます。 レポート上で最もよく使うコントロールは、テキスト ボックスです。 通常は、このテキスト ボックスを使って、レポートの基になるレコード ソースからデータを表示します。 レコード ソース内のフィールドにあらかじめ連結されているテキスト ボックスを作成するには、[フィールド リスト] ウィンドウからフィールドを追加するか、または、デザイン ビューでフィールドをレポートに追加し、レコード ソース内のフィールドに手動で連結します。 デザイン ビューのメリットは、四角形、改ページ、グラフなど、連結テキスト ボックスを除くさまざまな種類のコントロールを追加できるという点です。 ここでは、フィールド リストとデザイン ビューの両方でレポートにコントロールを追加する方法について説明します。

既存のレポートにフィールドを追加する

レポートにフィールドを追加するときは、レイアウト ビューを使うことをお勧めしますが、デザイン ビューも使用できます。 フィールドを追加するには、まず [フィールド リスト] ウィンドウが表示されていることを確認します。 [フィールド リスト] ウィンドウには、レポートに配置できるすべてのフィールドの一覧が表示されます。 [フィールド リスト] ウィンドウを表示するには、Alt キーを押しながら F8 キーを押します。

[フィールド リスト] ウィンドウからフィールドを追加する

  • 単一のフィールドを追加するには、[フィールド リスト] ウィンドウでフィールドを選び、レポート上でフィールドを表示するセクションにドラッグします。

  • 複数のフィールドを一度に追加する場合は、最初のフィールドを 1 つクリックし、Ctrl キーを押しながら必要な残りの各フィールドをクリックします。 次に、選んだフィールドをまとめてレポート上にドラッグします。

フィールドをドロップすると、フィールドごとに連結テキスト ボックス コントロールが作成され、各フィールドの横にラベル コントロールが自動的に配置されます。

注: 

  • 関連テーブルからフィールドを追加する場合は、適切なグループ レベルが自動的に追加されます。

  • その他の (非関連) テーブルからフィールドを追加する場合は、このテーブルをレポートの既存のデータ ソースに関連付ける方法を指定できるダイアログ ボックスが表示されます。

データベースで既に指定されている関連テーブルを確認したり、新しい関連テーブルを追加したりするには、次の操作を行います。

  1. [データベース ツール] タブの [表示/非表示] グループで [リレーションシップ] をクリックします。 ボタンの画像

詳細については、「リレーションシップを作成、編集、または削除する」を参照してください。

既存のレポートに他のコントロールを追加する

[フィールド リスト] ウィンドウからレポートにフィールドを追加すると、そのフィールドの連結テキスト ボックス コントロールが自動的に作成されます。 ラベル、線、イメージなどの他のコントロールを追加するには、デザイン ビューに切り替え、[デザイン] タブの [コントロール] グループのツールを使用します。

Access のリボンの画像

ツール名を確認する

  • ツール上にマウス ポインターを置きます。

    ツール名が表示されます。

[コントロール] のツールを使ってコントロールを作成する

  • 追加するコントロールの種類に合ったツールをクリックします。 たとえば、チェック ボックスを作成する場合は、[チェック ボックス] ツール ボタンの画像 をクリックします。

  • レポート デザイン内で、コントロールを配置したときにコントロールの左上端になる位置をクリックします。 1 回クリックして既定サイズのコントロールを作成するか、レポート内でコントロールをクリックしてドラッグし、目的のサイズに変更します。

  • コントロールを 1 回で適切な位置に配置できないときは、次の手順でコントロールを移動します。

    • コントロールをクリックして選びます。

    • ポインターをコントロール上に移動して、4 方向矢印 移動ポインター に変わるのを待ってから、コントロールを目的の場所にドラッグします。

これにより、"非連結” コントロールが作成されます データを表示できるタイプのコントロール (テキスト ボックス、チェック ボックスなど) の場合、そのコントロールの [コントロールソース] プロパティにフィールド名や式を指定するまで、データは表示されません。

プロパティ シートを表示する

  • F4 キーを押します。

注: 新しいレポートが完成したら、作業内容を保存してください。

ページの先頭へ

既存のレポートにグループ化や並べ替えを追加する、または既存のレポートのグループ化や並べ替えを変更する

ここでは、既存のレポートに並べ替えやグループ化を追加したり、レポートの既存の並べ替えやグループ化を変更したりする方法について説明します。

レイアウト ビューでグループ化、並べ替え、集計を追加する

単純な並べ替え、グループ化、集計の操作を実行するには、レイアウト ビュー内のフィールドを右クリックし、ショートカット メニューから適切な操作を選びます。レイアウト ビューに切り替えるには、ナビゲーション ウィンドウ内のレポートを右クリックし、[レイアウト ビュー] ボタンの画像 をクリックします。

注: ここで紹介する手順では [グループ化、並べ替え、集計] ウィンドウは直接使用しませんが、このウィンドウを開いて内容を確認しながら作業を行うと、Access でどのような処理が行われているのかを把握しやすくなります。[グループ化、並べ替え、集計] ウィンドウでの作業に慣れたら、このウィンドウを使ってレポートを細かく調整できるようになります。[グループ化、並べ替え、集計] ウィンドウを表示する方法は次のとおりです。

  1. [書式設定] タブの [グループ化と集計] グループの [グループ化と並べ替え] をクリックします。 ボタンの画像

単一のフィールドで並べ替えを行う

  • 並べ替えるフィールド内の値を右クリックします。

  • ショートカット メニューの適切な並べ替えオプションをクリックします。たとえば、テキスト フィールドを昇順で並べ替えるには、[昇順で並べ替え] ボタンの画像 をクリックします。数値フィールドを降順で並べ替えるには、[降順で並べ替え] ボタンの画像 をクリックします。

Access は、指定されたとおりにレポートを並べ替えます。[グループ化、並べ替え、集計] ウィンドウが開いている場合は、フィールドに新しい [並べ替えキー] 行が追加されたことを確認できます。

複数のフィールドで並べ替えを行う

注: レイアウト ビュー内のフィールドを右クリックして並べ替えを行う場合は、一度に複数のフィールドを並べ替えることはできません。別のフィールドに並べ替えを適用すると、最初のフィールドの並べ替えは解除されます。これに対して、フォームでは、各フィールドを順番に右クリックし、並べ替え順序を選ぶことで、複数の並べ替え順序を設定できます。複数の並べ替えレベルを作成するには、「[グループ化、並べ替え、集計] ウィンドウを使ってグループ化、並べ替え、集計を追加する」を参照してください。

フィールドでグループ化する

  • グループ化の基準にするフィールド内の任意の値を右クリックします。

  • ショートカット メニューの [グループ化] ボタンの画像 をクリックします。

グループ レベルが追加され、グループ ヘッダーが作成されます。[グループ化、並べ替え、集計] ウィンドウが開いている場合は、フィールドに新しい [グループ化] 行が追加されたことを確認できます。

フィールドに集計を追加する

フィールドに集計を追加して、フィールドの合計、平均、カウント、またはその他の集計などを計算することができます。レポートの末尾には総計、レポート上の任意のグループにはグループの集計が追加されます。

  • 集計を求めたいフィールド内の任意の値を右クリックします。

  • [集計] をクリックします。

  • [合計]、[平均]、[レコードのカウント] (すべてのレコードをカウントする場合)、[値のカウント] (このフィールドに値が設定されているレコードのみをカウントする場合)、[最大]、[最小]、[標準偏差]、[分散] のいずれかの操作をクリックします。

レポート フッターに演算テキスト ボックス コントロールが追加され、総計が求められます。レポートにグループ レベルが含まれている場合は、グループ フッターが追加され、各フッターに合計値が表示されます。

集計するフィールドをクリックして集計を追加し、[書式設定] タブの [グループ化と集計] グループで [集計] ボタンの画像 をクリックします。

[グループ化、並べ替え、集計] ウィンドウを使ってグループ化、並べ替え、集計を追加する

[グループ化、並べ替え、集計] ウィンドウでは、レポートに対するグループ化、並べ替え順序、および集計のオプションの追加や変更を非常に柔軟に行うことができます。ここでも、データの表示を確認しながら変更を加えることができる、レイアウト ビューの使用をお勧めします。

[グループ化、並べ替え、集計] ウィンドウを表示する

  • レイアウト ビューの場合

    [書式設定] タブの [グループ化と集計] グループの [グループ化と並べ替え] をクリックします。 ボタンの画像

  • デザイン ビューの場合

    [デザイン] タブの [グループ化と集計] グループの [グループ化と並べ替え] をクリックします。 ボタンの画像

[グループ化、並べ替え、集計] ウィンドウが表示されます。

[グループ化、並べ替え、集計] ウィンドウ

新しい並べ替えレベルまたはグループ レベルを追加するには、[グループの追加] または [並べ替えの追加] をクリックします。

[グループ化、並べ替え、集計] ウィンドウに新しい行が追加され、使用可能なフィールドのリストが表示されます。

[グループ化、並べ替え、集計] ウィンドウのフィールド リスト

フィールド名を 1 つ選んでクリックするか、フィールド リストの下の [] をクリックして、式を入力します。フィールドを選ぶか、式を入力すると、レポートにグループ レベルが追加されます。レイアウト ビューを使用している場合は、直ちに画面が変化し、グループまたは並べ替え順序が表示されます。

注記: 

  • 既にいくつかの並べ替えレベルまたはグループ レベルが定義されている場合は、[グループ化、並べ替え、集計] ウィンドウをスクロールしないと、[グループの追加] または [並べ替えの追加] が表示されない場合があります。

  • グループ レベルと並べ替えレベルは、1 つのレポート内に最大 10 個まで定義できます。

グループ化オプションを変更する

並べ替えレベル、グループ レベルごとに、いくつかのオプションが用意されています。このオプションを設定することで、望みどおりの結果を得ることができます。

グループ化オプション

  • ある特定の並べ替えレベル、またはグループ レベルのオプションをすべて表示するには、変更するレベルの [その他] をクリックします。

    グループ化オプション (展開済み)

  • オプションを非表示にするには、[閉じる] をクリックします。

[並べ替え順序]    並べ替え順序を変更するには、[並べ替え順序] ボックスの一覧をクリックし、適切なオプションをクリックします。

[グループ間隔]    レコードをグループ化する方法を決定します。たとえば、テキスト フィールドの先頭文字が A のグループ、先頭文字が B のグループ、先頭文字が C のグループで、以降同様とするグループ化が可能です。また、日付フィールドでは、日、週、月、四半期、または指定の間隔でのグループ化が可能です。

[集計]    集計を追加するには、このオプションをクリックします。複数のフィールドへの集計の追加や、ある特定のフィールドへの種類の異なる複数の集計の追加ができます。

[集計] ポップアップ ウィンドウ

  • [集計] ボックスの矢印をクリックし、要約するフィールドをクリックします。

  • [種類] ボックスの矢印をクリックし、実行する計算の種類をクリックします。

  • [総計の表示] をクリックして、レポートの末尾 (レポート フッター) に総計を追加します。

  • [グループの集計を総計に対する割合 (%) として表示] をクリックして、グループ フッターに、各グループの総計のパーセンテージを計算するコントロールを追加します。

  • [グループ ヘッダーに表示] または [グループ フッターに表示] をクリックして、適切な場所に集計を表示します。

フィールド オプションをすべて選択したら、[集計] ボックスの一覧から別のフィールドを選択し、ここまでの手順を繰り返してフィールドを要約します。または、[集計] ポップアップ ウィンドウの外側をクリックして、ダイアログ ボックスを閉じます。

[タイトル]    要約するフィールドのタイトルを変更できます。列見出しや、ヘッダーまたはフッターの要約フィールドのラベル付けに使用します。

タイトルを追加または変更するには、次の手順に従います。

  • [タイトル] の青いテキストをクリックします。

    [ズーム] ダイアログ ボックスが表示されます。

  • このダイアログ ボックスで新しいタイトルを指定し、[OK] をクリックします。

[ヘッダー セクション付き] または [ヘッダー セクションなし]    各グループの前へのヘッダー セクションの追加や、ヘッダー セクションの削除ができます。ヘッダー セクションを追加すると、グループ化フィールドが自動的にヘッダーに移動します。グループ化フィールド以外のコントロールを含むヘッダー セクションを削除しようとすると、コントロールを削除してもよいかどうかを確認するメッセージが表示されます。

[フッター セクション付き] または [フッター セクションなし]    各グループの後ろへのフッター セクションの追加や、フッター セクションの削除ができます。コントロールを含むフッター セクションを削除しようとすると、コントロールを削除してもよいかどうかを確認するメッセージが表示されます。

[1 ページにグループをまとめるかどうかを指定します]    レポートを印刷するときのグループのレイアウトを設定します。グループをできるだけまとめると、グループ全体を見るためにめくるページ数を減らすことができます。ただし、そのように設定すると、ほとんどのページの下部に空白ができるので、レポートの印刷枚数は多くなります。

  • [1 ページにグループをまとめない]    グループの途中に改ページが入ってもかまわない場合は、このオプションを使用します。このオプションを使用すると、たとえば、30 項目から成るグループのうち 10 項目が前のページの下部、残り 20 項目が次のページの上部に表示されることがあります。

  • [1 ページにグループをまとめる]    グループの途中にできるだけ改ページが入らないようにします。現在のページの下部にグループの全項目を表示しきれない場合は、現在のページの下部が空白になり、次のページからグループの表示を開始します。グループが大きいと、まったく改ページを挟まずに全項目を表示することは不可能ですが、このオプションを選択することにより、1 つのグループの途中の改ページの回数を最小限に抑えることができます。

  • [1 ページにヘッダーと最初のレコードをまとめる]    グループにグループ ヘッダーが付いている場合、グループ ヘッダーだけが前のページの下部に表示されないようにします。ヘッダーの後ろに 1 行以上データを表示するスペースがない場合、次のページからグループの表示を開始します。

グループ レベルと並べ替えレベルの優先度を変更する

グループ レベルまたは並べ替えレベルの優先度を変更するには、[グループ化、並べ替え、集計] ウィンドウで行をクリックし、行の右側の上矢印または下矢印をクリックします。

グループ レベルと並べ替えレベルを削除する

グループ レベルまたは並べ替えのレベルを削除するには、[グループ化、並べ替え、集計] ウィンドウで削除する行をクリックし、Del キーを押すか、行の右側の [削除] をクリックします。グループ レベルを削除すると、グループ ヘッダーまたはグループ フッター内のグループ化フィールドのみ、レポートの詳細セクションへ移動します。グループ ヘッダーまたはグループ フッター内のその他のコントロールは削除されます。

ページの先頭へ

サマリー レポートを作成する (レコードの詳細なし)

集計だけ、つまりヘッダー行とフッター行の情報だけを表示する場合は、[書式設定] タブ (またはデザイン ビューの [デザイン] タブ) の [グループ化と集計] で [詳細の非表示] をクリックします。すると、1 つ下のグループ レベルのレコードが非表示になり、要約データの表示がずっとコンパクトになります。レコードを非表示にしても、非表示セクション内のコントロールが削除されたわけではありません。[詳細の非表示] をもう一度クリックすると、非表示になっていた詳細行がレポートに再び表示されます。

ヘッダーを使用せずにグループ化の効果を得る

ヘッダーを使用せずに、レポート上でグループ化の効果を得ることができます。 ヘッダーを削除すると、縦方向のスペースをヘッダー行分使用できるので、よりコンパクトなレポートが作成されます。

通常は、各グループのヘッダーを削除して、グループ化フィールドをレポートの詳細セクションに移動します。 視覚的なグループ化の効果を元に戻すには、各グループ化フィールドの [重複データ非表示] プロパティを [はい] に設定します。

使用例

グループ ヘッダーのある典型的なグループ化レポートについて考えてみましょう。

グループのヘッダーによりグループ化されたレポート

会社名と発注 ID は、それぞれ 1 行ずつを使って表示されています。

この例では、次の図を参考にレポートを編集します。

グループのヘッダーが削除されている、グループ化されたレポート

  1. ナビゲーション ウィンドウでレポートを右クリックし、[レイアウト ビュー] ボタンの画像 をクリックして、レポートをレイアウト ビューで開きます。

  2. [書式設定] タブの [グループ化と集計] グループの [グループ化と並べ替え] をクリックします。 ボタンの画像

    注:  一番下のレベルのグループから順に処理することをお勧めします。そうしないと、作業中にレポートの表示がわかりにくくなる可能性があります。

  3. 一覧の一番下のグループ レベルをクリックし、[その他] をクリックします。

  4. ヘッダー セクションのドロップダウン リストの [ヘッダー セクションなし] をクリックします。

    ヘッダーを削除すると、グループ化フィールドのテキスト ボックスは詳細セクションに移動され、削除されません。 ただし、グループ ヘッダー内の他のすべてのコントロールは削除されます。 この操作の結果として削除されるコントロールがある場合は警告が表示されます。 グループ ヘッダー内に保存したいコントロールがある場合は、この操作を実行する前に、そのコントロールを別のレポート セクションに移動してください。 コントロールを別のセクションに移動するには、デザイン ビューに切り替える必要があります。

    次の図のようにレポートが表示されます。 最初の受注コードは、独立した行ではなく、最初の詳細レコードと同じ行に表示されています。

    OrderID ヘッダーが削除されているグループ化されたレポート

    残念ながら、すべての詳細行に受注コードが表示されているため、発注件数を正確に把握しにくくなっています。 このような場合は、テキスト ボックス コントロールの [重複データ非表示] プロパティが役立ちます。 このプロパティを設定するには、次の手順どおりに行います。

    • 繰り返し表示されている値を 1 つ選びます。

    • プロパティ シートが現在表示されていない場合は、F4 キーを押して表示します。

    • プロパティ シートの [書式] タブで、[重複データ非表示] ボックスの一覧をクリックして、[はい] をクリックします。

      重複した発注 ID が非表示になります。 これにより、発注件数と、注文あたりの製品数がわかりやすくなります。

      重複する OrderID が非表示になっているグループ化されたレポート

  5. この例で、会社名のグループ レベルの手順 4. を繰り返します。 最終的なレポートは次の図のようになります。

    グループのヘッダーが削除されている、グループ化されたレポート

    会社名の値は最初の詳細レコードと同じ行に表示されていますが、[重複データ非表示] プロパティが指定されているため、会社名の値がすべての行に表示されることはありません。 複数のグループ レベルを使用する長いレポートの場合、このようにすると、レポートの枚数を大幅に節約することができます。

ページの先頭へ

レポートを保存、印刷、または送信する

保存したレポート デザインは、繰り返し利用できます。 レポート デザインは変わりませんが、現在のデータはレポートを出力するたびに変化します。 レポートの要件が変化した場合は、レポート デザインを変更するか、元のレポート デザインを基にして類似した新しいレポートを作成できます。

レポートを保存する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックして [保存] をクリックするか、Ctrl キーを押しながら S キーを押します。 ボタンの画像

    または、クイック アクセス ツールバーの [保存] ボタンの画像 をクリックすることもできます。

  2. レポートのタイトルが指定されていない場合は、[レポート名] ボックスに名前を入力し、[OK] をクリックします。

レポート デザインを別名で保存する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックし、[名前を付けて保存] ボタンの画像 をクリックします。

  2. [名前を付けて保存] ダイアログ ボックスの [レポート名] ボックスに名前を入力し、[貼り付ける形式] 内の [レポート] をクリックして、[OK] をクリックします。

レポートを印刷する

レポートは、印刷プレビュー、レイアウト ビュー、デザイン ビュー、レポート ビュー、またはナビゲーション ウィンドウから印刷できます。 印刷を開始する前に、ページ余白、印刷方向などの設定をよく確認します。 ページ設定はレポートと共に自動的に保存されるので、1 回設定すれば何度も使用できます。 変更が必要な場合は、設定を後で保存できます。

ページ設定を変更する

  1. レポートを任意のビューで開きます。

  2. [ページ レイアウト] タブの [ページ] でオプションをクリックします。

    • [サイズ] ボタンの画像 では、用紙サイズを選んだり、ユーザー設定の用紙サイズを入力したりできます。

    • [] ボタンの画像 を選ぶと、ページが縦向きに印刷されます。

    • [] ボタンの画像 を選ぶと、ページが横向きに印刷されます。

    • [余白] ボタンの画像 では、いくつかの既定の余白の中から選ぶか、[ページ設定] ダイアログ ボックスの [詳細] をクリックして、ユーザー設定の余白を入力できます。

    • [余白の表示] では、余白の表示/非表示を切り替えることができます (レイアウト ビューのみ)。

    • [] を選ぶと、[ページ設定] ダイアログ ボックスが表示されます。 必要な列数を入力し、列サイズを設定して、[OK] をクリックします。

    • [データのみ印刷する] を選ぶと、レポートに配置したラベルが印刷されなくなります。 基になるテーブルまたはクエリ内のデータに連結されたコントロールだけが印刷されます。 この機能は、印刷済みフォーム上にレポートを印刷する場合に役に立ちます。 このような場合は、不要なラベルの印刷をオフにすることができます。白紙の用紙にレポートを印刷する場合はラベルの印刷をオンにします。

注: より詳細なページ設定を行うには、[ページ レイアウト] の右下隅にある [ページ設定] をクリックして [ページ設定] ダイアログ ボックスを表示します。 [ページ設定] ダイアログ ボックスでは、[ページ レイアウト] タブのすべての項目を設定できるだけでなく、レポートを印刷する特定のプリンターを選ぶこともできます。

レポートをプリンターに送信する

  1. レポートを任意のビューで開きます。またはナビゲーション ウィンドウでレポートを選びます。

  2. Office ボタンの画像 (Microsoft Office ボタン) をクリックし、[印刷] をクリックします。 [印刷] ボタン

  3. [印刷] ダイアログ ボックスで、プリンター、印刷範囲、印刷部数などのオプションを選びます。

  4. [OK] をクリックします。

ページの先頭へ

レポートを電子メール メッセージとして送信する

レポートを紙に印刷する代わりに、メール メッセージとして送信することができます。

  1. ナビゲーション ウィンドウで、レポートをクリックして選び、 Office ボタンの画像 (Microsoft Office ボタン) をクリックします。次に、[電子メール] ボタンの画像 をクリックします。

  2. [名前を付けてオブジェクトを保存] ダイアログ ボックスで、使用するファイル形式をクリックします。

    [名前を付けてオブジェクトを保存] ダイアログ ボックス

  3. 残りのすべてのダイアログ ボックスに入力します。

  4. メール プログラムが起動したら、メッセージの詳細を入力して送信します。

ページの先頭へ

解説

ルックアップ フィールドで並べ替えまたはグループ化を行うレポートを .accdb ファイルで作成し、そのレポートを .mdb ファイルにインポートして、以前のバージョンの Access で開く場合、問題が発生する可能性があります。

.accdb ファイルでルックアップ フィールドの並べ替えやグループ化を行う内部メソッドは、.mdb ファイルと互換性がありません。 ルックアップ フィールドでグループ化または並べ替えを使用するレポートを .accdb ファイルで作成し、.mdb ファイルにエクスポート (または [名前を付けて保存] を使用してデータベースを .mdb ファイルとして保存) して、そのレポートを以前のバージョンの Access で開こうとすると、レポートを読み込めません。

レポートを .mdb ファイルにインポートし、以前のバージョンの Access で開けるように修正するには、次の操作を行います。

  1. .accdb ファイルで、レポートのコピーを作成します。

  2. レポートのコピーをレイアウト ビューで開きます。

  3. [グループ化、並べ替え、集計] ウィンドウが表示されない場合は、次の操作を行います。

    1. [書式設定] タブの [グループ化と集計] グループの [グループ化と並べ替え] をクリックします。 ボタンの画像

  4. 各行の右側の [削除] をクリックして、[グループ化、並べ替え、集計] ウィンドウのすべての行を削除します。

  5. Office ボタンの画像 (Microsoft Office ボタン) をクリックして [保存] をクリックするか、Ctrl キーを押しながら S キーを押します。 ボタンの画像

  6. Office ボタンの画像 (Microsoft Office ボタン) をクリックし、[データベースを閉じる] をクリックします。 ボタン イメージ

  7. Office ボタンの画像 (Microsoft Office ボタン) をクリックし、[開く] をクリックします。 ボタンの画像

  8. レポートのインポート先の .mdb ファイルを参照し、[開く] をクリックします。

  9. レポートのコピーを .mdb ファイルにインポートします。

    方法

    1. [外部データ] タブの [インポート] で [Access] をクリックします。 ボタンの画像

    2. [参照] をクリックします。

    3. レポートを含む .accdb ファイルを参照し、[開く] をクリックします。

    4. この時点ではテーブルはインポートされていないため、ソース データのインポートを選ぶかソース データへのリンクを選ぶかは関係ありません。 [OK] をクリックして操作を続けます。

    5. [オブジェクトのインポート] ダイアログ ボックスで、[レポート] タブをクリックします。

    6. インポートするレポートをクリックし、[OK] をクリックします。

    7. インポート操作が正常に行われた場合は、後で使用するためにインポート手順を保存するかどうかを確認するメッセージが表示されます。 手順を保存する場合は、[インポート手順の保存] チェック ボックスをオンにし、要求された情報を入力して、[インポートの保存] をクリックします。 手順を保存しない場合は、[閉じる] をクリックします。

      レポートがインポートされ、ナビゲーション ウィンドウに表示されます。

  10. 10.レポートをレイアウト ビューで開きます。

  11. [フィールド リスト] ウィンドウが表示されていない場合は、次の操作を行います。

    1. [書式設定] タブの [コントロール] グループで [既存のフィールドの追加] をクリックします。 ボタンの画像

  12. [リレーション テーブルで利用可能なフィールド] ウィンドウで、レポートに表示するフィールドを含むテーブルを探します。 このフィールドには、現在レポートのルックアップ フィールドに表示されている値と同じ値が表示されます。

  13. フィールドをレポートにドラッグします。

    これで、同じ情報を表示する 2 つの列が作成されました。

  14. 追加した表示フィールドを右クリックし、使用する並べ替えオプションをクリックします。

  15. 追加や並べ替えを行った表示フィールドを削除します。

  16. [グループ化、並べ替え、集計] ウィンドウが表示されない場合は、次の操作を行います。

    1. [書式設定] タブの [グループ化と集計] グループの [グループ化と並べ替え] をクリックします。 ボタンの画像

  17. [グループの追加] をクリックします。

  18. [フィールド/式] ポップアップ ウィンドウで、レポートのルックアップ フィールドの名前をクリックします。

.accdb ファイルの場合と同じように、レポートの並べ替えやグループ化が行われます。 レポートを保存して閉じます。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×