グラフを作成する

基本的なグラフを作成できます。グラフに含める任意の範囲を選択して、[グラフ] リボン グループの [挿入] タブで目的のグラフの種類をクリックします。または、Excel の場合は Alt + F1 キーを押すだけで、自動的に簡単な縦棒グラフが作成されます。そこから、グラフを変更できる複数のオプションが用意されているので、目的に合わせて変更します。

目的に合ったトピックをクリックしてください

グラフについて

グラフを作成または変更する

  1. 基本のグラフを作成する

  2. グラフのレイアウトまたはスタイルを変更する

  3. タイトルまたはデータ ラベルを追加または削除する

  4. 凡例を表示または非表示にする

  5. グラフの軸またはグリッド線を表示または非表示にする

  6. グラフを移動する、またはサイズを変更する

  7. グラフをテンプレートとして保存する

グラフの概要

グラフは、大量のデータや、異なるデータ系列間の関係について理解しやすくするために、数値データの系列を図の形で表したものです。

Excel でグラフを作成するには、最初に ワークシート でグラフの数値データを入力します。入力後、[挿入] タブの [グラフ] グループで使用するグラフの種類を選択し、データでグラフを描画できます。

ワークシートのデータとグラフ

1. ワークシートのデータ

2. ワークシートのデータから作成されたグラフ

Excel では、見る人にとってわかりやすい方法でデータを表示できるように、多くの種類のグラフがサポートされています。 グラフを作成する場合や、既存のグラフを変更する場合には、さまざまなグラフの種類 (縦棒グラフや円グラフなど) およびグラフの形式 (積み上げ縦棒グラフや 3-D の円など) から選ぶことができます。 また、1 つのグラフで複数のグラフの種類を使用して、複合グラフを作成することもできます。

書式設定されたグラフ

縦棒グラフと折れ線グラフを使用した複合グラフの例

Excel で選択できるグラフの種類の詳細については、「利用可能なグラフの種類」を参照してください。

グラフ要素について理解する

グラフには多くの要素が含まれています。 これらの要素のいくつかは既定で表示され、いくつかは必要に応じて追加できます。 表示されているグラフ要素は、グラフ内で他の場所に移動したり、サイズを変更したり、形式を変更したりできます。 また、表示しないグラフ要素を削除することもできます。

グラフとその要素

1. グラフのグラフ領域

2. グラフのプロット エリア

3. グラフにプロットされたデータ系列のデータ ポイント

4. グラフ内でデータがプロットされる横軸 (項目) と縦軸 (数値)

5. グラフの凡例

6. グラフで使用できるグラフ タイトルと軸ラベル

7. データ系列内のデータ要素の詳細を識別するために使うことのできるデータ ラベル

ページの先頭へ

目的に合わせて基本のグラフを変更する

グラフを作成した後で、その任意の要素を変更できます。 たとえば、軸の表示方法の変更、グラフ タイトルの追加、凡例の移動や非表示、追加のグラフ要素の表示などを行うことができます。

グラフを変更するには、次のいずれか 1 つまたは複数の手順を実行します。

  • グラフの軸の表示を変更する    軸の目盛を指定し、表示される値間または項目間の間隔を調整できます。 また、グラフを読み取りやすくするために、軸に目盛を追加し、その表示間隔を指定できます。

  • グラフにタイトルやデータ ラベルを追加する    グラフに表示される情報を明確にするために、グラフ タイトル、軸ラベル、データ ラベルを追加できます。

  • 凡例やデータ テーブルを追加する    凡例の表示と非表示を切り替えたり、場所を変更したり、凡例項目を変更したりできます。グラフによっては、グラフに表示される 凡例マーカー や値をデータ テーブルに表示することもできます。

  • グラフの種類に固有のオプションを適用する    さまざまなグラフの種類に対して、特別な線 (高低線や近似曲線など)、棒 (ローソクや誤差範囲など)、データ マーカー、その他のオプションを使用できます。

ページの先頭へ

定義済みのグラフのレイアウトとスタイルを適用して、プロフェッショナルな外観にする

グラフ要素を手動で追加または変更したり、グラフの書式を手動で設定したりしなくても、定義済みのグラフ レイアウトおよびグラフ スタイルをグラフにすばやく適用できます。Excel には定義済みの便利なレイアウトやスタイルが多数用意されていますが、必要に応じて、個別のグラフ要素 (グラフ エリア、プロット エリア、データ系列、凡例など) のレイアウトや書式に手動で変更を加えることにより、レイアウトまたはスタイルを微調整できます。

定義済みのグラフ レイアウトを適用すると、特定のグラフ要素 (タイトル、凡例、データ テーブル、データ ラベルなど) のセットが特定の形式でグラフに表示されます。 それぞれのグラフの種類に対して用意されたさまざまなレイアウトから選ぶことができます。

定義済みのグラフ スタイルを適用すると、適用したドキュメント テーマに基づいてグラフの書式が設定されるため、組織または個人で使用しているテーマの色 (色のセット)、テーマのフォント (見出しおよび本文テキストのフォントのセット)、テーマの効果 (線および塗りつぶし効果のセット) にグラフを一致させることができます。

独自のグラフ レイアウトやグラフ スタイルを作成することはできませんが、必要なレイアウトや書式を含めたグラフ テンプレートを作成できます。

ページの先頭へ

グラフに目立つ書式を追加する

定義済みのグラフ スタイルの適用に加えて、データ マーカー、グラフ エリア、プロット エリア、タイトルやラベル内の数値やテキストなど、個別のグラフ要素に簡単に書式を適用して、グラフの外観を独自に目立たせることができます。 特定の図形のスタイルやワードアート スタイルを適用したり、グラフ要素の形状やテキストの書式を手動で設定したりできます。

書式を追加するには、次のいずれか 1 つまたは複数の手順を実行します。

  • グラフ要素を塗りつぶす    色、テクスチャ、画像、グラデーションによる塗りつぶしを使用して、グラフの特定の要素に注意を引きつけることができます。

  • グラフ要素の輪郭を変更する    色、線のスタイル、線の太さを使用して、グラフ要素を強調できます。

  • グラフ要素に特殊効果を追加する    グラフ要素の図形に影、反射、光彩、ぼかし、面取り、3-D 回転などの特殊効果を適用して、グラフを本格的な外観にしあげることができます。

  • テキストや数値の書式を設定する    ワークシート上のテキストや数値の場合と同様に、グラフ上のタイトル、ラベル、テキスト ボックスに含まれるテキストや数値の書式を設定できます。 テキストや数値を目立たせるために、ワードアート スタイルを適用することもできます。

ページの先頭へ

グラフ テンプレートを作成してグラフを再利用する

自分の必要性に合わせてカスタマイズしたグラフを再利用するには、そのグラフをグラフ テンプレート (*.crtx) としてグラフ テンプレート フォルダーに保存します。 その後、グラフを作成するときに、グラフ テンプレートを他の組み込みのグラフの種類とまったく同じように適用できます。 実際、グラフ テンプレートとはグラフの種類のカスタム版であり、それを使用して既存のグラフの種類を変更することもできます。 特定のグラフ テンプレートを頻繁に使用する場合は、それを既定のグラフの種類として保存できます。

ページの先頭へ

手順 1: 基本のグラフを作成する

縦棒グラフや横棒グラフなど、ほとんどのグラフは、ワークシート上で行または列に配置したデータをグラフにプロットできます。 ただし、円グラフやバブル チャートなどの一部の種類では、データを特定の方法で配置する必要があります。

  1. ワークシートで、グラフにプロットするデータを配置します。

    データは行または列に配置でき、データをグラフにプロットする最適な方法が Excel によって自動的に決定されます。円グラフやバブル チャートなどの一部の種類では、データを特定の方法で配置する必要があります。

    ワークシート上のデータを配置する方法

    グラフの種類

    データの配置方法

    縦棒グラフ、横棒グラフ、折れ線グラフ、面グラフ、等高線グラフ、またはレーダー チャート

    Excel の横棒グラフ

    次のように、行または列に配置します。

    リンゴ

    オレンジ

    バナナ

    2013

    800

    600

    50

    2014

    600

    700

    550

    2015

    50

    90

    150

    または:

    フルーツ

    2013

    2014

    2015

    リンゴ

    800

    600

    50

    オレンジ

    600

    700

    90

    バナナ

    50

    90

    150

    円グラフまたはドーナツ グラフ

    1 つのデータ系列の場合は、次のように、データを 1 列または 1 行に配置し、データ ラベルを 1 列または 1 行に配置します。

    A

    1

    B

    2

    C

    3

    または:

    A

    B

    C

    1

    2

    3

    複数のデータ系列の場合は、次のように、データを複数の列または行に配置し、データ ラベルを 1 列または 1 行に配置します。

    A

    1

    2

    B

    3

    4

    C

    5

    6

    または:

    A

    B

    C

    1

    2

    3

    4

    5

    6

    散布図またはバブル チャート

    次のように、1 列目に x 値を配置し、隣接する列に対応する y 値やバブル サイズ値を配置します。

    X

    Y

    バブル サイズ

    1

    2

    3

    4

    5

    6

    株価チャート

    銘柄または日付をラベルにして

    高値、安値、終値の順で列または行に配置します。

    Like:

    日付

    高値

    安値

    終値

    2002/1/1

    46.125

    42%

    44.063

    または:

    日付

    2002/1/1

    高値

    46.125

    安値

    42%

    終値

    44.063

  2. グラフに使用するデータ範囲内で、任意のセルを選択します。

    ヒント    1 つのセルのみを選択した場合、Excel は、そのセルに隣接するデータを含むすべてのセルを自動的にプロットします。グラフにプロットするセルが連続した範囲に含まれていない場合、選択範囲が四角形である限り、Ctrl + 左方向キーをクリックして、隣接していないセルや範囲を選択できます。また、グラフにプロットさせない行や列を非表示にすることもできます。

    ヒント: セルの選択を取り消すには、ワークシート内の任意のセルをクリックします。

  3. [挿入] タブの [グラフ] で、次のいずれかの操作を行います。

    • グラフの種類をクリックし、使用するグラフのサブタイプをクリックします。

    • 使用できるすべてのグラフの種類を確認するには、 ボタンの画像 をクリックして、[グラフの挿入] ダイアログ ボックスを開き、矢印をクリックして、グラフの種類をスクロールします。

      Excel のリボンの画像

      ヒント:    グラフの種類やグラフのサブタイプの上にマウス ポインターを置くと、そのグラフの種類の名前を示すポップ ヒントが表示されます。使用できるグラフの種類の詳細については、「利用可能なグラフの種類」を参照してください。

  4. 既定では、グラフはワークシートに埋め込みグラフとして配置されます。 グラフを別のグラフ シートに配置する場合は、次の操作を行って場所を変更します。

    1. 埋め込みグラフ内の任意の場所をクリックすると、グラフが有効になります。

      [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

    2. [デザイン] タブの [場所] で [グラフの移動] をクリックします。

      リボンの画像

    3. [グラフの配置先] で次のいずれかを行います。

      • グラフをグラフ シートに表示するには、[新しいシート] をクリックします。

        ヒント:    自動的に表示されるシート名を変更する場合は、[新しいシート] ボックスに変更後の名前を入力します。

      • グラフを埋め込みグラフとしてワークシートに表示するには、[オブジェクト] をクリックし、[オブジェクト] ボックスの一覧で配置先のワークシートをクリックします。

  5. グラフには自動的に名前が割り当てられます (ワークシートに最初に作成したグラフであれば "グラフ 1" など)。 グラフの名前を変更するには、次の操作を行います。

    1. グラフをクリックします。

    2. [レイアウト] タブの [プロパティ] で [グラフ名] ボックスをクリックします。

      ヒント:    必要に応じて、[プロパティ] で [プロパティ] アイコンをクリックして、グループを展開します。

    3. 新しい名前を入力します。

    4. Enter キーを押します。

注:   

  • 既定のグラフの種類を使用してグラフをすばやく作成するには、グラフに使用するデータを選び、Alt + F1 キーまたは F11 キーを押します。 Alt キーを押しながら F1 キーを押すと、グラフが埋め込みグラフとして表示されます。F11 キーを押すと、グラフが別のグラフ シートに表示されます。

  • グラフが必要でなくなったら、削除することができます。 グラフをクリックして選び、Del キーを押します。

ページの先頭へ

手順 2: グラフのレイアウトやスタイルを変更する

グラフを作成した後で、その外観を即座に変更できます。グラフ要素を手動で追加または変更したり、グラフ スタイルを手動で設定したりしなくても、定義済みのレイアウトおよびスタイルをグラフにすばやく適用できます。Excel には、定義済みの便利なレイアウトやスタイル (または、クイック レイアウトやクイック スタイル) が多数用意されており、その中から目的に合ったものを選ぶことができますが、必要に応じて個々のグラフ要素のレイアウトや書式を手動で変更することにより、レイアウトやスタイルをカスタマイズできます。

定義済みのグラフのレイアウトを適用する

  1. 定義済みのグラフのレイアウトを使用して書式を設定するグラフ内の任意の場所をクリックします。

    [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

  2. [デザイン] タブの [グラフのレイアウト] で、使用するグラフの書式をクリックします。

    リボンの画像

    注:    Excel のウィンドウを縮小した場合は、グラフのレイアウトは、[グラフのレイアウト] の [クイック レイアウト] に表示されます。

    ヒント:    使用できるレイアウトをすべて表示するには、[その他] をクリックします。 ボタンの画像

ページの先頭へ

定義済みのグラフ スタイルを適用する

  1. 定義済みのグラフのスタイルを使用して書式を設定するグラフ内の任意の場所をクリックします。

    [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

  2. [デザイン] タブの [グラフのスタイル] で、使用するグラフのスタイルをクリックします。

    リボンの画像

    注:    Excel のウィンドウを縮小した場合は、グラフのスタイルは、[グラフのスタイル] の [グラフ クイック スタイル] に表示されます。

    ヒント:    定義済みのグラフの書式をすべて表示するには、[その他] をクリックします。 ボタンの画像

ページの先頭へ

グラフ要素のレイアウトを手動で変更する

  1. レイアウトを変更するグラフ要素をクリックするか、次の操作を実行してグラフ要素の一覧からグラフ要素を選択します。

    1. グラフ内の任意の場所をクリックして [グラフ ツール] を表示します。

    2. [書式] タブの [現在の選択範囲] で [グラフの要素] ボックスの矢印をクリックし、目的のグラフの要素をクリックします。

      リボンの画像

  2. [レイアウト] タブの [ラベル]、[]、または [背景] で、選択したグラフ要素に対応するグラフ要素ボタンをクリックし、目的のレイアウト オプションをクリックします。

    リボンの画像

    リボンの画像

    リボンの画像

注:    ここで選ぶレイアウト オプションは、選んだグラフ要素に適用されます。たとえば、グラフ全体を選ぶと、すべての データ系列 にデータ ラベルが適用されます。単一のデータ要素を選ぶと、選んだデータ系列またはデータ要素に対してのみデータ ラベルが適用されます。

ページの先頭へ

グラフ要素の書式を手動で変更する

  1. スタイルを変更するグラフ要素をクリックするか、次の操作を実行してグラフ要素の一覧からグラフ要素を選択します。

    1. グラフ内の任意の場所をクリックして [グラフ ツール] を表示します。

    2. [書式] タブの [現在の選択範囲] で [グラフの要素] ボックスの矢印をクリックし、目的のグラフの要素をクリックします。

      リボンの画像

  2. [書式] タブで、次の操作のいずれか、または複数の操作を実行します。

    1. 選んだグラフ要素に書式を設定するには、[現在の選択範囲] の [選択対象の書式設定] をクリックし、目的の書式のオプションを選びます。

    2. 選んだグラフ要素の図形に書式を設定するには、[図形のスタイル] で目的のスタイルをクリックするか、[図形の塗りつぶし]、[図形の枠線]、または [図形の効果] をクリックし、目的の書式のオプションを選びます。

    3. 選択したグラフ要素のテキストに WordArt を使って書式を設定するには、[ワードアートのスタイル] でスタイルをクリックするか、[文字の塗りつぶし]、[文字の輪郭]、または [文字の効果] をクリックし、目的の書式のオプションを選択します。

      注:    ワードアート スタイルを適用した後で、そのワードアート書式を削除することはできません。適用したワードアート スタイルが不要になった場合は、別のワードアート スタイルを選ぶか、クイック アクセス ツール バーの [元に戻す] をクリックしてテキストを前の書式に戻します。

      ヒント:    通常の書式を使ってグラフ要素のテキストに書式を設定するには、文字列を右クリックするか選択し、ミニ ツール バーの適切な書式設定オプションをクリックします。リボンの書式ボタン ([ホーム] タブの [フォント]) を使うこともできます。

ページの先頭へ

手順 3: タイトルやデータ ラベルを追加または削除する

グラフをわかりやすくするために、グラフ タイトルや軸ラベルなどのタイトルを追加することができます。 通常、軸ラベルは、3-D グラフの奥行き (系列) 軸も含め、グラフに表示されるすべての軸で使用できます。 ただし、グラフの種類によっては、レーダー チャートのように、軸があっても軸ラベルを表示できない場合があります。 円グラフやドーナツ グラフなど、軸のない種類のグラフには、軸ラベルを表示することはできません。

ワークシートのセルへの参照を作成することで、グラフ タイトルや軸ラベルと、セル内の対応する文字列との間にリンクを設定することもできます。 対応する文字列をワークシート上で変更すると、グラフ上でも、リンクされたタイトルやラベルが自動的に更新されます。

グラフのデータ系列をすばやく識別できるようにするために、グラフのデータ ポイントにはデータ ラベルを追加できます。 既定では、データ ラベルとワークシートの値との間にリンクが設定され、ワークシートの値を変更すると、データ ラベルも自動的に更新されます。

グラフ タイトルを追加する

  1. タイトルを追加するグラフ内の任意の場所をクリックします。

    [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

  2. [レイアウト] タブの [ラベル] で [グラフ タイトル] をクリックします。

    リボンの画像

  3. [グラフ タイトルを中央揃えで重ねて配置] または [グラフの上] をクリックします。

  4. グラフに [グラフ タイトル] ボックスが表示されるので、適切な文字列を入力します。

    ヒント:    改行を挿入するには、改行する位置をクリックしてポインターを置き、Enter キーを押します。

  5. 文字列の書式を設定するには、文字列を選び、ミニ ツール バーの適切な書式設定オプションをクリックします。

    ヒント:    リボンの書式ボタン ([ホーム] タブの [フォント]) を使うこともできます。タイトル全体の書式を設定するには、タイトルを右クリックし、[グラフ タイトルの書式設定] をクリックして、必要な書式設定オプションを選択します。

ページの先頭へ

軸ラベルを追加する

  1. グラフ内で軸タイトルを追加する場所をクリックします。

    [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

  2. [レイアウト] タブの [ラベル] で [軸ラベル] をクリックします。

    リボンの画像

  3. 次の操作のいずれか、または複数の操作を行います。

    • 主横 (項目) 軸にラベルを追加するには、[主横軸ラベル] をクリックし、必要なオプションをクリックします。

      ヒント:     グラフに第 2 横軸がある場合は、[第 2 横軸ラベル] をクリックすることもできます。

    • 主縦 (数値) 軸にラベルを追加するには、[主縦軸ラベル] をクリックし、必要なオプションをクリックします。

      ヒント:    グラフに第 2 縦軸がある場合は、[第 2 縦軸ラベル] をクリックすることもできます。

    • 奥行き (系列) 軸にラベルを追加するには、[奥行き軸ラベル] をクリックし、必要なオプションをクリックします。

      注:    このオプションは、3-D 縦棒グラフなど、選択中のグラフが実際に 3-D グラフである場合にしか使用できません。

  4. グラフに [軸ラベル] ボックスが表示されるので、適切な文字列を入力します。

    ヒント:    改行を挿入するには、改行する位置をクリックしてポインターを置き、Enter キーを押します。

  5. 文字列の書式を設定するには、文字列を選び、ミニ ツール バーの適切な書式設定オプションをクリックします。

    ヒント:    \ リボンの書式ボタン ([ホーム] タブの [フォント]) を使うこともできます。ラベル全体の書式を設定するには、ラベルを右クリックし、[軸ラベルの書式設定] をクリックして、必要な書式設定オプションを選択します。

注:   

  • 軸ラベルをサポートしていない別の種類のグラフ (円グラフなど) に切り替えると、軸ラベルは表示されなくなります。 軸ラベルをサポートしている種類のグラフに戻すと、ラベルがもう一度表示されます。

  • 第 2 軸に表示される軸ラベルは、第 2 軸が表示されない種類のグラフに切り替えると表示されなくなります。

ページの先頭へ

タイトルをワークシートのセルにリンクする

  1. グラフ上で、ワークシートのセルとの間にリンクを設定するグラフ タイトルまたは軸ラベルをクリックします。

  2. ワークシートで数式バーの内部をクリックし、等号 (=) を入力します。

  3. グラフに表示するデータまたは文字列が入力されたワークシートのセルを選びます。

    ヒント:    数式バーには、ワークシートのセルへの参照を入力することもできます。その場合は、等号 (=) とシート名の後に感嘆符 (!) を記述します。たとえば、「=Sheet1!F2」と入力します。

  4. Enter キーを押します。

ページの先頭へ

データ ラベルを追加する

  1. グラフ上で、次のいずれかの操作を行います。

    • すべてのデータ系列のすべてのデータ要素にデータ ラベルを追加するには、グラフ領域をクリックします。

    • 1 つのデータ系列のすべてのデータ要素にデータ ラベルを追加するには、ラベルを追加するデータ系列内の任意の場所をクリックします。

    • 1 つのデータ系列の 1 つのデータ要素にデータ ラベルを追加するには、ラベルを追加するデータ要素のあるデータ系列をクリックしてから、ラベルを追加するデータ要素をクリックします。

      [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

  2. [レイアウト] タブの [ラベル] で [データ ラベル] をクリックし、必要な表示オプションをクリックします。

    リボンの画像

    注:    使用しているグラフの種類によって、利用できるデータ ラベル オプションは異なります。

ページの先頭へ

グラフからタイトルまたはデータ ラベルを削除する

  1. グラフをクリックします。

    [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

  2. [レイアウト] タブの [ラベル] で、次のいずれかの操作を行います。

    • グラフ タイトルを削除するには、[グラフ タイトル] をクリックし、[なし] をクリックします。

    • 軸ラベルを削除するには、[軸ラベル] をクリックし、削除する軸ラベルの種類をクリックして、[なし] をクリックします。

    • データ ラベルを削除するには、[データ ラベル] をクリックし、[なし] をクリックします。

      リボンの画像

ヒント:    タイトルまたはデータ ラベルをすばやく削除するには、タイトルやラベルをクリックし、Del キーを押します。

ページの先頭へ

手順 4: 凡例の表示と非表示を切り替える

グラフを作成すると凡例が表示されますが、この凡例はグラフの作成後に非表示にしたり、位置を変更したりできます。

  1. 凡例の表示と非表示を切り替えるグラフをクリックします。

    [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

  2. [レイアウト] タブの [ラベル] で [凡例] をクリックします。

    リボンの画像

  3. 次のいずれかの操作を行います。

    • 凡例を非表示にするには、[なし] をクリックします。

      ヒント:    グラフから凡例または凡例文字列をすばやく削除するには、凡例または凡例文字列を選択し、Del キーを押します。凡例または凡例文字列を右クリックし、[削除] をクリックすることもできます。

    • 凡例を表示するには、使用する表示オプションをクリックします。

      注:    表示オプションの 1 つをクリックすると、凡例が移動し、それに合わせて プロット エリア が自動的に調整されます。マウスを使用して凡例を移動およびサイズ変更した場合は、プロット エリアの自動調整は行われません。

    • その他のオプションを使用する場合は、[その他の凡例オプション] をクリックし、使用する表示オプションを選びます。

      ヒント:    スペースの制約がある場合、[凡例をグラフに重ねずに表示する] チェック ボックスをオフにして、グラフのサイズを小さくできます。

ヒント:    グラフに凡例が表示されている場合、ワークシートの該当データを編集し、個々の凡例項目を変更できます。追加の編集オプションの場合、またはワークシート データを変更せずに凡例項目を変更する場合は、[データ ソースの選択] ダイアログ ボックスで凡例項目を変更できます ([デザイン] タブ、[データ] グループ、[データの選択] ボタン)。

ページの先頭へ

手順 5: グラフの軸または目盛線の表示と非表示を切り替える

グラフを作成すると、ほとんどのグラフの種類に対して主軸が 表示されます。 主軸の表示は、必要に応じてオンまたはオフにできます。 軸を追加するときには、その軸で表示する詳細のレベルを指定できます。 3-D グラフを作成すると、奥行き軸が表示されます。

作成したグラフの値の範囲がデータ系列によって大きく異なる場合、または異なる種類のデータ (価格と数量など) が使用されている場合は、1 つ以上のデータ系列を第 2 縦 (数値) 軸にプロットすることができます。第 2 縦軸の目盛には、関連付けられたデータ系列の値が表示されます。第 2 縦軸をグラフに追加すると、第 2 横 (項目) 軸を追加することもでき、これは XY (散布) 図やバブル チャートで便利です。

グラフを見やすくするために、グラフの横軸および縦軸からプロット エリアにかけて、グラフの横目盛線と縦目盛線を表示したり、非表示にしたりできます。

主軸の表示と非表示を切り替える

  1. 軸の表示と非表示を切り替えるグラフをクリックします。

    [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

  2. [レイアウト] タブの [] で [] をクリックし、次のいずれかの操作を行います。

    • 軸を表示するには、[主横軸]、[主縦軸]、または [奥行き軸] (3-D グラフの場合) をクリックし、必要な軸表示オプションをクリックします。

    • 軸を非表示にするには、[主横軸]、[主縦軸]、または [奥行き軸] (3-D グラフの場合) をクリックし、[なし] をクリックします。

    • 詳細な軸表示オプションや目盛オプションを指定するには、[主横軸]、[主縦軸]、または [奥行き軸] (3-D グラフの場合) をクリックし、[その他の主横軸オプション]、[その他の主縦軸オプション]、または [その他の奥行き軸オプション] をクリックします。

      リボンの画像

ページの先頭へ

第 2 軸の表示と非表示を切り替える

  1. 第 2 縦軸にプロットするデータ系列をグラフ上でクリックするか、次の操作を行って、グラフ要素の一覧から目的のデータ系列を選びます。

    1. グラフをクリックします。

      [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

    2. [書式] タブの [現在の選択範囲] グループで、[グラフの要素] ボックスの矢印をクリックし、第 2 縦軸にプロットするデータ系列をクリックします。

      リボンの画像

  2. [書式] タブの [現在の選択範囲] グループの [選択対象の書式設定] をクリックします。

  3. [系列のオプション] が選択されていない場合はクリックし、[使用する軸] の [第 2 軸 (上/右側)] をクリックして、[閉じる] をクリックします。

  4. [レイアウト] タブの [] で [] をクリックします。

    リボンの画像

  5. 次のいずれかの操作を行います。

    • 第 2 縦軸を表示するには、[第 2 縦軸] をクリックし、必要な表示オプションをクリックします。

      ヒント:    第 2 縦軸を区別するには、1 つのデータ系列だけを別の種類のグラフに変更します。たとえば、1 つのデータ系列を折れ線グラフに変更できます。

  6. 第 2 横軸を表示するには、[第 2 横軸] をクリックし、必要な表示オプションをクリックします。

    注:    このオプションは、第 2 縦軸を表示した場合にのみ使用できます。

  7. 第 2 軸を非表示にするには、[第 2 縦軸] または [第 2 横軸] をクリックし、[なし] をクリックします。

ヒント:    削除する第 2 軸をクリックして、Del キーを押しても、同じ操作を実行できます。

ページの先頭へ

目盛線の表示と非表示を切り替える

  1. グラフの目盛線の表示と非表示を切り替えるグラフをクリックします。

    [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

  2. [レイアウト] タブの [] で [目盛線] をクリックします。

    リボンの画像

  3. 次の手順を実行します。

    • グラフに横目盛線を追加するには、[主横軸目盛線] をポイントし、必要なオプションをクリックします。 グラフに第 2 横軸がある場合は、[第 2 横軸目盛線] をポイントすることもできます。

    • グラフに縦目盛線を追加するには、[主縦軸目盛線] をポイントし、必要なオプションをクリックします。 グラフに第 2 縦軸がある場合は、[第 2 縦軸目盛線] をポイントすることもできます。

    • 3-D グラフに奥行き方向目盛線を追加するには、[奥行き方向目盛線] をポイントし、必要なオプションをクリックします。 このオプションは、3-D 縦棒グラフなど、選択中のグラフが実際に 3-D グラフである場合にしか使用できません。

    • グラフの目盛線を非表示にするには、[主横軸目盛線]、[主縦軸目盛線]、または [奥行き方向目盛線] (3-D グラフの場合) をポイントし、[なし] をクリックします。 グラフに第 2 軸がある場合は、[第 2 横軸目盛線] または [第 2 縦軸目盛線] をポイントし、[なし] をクリックすることもできます。

    • グラフの目盛線をすばやく削除するには、削除する目盛線を選び、Del キーを押します。

ページの先頭へ

手順 6: グラフを移動またはサイズ変更する

グラフは ワークシート の任意の場所に、新しいワークシート、または既存のワークシートに移動できます。グラフのサイズを見やすい大きさに変更することもできます。

グラフを移動する

  • グラフを移動するには、目的の場所にグラフをドラッグします。

ページの先頭へ

グラフのサイズを変更する

グラフのサイズを変更するには、次のいずれかの操作を行います。

  • グラフをクリックし、目的のサイズになるまでグラフのサイズ変更ハンドルをドラッグします。

  • [書式] タブの [サイズ] で、[図形の高さ] ボックスと [図形の幅] ボックスにサイズを入力します。

    リボンの画像

ヒント:    他のサイズ変更オプションについては、[形式] タブの [サイズ] グループで ボタンの画像 をクリックし、[グラフ エリアの書式設定] ダイアログ ボックスを起動します。[サイズ] タブでは、グラフのサイズ変更、回転、または拡大縮小のオプションを選択できます。[プロパティ] タブでは、ワークシートのセルでグラフを移動または拡大縮小する方法を指定できます。

ページの先頭へ

手順 7: グラフをテンプレートとして保存する

作成したグラフと似たグラフを作成する場合は、そのグラフをテンプレートとして保存すると、同様のグラフを作成するときの基礎として使用できます。

  1. テンプレートとして保存するグラフをクリックします。

  2. [デザイン] タブの [種類] で [テンプレートとして保存] をクリックします。

    Excel のリボン イメージ

  3. [ファイル名] ボックスに、テンプレートの名前を入力します。

    ヒント:    別のフォルダーを指定した場合を除き、テンプレート ファイル (.crtx) は Charts フォルダーに保存され、[グラフの挿入] ダイアログ ボックス ([挿入] タブの [グラフ] で ボタンの画像 (ダイアログ ボックス起動ツール) をクリック) および [グラフの種類の変更] ダイアログ ボックス ([デザイン] タブの [種類] で [グラフの種類の変更] をクリック) の両方の [テンプレート] で、そのテンプレートを使用できるようになります。

注:    グラフ テンプレートには、グラフの書式設定が格納され、グラフをテンプレートとして保存するときに使用していた色も格納されます。グラフ テンプレートを使用して別のブックでグラフを作成すると、その新しいグラフでは、ブックに現在適用されているドキュメントのテーマの色ではなく、グラフ テンプレートの色が使用されます。グラフ テンプレートの色ではなく、ドキュメントのテーマの色を使用するには、グラフ エリアを右クリックし、[リセットしてスタイルに合わせる] をクリックします。

ページの先頭へ

関連項目

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×