スキップしてメイン コンテンツへ
Office
グラフ

グラフに近似曲線や移動平均線を追加する

グラフに近似曲線や移動平均線を追加する

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに英語の記事があります。

グラフに近似曲線を追加して、視覚的なデータの傾向を示すことができます。

お使いのブラウザーはビデオをサポートしていません。 Microsoft Silverlight、Adobe Flash Player、Internet Explorer 9 のいずれかをインストールしてください。

注: 以下の手順は、Office 2013 およびそれ以降のバージョンに適用されます。 Office 2010 の手順をお探しですか?

近似曲線を追加する

  1. グラフを選択します。

  2. グラフの右上にある [+] を選択します。

  3. [近似曲線] を選択します。

    注: [近似曲線] オプションは、データ系列を選択せずに、複数のデータ系列を含むグラフを選択した場合にのみ表示されます。

  4. [近似曲線の追加] ダイアログボックスで、必要なデータ系列オプションを選び、[ OK]をクリックします。

近似曲線の書式を設定する

  1. グラフ内の任意の場所をクリックします。

  2. [書式] タブの [現在の選択範囲] グループで、ドロップダウンリストの [近似曲線] オプションを選択します。

  3. [選択対象の書式設定] をクリックします。

  4. [近似曲線の書式設定] ウィンドウで、グラフに必要な近似曲線を選択するための近似曲線オプションを選択します。 近似曲線の書式設定は、データを測定する
    ための統計的な方法です。

  5. [前方] フィールドと [後方] フィールドに値を設定して、データを将来のプロジェクトに合わせます。

移動平均線を追加する

近似曲線を移動平均線に書式設定できます。

  1. グラフ内の任意の場所をクリックします。

  2. [書式] タブの [現在の選択範囲] グループで、ドロップダウンリストの [近似曲線] オプションを選択します。

  3. [選択対象の書式設定] をクリックします。

  4. [近似曲線の書式設定] ウィンドウの [近似曲線のオプション] で、[移動平均] を選択します。 必要に応じて点を指定します。

    注: 移動平均の近似曲線上のポイント数は、その期間に指定した要素数をデータ系列全体のポイント数から引いた値に等しくなります。

Office 2010 でグラフに近似曲線または移動平均線を追加する

  1. 非積み上げグラフ、2-D グラフ、面グラフ、横棒グラフ、縦棒グラフ、折れ線グラフ、株価チャート、散布図、またはバブル チャートでは、近似曲線または移動平均を追加するデータ系列をクリックするか、次のいずれかを行ってグラフ要素の一覧からデータ系列を選択します。

    1. グラフ内の任意の場所をクリックします。

      [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

    2. [書式] タブの [現在の選択範囲] で [グラフの要素] ボックスの横にある矢印をクリックし、目的のグラフの要素をクリックします。

      [レイアウト] タブの [現在の選択範囲] グループ ([グラフ ツール])

  2. 注: データ系列を選択せずに複数のデータ系列を含むグラフを選択すると、Excel に [近似曲線の追加] ダイアログ ボックスが表示されます。 一覧のボックスで、目的のデータ系列をクリックして、[OK] をクリックします。

  3. [レイアウト] タブの [分析] グループで、[近似曲線] をクリックします。

    [レイアウト] タブの [分析] グループ ([グラフ ツール])

  4. 次のいずれかの操作を行います。

    1. 使用する定義済みの近似曲線オプションをクリックします。

      注: これにより、近似曲線が適用されますが、特定のオプションの選択はできません。

    2. [その他の近似曲線オプション] をクリックし、[近似曲線のオプション] カテゴリの [近似または回帰の種類] で、使用する近似曲線の種類をクリックします。

    使用する種類

    作成されるもの

    線形

    線形近似曲線。次の式に基づいて直線に対する最小二乗適合の計算が行われます。

    数式

    ただし m は傾き、b は切片です。

    対数近似

    対数近似曲線。次の式に基づいて複数のポイントに対する最小二乗適合の計算が行われます。

    数式

    ただし、cb は定数、In は自然対数関数です。

    多項式近似

    多項式近似曲線。次の式に基づいて複数のポイントに対する最小二乗適合の計算が行われます。

    数式

    ただし、b変数 は定数です。

    べき乗

    べき乗近似曲線。次の式に基づいて複数のポイントに対する最小二乗適合の計算が行われます。

    数式

    ただし、cb は定数です。

    注: データに負の値または 0 が含まれている場合、このオプションは使用できません。

    指数

    指数近似曲線。次の式に基づいて複数のポイントに対する最小二乗適合の計算が行われます。

    数式

    ただし、cb は定数、e は自然対数の底です。

    注: データに負の値または 0 が含まれている場合、このオプションは使用できません。

    移動平均

    移動平均の近似曲線。次の式を使用します: 数式

    注: 移動平均の近似曲線上のポイント数は、区間として指定した要素数をデータ系列全体の要素数から引いた値に等しくなります。

    R-2 乗値

    グラフに R-2 乗値を表示する近似曲線。次の式を使用します:

    数式

    この近似曲線は [近似曲線の追加] の [オプション] タブまたは [近似曲線の書式設定] ダイアログ ボックスで設定できます。

    注: 近似曲線に表示できる R-2 乗値は、調整された R-2 乗値ではありません。 対数近似曲線、べき乗近似曲線、指数近似曲線では、変換された回帰モデルが使用されます。

    • [多項式近似] を選択した場合は、[次数] ボックスに独立変数の最大の次数を入力します。

    • [移動平均] を選択した場合は、移動平均の計算に使用する区間の数を [区間] ボックスに入力します。

    • 移動平均を散布図に追加する場合、移動平均はグラフで x の値をプロットする順序に基づいて計算されます。 目的の結果を得るために、移動平均を追加する前に x 値の並べ替えが必要になる場合があります。

    • 折れ線、縦棒、面、横棒のグラフに近似曲線を追加する場合、近似曲線は x の値が 1、2、3、4、5、6... であるという前提に基づいて計算されます。 この前提は x の値が数値か文字列かで行われます。 近似曲線の x の値を数値とする場合は、散布図を使用する必要があります。

    • Excel によって近似曲線に自動的に名前が割り当てられますが、これは変更することができます。 [近似曲線の書式設定] ダイアログ ボックスの [近似曲線のオプション] カテゴリで [近似曲線名] で、[カスタム] をクリックし、[カスタム] ボックスに名前を入力します。

ヒント: 

  • データの変動が滑らかになるため、パターンや傾向がより明確に示される移動平均も作成できます。

  • グラフの種類を 3-D グラフに変更したり、ピボットグラフ レポートまたは関連するピボットテーブル レポートのビューを変更したりして、関連する近似曲線をサポートしないようにグラフまたはデータ系列を変更すると、近似曲線がグラフに表示されなくなります。

  • グラフのない行データの場合、オートフィルまたは GROWTH() や TREND() などの統計関数のいずれかを使用して、最適な線形近似または指数曲線のデータを作成することができます。

  1. 非積み上げグラフ、2-D グラフ、面グラフ、横棒グラフ、縦棒グラフ、折れ線グラフ、株価チャート、散布図、またはバブル チャートでは、変更する近似曲線をクリックするか、次のいずれかを行ってグラフ要素の一覧から近似曲線を選択します。

    1. グラフ内の任意の場所をクリックします。

      [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

    2. [書式] タブの [現在の選択範囲] で [グラフの要素] ボックスの横にある矢印をクリックし、目的のグラフの要素をクリックします。

      [レイアウト] タブの [現在の選択範囲] グループ ([グラフ ツール])

  2. [レイアウト] タブの [分析] グループで [近似曲線] をクリックし、[その他の近似曲線オプション] をクリックします。

    [レイアウト] タブの [分析] グループ ([グラフ ツール])

  3. 近似曲線の色、スタイル、または影のオプションを変更するには、[線の色]、[線のスタイル]、または [] のカテゴリをクリックして、目的のオプションを選択します。

  1. 非積み上げグラフ、2-D グラフ、面グラフ、横棒グラフ、縦棒グラフ、折れ線グラフ、株価チャート、散布図、またはバブル チャートでは、変更する近似曲線をクリックするか、次のいずれかを行ってグラフ要素の一覧から近似曲線を選択します。

    1. グラフ内の任意の場所をクリックします。

      [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

    2. [書式] タブの [現在の選択範囲] で [グラフの要素] ボックスの横にある矢印をクリックし、目的のグラフの要素をクリックします。

      [レイアウト] タブの [現在の選択範囲] グループ ([グラフ ツール])

  2. [レイアウト] タブの [分析] グループで [近似曲線] をクリックし、[その他の近似曲線オプション] をクリックします。

    [レイアウト] タブの [分析] グループ ([グラフ ツール])

  3. 予測に含める区間の数を指定するには、[予測] で、[次区間] または [前区間] ボックスの数字をクリックします。

  1. 非積み上げグラフ、2-D グラフ、面グラフ、横棒グラフ、縦棒グラフ、折れ線グラフ、株価チャート、散布図、またはバブル チャートでは、変更する近似曲線をクリックするか、次のいずれかを行ってグラフ要素の一覧から近似曲線を選択します。

    1. グラフ内の任意の場所をクリックします。

      [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

    2. [書式] タブの [現在の選択範囲] で [グラフの要素] ボックスの横にある矢印をクリックし、目的のグラフの要素をクリックします。

      [レイアウト] タブの [現在の選択範囲] グループ ([グラフ ツール])

  2. [レイアウト] タブの [分析] グループで [近似曲線] をクリックし、[その他の近似曲線オプション] をクリックします。

    [レイアウト] タブの [分析] グループ ([グラフ ツール])

  3. [切片 =] チェック ボックスを選択して、[切片 =] ボックスに、近似曲線が軸と交わる縦 (値) 軸のポイントを値を入力して指定します。

    注: これは指数、線形、または多項式の近似曲線を使用する場合にのみ行うことができます。

  1. 非積み上げグラフ、2-D グラフ、面グラフ、横棒グラフ、縦棒グラフ、折れ線グラフ、株価チャート、散布図、またはバブル チャートでは、変更する近似曲線をクリックするか、次のいずれかを行ってグラフ要素の一覧から近似曲線を選択します。

    1. グラフ内の任意の場所をクリックします。

      [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

    2. [書式] タブの [現在の選択範囲] で [グラフの要素] ボックスの横にある矢印をクリックし、目的のグラフの要素をクリックします。

      [レイアウト] タブの [現在の選択範囲] グループ ([グラフ ツール])

  2. [レイアウト] タブの [分析] グループで [近似曲線] をクリックし、[その他の近似曲線オプション] をクリックします。

    [レイアウト] タブの [分析] グループ ([グラフ ツール])

  3. グラフに近似曲線の式を表示するには、[グラフに数式を表示する] チェック ボックスを選択します。

    注: 移動平均の近似曲線の式を表示することはできません。

ヒント: 近似曲線の数式は、読みやすくするために丸められます。 ただし、[近似曲線ラベルの書式設定] ダイアログボックスの [数値] タブにある [小数点以下の桁数] ボックスで、選択した近似曲線ラベルの桁数を変更することができます。 ([書式] タブの [現在の選択範囲] グループの [書式の選択] ボタン)。

  1. 非積み上げグラフ、2-D グラフ、面グラフ、横棒グラフ、縦棒グラフ、折れ線グラフ、株価チャート、散布図、またはバブル チャートでは、R-2 乗値を表示する近似曲線をクリックするか、次のいずれかを行ってグラフ要素の一覧から近似曲線を選択します。

    1. グラフ内の任意の場所をクリックします。

      [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

    2. [書式] タブの [現在の選択範囲] で [グラフの要素] ボックスの横にある矢印をクリックし、目的のグラフの要素をクリックします。

      [レイアウト] タブの [現在の選択範囲] グループ ([グラフ ツール])

  2. [レイアウト] タブの [分析] グループで [近似曲線] をクリックし、[その他の近似曲線オプション] をクリックします。

    [レイアウト] タブの [分析] グループ ([グラフ ツール])

  3. [その他の近似曲線オプション] タブで、[グラフに R-2 乗値を表示する] を選択します。

注: 移動平均の R-2 乗値は表示できません。

  1. 非積み上げグラフ、2-D グラフ、面グラフ、横棒グラフ、縦棒グラフ、折れ線グラフ、株価チャート、散布図、またはバブル チャートでは、削除する近似曲線をクリックするか、次のいずれかを行ってグラフ要素の一覧から近似曲線を選択します。

    1. グラフ内の任意の場所をクリックします。

      [グラフ ツール] が表示され、[デザイン]、[レイアウト]、[書式] の各タブが表示されます。

    2. [書式] タブの [現在の選択範囲] で [グラフの要素] ボックスの横にある矢印をクリックし、目的のグラフの要素をクリックします。

      [レイアウト] タブの [現在の選択範囲] グループ ([グラフ ツール])

  2. 次のいずれかの操作を行います。

    1. [レイアウト] タブの [分析] で [近似曲線] をクリックし、[なし] をクリックします。

      [レイアウト] タブの [分析] グループ ([グラフ ツール])

    2. Del キーを押します。

ヒント: グラフに追加した近似曲線は、クイックアクセスツールバーの [元に戻す ] をクリックするか、CTRL キーを押しながら Z キーを押して、すぐに削除することもできます。

近似曲線を追加する

  1. [表示] メニューの [印刷レイアウト] をクリックします。

  2. 近似曲線を追加するデータ系列をグラフから選び、[グラフデザイン] タブをクリックします。 

    たとえば、折れ線グラフの場合、グラフ内の折れ線のいずれかをクリックすると、そのデータ系列のすべてのデータ マーカーが選択されます。

    [グラフデザイン] タブ

  3. [グラフデザイン] タブで [グラフ要素を追加] をクリックし、[近似曲線] をクリックします。

    近似曲線を追加する

  4. [近似曲線] オプションを選択するか、[その他の近似曲線オプション] をクリックします。

    [近似曲線] のオプション

    次のいずれかを選ぶことができます。

    • 指数

    • 線形

    • 対数近似

    • 多項式近似

    • 仕事率

    • 移動平均

    また、近似曲線の名前を指定し、[予測] オプションを選択することもできます。

近似曲線を削除する

  1. [表示] メニューの [印刷レイアウト] をクリックします。

  2. 近似曲線のあるグラフをクリックし、[グラフデザイン] タブをクリックします。

    [グラフデザイン] タブ

  3. [グラフ要素を追加] をクリックし、[近似曲線] をクリックして、[なし] をクリックします。

    線を削除する

    近似曲線をクリックして Delete キーを押すこともできます。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

関連項目

Office の [近似曲線] オプション

グラフの作成を開始する

グラフの要素の書式を設定する

グラフにデータラベルを追加する

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×