カタログ データの差し込みを作成する

この記事は皆様からのフィードバックを受け付けています。頂いたコメントは、担当編集者が確認し、記事に修正を加えたうえで、最終版の記事を作成します。コメントをお送りいただくには、この記事の末尾の [はい] または [いいえ] をクリックし、ご感想やご希望を入力してください。ご協力をお待ちしています。

Publisher には、短いカタログの作成に使用できるテンプレートが付属しています。カタログ テンプレートを選択し、プレースホルダ画像を独自の画像で置き換え、任意のテキストを入力するだけで、カタログを作成できます。

長いカタログを作成する場合は、カタログ データの差し込みを使用できます。カタログ データの差し込みを使用して、ディレクトリやフォト アルバムなど、1 ページに 1 つ以上のアイテムが表示される文書を作成することもできます。カタログ データの差し込みの操作方法は、Microsoft Office の [カタログ データの差し込み] 作業ウィンドウに順を追って表示されます。

この記事の内容

カタログ データの差し込みのしくみ

カタログを設計する

テンプレートを作成する

データ ソースに接続する

差し込みフィールドを挿入する

カタログ文書を完了、印刷、および保存する

カタログ データの差し込みのしくみ

カタログ データの差し込みは、差し込み印刷に似ています。カタログ データの差し込みを使用するときは、まずカタログ データの差し込みテンプレートを作成し、次にそのテンプレートにデータ ソースの情報を組み込んで、差し込みページを生成します。

Data source combined with a merge template to generate pages for a publication

1. アイテム名や説明などのレコード情報を持つデータ ソース。

2. カタログ データの差し込み領域と、レコード情報のプレースホルダとなる差し込みフィールドを持つ、カタログ データの差し込みテンプレート。

3. 1 ページに複数のレコードが表示された差し込み後のページ。

カタログ データの差し込みは、新しい文書として保存したり、既存の文書の最後に追加したりできます。カタログ データの差し込みテンプレートを保存しておくと、データ ソースの情報を更新した場合にそのテンプレートを再び使用して、差し込みページを追加で作成できます。

準備

カタログ データの差し込みを正しく行うには、次のヒントが役立ちます。

  • カタログ データの差し込みは、新しい文書で開始します。

  • カタログ データの差し込みテンプレートの長さは、1 ページに制限します。

  • 最終的な差し込みページのページ サイズに合わせて、カタログ データの差し込みテンプレートのページ サイズを設定します。

  • 作成した差し込みページを既存の文書の最後に追加する場合は、カタログ データの差し込みテンプレートが次の点で既存の文書と一致していることを確認します。

    • ページ サイズ (高さと幅)

    • ページ ビュー (1 ページまたは見開き 2 ページ)

    • 文書の種類 (Web 形式または印刷形式)

    • ページの順番 (左から右または右から左)

ページの先頭へ

カタログを設計する

カタログ データの差し込みを開始する前に、最終的な差し込みページに出力する情報の種類を検討します。

  • アイテムの名前と価格を表示するかどうか。

  • 各アイテムの説明を含めるかどうか。

  • 各アイテムの画像を含めるかどうか。

データ ソースを計画する

カタログに含める情報の種類を決定したら、カタログ データの差し込みに使用するデータ ソースを作成できます。データ ソースが既にある場合は、差し込みに含めるすべての情報が含まれていることを確認します。

[カタログ データの差し込み] 作業ウィンドウでは、さまざまな形式のデータ ソースを使用できます。差し込みに使用するデータ ソースがない場合は、Publisher で生成できます。Microsoft Office Excel のワークシートや Microsoft Office Word の表を使ってデータ ソースを作成することもできます。

データ ソースに含めるdata fieldは、カタログ データの差し込みテンプレートに挿入するmerge fieldに対応します。

データ ソースを準備するときは、アイテム名、在庫番号、価格などの情報の種類ごとに列を作成します。それぞれの行 (レコード) は、1 つのアイテムの情報に対応します。

重要: 差し込む情報の種類ごとに、対応するデータ フィールド (列) がデータ ソースに含まれていることを確認してください。データ ソースの種類によっては、Publisher でデータ ソースに接続した後でもデータ ソースに変更を加えることができますが、この時点で情報を確定しておくことをお勧めします。

カタログ ページに写真を差し込む場合は、使用する各画像ファイルのpathの列を含める必要があります。実際の画像やイメージはデータ ソースに含めないでください。

Publisher でデータ ソースを作成する場合は、テンプレートを作成した後にデータ ソースを作成できます。

ページの先頭へ

テンプレートを作成する

この手順では、カタログ データの差し込みテンプレートを作成し、最終的な差し込みページのレイアウトをデザインできます。差し込みが完了したら、カタログ データの差し込みテンプレートを使用して差し込みページを生成し、そのページを新しい文書として保存するか、既存の文書の最後に追加できます。

カタログ データの差し込みテンプレートのレイアウト (ページのサイズと向き) は、最終的な差し込みページに使用するものと同じにする必要があります。また、背景の画像や会社の名前など、最終的な文書の各ページに表示するテキストやグラフィックスも含める必要があります。

差し込みページを既存の文書の最後に追加する場合は、カタログ データの差し込みテンプレートが次の点で既存の文書と一致していることを確認します。

  • ページ サイズ (高さと幅)

  • ページ ビュー (1 ページまたは見開き 2 ページ)

  • 文書の種類 (Web 形式または印刷形式)

  • ページの順番 (左から右または右から左)

カタログ データの差し込みテンプレートを作成する

  1. [ファイル] メニューの [新規作成] をクリックします。

  2. [新しい文書] 作業ウィンドウで、[白紙のページ サイズ] をクリックし、使用するサイズを選択します。

    注: カタログを Web サイトに投稿する場合は、[白紙のページ サイズ] の [Web サイト] をクリックし、目的の画面解像度に一致するサイズをクリックします。

  3. [作成] をクリックします。

  4. [ファイル] メニューの [ページ設定] をクリックします。

  5. [ページ設定] ダイアログ ボックスで、必要に応じて余白に変更を加え、[OK] をクリックします。

  6. [ツール] メニューの [宛名/カタログ] をポイントし、[カタログ データの差し込み] をクリックします。

ページの先頭へ

データ ソースに接続する

カタログ データの差し込みテンプレート ページの書式を設定したら、[カタログ データの差し込み] 作業ウィンドウを使用して、データ ソースを作成または指定して接続します。次に選択するオプションは、データ ソースが既にあるかどうか、または Publisher で新しいリストを作成するかどうかによって変わります。

  1. [カタログ データの差し込み] 作業ウィンドウの [製品リストの選択] で、次のいずれかの操作を行います。

  2. [次: アドレス帳の作成、またはアドレス帳に接続] をクリックします。

既存のリストを使用する

  1. [データ ソースの選択] ダイアログ ボックスで、使用するデータ ソースを探してクリックします。

    既定では、データ ソースは [My Data Sources] フォルダに保存されています。必要に応じて [My Data Sources] フォルダを参照して、データ ソースを探します。

  2. [開く] をクリックします。

    選択したデータ ソースの種類によっては、特定の情報の入力を求める別のダイアログ ボックスが表示される場合があります。たとえば、選択したデータ ソースが複数のタブを含む Excel ワークシートの場合、必要な情報が含まれるタブを選択してから [OK] をクリックする必要があります。

Outlook 連絡先から選択する

  1. 次のいずれかを実行します。

    • [連絡先の選択] ダイアログ ボックスで、使用する連絡先のリストをクリックします。

    • [プロファイルの選択] ダイアログ ボックスで、使用する連絡先の正しいプロファイルを選択します。

  2. [OK] をクリックします。

新しいリストを入力する

  1. [新しい製品リスト] ダイアログ ボックスで、カタログに含める最初のアイテムまたはレコードの情報を入力します。

    画像を含めない場合など、列を追加または削除するには、[列のカスタマイズ] をクリックし、必要な変更を加えます。

  2. 最初のレコードの情報をすべて入力したら、[新しいエントリ] をクリックし、次のレコードの情報を入力します。この操作を続けて、カタログに含めるすべてのレコードの情報を入力します。

  3. 新しいリストの入力が完了したら、[OK] をクリックします。

  4. [アドレス帳の保存] ダイアログ ボックスで、新しいリストの名前を入力し、[保存] をクリックします。

リストを追加する

カタログ データの差し込みで複数のリストを使用する場合は、リストを追加できます。

  1. [カタログ データ差し込みの対象製品リスト] の [製品リストに追加] で、作成中の文書に応じて、[既存のリストを選択] または [Outlook 連絡先から選択] をクリックします。

アイテムを追加する

少数のアイテムを追加する場合は、それらの新しいアイテムのリストを作成し、既に選択したリストに結合できます。

  1. [カタログ データ差し込みの対象製品リスト] の [製品リストに追加] で、[新しいリストの入力] をクリックします。

  2. [新しい製品リスト] ダイアログ ボックスで、カタログに含める最初のアイテムの情報を入力します。

    使用する他のリストと一致するように列を追加または削除するには、[列のカスタマイズ] をクリックし、必要な変更を加えます。

  3. 最初のレコードの情報をすべて入力したら、[新しいエントリ] をクリックし、次のレコードの情報を入力します。この操作を続けて、カタログに含めるすべてのレコードの情報を入力します。

  4. 新しいリストの入力が完了したら、[OK] をクリックします。

  5. [アドレス帳の保存] ダイアログ ボックスで、新しいリストの名前を入力し、[保存] をクリックします。

  6. [カタログ データ差し込みの対象製品リスト] ダイアログ ボックスの [データ ソース] に、新しいリストが自動的に表示されます。

カタログに含めるレコードを選択する

  1. [カタログ データ差し込みの対象製品リスト] ダイアログ ボックスで、次のいずれかの操作を行います。

    • カタログに含めるレコードの横のチェック ボックスをオンにし、カタログから除外するレコードの横のチェック ボックスをオフにします。

      ヒント: リスト内の少数のレコードのみを含める場合は、[すべてクリア] をクリックしてから、含めるレコードを選択します。

    • 特定の条件に基づいてリストにフィルタを適用するには、フィルタを適用するアイテムの列見出しの横にある矢印をクリックし、フィルタとして使用する値をクリックします。

      • [(データなし)] をクリックすると、対応するフィールドが空白のレコードがすべて表示されます。

      • [(データあり)] をクリックすると、対応するフィールドにデータが含まれているレコードがすべて表示されます。

        注: 同じデータを共有するレコードがデータ ソースに含まれていて、その列に 10 個程度の一意の値がある場合は、特定の情報でフィルタをかけることができます。たとえば、データ ソースが売上のプロパティのリストで、市区町村が神奈川県のプロパティ レコードが複数あるとすると、"神奈川県" でフィルタをかけることができます。

        [カタログ データ差し込みの対象製品リスト] ダイアログ ボックスに、指定されたレコードのみが表示されます。すべてのレコードを表示するには、[(すべて)] をクリックします。

    • リストのアイテムを並べ替えるには、並べ替えの基準とするアイテムの列見出しをクリックします。たとえば、市区町村を基準に五十音順で表示する場合は、[市区町村] の列見出しをクリックします。

  2. [OK] をクリックすると、[カタログ データの差し込み] 作業ウィンドウに戻ります。指定されたレコードが差し込みに使用されます。

  3. [次: 文書の準備] をクリックします。

ページの先頭へ

差し込みフィールドを挿入する

ここでは、文書に表示する情報を配置します。ページをレイアウトするには、カタログ データの差し込み領域に差し込みフィールドを追加します。各差し込みフィールドはデータ ソースの列を表し、カタログ データの差し込み領域には、1 つのレコードの情報がどのように表示されるかが示されます。

思いどおりにカタログ データの差し込み領域を配置したら、各ページで差し込み領域を繰り返す回数を指定します。たとえば、各ページに 4 つのアイテムを表示するとします。それぞれのアイテムは、カタログ データの差し込み領域の配置方法に基づいて同じように表示されます。各アイテムのサイズの調整や、カタログ データの差し込み領域のサイズ変更を行うことができます。

重要:  差し込みフィールドをカタログ データの差し込み領域の外側に挿入すると、差し込みを実行しても差し込みフィールドは繰り返されません。

カタログ データの差し込み領域に差し込みフィールドを挿入する

  • [カタログ データの差し込み] 作業ウィンドウの [文書の準備] で、挿入する最初の差し込みフィールドをクリックします。

  • カタログ データの差し込み領域で、差し込みフィールドを選択し、次の操作を行って、差し込みフィールドの位置とサイズを変更します。

    • 差し込みフィールドを移動するには、差し込みフィールドの上にマウス ポインタを移動し、ポインタが 移動ポインター (移動ポインタ) に変わったら、差し込みフィールドを新しい位置にドラッグします。

    • 差し込みフィールドのサイズを変更するには、テキスト ボックスまたは図枠のhandleの 1 つの上にマウス ポインタを移動し、ポインタが move ruler (サイズ変更ポインタ) に変わったら、マウスをドラッグしてテキスト ボックスまたは図枠を目的のサイズにします。

  • 差し込みフィールドの外側をクリックして、差し込みフィールドの選択を解除します。

  • 手順 1. ~ 3. を繰り返して、データ ソースから必要なフィールドをすべて挿入します。

    前に挿入した差し込みフィールドを選択した状態で新しい差し込みフィールドを挿入すると、前に挿入した差し込みフィールドと同じ場所に新しい差し込みフィールドが挿入されます。

差し込みフィールドの書式を設定する

カタログ データの差し込みテンプレートで差し込みフィールドの書式を設定すると、差し込まれたカタログ データの書式を設定できます。

  1. カタログ データの差し込みテンプレートで、書式を設定する情報が含まれているフィールドを、前後の差し込みフィールド文字 («« »») ごと選択します。

  2. [書式] メニューの [フォント] をクリックし、必要なオプションを選択します。

カタログ データの差し込み領域の位置またはサイズを変更する

書式を設定した差し込みフィールドがカタログ データの差し込み領域に収まらなくなった場合は、差し込み領域のサイズを変更できます。

注: サイズを大きくすると、各ページに含めるアイテム (レコード) の数を減らすことが必要になる場合があります。

  1. カタログ データの差し込み領域をクリックして選択します。

  2. カタログ データの差し込み領域のhandleの 1 つにマウス ポインタを合わせ、マウスをドラッグします。

  3. 各ページに表示されるアイテム数を指定するには、[カタログ データの差し込みのレイアウト] ツールバーで、ページの縦および横に配置するアイテムの数を入力します。

テンプレートを完了してプレビュー表示する

  1. データ ソースからの情報の横に表示するテキストや情報があれば入力します。たとえば、価格の差し込みフィールドの横に通貨記号を追加します。

  2. [ページのプレビュー] の矢印をクリックすると、差し込みデータの各ページが表示されます。

    いずれかのアイテムを含めないようにする場合は、そのアイテムが挿入されているカタログ データの差し込み領域をクリックし、[カタログ データの差し込み] 作業ウィンドウの [このアイテムを除外する] をクリックします。

  3. 次へ進む準備ができたら、[次: 差し込み文書の作成] をクリックします。

ページの先頭へ

カタログ文書を完了、印刷、および保存する

差し込みを完了するには、3 つのオプションがあります。

  • 差し込み文書を直接印刷する。

  • 差し込まれたコンテンツを含む新しい文書を作成および印刷する。Publisher で他の文書を変更する場合と同じように、この文書のコンテンツに変更を加えることができます。

  • 差し込まれたコンテンツを既存の文書に追加する。

文書に表紙と裏表紙を追加したり、他のページを追加したりする場合は、新しい文書を作成するか、コンテンツを既存の文書に追加する必要があります。

差し込み文書を印刷する

  • [カタログ データの差し込み] 作業ウィンドウで、[印刷] をクリックします。

    差し込みページが印刷されます。

新しい文書に差し込む

差し込みページを編集する場合、後で使用できるように保存する場合、または後で印刷する場合は、差し込みページをすべて集め、差し込みフィールドではなく、製品名や価格などの実際のデータを含む 1 つの新しい差し込み文書として保存できます。

  • [カタログ データの差し込み] 作業ウィンドウで、[新しい文書への差し込み] をクリックします。

    保存および編集できる新しい文書が作成されます。表紙と裏表紙のページを追加することもできます。

    注: カタログを小冊子として印刷する場合は、ページの合計数が 4 の倍数になるようにします。

  • [カタログ データの差し込み] 作業ウィンドウで、[この文書の保存] をクリックします。

  • [ファイル名] ボックスに新しい文書の名前を入力し、[保存] をクリックします。

  • 必要に応じて、カタログ データの差し込みテンプレートに加えた変更を保存します。データ ソースの情報を更新した場合は、このカタログ データの差し込みテンプレートを再び使用して、差し込みページを追加で作成できます。

既存の文書に追加する

既に表紙が別の文書として準備されている場合や、別の長い文書の最後にカタログを配置する場合は、差し込んだコンテンツを直接追加できます。

差し込みページを既存の文書の最後に追加する前に、カタログ データの差し込みテンプレートが次の点で既存の文書と一致していることを確認します。

  • ページ サイズ (高さと幅)

  • ページ ビュー (1 ページまたは見開き 2 ページ)

  • 文書の種類 (Web 形式または印刷形式)

  • ページの順番 (左から右または右から左)

注: Publisher では、開いている文書に差し込みページを追加することはできません。差し込み先の文書で作業している場合は、差し込みを完了する前に、その文書を保存して閉じてください。

  1. [カタログ データの差し込み] 作業ウィンドウで、[既存の文書へ追加] をクリックします。[文書を開く] ダイアログ ボックスで、差し込みページを追加する文書を探して選択し、[開く] をクリックします。

    差し込みページが既存の文書の最後に追加されます。

    ヒント: 更新された文書でページを再配置するには、ページの並べ替えアイコン上で移動するページをクリックし、目的の場所にドラッグします。

  2. 既存の文書で、[ファイル] メニューの [上書き保存] をクリックして更新内容を保存します。

  3. 必要に応じて、カタログ データの差し込みテンプレートに加えた変更を保存します。データ ソースの情報を更新した場合は、このカタログ データの差し込みテンプレートを再び使用して、差し込みページを追加で作成できます。

カタログ文書を印刷して保存する

新しい差し込み文書を作成した場合、またはカタログ データの差し込みを既存の文書に追加した場合、[ファイル] メニューの [印刷] をクリックして文書を印刷できます。

カタログ文書を小冊子として印刷する

  1. [ファイル] メニューの [ページ設定] をクリックします。

  2. [余白ガイド] の [詳細設定] をクリックします。

  3. [レイアウトの種類] の [小冊子] をクリックします。

  4. [ページ] で、[] と [高さ] の設定が文書の元のサイズと一致するように調整します。

    重要: ページの幅と高さを調整しないと、Publisher によって元のページ サイズに小冊子の 2 ページが配置されますが、カタログはこのサイズに収まりません。

再び使用できるようにテンプレートを保存する

カタログ データの差し込みテンプレートは保存しておくと便利です。データ ソースの情報を更新した場合は、このカタログ データの差し込みテンプレートを再び使用して、差し込みページを追加で作成できます。カタログ データの差し込み文書を保存するには、次の操作を行います。

  1. カタログ データの差し込み文書が表示されていることを確認します。

  2. [ファイル] メニューの [上書き保存] をクリックします。

  3. カタログ データの差し込み文書に名前を付け、[保存] をクリックします。

ページの先頭へ

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×