カタログ データの差し込みを作成する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Publisher では、データベース、スプレッドシート、テキスト ファイルなどのデータ ソースに接続し、そのデータを使用して製品やサービスのカタログを簡単に作成できます。カタログ データの差し込みを使用して、ディレクトリやフォト アルバムなど、各ページに 1 つ以上のアイテムが表示される文書を作成することもできます。

カタログ データの差し込みのしくみ

カタログを設計する

テンプレート文書を作成する

データ ソースに接続する

差し込み印刷フィールドを挿入する

カタログ文書を完了、印刷、および保存する

カタログ データの差し込みのしくみ

カタログ データの差し込みは、差し込み印刷に似ています。カタログ データの差し込みを使用するときは、まずカタログ データの差し込みテンプレート文書を作成し、次にそのテンプレートにデータ ソースの情報を組み込んで、差し込みページを生成します。

データ ソースと差し込みテンプレートが組み合わされ、カタログ ページが生成される

1 アイテム名や説明などのレコード情報を持つデータ ソース。

2 カタログ データの差し込み領域と、レコード情報のプレースホルダーとなる差し込み印刷フィールドを持つ、カタログ データの差し込みテンプレート文書。

3 ページに複数のレコードが表示された差し込み後のページ。

カタログ データの差し込みは、新しい文書として保存したり、既存の文書の最後に追加したりできます。カタログ データの差し込みテンプレートを保存しておくと、データ ソースの情報を更新した場合にそのテンプレートを再び使用して、差し込みページを追加で作成できます。

準備

カタログ データの差し込みを正しく行うには、次のヒントが役立ちます。

  • カタログ データの差し込みは、新しい文書で開始します。

  • 差し込みを行う文書を作成したら、カタログが複数ページになる場合でも、表紙、目次、注文書などのページに加えて、差し込み印刷フィールド用に 1 ページを割り当てます。

  • 最終的な差し込みページのページ サイズに合わせて、カタログ データの差し込みテンプレートのページ サイズを設定します。

  • 作成した差し込みページを既存の文書の最後に追加する場合は、カタログ データの差し込みテンプレートが次の点で既存の文書と一致していることを確認します。

    • ページ サイズ (高さと幅)

    • ページ ビュー (1 ページまたは見開き 2 ページ)

    • 文書の種類 (Web 用または印刷用)

    • ページの順序 (左から右、または右から左)

ページの先頭へ

カタログを設計する

カタログ データの差し込みを開始する前に、最終的な差し込みページに出力する情報の種類を検討します。

  • アイテムの名前と価格を表示するかどうか。

  • 各アイテムの説明を含めるかどうか。

  • 各アイテムの画像を含めるかどうか。

データ ソースを計画する

カタログに含める情報の種類を決定したら、カタログ データの差し込みに使用するデータ ソースを作成できます。データ ソースが既にある場合は、差し込みに含めるすべての情報が含まれていることを確認します。

Publisher のカタログ データの差し込みでは、さまざまな形式のデータ ソースを使用できます。差し込みに使用するデータ ソースがない場合は、Publisher で生成できます。Microsoft Office Excel のワークシートや Microsoft Office Word の表を使ってデータ ソースを作成することもできます。

データ ソースに含めるデータ フィールドは、カタログ データの差し込みテンプレートに挿入する差し込み印刷フィールドに対応します。

データ ソースを準備するときは、アイテム名、在庫番号、価格などの情報の種類ごとに列を作成します。それぞれの行 (レコード) は、1 つのアイテムの情報に対応します。

 重要  差し込む情報の種類ごとに、対応するデータ フィールド (列) がデータ ソースに含まれていることを確認してください。データ ソースの種類によっては、Publisher でデータ ソースに接続した後でもデータ ソースに変更を加えることができますが、この時点で情報を確定しておくことをお勧めします。

カタログ ページに写真を差し込む場合は、使用する各画像ファイルのパスの列を含める必要があります。実際の画像やイメージはデータ ソースに含めないでください。

Publisher でデータ ソースを作成する場合、テンプレート文書を作成した後にデータ ソースを作成できます。

ページの先頭へ

テンプレート文書を作成する

ここでは、カタログ データの差し込みテンプレート文書を作成し、最終的な差し込みページのレイアウトをデザインできます。差し込みが完了したら、このカタログ データの差し込みテンプレートを使用して差し込みページを生成し、そのページを新しい文書として保存するか、既存の文書の最後に追加できます。

カタログ データの差し込みテンプレートのレイアウト (ページのサイズと向き) は、最終的な差し込みページに使用するものと同じにする必要があります。また、背景の画像や会社の名前と電話番号など、最終的な文書の各ページに表示するテキストやグラフィックスも含める必要があります。そのためには、差し込みテンプレートのこれらの要素の [マスター ページ] を使用することをお勧めします。

差し込みページを既存の文書の最後に追加する場合は、カタログ データの差し込みテンプレートが次の点で既存の文書と一致していることを確認します。

  • ページ サイズ (高さと幅)

  • ページ ビュー (1 ページまたは見開き 2 ページ)

  • 文書の種類 (Web 用または印刷用)

  • ページの順序 (左から右、または右から左)

カタログ データの差し込みテンプレートを作成する

  1. カタログに適した文書テンプレートを選択します。

  2. [挿入] タブの [カタログ ページ]
    カタログ ページの差し込み印刷を開始する をクリックします。

  3. カタログ ページは既定の [差し込み印刷領域] で作成され、リボンに [カタログ ツール] タブが表示されます。この時点では、ページに思いどおりに [差し込み印刷領域 ] を配置し、カタログの各ページに表示する任意のテキストまたは画像を追加できます。差し込み領域が小さいほど、ページに差し込まれるカタログ アイテムが多くなります。たとえば、5 cm × 5 cm の差し込み領域は、10 cm × 10 cm の差し込み領域よりも多く繰り返されます。いつでもこれらのアイテムに戻って編集できるため、正確さにはそれほどこだわる必要はありません。

     ヒント   差し込み領域の構成は、この時点ではなく、差し込み印刷フィールドを挿入し、レイアウト ギャラリーから事前に作成されたデザインの 1 つを使用するときに行います。

ページの先頭へ

データ ソースに接続する

カタログ データの差し込みテンプレート ページの書式を設定したら、データ ソースを作成または指定して接続します。次に選択するオプションは、データ ソースが既にあるかどうか、または Publisher で新しいリストを作成するかどうかによって変わります。

  1. [カタログ ツール] タブの [リストの追加] をクリックし、次のいずれかの操作を行います。

    • 差し込みに使用するデータ ソースを作成する必要がある場合は、[新しいリストの入力] をクリックします。

    • 使用するデータ ソースが既にある場合は、[既存のリストを使用] をクリックします。

    • 連絡先のディレクトリを作成する場合は、[Outlook の連絡先から選択] をクリックします。

新しいリストを入力する

  1. [新しい製品リスト] ダイアログ ボックスで、カタログに含める最初のアイテムまたはレコードの情報を入力します。

    画像を含めない場合など、列を追加または削除するには、[列のカスタマイズ] をクリックし、必要な変更を行います。

  2. 最初のレコードの情報をすべて入力したら、[新しいエントリ] をクリックし、次のレコードの情報を入力します。この操作を続けて、カタログに含めるすべてのレコードの情報を入力します。

  3. 新しいリストの入力が完了したら、[OK] をクリックします。

  4. [アドレス帳の保存] ダイアログ ボックスで新しいリストの名前を入力し、[保存] をクリックします。

既存のリストを使用する

  1. [データ ソースの選択] ダイアログ ボックスで、使用するデータ ソースを探してクリックします。

    既定では、データ ソースは [My Data Sources] フォルダーに保存されています。必要に応じて [My Data Sources] フォルダーを参照して、データ ソースを探します。

  2. [開く] をクリックします。

    選択したデータ ソースの種類によっては、特定の情報の入力を求める別のダイアログ ボックスが表示される場合があります。たとえば、選択したデータ ソースが複数のタブを含む Excel ワークシートの場合、必要な情報が含まれるタブを選択してから [OK] をクリックする必要があります。

Outlook 連絡先から選択する

  1. 次の操作のいずれかを行います。

    • [連絡先の選択] ダイアログ ボックスで、使用する連絡先のリストをクリックします。

    • [プロファイルの選択] ダイアログ ボックスで、使用する連絡先の正しいプロファイルを選択します。

  2. [OK] をクリックします。

リストを追加する

カタログ データの差し込みで複数のリストを使用する場合は、リストを追加できます。

  1. [リストの編集] をクリックし、[カタログ データ差し込みの対象製品リスト] の [製品リストに追加] で、[既存のリストを選択]、[Outlook の連絡先から選択]、または [新しいリストの入力] をクリックします。
    [製品リストに追加] ダイアログ ボックスが開き、さまざまなソース リストのフィールド間の不一致を修正するように求めるメッセージがPublisher に表示されます。

  2. [製品リストに追加] ダイアログ ボックスで、[対応付け済み] 列がオンになっていないフィールドを選択し、[対応付け済みの製品リストのフィールド] ボックスの一覧で対応付けるフィールドを選択して、[対応付け] をクリックします。

  3. [フィールドの対応] ダイアログ ボックスで、選択したフィールドが [製品リストのフィールドに対応付ける] に表示されていることを確認するか、別のフィールドを選択し、[OK] をクリックします。

  4. 対応付けるアドレス帳に新しいフィールドを追加する必要がある場合は、新しいリスト ([アドレス帳に追加] ダイアログ ボックスの左側のリスト) で追加するフィールドを選択し、[追加] をクリックして、[OK] をクリックします。
    追加されたフィールドが [アドレス帳に追加される新しいフィールド] に表示されます。

カタログに含めるレコードを選択する

  1. [リストの編集] をクリックします。

  2. [カタログ データ差し込みの対象製品リスト] ダイアログ ボックスで、次のいずれかの操作を行います。

    • カタログに含めるレコードの横のチェック ボックスをオンにし、カタログから除外するレコードの横のチェック ボックスをオフにします。

       ヒント   リスト内の少数のレコードのみを含める場合は、[すべてクリア] をクリックしてから、含めるレコードを選択します。

    • 特定の条件に基づいてリストにフィルターを適用するには、フィルターを適用するアイテムの列見出しの横にある矢印をクリックし、フィルターとして使用する値をクリックします。

      • [データなし] をクリックすると、対応するフィールドに空白のレコードをすべて表示されます。

      • [データ有り] をクリックすると、対応するフィールドにデータが含まれているレコードをすべて表示します。

         注   同じデータを共有するレコードがデータ ソースに含まれていて、その列に 10 個程度の一意の値がある場合は、特定の情報でフィルターをかけることができます。たとえば、データ ソースが売上のプロパティのリストで、市区町村が横浜市のプロパティ レコードが複数ある場合、"横浜市" でフィルターをかけることができます。

        [カタログ データ差し込みの対象製品リスト] ダイアログ ボックスに、指定されたレコードのみが表示されます。すべてのレコードを表示するには、[すべて] をクリックします。

    • リストのアイテムを並べ替えるには、並べ替えの基準とするアイテムの列見出しをクリックします。たとえば、市区町村を基準に五十音順で表示する場合は、[市区町村] の列見出しをクリックします。

  3. [OK] をクリックします。

ページの先頭へ

差し込み印刷フィールドを挿入する

ここでは、文書に表示する情報を配置します。ページをレイアウトするには、カタログ データの差し込み領域に差し込み印刷フィールドを追加します。各差し込み印刷フィールドはデータ ソースの列を表し、カタログ データの差し込み領域には、1 つのレコードの情報がどのように表示されるかが示されます。

思いどおりにカタログ データの差し込み領域を配置したら、各ページで差し込み領域を繰り返す回数を指定します。たとえば、各ページに 4 つのアイテムを表示するとします。それぞれのアイテムは、カタログ データの差し込み領域の配置方法に基づいて同じように表示されます。各アイテムのサイズの調整や、カタログ データの差し込み領域のサイズ変更を行うことができます。

 重要    差し込み印刷フィールドをカタログ データの差し込み領域の外側に挿入すると、差し込みを完了しても差し込み印刷フィールドは繰り返されません。

差し込み領域のレイアウトを選択する

  1. [レイアウト] で、次のいずれかの操作を行います。

    • あらかじめ作成されているデザイン ギャラリーの 1 つを選択します。
      [カタログ データの差し込みのレイアウト] オプション

    • [行と列] ボックスの一覧で、各ページの行と列の数をクリックします。
      カタログ ページ レイアウトの行と列

カタログ データの差し込み領域にテキスト差し込み印刷フィールドを挿入する

  1. [テキスト フィールド] をクリックし、挿入する最初の差し込み印刷フィールドをクリックします。
    カタログ データの差し込み印刷で、テキスト フィールドを挿入する

  2. カタログ データの差し込み領域で、差し込み印刷フィールドを選択し、次の操作を行って、差し込み印刷フィールドの位置とサイズを変更します。

    • 差し込み印刷フィールドを移動するには、差し込み印刷フィールドの上にマウス ポインターを移動し、ポインターが [移動ポインター] 移動ポインター に変わったら、差し込み印刷フィールドを新しい位置にドラッグします。

    • 差し込み印刷フィールドのサイズを変更するには、テキスト ボックスまたは画像枠のサイズ変更ハンドルの 1 つにマウス ポインターを合わせ、ポインターが [サイズ変更ポインター] ルーラー ポインターを移動する に変わったら、テキスト ボックスまたは画像枠が目的のサイズになるまでドラッグします。

  3. 差し込み印刷フィールドの外側をクリックして、差し込み印刷フィールドの選択を解除します。

  4. 手順 1 ~ 3 を繰り返して、データ ソースから必要なフィールドをすべて挿入します。

 重要    カーソル位置 (カーソルが点滅している挿入ポイント) にフィールドが挿入されます。カーソル位置がない場合は、新しいテキスト ボックスが作成され、この新しいテキスト ボックスに差し込み印刷フィールドが配置されます。

テキスト差し込み印刷フィールドの書式を設定する

カタログ データの差し込みテンプレートで差し込み印刷フィールドの書式を設定すると、差し込まれるカタログ データの書式を設定できます。これらのフィールドは、テキスト ボックスのように扱うことができ、差し込まれたアイテムと同様に、差し込まれていないテキストや書式設定を含めることができます。

  1. カタログ データの差し込みテンプレートで、書式を設定する情報が含まれているフィールドを、前後の差し込み印刷フィールド文字 («« »») ごと選択します。

  2. [テキスト ボックス ツール] タブで、目的のオプションをクリックします。

カタログ データの差し込み領域に画像差し込み印刷フィールドを挿入する

  1. [画像フィールド] をクリックし、挿入する最初の差し込み印刷フィールドをクリックします。

  2. カタログ データの差し込み領域で、差し込み印刷フィールドを選択し、次の操作を行って、差し込み印刷フィールドの位置とサイズを変更します。

    • 差し込み印刷フィールドを移動するには、差し込み印刷フィールドの上にマウス ポインターを移動し、ポインターが [移動ポインター] カーソルを移動する に変わったら、差し込み印刷フィールドを新しい位置にドラッグします。

    • 差し込み印刷フィールドのサイズを変更するには、テキスト ボックスまたは画像枠のハンドルの 1 つにマウス ポインターを合わせ、ポインターが [サイズ変更ポインター] サイズ変更カーソル に変わったら、テキスト ボックスまたは画像枠が目的のサイズになるまでドラッグします。

  3. 差し込み印刷フィールドの外側をクリックして、差し込み印刷フィールドの選択を解除します。

  4. 手順 1 ~ 3 を繰り返して、データ ソースから必要なフィールドをすべて挿入します。

 重要    カーソル位置 (カーソルが点滅している挿入ポイント) にフィールドが挿入されます。カーソル位置がない場合は、新しいテキスト ボックスが作成され、この新しいテキスト ボックスに差し込み印刷フィールドが配置されます。

カタログ データの差し込み領域の位置またはサイズを変更する

書式を設定した差し込み印刷フィールドがカタログ データの差し込み領域に収まらなくなった場合は、差し込み領域のサイズを変更できます。

 注   サイズを大きくすると、各ページに含めるアイテムやレコードの数を減らすことが必要になる場合があります。

  1. [差し込み印刷領域] をクリックして選択します。

  2. [差し込み印刷領域] のハンドルの 1 つにマウス ポインターを合わせ、マウスをドラッグします。

  3. 各ページに表示されるアイテム数を指定するには、[カタログ データの差し込みのレイアウト] ツールバーで、ページの縦および横に配置するアイテムの数を入力します。

テンプレートを完了してプレビュー表示する

  1. [結果のプレビュー] をクリックします。

  2. 矢印をクリックすると、差し込まれたデータの各ページが表示されます。
    カタログ プレビュー グループ

    アイテムを含めない場合は、プレビューされたアイテムをクリックし、[ページのプレビュー] で [エントリの除外] をクリックします。

ページの先頭へ

カタログ文書を完了、印刷、および保存する

差し込みを完了するには、3 つのオプションがあります。

  • 差し込み文書を直接印刷する。

  • 差し込まれたコンテンツを含む新しい文書を作成および印刷する。Publisher で他の文書を変更する場合と同じように、この文書のコンテンツに変更を加えることができます。

 ヒント   複数のカタログ データの差し込みを文書に含める場合、1 つの文書に含めることができるカタログ ページ セットは 1 つのみのため、新しい文書を作成する必要があります。

  • 差し込まれたコンテンツを既存の文書に追加する。

文書に表紙と裏表紙を追加したり、他のページを追加したりする場合は、新しい文書を作成するか、コンテンツを既存の文書に追加する必要があります。

新しい文書に差し込む

差し込みページを編集する場合、後で使用できるように保存する場合、または後で印刷する場合は、差し込みページをすべて集め、差し込み印刷フィールドではなく、製品名や価格などの実際のデータを含む 1 つの新しい差し込み文書として保存できます。

  1. [差し込み] で [新しい文書へ差し込み]
    カタログを新しい文書に結合
    をクリックします。保存および編集が可能な新しい文書が作成されます。表紙と裏表紙のページを追加することもできます。
     注   カタログを小冊子として印刷する場合は、ページの合計数が 4 の倍数になるようにします。

  2. [カタログ データの差し込み] 作業ウィンドウで、[この文書の保存] をクリックします。

  3. [ファイル名] ボックスに新しい文書の名前を入力し、[保存] をクリックします。

  4. 必要に応じて、カタログ データの差し込みテンプレートに加えた変更を保存します。データ ソースの情報を更新した場合は、このカタログ データの差し込みテンプレートを再び使用して、差し込みページを追加で作成できます。

既存の文書に追加する

既に表紙が別の文書として準備されている場合や、別の長い文書の最後にカタログを配置する場合は、差し込んだコンテンツを直接追加できます。

差し込みページを既存の文書の最後に追加する前に、カタログ データの差し込みテンプレートが次の点で既存の文書と一致していることを確認します。

  • ページ サイズ (高さと幅)

  • ページ ビュー (1 ページまたは見開き 2 ページ)

  • 文書の種類 (Web 用または印刷用)

  • ページの順序 (左から右、または右から左)

 注   Publisher では、開いている文書に差し込みページを追加することはできません。差し込み先の文書で作業している場合は、文書を保存して閉じてから、差し込みを完了してください。

  1. [差し込み] で [既存の文書へ追加]
    カタログを既存の文書に結合 をクリックします。

  2. [文書を開く] ダイアログ ボックスで、差し込みページを追加する文書を探して選択し、[開く] をクリックします。

    差し込みページが既存の文書の最後に追加されます。

     ヒント   更新された文書でページを再配置するには、ページのナビゲーション ウィンドウ上で移動するページをクリックし、目的の場所にドラッグします。

  3. 既存の文書で、[保存] をクリックして更新内容を保存します。

  4. 必要に応じて、カタログ データの差し込みテンプレートに加えた変更を保存します。データ ソースの情報を更新した場合は、このカタログ データの差し込みテンプレートを再び使用して、差し込みページを追加で作成できます。

差し込み印刷文書を印刷する

  • [差し込み] で [印刷]
    カタログ データの差し込み印刷 をクリックします。

    Backstage ビューに印刷ページが表示されます。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×