スキップしてメイン コンテンツへ

オートコンプリートのリストを別のコンピューターにインポートまたはコピーする

オートコンプリートリストは、入力を開始したときに名前とメールアドレスの候補を表示する機能です。 これらの候補は、送信したメールメッセージの名前とメールアドレスのリストと一致する可能性があります。 

オートコンプリート リスト

オートコンプリートリストを1台のコンピューターから別のコンピューターにコピーする方法は、Outlook に追加したメールアカウントの種類によって異なります。 Office 365 アカウント、Exchange Server アカウント、または IMAP アカウント (その他のメールアカウントの一般的な種類) を使用している場合、オートコンプリートリストは Outlook データファイルに非表示のファイルとして保存されます。 手順については、「オートコンプリートリストをコピーする」を参照してください。

POP3 アカウント (あまり一般的ではないが、Comcast、Earthlink、Verizon などのサードパーティのメールプロバイダーで使用されることが多い) の場合、オートコンプリートリストはコンピューターに保存されているファイルに保存されます。 「 .Nk2 ファイルをコピーしてインポートする」を参照してください。

使用しているアカウントの種類がわからない場合は、[ファイル>アカウントの設定>アカウント設定] を選びます。 アカウントの種類はこちらで確認できます。

オートコンプリートのリストをコピーする

手順 1: AutoComplete メールボックスメッセージをエクスポートする

  1. Outlook を終了して、メールボックスに接続されているすべてのワークステーションで Outlook Web Access または Outlook Web App (OWA) を閉じます。

  2. Http://mfcmapi.codeplex.com から MFCMAPI をダウンロードしてインストールします。

  3. Mfcmapi を実行します。

  4. [セッション] メニューの [ログオン] をクリックします。

  5. プロファイルの入力を求めるメッセージが表示された場合は、目的のプロファイル名を選択し、[ OK]をクリックします。

  6. 上部のウィンドウで、メールボックスに対応する行を探してダブルクリックします。

  7. 左側のナビゲーションウィンドウで、[ルートコンテナー] を展開し、[インフォメーションストアの上位] または [ IPM_SUBTREE] を展開します。

  8. [受信トレイ] フォルダーを右クリックし、[関連付けられているコンテンツテーブルを開く] をクリックします。 このアクションでは、さまざまなプロパティを含む新しい MFCMAPI ウィンドウが開きます。

  9. [件名] 列で、件名 IPM を持つアイテムを右クリックします。[構成] をクリックし、[メッセージのエクスポート] をクリックします。 このアクションでは、[メッセージをファイルに保存] ウィンドウが開きます。

  10. ドロップダウンリストで、[ MSG file (UNICODE)] を選び、[ OK] をクリックします。

  11. メッセージを保存するフォルダーの場所を選択し、[保存] をクリックします。 この場所をメモします。

手順 2: AutoComplete メールボックスメッセージをインポートする

  1. Outlook を終了して、メールボックスに接続されているすべてのワークステーションで Outlook Web Access または Outlook Web App (OWA) を閉じます。

  2. Http://mfcmapi.codeplex.com から MFCMAPI をダウンロードしてインストールします。

  3. Mfcmapi を実行します。

  4. [セッション] メニューの [ログオン] をクリックします。

  5. プロファイルの入力を求めるメッセージが表示された場合は、目的のプロファイル名を選択し、[ OK]をクリックします。

  6. 上部のウィンドウで、メールボックスに対応する行を探してダブルクリックします。

  7. 左側のナビゲーションウィンドウで、[ルートコンテナー] を展開し、[インフォメーションストアの上位] または [ IPM_SUBTREE] を展開します。

  8. [受信トレイ] フォルダーを右クリックし、[関連付けられているコンテンツテーブルを開く] をクリックします。 このアクションでは、さまざまなプロパティを含む新しい MFCMAPI ウィンドウが開きます。

  9. 重複するエントリを避けるため、既存のオートコンプリートメッセージは削除する必要があります。

    注: IPM を削除する前に、構成: Autocomplete メッセージの場合は、「オートコンプリートキャッシュをエクスポートする方法」の手順を使用して、メッセージをエクスポートする必要があります。

    既存のオートコンプリートメッセージを削除するには、次の手順を実行します。

    1. [件名] 列で、件名 IPM を持つアイテムを見つけます。構成のオートコンプリート

    2. アイテムを右クリックし、[メッセージの削除] をクリックします。 [アイテムの削除] ウィンドウが開きます。

    3. ドロップダウンリストで、[永久削除] (サポートされている場合は [削除済みアイテムの保持を削除する])を選び、[ OK]をクリックします。

  10. [フォルダー] メニューの [インポート] をクリックし、[差出人] をクリックします。

  11. 上記の「オートコンプリートメールボックスメッセージをエクスポートする」の手順11で作成した .msg ファイルを見つけて、[ OK]をクリックします。

  12. [ LOAD MSG ] ウィンドウが表示されたら、[ load style ] ボックスの一覧で [メッセージを現在のフォルダーに読み込む] を選び、[ OK] をクリックします。

オートコンプリート情報が IPM からインポートされます。[構成] Autocomplete_<16 進数形式> .msg という文字が付いています。この場合、<プレースホルダーは16 進数コード>、数字と文字の長い文字列を表します。

.Nk2 ファイルをコピーしてインポートする

手順 1: 古いコンピューターからオートコンプリートファイルをコピーする

  1. 既定のフォルダーは隠しフォルダーであるため、フォルダーを開くには、Windows の [検索] ボックスのコマンド%APPDATA%\Microsoft\Outlookを使うのが最も簡単な方法です (または、\AppData\Roaming\Microsoft\Outlook を参照してください)。

  2. Outlook フォルダーで、オートコンプリートリスト (.nk2) ファイルを見つけます。

    注: 既定で、ファイル拡張子は Windows で表示されません。 ファイルの拡張子を表示するかどうかを変更するには、エクスプローラーの [ツール] メニュー (Windows 7 または Windows Vista の場合は、ALT キーを押して、[ツール] メニューを表示します) で、[フォルダー オプション] をクリックします。 [表示] タブで、[登録されている拡張子は表示しない] チェック ボックスをオンまたはオフにします。

  3. 新しいコンピューターにファイルをコピーします。 ファイルは小型で、USB メモリスティックなどのリムーバブルメディアに配置できます。

手順 2: 新しいコンピューターにオートコンプリートファイルをコピーする

  1. 新しいコンピューターのコントロールパネルで、[メール] をクリックまたはダブルクリックします。

    [メール] は、Microsoft Windows オペレーティングシステムのバージョン、コントロールパネルの表示方法、32または64ビットのオペレーティングシステムまたはバージョンの Outlook 2010 がインストールされているかどうかによって、コントロールパネルのさまざまな場所に表示されます。

    [メール] を見つけるには、Windows のコントロール パネルを開き、ウィンドウ上部の [検索] ボックスに「メール」と入力する方法が最も簡単です。 Windows XP のコントロール パネルでは、[アドレス] ボックスに「メール」と入力します。

    注: [メール] アイコンは、Outlook を初めて起動した後に表示されます。

  2. [Show Profiles] をクリックします。

  3. プロファイルの名前をメモしておきます。 後で名前と一致するように、.nk2 ファイルの名前を変更する必要があります。

  4. .Nk2 ファイルを、Outlook 構成が保存されているフォルダー内の新しいコンピューターにコピーします。 既定のフォルダーは隠しフォルダーであるため、フォルダーを開くには、Windows の [検索] ボックスのコマンド%APPDATA%\Microsoft\Outlookを使うのが最も簡単な方法です (または、\AppData\Roaming\Microsoft\Outlook を参照してください)。

  5. ファイルをフォルダーにコピーした後、ファイルを右クリックし、[名前の変更] をクリックして、手順3で表示したプロファイル名と一致するように名前を変更します。

手順 3: オートコンプリートリストをインポートする

これで Outlook を起動してファイルをインポートする準備ができましたが、1回限りのコマンドで Outlook を起動する必要があります。

  • Windows の検索ボックスに「 outlook/importnk2 」と入力して、enter キーを押します。

オートコンプリートリストには、メッセージを作成して [宛先]、[ Cc]、または [ Bcc ] ボックスで入力を開始したときに、他のコンピューターのエントリが表示されるようになりました。

ページの先頭へ

Outlook 2007 では、オートコンプリートのリストにある名前とメールアドレスを別のコンピューターにコピーできます。 たとえば、新しいコンピューターにアップグレードしていて、オートコンプリートリストに保存されているすべての情報を失いたくない場合は、名前とメールアドレスを古いコンピューターから新しいコンピューターにコピーすることができます。

重要: 次の手順を開始する前に、 Microsoft Outlook を終了する必要があります。 名前は、Outlook を再起動するとオートコンプリートリストに追加されます。

古いコンピューターからオートコンプリートファイルをコピーする

  1. 使用していないコンピューターで、ドライブ: \ user\AppData\Local\Microsoft\Outlook. に移動します。

    注: ファイルの設定によっては、このフォルダーが非表示になっている可能性があります。

  2. [.Nk2] を右クリックし、[コピー] をクリックします。

    ヒント: USB メディアスティックなどのリムーバブルメディアにファイルをコピーして、新しいコンピューター上の適切な場所にファイルをコピーすることができます。 または、メールメッセージにファイルを添付して、自分自身にメッセージを送信することもできます。 新しいコンピューターで、Outlook で添付ファイルを開き、適切な場所に保存します。

  3. オートコンプリートリストを設定するコンピューターで、ドライブ: \ user\AppData\Local\Microsoft\Outlook の任意の場所を右クリックし、[貼り付け] をクリックして .nk2 を保存します。

  4. .Nk2 ファイルを移動するコンピューター上の Outlook ユーザープロファイル名が異なる場合は、ファイルを正しいフォルダーにコピーした後、新しいコンピューターで使用されている Outlook ユーザープロファイル名でファイルの名前を変更する必要があります。 たとえば、元のコンピューターから kim Akers の Outlook ユーザープロファイル名を使用して Kim Akers .nk2 を移動し、Kim Akers ファイルを新しいコンピューターにコピーする場合は、新しいコンピューターで使用されている Outlook プロファイル名でファイルの名前を変更する必要があります。

  5. 既存のファイルを置き換えるかどうかをたずねるメッセージが表示されたら、[はい] をクリックします。

  6. Outlook を開いて、オートコンプリートリストの変更内容を表示します。

ページの先頭へ

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×