アドインを追加または削除する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

アドインは、Microsoft Excel のオプションのコマンドと機能を提供します。既定では、Excel でアドインをすぐに利用できないため、最初にアドインをインストールし、(場合によっては) ライセンス認証を行って使用できるようにします。

目的に合ったトピックをクリックしてください

アドインについて

Excel アドインを追加または削除する

COM アドインを追加または削除する

オートメーション アドインを追加または削除する

アドインについて

一部のアドインは、ソルバーおよび分析ツールなどの excel 構築されます。その他のアドインがある、ダウンロード センターからとする必要があります最初ダウンロードしてインストールします。最後に、組織またはソフトウェア ソリューション プロバイダーでプログラマなど、サード パーティによって作成されたアドインがあります。コンポーネント オブジェクト モデル (COM) アドインのアドイン、Visual Basic for Applications (VBA) アドイン DLL アドインを使用できます。これらのアドインは、それらを使用するためにもインストールする必要があります。

ほとんどのアドインは、次の 3 種類に分類できます。

  • Excel アドイン:    これらには通常、Excel アドイン (.xlam) ファイル、Excel 97-2003 アドイン (.xla) ファイル、または DLL アドイン (.xll) ファイルが含まれるか、あるいはオートメーション アドインです。ソルバーや分析ツールなど、一部の Excel アドインは、Excel または Microsoft Office のインストール後に使用できます。通常、これらのアドインの使用に必要なのはライセンス認証だけです。

  • ダウンロード可能なアドイン:   その他の Excel 用アドインは、Office.com の「ダウンロード センター」からダウンロードしてインストールできます。

  • カスタム アドイン:    開発者やソリューション プロバイダーは、一般的に、カスタムのコンポーネント オブジェクト モデル (COM) アドイン、オートメーション アドイン、VBA アドイン、XLL アドインを設計します。これらのアドインを使用するには、インストールする必要があります。

アドインをインストールまたは有効にすると、アドインとそのコマンドが次のいずれかの場所で使用できるようになります。

  • [データ] タブ。分析ツール アドインとソルバー アドインをインストールして有効にすると、[分析] で [データ分析] と [ソルバー] を使用できます。

    [データ分析] と [ソルバー]

  • [数式] タブ。ユーロ通貨対応ツールをインストールして有効にすると、[ソリューション] に [ユーロ換算] および [ユーロ書式設定] が表示されます。

    [ユーロ換算] と [ユーロ書式設定]

  • [アドイン] タブ。その他のアドインは [アドイン] タブに追加できます。[アドイン] タブに表示される最初のアドインをインストールして有効にすると、このタブがリボンに追加されます。[アドイン] タブが表示されない場合は、Excel を終了して再起動する必要があります。

[はじめに] タブなど、その他のアドインは、Excel の他の場所 (リボンのタブなど) で使用したり、マクロやユーザー設定のメニューから使用できます。

ページの先頭へ

Excel アドインを追加または削除する

重要   ソフトウェア開発者は、作成したアドインのインストール プログラムや削除プログラムを設計する前に、以下の手順でオートメーション プログラムのインストールおよび削除ができます。

Excel アドインを有効にするには   

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。[アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、有効にするアドインの横のチェック ボックスをオンにして、[OK] をクリックします。

有効にするアドインが [有効なアドイン] ボックスに表示されない場合は、インストールする必要があります。

Excel アドインをインストールするには   

  • ソルバーや分析ツールなど、通常は Excel と共にインストールされるアドインをインストールするには、Excel または Microsoft Office のセットアップ プログラムを実行し、[変更] オプションを選択してアドインをインストールします。Excel を再起動した後、[有効なアドイン] ボックスにアドインが表示されます。

  • 一部の Excel アドインはコンピューターに保存されており、[アドイン] ダイアログ ボックスの [参照] をクリックしてアドインを探し、[OK] をクリックすると、インストールまたは有効にすることができます。

  • 一部の Excel アドインは、インストール パッケージの実行が必要です。インストール パッケージをコンピューターにダウンロードまたはコピーして (インストール パッケージは通常 .msi 拡張子のファイル) 実行することが必要な場合があります。

  • その他のアドインはコンピューターで利用できないことができますダウンロードしてインストールダウンロード、またはインターネットまたは組織内のサーバー上の他のサイトから Web ブラウザーを使用します。必要に応じてダウンロードのセットアップ手順を実行します。

Excel アドインを無効にするには   

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。

  3. [有効なアドイン] ボックスで、無効にするアドインの横のチェック ボックスをオフにして、[OK] をクリックします。

    多くの場合、アドインを無効にすると、リボンのグループから削除されます。別のケースでは、リボンからアドインを削除するために、Excel の再起動が必要になる場合があります。

       アドインを無効にしてもアドイン ファイル自体はコンピューターから削除されません。コンピューターからアドインを削除するには、アドインをアンインストールする必要があります。

Excel アドインを削除するには   

重要    最初にネットワーク ファイル サーバーまたは共有フォルダーから Excel アドインをインストールした場合は、その場所からのアドインの削除が必要な場合があります。CD-ROM から Excel アドインをインストールし、アドインをインストールした後に CD-ROM ドライブに新しいドライブ文字を割り当てた場合は、CD-ROM からアドインを再インストールする必要があります。CD-ROM から Excel アドインを実行している場合は、Excel アドインをアンインストールし、CD-ROM から再インストールする必要があります。

  1. Excel を終了します ([ファイル] タブをクリックし、[終了] をクリックします)。

  2. コントロール パネルの [プログラムと機能] (Windows 7 および Windows Vista の場合) または [プログラムの追加と削除] (Windows XP の場合) をクリックします。

  3. 次のいずれかの操作を行います。

    • Excel を Microsoft Office の一部としてインストールした場合は、インストールされているプログラムの一覧で [Microsoft Office] をクリックし、[変更] をクリックします。

    • Excel を個別にインストールした場合は、インストールされているプログラムの一覧で目的のプログラム名をクリックし、[変更] をクリックします。

    • ダウンロード センターからダウンロードしたアドインをインストールした場合は、インストールされているプログラムの一覧で目的のプログラム名をクリックし、[アンインストール] をクリックします。

  4. インストール プログラムに表示される指示に従って操作します。

ページの先頭へ

COM アドインを追加または削除する

重要   ソフトウェア開発者は、作成したアドインのインストール プログラムや削除プログラムを設計する前に、以下の手順でオートメーション プログラムのインストールおよび削除ができます。開発者ではない場合は、この手順に従う必要はありません。インストールや削除の手順についての情報が必要な場合は、アドインを提供したシステム管理者にお問い合わせください。

COM アドインを追加する

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの [COM アドイン] をクリックし、[設定] をクリックします。[COM アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、インストールするアドインの横のチェック ボックスをオンにして、[OK] をクリックします。

    ヒント    [有効なアドイン] ボックスの一覧に目的のアドインが表示されない場合は、[追加] をクリックしてアドインを検索します。

COM アドインを削除する

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの [COM アドイン] をクリックし、[設定] をクリックします。[COM アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、削除するアドインの横のチェック ボックスをオフにして、[OK] をクリックします。

       これで、アドインがメモリから削除されますが、有効なアドインの一覧にはその名前が残ります。アドイン自体はコンピューターから削除されません。

  4. 有効なアドインの一覧から COM アドインを削除し、コンピューターからアドインを削除するには、[使用できるアドイン] ボックスの一覧でアドイン名をクリックし、[削除] をクリックします。

ページの先頭へ

オートメーション アドインを追加または削除する

重要   ソフトウェア開発者は、作成したアドインのインストール プログラムや削除プログラムを設計する前に、以下の手順でオートメーション プログラムのインストールおよび削除ができます。開発者ではない場合は、この手順に従う必要はありません。インストールや削除の手順についての情報が必要な場合は、アドインを提供したシステム管理者にお問い合わせください。

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。[アドイン] ダイアログ ボックスが表示されます。

  3. オートメーション アドインをインストールするには、[オートメーション] をクリックし、[有効なオートメーション サーバー] ボックスで目的のアドインをクリックします。

    ヒント   目的のアドインが一覧に表示されていない場合は、[参照] をクリックしてアドインを検索し、[OK] をクリックします。

  4. オートメーション アドインを削除するには、レジストリから削除する必要があります。詳細については、システム管理者にお問い合わせください。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

共有 Facebook Facebook Twitter Twitter メール メール

この情報は役に立ちましたか?

ありがとうございます。その他のフィードバックはありませんか?

改善内容をお聞かせください

ご意見をいただきありがとうございます。

×