Visualizzare l'attendibilità aggiungendo una firma digitale

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

È possibile mostrare che si ritiene che un database sia sicuro e che il relativo contenuto possa essere considerato attendibile aggiungendo un firma digitale al database. In questo modo le persone che usano il database decidono se considerarsi attendibili e il relativo contenuto.

Il processo usato per la firma digitale di un database varia a seconda che il database usi un formato di file più recente, ad esempio un file con estensione accdb o un formato precedente, ad esempio un file con estensione mdb. Tuttavia, entrambi i processi richiedono l'uso di un certificato di sicurezza.

È possibile usare un certificato di sicurezza commerciale oppure crearne uno personalizzato. Questo argomento spiega come creare un certificato di sicurezza personalizzato.

In questo articolo

Prima di iniziare

Creare un pacchetto, firmare e distribuire un database di Access

Firmare digitalmente un database di versioni precedenti

Prima di iniziare

Per aggiungere una firma digitale, è necessario prima di tutto ottenere o creare un certificato di sicurezza. Si pensi a un certificato di sicurezza come a una penna che si usa per firmare digitalmente le cose o a una guarnizione a cera che solo tu puoi applicare.

Se non si dispone di un certificato di sicurezza, è possibile crearne uno usando lo strumento SelfCert (incluso in Microsoft Office).

Creare un certificato autofirmato

  1. In Microsoft Windows fare clic sul pulsante Start , scegliere tutti i programmi, scegliere Microsoft Office, strumenti di Microsoft Officee quindi fare clic su certificato digitale per i progetti VBA.

    - oppure -

    Passare alla cartella che contiene i file di programma di Microsoft Office.

    È necessario individuare il file eseguibile, SelfCert. exee la posizione può variare in base a varie condizioni, ad esempio se si usa un sistema operativo Windows a 32 bit o a 64 bit o se si usa una versione in abbonamento di Office 365.

    Se si usa Office 2019 o Office 2016, provare a eseguire una di queste posizioni:

    • C:\Programmi\Microsoft Office\Office16

    • C:\Programmi (x86) \Microsoft Office\Office16

    Se si usa Office 365, provare a eseguire una di queste posizioni:

    • C:\Programmi\Microsoft Office\root\Office16

    • C:\Programmi (x86)\Microsoft Office\root\Office16

    Se si usa Office 2013, cercare la cartella Office15 dalle opzioni precedenti. Se si usa Office 2010, cercare la cartella Office14. Se si usa Office 2007, cercare la cartella Office12.

    Individuare la cartella corretta e fare doppio clic su SelfCert. exe.

    Viene visualizzata la finestra di dialogo Crea certificato digitale.

  2. Nella casella Nome certificato digitare un nome per il nuovo certificato di prova.

  3. Fare due volte clic su OK.

Nota: Se il comando Certificato digitale per progetti VBA non è visualizzato o non è possibile individuare il file SelfCert.exe, potrebbe essere necessario installare SelfCert.

Installare SelfCert.exe

  1. Avviare il CD di installazione di Microsoft Office o un altro supporto di installazione.

  2. Nel programma di installazione fare clic su Aggiungi/Rimuovi caratteristiche e quindi su Continua.

    Nota: Se si opera in un ambiente in cui Microsoft Office viene installato nei singoli computer da amministratori IT anziché da un CD, eseguire la procedura seguente:

    1. In Microsoft Windows fare clic sul pulsante Start e quindi scegliere Pannello di controllo.

    2. Fare doppio clic su Aggiungi o Rimuovi programmi.

    3. Selezionare la versione di Microsoft Office e quindi fare clic su Cambia.

      Viene avviato il programma di installazione.

    4. Fare clic su Aggiungi/Rimuovi caratteristiche e quindi su Continua.

    5. Continuare eseguendo la procedura seguente.

  3. Espandere i nodi Microsoft Office e Caratteristiche condivise di Office facendo clic sui segni più (+) posti accanto.

  4. Fare clic su Certificato digitale per progetti VBA.

  5. Fare clic su Esecuzione dal computer locale.

  6. Scegliere Continua per installare il componente.

Devi usare SelfCert solo per creare firme da usare all'interno della tua organizzazione. Se si vuole firmare digitalmente un database e quindi distribuirlo commercialmente, è necessario ottenere un certificato di sicurezza commerciale da un'autorità di certificazione (CA) commerciale.

Creare un pacchetto, firmare e distribuire un database di Access

Access consente di firmare e distribuire un database in modo semplice e veloce. Quando si crea un file con estensione accdb o accde, è possibile creare un pacchetto del file, applicare una firma digitale al pacchetto e quindi distribuire il pacchetto firmato ad altri utenti. Tramite lo strumento Crea pacchetto e apponi firma, il database viene inserito in un file di distribuzione di Access (con estensione accdc), il file viene firmato e quindi il pacchetto firmato viene inserito nel percorso specificato dall'utente. Gli utenti hanno quindi la possibilità di estrarre il database dal pacchetto e di lavorare direttamente nel database e non nel file del pacchetto.

Mentre si procede, tenere presente gli aspetti seguenti:

  • La creazione di un pacchetto del database e la firma del pacchetto sono modalità che consentono di comunicare informazioni sull'attendibilità. Quando si crea un pacchetto e si firma un database, la firma digitale conferma che il pacchetto non è stato manomesso dopo che è stato creato.

  • Una volta estratto il database dal pacchetto, non vi sarà più alcuna connessione tra il pacchetto firmato e il database estratto.

  • Puoi usare lo strumento pacchetto e firma solo con i database salvati in un formato di file più recente (con estensione accdb, ACCDE,...). Access offre anche strumenti per firmare e distribuire database con un formato di file precedente. È necessario usare lo strumento per la firma digitale appropriato al formato di file del database in uso.

  • È possibile aggiungere solo un database a un pacchetto.

  • La firma digitale viene apposta su un pacchetto contenente un intero database, non solo le macro o i moduli.

  • Il file del pacchetto viene compresso durante il processo per ridurne i tempi di download.

  • È possibile estrarre database da file di pacchetto che si trovano nei server che usano Windows SharePoint Services 3.0 o versioni successive.

Nelle procedure riportate nelle sezioni che seguono viene illustrato come creare un file del pacchetto firmato e come estrarre e usare il database da questo tipo di file.

Creare un pacchetto firmato

  1. Aprire il database di cui si vuole creare il pacchetto firmato.

  2. Fare clic su file _GT_ Salva comepacchetto > e firmare. Nota: se si usa 2007 di Access, fare clic sul pulsante Microsoft Office > pubblicare il pacchetto > e firmare.

    Viene visualizzata la finestra di dialogo Selezione certificato.

  3. Selezionare un certificato digitale e quindi fare clic su OK.

    Verrà visualizzata la finestra di dialogo Crea pacchetto firmato Microsoft Access .

  4. Nell'elenco Salva in selezionare una posizione per il pacchetto di database firmato.

  5. Immettere un nome per il pacchetto firmato nella casella Nome file e quindi fare clic su Crea.

    Il file con estensione accdc verrà creato da Access e inserito nel percorso scelto.

Estrarre e usare un pacchetto firmato

  1. Fare clic su File > Apri > Sfoglia. Viene visualizzata la finestra di dialogo Apri. Nota: se si usa 2007 di Access, fare clic sul pulsante Microsoft Office > aperto.

  2. Selezionare pacchetti con firma di Microsoft Access (*. accdc) come tipo di file.

  3. Individuare la cartella che contiene il file con estensione accdc, selezionare il file e quindi fare clic su Apri.

  4. Eseguire una delle operazioni seguenti:

    • Se si sceglie di considerare attendibile il certificato di sicurezza usato per firmare il pacchetto di distribuzione, verrà visualizzata la finestra di dialogo Estrai database in. Passare al passaggio successivo.

    • Se non si è scelto di considerare attendibile il certificato di sicurezza, verrà visualizzato il messaggio seguente.

      Messaggio di avviso

      Se si considera attendibile il database, fare clic su Apri. Se si considera attendibile qualsiasi certificato del provider, fare clic su Considera attendibile tutto quello che proviene da questo autore. Viene visualizzata la finestra di dialogo Estrai database in.

      Nota: Se si usa un certificato autofirmato per firmare un pacchetto di database, quindi si fa clic su Considera attendibile tutto quello che proviene da questo editore all'apertura del pacchetto tutti i pacchetti a cui si appone la firma utilizzando i certificati autofirmati saranno sempre considerati attendibili.

  5. Nell'elenco Salva in è possibile selezionare una posizione per il database estratto, quindi nella casella Nome file immettere un nome diverso per il database estratto.

    Suggerimento: Se si estrae il database in un percorso attendibile, il contenuto sarà automaticamente abilitato ogni volta che si apre il database. Se si sceglie un percorso non attendibile, è possibile che una parte del contenuto sia disabilitata per impostazione predefinita.

  6. Fare clic su OK.

Se non si è sicuri se considerare attendibile o meno un certificato, vedere l'articolo Verifica dell'attendibilità di una firma digitale in cui vengono fornite informazioni generali sulla verifica delle date e degli altri elementi di un certificato per garantirne la validità.

Inizio pagina

Firmare digitalmente un database di versioni precedenti

Importante: La procedura descritta in questa sezione non si applica ai database che usano uno dei nuovi formati di file.

Per i database che usano i formati di file mdb o MDE, è possibile applicare un firma digitale ai componenti del database. Una firma digitale conferma che le macro, i moduli di codice e gli altri componenti eseguibili inclusi nel database sono stati creati dal firmatario e che nessun altro utente li ha modificati dopo che la firma è stata apposta al database.

Per applicare una firma al database, è innanzitutto necessario avere un certificato digitale. Se si creano database per la distribuzione commerciale, sarà necessario ottenere un certificato da un'autorità di certificazione (CA) commerciale. Le autorità di certificazione eseguono dei controlli per verificare l'attendibilità delle persone che creano contenuto, ad esempio i database.

Se si vuole usare un database per scenari di gruppi di lavoro personali o limitati, Access offre uno strumento per la creazione di un certificato autofirmato. Le procedure delle sezioni che seguono illustrano come installare e usare lo strumento SelfCert.exe per creare un certificato autofirmato.

Apporre una firma codificata a un database

Nota: Tenere presente che questi passaggi si applicano solo quando si usano database che usano uno dei formati di file di database precedenti, ad esempio un file con estensione mdb. Per firmare i database più recenti, vedere il pacchetto di sezione , firmare e distribuire un database di Access.

  1. Aprire il database che si desidera firmare.

  2. Nel gruppo Macro della scheda Strumenti database fare clic su Visual Basic per avviare Visual Basic Editor.

    Scelta rapida da tastiera Premere ALT+F11.

  3. Nella finestra Explorer del progetto selezionare il database o il progetto di Visual Basic, Applications Edition (VBA) che si desidera firmare.

  4. Scegliere Firma digitale dal menu Strumenti.

    Viene visualizzata la finestra di dialogo Firma digitale.

  5. Fare clic su Scegli per selezionare il certificato di prova.

    Viene visualizzata la finestra di dialogo Selezione certificato.

  6. Selezionare il certificato da applicare.

    Se è stata eseguita la procedura nella sezione precedente, selezionare il certificato creato con SelfCert.

  7. Fare clic su OK per chiudere la finestra di dialogo Seleziona certificato e quindi fare di nuovo clic su OK per chiudere la finestra di dialogo firma digitale .

Suggerimenti per firmare digitalmente database di versioni precedenti

  • Per evitare che gli utenti della soluzione modifichino involontariamente il progetto VBA invalidando la firma, bloccare il progetto prima di firmarlo.

    Nota: Il blocco del progetto VBA non impedisce a un altro utente di sostituire la firma digitale con un'altra firma. Gli amministratori aziendali possono firmare di nuovo i modelli e i componenti aggiuntivi, in modo da controllare esattamente quali componenti possono essere eseguiti dagli utenti nei propri computer.

  • Quando si firma digitalmente un progetto VBA, è possibile indicare l'ora e la data in modo da consentire ad altri utenti di verificare la firma anche dopo la scadenza del certificato.

Inizio pagina

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×