Utilizzare la funzione MATR.SOMMA.PRODOTTO per sommare il prodotto di valori corrispondenti in una o più matrici

Matr usa gli intervalli di celle (o Crea una formulain forma di matrice) come argomenti (le parti della formula che lo rendono valido). Moltiplica i valori nelle matrici e ne somma il risultato.

Questo esempio mostra una lista della spesa, dove una matrice elenca il costo di ciascun articolo, e l'altra matrice mostra il numero di articoli che saranno acquistati.

Elenco di elementi della drogheria nella colonna A. Nella colonna B (matrice 1) è il costo per unità. Nella colonna C (matrice 2) è la quantità acquistata

  1. Per creare la formula, digitare =MATR.SOMMA.PRODOTTO(B3:B6;C3:C6) e premere INVIO.

Ogni cella della colonna B viene moltiplicata per il valore della cella corrispondente sulla stessa riga nella colonna C, e i risultati sono sommati. Il totale della lista della spesa è €21,60.

  1. Per scrivere una formula più lunga che dia lo stesso risultato, digitare =B3*C3+B4*C4+B5*C5+B6*C6 e premere INVIO.

Premendo Invio, si ottiene sempre lo stesso risultato: €21,60. La cella B3 è moltiplicata per C3, e il risultato è aggiunto al prodotto della cella B4 moltiplicata per la cella C4 e così via. Immaginate quanto la funzione MATR.SOMMA.PRODOTTO renda tutto più semplice quando si hanno migliaia (ma anche solo centinaia) di righe.

Note: 

  • Le colonne o righe (matrici) devono avere la stessa lunghezza.

  • Se in una cella è presente del testo al posto di un numero, la cella sarà considerata come avente valore zero.

Esempio

Se si vuole giocare con matr e creare una formulain forma di matrice, ecco una cartella di lavoro Excel per il Web con dati diversi da quelli usati in questo articolo.

Copiare i dati di esempio nella tabella seguente e incollarli nella cella A1 di una nuova cartella di lavoro Excel. Affinché la formula mostri i risultati, selezionare i dati, premere F2 e quindi premere Invio. Se necessario, è possibile adattare la larghezza delle colonne per vedere tutti i dati.

A

B

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Formula

Risultato

'=MATR.SOMMA.PRODOTTO(A2:B4,D2:E4)

=MATR.SOMMA.PRODOTTO(A2:B4; D2:E4)

Moltiplica tutti gli elementi delle due matrici (A2:B4 e D2:E4) e ne somma i prodotti, ovvero 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Per un'esperienza più completa, è possibile aprire questa cartella di lavoro in Excel. Basta fare clic sull'icona di Excel nell'angolo in basso a destra della Icona di Excel in Excel Web App della cartella di lavoro, salvare il file in una posizione comoda nel computer e quindi aprirlo.

Inizio pagina

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×