Utilizzare funzioni annidate in una formula

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Utilizzo di una funzione come uno degli argomenti in una formula che usa una funzione è denominato annidamento e si farà riferimento a tale funzione come funzione annidata. Ad esempio, da annidare la funzione Media e somma gli argomenti della funzione se, la seguente formula somma un insieme di numeri (G2: G5) solo se la media di un'altra coppia di numeri (F2: F5) è maggiore di 50. In caso contrario restituisce 0.

funzioni annidate

Le funzioni Media e somma sono nidificate all'interno della funzione se.

È possibile annidare fino a 64 livelli di funzioni in una formula.

  1. Fare clic sulla cella in cui si desidera immettere la formula.

  2. Per iniziare la formula con la funzione, fare clic su Inserisci funzione Callout 4 dalla formula barre Callout 4 .

    Verrà inserito automaticamente il segno di uguale (=).

  3. Nella casella Oppure selezionare una categoria selezionare Tutte.

    Se si ha familiarità con le categorie di funzione, è anche possibile selezionare una categoria.

    In caso di incertezze sulla funzione da utilizzare, è possibile digitare nella casella Cerca una funzione una domanda che descriva l'operazione da eseguire. "Aggiungere numeri" ad esempio restituisce la funzione SOMMA.

  4. Per immettere un'altra funzione come argomento, immettere la funzione nella casella dell'argomento desiderato.

    Le parti della formula visualizzate nella finestra di dialogo Argomenti funzione riflettono la funzione selezionata nel passaggio precedente.

    Con un clic su SE la finestra di dialogo Argomenti funzione visualizzerà gli argomenti per la funzione SE. Per annidare un'altra funzione, è possibile immetterla nella casella dell'argomento. È possibile ad esempio immettere SOMMA(G2:G5) nella casella Se_vero della funzione SE.

  5. Immettere eventuali argomenti aggiuntivi necessari per completare la formula.

    Anziché digitare riferimenti di cella, è inoltre possibile selezionare le celle a cui si desidera fare riferimento. Fare clic su Icona del pulsante per ridurre al minimo la finestra di dialogo, selezionare le celle a cui fare riferimento e fare clic su Icona del pulsante per espandere di nuovo la finestra di dialogo.

    Suggerimento: Per ulteriori informazioni sulla funzione e sui relativi argomenti, fare clic sulla Guida relativa a questa funzione.

  6. Dopo avere completato gli argomenti della formula, fare clic su OK.

  1. Fare clic sulla cella in cui si desidera immettere la formula.

  2. Per iniziare la formula con la funzione, fare clic su Inserisci funzione Callout 4 dalla formula barre Callout 4 .

  3. Nella casella Selezionare una categoria della finestra di dialogo Inserisci funzione selezionare tutti.

    Se si ha familiarità con le categorie di funzione, è anche possibile selezionare una categoria.

  4. Per immettere un'altra funzione come argomento, immettere la funzione nella casella dell'argomento nel generatore di formule o direttamente nella cella.

  5. Immettere eventuali argomenti aggiuntivi necessari per completare la formula.

  6. Dopo avere completato gli argomenti della formula, premere INVIO.

Esempi

Di seguito viene illustrato un esempio dell'uso annidate se punteggio del test di funzioni per assegnare una votazione a un valore numerico.

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro Excel. Affinché le formule mostrino i risultati, selezionarle, premere il tasto F2 e quindi Invio. Se necessario, adattare l'ampiezza delle colonne per visualizzare tutti i dati.

Punteggio

45

90

78

Formula

Descrizione

Risultato

'=SE(A2>89,"A",SE(A2>79,"B", SE(A2>69,"C",SE(A2>59,"D","F"))))

Usa condizioni SE annidate per assegnare una votazione al punteggio nella cella A2.

=SE(A2>89,"A",SE(A2>79,"B",SE(A2>69,"C",SE(A2>59,"D","F"))))

'=SE(A3>89,"A",SE(A3>79,"B", SE(A3>69,"C",SE(A3>59,"D","F"))))

Usa condizioni SE annidate per assegnare una votazione al punteggio nella cella A3.

=SE(A3>89,"A",SE(A3>79,"B",SE(A3>69,"C",SE(A3>59,"D","F"))))

'=SE(A4>89,"A",SE(A4>79,"B", SE(A4>69,"C",SE(A4>59,"D","F"))))

Usa condizioni SE nidificate per assegnare una votazione al punteggio nella cella A4.

=SE(A4>89,"A",SE(A4>79,"B",SE(A4>69,"C",SE(A4>59,"D","F"))))

Suggerimenti: 

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Video: Funzioni se annidate

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×