Usare i filtri dei dati per filtrare i dati

Nei filtri dei dati sono disponibili pulsanti su cui è possibile fare clic per filtrare i dati delle tabelle o delle tabelle pivot. Oltre a filtrare rapidamente, i filtri dei dati indicano anche lo stato corrente del filtro, che consente di capire facilmente quali elementi sono effettivamente mostrati in una tabella pivot filtrata.

Immagine della barra multifunzione di Excel

Quando si seleziona un elemento, tale elemento viene incluso nel filtro e nel rapporto vengono visualizzati i dati corrispondenti. Ad esempio, quando si seleziona un nome nel campo relativo ai venditori, vengono visualizzati solo i dati che includono quel nome in quel campo.

  1. Fare clic in un punto qualsiasi della tabella pivot per cui si vuole creare un filtro dei dati.

  2. Nella scheda Analizza fare clic su Inserisci filtro dati. Nelle versioni precedenti di Excel fare clic sulla scheda Opzioni e quindi su Inserisci filtro dati.

  3. Nella finestra di dialogo Inserisci filtro dati selezionare la casella di controllo relativa ai campi di tabella pivot per cui si vuole creare un filtro dei dati.

  4. Fare clic su OK.

    Viene visualizzato un filtro dei dati per ogni campo selezionato.

  5. In ogni filtro dei dati fare il clic sugli elementi da filtrare.

    Per selezionare più elementi, tenere premuto CTRL e quindi fare clic sugli elementi da filtrare.

Tenere presente che questa funzionalità è supportata in Excel 2013 e versioni successive.

  1. Fare clic in un punto qualsiasi della tabella per cui si vuole creare un filtro dei dati.

  2. Nella scheda Inserisci fare clic su Filtro dati.

  3. Nella finestra di dialogo Inserisci filtro dati selezionare la casella di controllo relativa ai campi (colonne) per cui si vuole creare un filtro dei dati.

  4. Fare clic su OK.

    Viene visualizzato un filtro dei dati per ogni campo (colonna) selezionato.

  5. In ogni filtro dei dati fare il clic sugli elementi da filtrare.

    Per selezionare più elementi, tenere premuto CTRL e quindi fare clic sugli elementi da filtrare.

  1. Fare clic sul filtro dei dati da formattare.

  2. Nel gruppo Stili filtro dati della scheda Opzioni fare clic sullo stile che si preferisce.

Se in una tabella pivot è già presente un filtro dei dati, è possibile usarlo per filtrare un'altra tabella pivot. Questo è possibile solo quando le due tabelle pivot usano la stessa origine dati.

  1. Creare prima di tutto una tabella pivot basata sulla stessa origine dati della tabella pivot che contiene il filtro dei dati da riutilizzare.

  2. Fare clic sul filtro dei dati che si vuole condividere in un'altra tabella pivot.

    Viene visualizzato Strumenti filtro dati con una scheda Opzioni.

  3. Nel gruppo Filtro dati della scheda Opzioni fare clic su Connessioni rapporto. Tenere presente che nelle versioni precedenti di Excel questo pulsante può essere denominato Connessioni tabella pivot.

  4. Nella finestra di dialogo selezionare la casella di controllo relativa alle tabelle pivot in cui si vuole rendere disponibile il filtro dei dati.

  1. Fare clic in un punto qualsiasi della tabella pivot per cui si vuole disconnettere un filtro dei dati.

    Viene visualizzata la scheda Strumenti tabella pivot.

  2. In Excel 2016 fare clic sulla scheda Analizza e quindi su Connessioni filtro. Nelle versioni precedenti di Excel fare clic sulla scheda Opzioni > Inserisci filtro dati > Connessioni filtro dati.

  3. Nella finestra di dialogo deselezionare la casella di controllo relativa a ogni campo di tabella pivot per cui si vuole disconnettere un filtro dei dati.

Eseguire una delle operazioni seguenti:

  • Fare clic sul filtro dei dati e premere CANC.

  • Fare clic con il pulsante destro del mouse sul filtro dei dati e quindi scegliere Rimuovi <nome del filtro dei dati>.

Un filtro dei dati solitamente visualizza i componenti seguenti:



Elementi di un filtro dei dati di tabella pivot

1. Un'intestazione di filtro dei dati indica la categoria degli elementi nel filtro dei dati.

2. Un pulsante di filtro non selezionato indica che l'elemento non è incluso nel filtro.

3. Un pulsante di filtro selezionato indica che l'elemento è incluso nel filtro.

4. Un pulsante Cancella filtro rimuove il filtro selezionando tutti gli elementi contenuti nel filtro dei dati.

5. Una barra di scorrimento consente lo scorrimento se il filtro dei dati contiene più elementi di quelli attualmente visibili.

6. Controlli di spostamento e di ridimensionamento dei bordi consentono di modificare le dimensioni e la posizione del filtro dei dati.

  1. Fare clic in un punto qualsiasi della tabella pivot per cui si vuole creare un filtro dei dati.

    Viene visualizzata la scheda Analizza tabella pivot.

  2. Nella scheda Analizza tabella pivot fare clic su Inserisci filtro dati.

  3. Nella finestra di dialogo Inserisci filtro dati selezionare la casella di controllo relativa ai campi di tabella pivot per cui si vuole creare un filtro dei dati.

  4. Fare clic su OK.

    Viene visualizzato un filtro dei dati per ogni campo selezionato.

  5. In ogni filtro dei dati fare il clic sugli elementi da filtrare.

    Per selezionare più elementi, tenere premuto COMANDO e quindi fare clic sugli elementi in base ai quali applicare il filtro.

  1. Fare clic in un punto qualsiasi della tabella per cui si vuole creare un filtro dei dati.

    Viene visualizzata la scheda Tabella.

  2. Nella scheda Tabella fare clic su Inserisci filtro dati.

  3. Nella finestra di dialogo Inserisci filtro dati selezionare la casella di controllo relativa ai campi (colonne) per cui si vuole creare un filtro dei dati.

  4. Fare clic su OK.

    Viene visualizzato un filtro dei dati per ogni campo (colonna) selezionato.

  5. In ogni filtro dei dati fare il clic sugli elementi in base ai quali applicare il filtro.

    Per selezionare più elementi, tenere premuto COMANDO e quindi fare clic sugli elementi in base ai quali applicare il filtro.

  1. Fare clic sul filtro dei dati da formattare.

    Viene visualizzata la scheda Filtro dati.

  2. Nella scheda Filtro dati fare clic sullo stile colorato che si preferisce.

Se in una tabella pivot è già presente un filtro dei dati, è possibile usarlo per filtrare un'altra tabella pivot. Questo è possibile solo quando le due tabelle pivot usano la stessa origine dati.

  1. Creare prima di tutto una tabella pivot basata sulla stessa origine dati della tabella pivot che contiene il filtro dei dati da riutilizzare.

  2. Fare clic sul filtro dei dati che si vuole condividere in un'altra tabella pivot.

    Viene visualizzata la scheda Filtro dati.

  3. Nella scheda Filtro dati fare clic su Connessioni rapporto.

  4. Nella finestra di dialogo selezionare la casella di controllo relativa alle tabelle pivot in cui si vuole rendere disponibile il filtro dei dati.

  1. Fare clic in un punto qualsiasi della tabella pivot per cui si vuole disconnettere un filtro dei dati.

    Viene visualizzata la scheda Analizza tabella pivot.

  2. Fare clic sulla scheda Analizza tabella pivot e quindi su Connessioni filtro.

  3. Nella finestra di dialogo deselezionare la casella di controllo relativa a ogni campo di tabella pivot per cui si vuole disconnettere un filtro dei dati.

Eseguire una delle operazioni seguenti:

  • Fare clic sul filtro dei dati e premere CANC.

  • Fare clic sul filtro dei dati tenendo premuto CTRL e quindi scegliere Rimuovi <nome del filtro dei dati>.

Un filtro dei dati solitamente visualizza i componenti seguenti:



Elementi di un filtro dei dati di tabella pivot

1. Un'intestazione di filtro dei dati indica la categoria degli elementi nel filtro dei dati.

2. Un pulsante di filtro non selezionato indica che l'elemento non è incluso nel filtro.

3. Un pulsante di filtro selezionato indica che l'elemento è incluso nel filtro.

4. Un pulsante Cancella filtro rimuove il filtro selezionando tutti gli elementi contenuti nel filtro dei dati.

5. Una barra di scorrimento consente lo scorrimento se il filtro dei dati contiene più elementi di quelli attualmente visibili.

6. Controlli di spostamento e di ridimensionamento dei bordi consentono di modificare le dimensioni e la posizione del filtro dei dati.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×