Usare funzioni e funzioni annidate nelle formule di Excel

Le funzioni sono formule predefinite che eseguono calcoli usando valori specifici, denominati argomenti, in un particolare ordine o in una struttura specifica. Le funzioni possono essere usate per eseguire calcoli semplici e complessi. Tutte le funzioni di Excel sono disponibili nella scheda Formule della barra multifunzione:

Scheda Formule sulla barra multifunzione di Excel
  • Sintassi della funzione di Excel

    Nell'esempio seguente di arrotondamento di un numero nella cella A10 con la funzione ARROTONDA viene illustrata la sintassi di una funzione.

    Struttura di una funzione

    1. Struttura. La struttura di una funzione inizia con un segno di uguale (=) seguito dal nome della funzione, da una parentesi aperta, dagli argomenti della funzione separati da virgole e da una parentesi chiusa.

    2. Nome della funzione. Per visualizzare un elenco di funzioni disponibili, fare clic su una cella e premere MAIUSC+F3, che apre la finestra di dialogo Inserisci funzione.

    Formule di Excel - finestra di dialogo Inserisci funzione

    3. Argomenti. Gli argomenti possono essere numeri, testo, valori logici come VERO o FALSO, matrici, valori di errore come #N/D o riferimenti di cella. L'argomento designato deve produrre un valore valido per tale argomento. Gli argomenti possono anche essere costanti, formule o altre funzioni.

    4. Descrizione dell'argomento. Quando si digita la funzione, viene visualizzata una descrizione della sintassi e degli argomenti. Ad esempio, digitare =ARROTONDA( per visualizzare la descrizione. Le descrizioni sono disponibili solo per le funzioni predefinite.

    Nota: Non è necessario digitare le funzioni in maiuscolo, ad esempio =ARROTONDA, perché Excel le converte automaticamente in maiuscolo quando si preme INVIO. Se si sbaglia a scrivere un nome di funzione, ad esempio =SOMA(A1:A10) invece di =SOMMA(A1:A10), viene restituito un errore #NOME?.

  • Immettere funzioni di Excel

    Quando si crea una formula che contiene una funzione, è possibile immettere le funzioni dei fogli di lavoro nella finestra di dialogo Inserisci funzione. Dopo aver selezionato una funzione dalla finestra di dialogo Inserisci funzione, Excel avvia una procedura guidata che visualizza il nome della funzione, tutti gli argomenti, una descrizione della funzione e di ogni argomento, il risultato corrente della funzione e il risultato corrente dell'intera formula.

    Creazione guidata Funzione di Excel

    Per semplificare la creazione e la modifica delle formule e ridurre l'incidenza di errori di digitazione e di sintassi, usare Completamento automatico formule. Dopo aver digitato il segno di uguale (=) e le lettere iniziali di una funzione, Excel visualizza un elenco a discesa dinamico di funzioni, nomi e argomenti validi che corrispondono alle lettere. Selezionandone uno, Excel lo inserisce automaticamente.

    Completamento automatico formule di Excel

  • Annidare funzioni di Excel

    In alcuni casi può essere necessario usare una funzione come uno degli argomenti di un'altra funzione. La formula seguente usa ad esempio una funzione MEDIA annidata e confronta il risultato con il valore 50.

    Funzioni annidate

    1. Le funzioni MEDIA e SOMMA sono annidate nella funzione SE.

    Validità dei valori restituiti       Quando si utilizza una funzione come argomento, è necessario che questa restituisca lo stesso tipo di valore utilizzato dall'argomento. Se ad esempio l'argomento restituisce un valore VERO o FALSO, la funzione annidata deve restituire VERO o FALSO. In caso contrario, verrà visualizzato un valore di errore #VALORE!.

    Limiti dei livelli di annidamento    Una formula può contenere fino a sette livelli di funzioni annidate. Quando una funzione, ad esempio la Funzione B, viene usata come argomento di un'altra funzione, ad esempio la Funzione A, la Funzione B sarà una funzione di secondo livello. Ad esempio, la funzione MEDIA e la funzione SOMMA sono entrambe funzioni di secondo livello se vengono usate come argomenti della funzione SE. Una funzione annidata all'interno della funzione MEDIA annidata sarebbe invece una funzione di terzo livello e così via.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×