Unire più moduli di InfoPath

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

InfoPath Forms Services è una tecnologia server, disponibile in Microsoft Office Forms Server 2007 e Microsoft Office SharePoint Server 2007, che consente agli utenti di compilare i moduli Microsoft Office InfoPath 2007 tramite un Web browser anziché o in aggiunta ai, il programma client Office InfoPath 2007. Questa tecnologia consente l'accesso più ampio ai moduli rispetto alle versioni precedenti di Microsoft Office InfoPath.

In questo articolo viene illustrato come unire moduli Office InfoPath 2007 su un server che esegue InfoPath Forms Services.

In questo articolo

Panoramica

Unire più moduli di InfoPath in una raccolta

Panoramica

Una raccolta è una posizione in un sito in cui è possibile creare, raccogliere, aggiornare e gestire i file con i membri del team. Ogni raccolta viene visualizzato un elenco di file e le informazioni chiave relativi ai file che consente agli utenti di utilizzare i file per collaborare.

Archiviando i moduli di InfoPath in una raccolta, è possibile condividere e tenere traccia facilmente i moduli. Ad esempio, è possibile creare una raccolta per lo stato del team moduli. Se la progettazione del modello di modulo abilitato il modulo opzione per il modello di modulo di unione, è anche possibile unire moduli in una raccolta. Unione dei moduli consente agli utenti di consolidamento dei dati da più moduli basati sullo stesso modello di modulo. Unione dati del modulo è utile se si desidera confrontare o riepilogare i dati di più moduli. Ad esempio, un responsabile di team compilazione di un modulo di report di stato settimanali possibile unire i dati di più moduli in un unico modulo di riepilogo per il proprio manager. I dati nei moduli originali non vengono eliminati quando si uniscono i moduli. Gli utenti possono ancora vedere dati originali aprendo ogni forma singolarmente.

Per unire moduli in una raccolta, utilizzare il comando Unisci documenti nel menu Visualizza per la raccolta. Questo comando viene aggiunto al menu Visualizza per una raccolta documenti quando la progettazione del modello di modulo pubblica un modello di modulo in una nuova raccolta da Microsoft Office InfoPath. Il comando viene aggiunto anche quando si aggiunge un tipo di contenuto del sito che supporta l'unione di moduli in una raccolta esistente.

Una volta disponibile il comando di Documenti di stampa unione, è possibile selezionare i file che si desidera unire senza aprire i file. Quando si uniscono moduli di InfoPath con il comando Unisci documenti, InfoPath apre per visualizzare una nuova maschera che contiene i dati uniti dei moduli selezionati. La nuova maschera viene aperta in InfoPath anche i moduli basati su un modello di modulo abilitato per i browser. Se si salva la nuova maschera alla stessa raccolta moduli originali, sarà abilitati per i browser ad altre forme nella raccolta.

Note: 

  • Per garantire che un modello di modulo abilitati per i browser viene sempre aperta nel browser, è necessario fare clic su Visualizza come pagina Web nella pagina Impostazioni avanzate per la raccolta.

  • Per impostazione predefinita, durante l'unione di più moduli in un modulo unico solo i dati uniti sono i dati contenuti in un tabella ripetuta o un sezione ripetuta o dati che sono associati a un controllo elenco o un controllo casella di testo RTF. Tuttavia, quando si progetta modello di modulo, è possibile specificare che i dati in altri tipi di controlli anche devono essere uniti.

Torna all'inizio

Unire più moduli di InfoPath in una raccolta

Per unire più moduli archiviati in una raccolta documenti, eseguire le operazioni seguenti:

  1. Se la raccolta non è già aperta, fare clic sul relativo nome sulla barra di avvio veloce.

    Se il nome della raccolta non è visualizzato, fare clic su Visualizza tutto il contenuto del sito e quindi fare clic sul nome della raccolta.

  2. Il menu visualizzazione Menu Visualizza , scegliere Unisci revisioni.

  3. Nella colonna sottoposta a Merge selezionare le caselle di controllo accanto ai moduli che si desidera unire.

  4. Sulla barra degli strumenti elenco, fare clic su Unisci documenti selezionati.

    Verrà visualizzata la finestra di InfoPath con un nuovo modulo basato sullo stesso modello di modulo che contiene i dati uniti.

    Nota: Quando un utente unisce posta elettronica di InfoPath, i dati uniti dai controlli ripetuti possono contenere una riga vuota. Ad esempio, se un utente unisce tre moduli delle note spese che ogni contengono una singola riga delle spese in una tabella ripetuta, la tabella ripetuta nel modulo di posta elettronica di InfoPath che contiene dati uniti può contenere una riga vuota, seguita da tre righe di dati provenienti da ognuna del tipo di oggetto la sua posta elettronica di InfoPath.

  5. Per salvare la maschera che contiene i dati uniti, nel menu File fare clic su Salva con nome, passare al percorso in cui si vuole salvare la maschera e quindi fare clic su Salva.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×