Ulteriori informazioni SOMMA

Ulteriori informazioni sulla funzione SOMMA

Se si vuole ottenere rapidamente la somma di un intervallo di celle, basta selezionare l'intervallo e osservare l'angolo in basso a destra della finestra di Excel.

Schermata di selezione di un intervallo di celle e visualizzazione della barra di stato


Questa è la barra di stato e mostra informazioni relative a tutti gli elementi selezionati, che si tratti di una singola cella o di più celle. Se si fa clic con il pulsante destro del mouse sulla barra di stato, viene visualizzato un menu con tutte le opzioni che è possibile selezionare. Vengono visualizzati anche i valori dell'intervallo selezionato, se tali attributi sono attivati. 

Il modo più semplice di aggiungere una formula SOMMA al foglio di lavoro consiste nell'usare la procedura guidata Somma automatica. Selezionare una cella vuota direttamente sopra o sotto l'intervallo che si vuole sommare, quindi nella scheda Home o Formule sulla barra multifunzione selezionare Somma automatica > Somma. La procedura guidata Somma automatica rileva automaticamente l'intervallo da sommare e crea la formula. Funziona anche in orizzontale se si seleziona una cella a sinistra o a destra dell'intervallo da sommare. Non funziona invece con gli intervalli non contigui, ma questo argomento verrà affrontato nella prossima sezione.

È possibile usare la procedura guidata Somma automatica per creare automaticamente una formula SOMMA.  Selezionare un intervallo sopra/sotto o a sinistra/destra dell'intervallo da sommare e quindi scegliere la scheda Formule sulla barra multifunzione e selezionare Somma automatica > Somma.


La finestra Somma automatica consente anche di selezionare altre funzioni comuni, ad esempio:

Somma automatica in verticale

La cella B6 mostra la formula SOMMA con Somma automatica: =SOMMA(B2:B5)

La procedura guidata Somma automatica ha individuato automaticamente le celle B2:B5 come l'intervallo da sommare. Non resta che premere INVIO per confermare. Se occorre aggiungere/escludere altre celle, è possibile tenere premuto MAIUSC e il tasto di direzione appropriato finché la selezione non corrisponde a quella desiderata, quindi premere INVIO.

Guida IntelliSense per le funzioni: la casella mobile SOMMA(num1;[num2]; …) sotto la funzione è la relativa guida IntelliSense. Se si fa clic sul nome della funzione, questa diventa un collegamento ipertestuale blu che consente di accedere all'argomento della Guida relativo alla funzione. Se si fa clic sui singoli elementi della funzione, vengono evidenziate le parti rappresentative nella formula. In questo caso viene evidenziato solo l'intervallo B2:B5 perché è presente un solo riferimento numerico in questa formula. La casella della guida IntelliSense viene visualizzata per qualsiasi funzione.

Somma automatica in orizzontale

La cella D2 mostra la formula SOMMA con Somma automatica: =SOMMA(B2:C2)

Uso di SOMMA con intervalli non contigui.  La formula della cella C8 è =SOMMA(C2:C3;C5:C6). Si possono usare anche intervalli denominati, nel qual caso la formula sarebbe =SOMMA(Settimana1;Settimana2).

La procedura guidata Somma automatica funziona in genere solo con gli intervalli contigui, quindi se l'intervallo da sommare contiene righe o colonne vuote, Excel si interrompe appena ne incontra una. In questo caso è necessario aggiungere i singoli intervalli da sommare uno per uno. In questo esempio, se la cella B4 contenesse dati, Excel genererebbe =SOMMA(C2:C6) in quanto riconoscerebbe un intervallo contiguo.

È possibile selezionare rapidamente più intervalli non contigui Ctrl + Maiusc + clic. Immettere "= SOMMA(", quindi selezionare i diversi intervalli ed Excel aggiungerà automaticamente il virgola come separatore tra gli intervalli. Al termine, premere INVIO.

SUGGERIMENTO: è possibile premere ALT+= per aggiungere rapidamente la funzione SOMMA a una cella. Quindi non resta che selezionare gli intervalli.

Nota: come si può notare, Excel ha evidenziato con un colore diverso i diversi intervalli della funzione, corrispondenti alla formula stessa, quindi C2:C3 è di un colore e C5:C6 è di un altro colore. Excel esegue questa operazione per tutte le funzioni, a meno che l'intervallo a cui si fa riferimento non sia in un foglio di lavoro diverso o in una cartella di lavoro diversa. Per migliorare l'accessibilità con gli strumenti di assistive technology, è possibile usare intervalli denominati, come "Settimana1", "Settimana2" e così via, e quindi fare riferimento a essi nella formula:

=SOMMA(Settimana1;Settimana2)

  1. È possibile usare la funzione SOMMA con altre funzioni. Ecco un esempio che crea un calcolo di media mensile:

    Uso di SOMMA con altre funzioni.  La formula nella cella M2 è =SOMMA(A2:L2)/CONTA.VALORI(A2:L2).  Nota: le colonne Maggio-Novembre sono nascoste per maggiore chiarezza.
    • =SOMMA(A2:L2)/CONTA.VALORI(A2:L2)

  2. Questa formula divide la somma di A2:L2 per il numero di celle non vuote in A2:L2 (le celle da Maggio a Dicembre sono vuote).

  1. A volte può essere necessario sommare una determinata cella in più fogli di lavoro. Si potrebbe fare clic su ogni foglio e sulla cella desiderata e quindi usare "+" per sommare i valori delle celle, ma si tratta di un'operazione noiosa e soggetta a errori.

    • =Foglio1!A1+Foglio2!A1+Foglio3!A1

    È possibile ottenere lo stesso risultato in modo molto più semplice, con una funzione SOMMA 3D o tridimensionale:

    SOMMA 3D - La formula nella cella D2 è =SOMMA(Foglio1:Foglio3!A2)
    • =SOMMA(Foglio1:Foglio3!A1)

    Che somma la cella A1 in tutti i fogli da Foglio1 a Foglio3.

    Questa funzione è particolarmente utile ad esempio quando si ha un foglio per ogni mese (Gennaio-Dicembre) e si vuole ottenerne il totale in un foglio di riepilogo.

    SOMMA 3D tra fogli denominati.  La formula in D2 è =SOMMA(Gennaio:Dicembre!A2)
    • =SOMMA(Gennaio:Dicembre!A2)

    Questa funzione somma la cella A2 di ogni foglio da Gennaio a Dicembre.

    Note: se i nomi dei fogli di lavoro contengono spazi, ad esempio "Vendite gennaio", occorre usare un apostrofo per fare riferimento ai nomi dei fogli in una formula. Si noti l'apostrofo PRIMA del nome del primo foglio di lavoro e DOPO il nome dell'ultimo.

    • =SOMMA('Vendite gennaio:Vendite dicembre'!A2)

    Il metodo 3D funziona anche con altre funzioni, come MEDIA, MIN, MAX e altre:

    • =MEDIA(Foglio1:Foglio3!A1)

    • =MIN(Foglio1:Foglio3!A1)

    • =MAX(Foglio1:Foglio3!A1)

È possibile eseguire facilmente operazioni matematiche con Excel, da sole o insieme a funzioni di Excel come SOMMA. La tabella seguente contiene gli operatori che è possibile usare, insieme ad alcune funzioni correlate. È possibile immettere gli operatori usando la fila dei numeri nella parte alta della tastiera oppure il tastierino numerico, se disponibile. Ad esempio, MAIUSC+8 inserisce l'asterisco (*) per la moltiplicazione.

Operatore

Operazione

Esempi

+

Addizione

=1+1

=A1+B1

=SOMMA(A1:A10)+10

=SOMMA(A1:A10)+B1

-

Sottrazione

=1-1

=A1-B1

=SOMMA(A1:A10)-10

=SOMMA(A1:A10)-B1

*

Moltiplicazione

=1*1

=A1*B1

=SOMMA(A1:A10)*10

=SOMMA(A1:A10)*B1

=PRODOTTO(1;1) - funzione PRODOTTO

/

Divisione

=1/1

=A1/B1

=SOMMA(A1:A10)/10

=SOMMA(A1:A10)/B1

=QUOZIENTE(1;1) - funzione QUOZIENTE

^

Elevamento a potenza

=1^1

=A1^B1

=SOMMA(A1:A10)^10

=SOMMA(A1:A10)^B1

=POTENZA(1;1) - funzione POTENZA

Per altre informazioni, vedere Usare Excel come calcolatrice.

Altri esempi

  1. Supponiamo di voler applicare uno sconto in percentuale a un intervallo di celle sommate.

    Uso di operatori con SOMMA.  La formula nella cella B16 è =SOMMA(A2:A14)*-25%.  La formula sarebbe costruita correttamente se il valore -25% fosse un riferimento di cella, come =SOMMA(A2:A14)*E2
    • =SOMMA(A2:A14)*-25%

    Restituisce il 25% dell'intervallo sommato, ma codifica il valore 25% nella formula, rendendolo quindi difficile da trovare in seguito se dovesse essere necessario cambiarlo. È invece consigliabile inserire il valore 25% in una cella e fare riferimento a tale cella, che è ben distinguibile e può essere facilmente modificata, come in questa formula:

    • =SOMMA(A2:A14)*E2

    Per dividere invece di moltiplicare, basta sostituire l'operatore "*" con "/": =SOMMA(A2:A14)/E2

  2. Aggiunta o sottrazione da una funzione SOMMA

    i. È possibile eseguire facilmente operazioni di somma o sottrazione usando + o - in questo modo:

    • =SOMMA(A1:A10)+E2

    • =SOMMA(A1:A10)-E2

Vedere anche

SOMMA

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×