SOMMA.PIÙ.SE (funzione SOMMA.PIÙ.SE)

SOMMA.PIÙ.SE (funzione SOMMA.PIÙ.SE)

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

La funzione SOMMA.PIÙ.SE, una delle funzioni matematiche e trigonometriche, somma tutti i suoi argomenti che soddisfano più criteri. Ad esempio, è possibile usare SOMMA.PIÙ.SE per sommare il numero dei rivenditori nel paese che (1) hanno lo stesso codice postale e (2) i cui profitti superano un importo specifico.

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Questo video fa parte di un corso di formazione intitolato Funzioni SE avanzate.

Sintassi

SOMMA.PIÙ.SE(int_somma; intervallo_criteri1; criteri1; [intervallo_criteri2; criteri2]; ...)

  • =SOMMA.PIÙ.SE(A2:A9;B2:B9;"=A*";C2:C9;"Luca")

  • =SOMMA.PIÙ.SE(A2:A9;B2:B9;"<>Banane";C2:C9;"Luca")

Nome argomento

Descrizione

int_somma    (obbligatorio)

Intervallo di celle da sommare.

intervallo_criteri1    (obbligatorio)

Intervallo testato tramite criteri1.

intervallo_criteri1 e criteri1 impostano una coppia di ricerca in base alla quale eseguire la ricerca di criteri specifici in un intervallo. Una volta trovati gli elementi nell'intervallo, vengono sommati i valori corrispondenti in int_somma.

criteri1    (obbligatorio)

Criteri che definiscono quali celle in intervallo_criteri1 verranno sommate. Ad esempio, i criteri possono essere immessi come 32, ">32", B4, "mele" o "32".

intervallo_criteri2; criteri2; ...    (facoltativo)

Intervalli aggiuntivi e criteri associati. È possibile immettere fino a 127 coppie di intervalli/criteri.

Esempi

Per usare questi esempi in Excel, trascinare per selezionare i dati nella tabella, quindi fare clic con il pulsante destro del mouse sulla selezione e scegliere Copia. In un nuovo foglio di lavoro fare clic con il pulsante destro del mouse nella cella A1, quindi scegliere Mantieni formattazione originale in Opzioni Incolla.

Quantità venduta

Prodotto

Agente di vendita

5

Mele

Luca

4

Mele

Martina

15

Carciofi

Luca

3

Carciofi

Martina

22

Banane

Luca

12

Banane

Martina

10

Carote

Luca

33

Carote

Martina

Formula

Descrizione

=SOMMA.PIÙ.SE(A2:A9; B2:B9; "=C*"; C2:C9; "Luca")

Aggiunge il numero di prodotti che iniziano con a e sono stati venduti da Tom. Usa il carattere jolly * in Criteri1, "= a *" per cercare i nomi dei prodotti corrispondenti in Criterial_range1 B2: B9 e cerca il nome "Tom" in Criterial_range2 C2: C9. Aggiunge quindi i numeri in Sum_range a2: A9 che soddisfano entrambe le condizioni. Il risultato è 20.

=SOMMA.PIÙ.SE(A2:A9; B2:B9; "<>Banane"; C2:C9, "Luca")

Somma il numero di prodotti che non sono banane e che sono stati venduti da Luca. Esclude le banane usando <> in criteri1, "<>Banane", e cerca il nome "Luca" in intervallo_criteri2 C2:C9. Somma quindi i numeri in int_somma A2:A9 che soddisfano entrambe le condizioni. Il risultato è 30.

Problemi comuni

Problema

Descrizione

0 (zero) viene visualizzato al posto del risultato previsto.

Controllare che criteri1,2 siano racchiusi tra virgolette se si stanno verificando valori di testo, come il nome di una persona.

Il risultato non è corretto quando int_somma ha valori VERO o FALSO.

I valori VERO e FALSO per int_somma vengono valutati in modo diverso e questo può generare risultati imprevisti quando vengono sommati.

Le celle in int_somma che contengono il valore VERO restituiscono 1. Quelle che contengono il valore FALSO restituiscono 0 (zero).

Procedure consigliate

Operazione da eseguire

Descrizione

Usare caratteri jolly.

L'uso di caratteri jolly come il punto interrogativo (?) e l'asterisco (*) in criteri1,2 può aiutare a trovare corrispondenze simili ma non esatte.

Un punto interrogativo corrisponde a qualsiasi carattere singolo. Un asterisco corrisponde a qualsiasi sequenza di caratteri. Per trovare un vero e proprio punto interrogativo o asterisco, anteporre una tilde (~) a tale carattere.

Ad esempio, =SOMMA.PIÙ.SE(A2:A9, B2:B9, "=C*", C2:C9, "Luc?") sommerà tutte le istanze il cui nome inizia con "Luc" e termina con un'ultima lettera variabile.

Comprendere la differenza tra SOMMA.PIÙ.SE e SOMMA.SE.

L'ordine degli argomenti è diverso in SOMMA.PIÙ.SE rispetto a SOMMA.SE. In particolare, l'argomento int_somma è il primo argomento in SOMMA.PIÙ.SE, mentre in SOMMA.SE è il terzo. Questa è una delle cause più comuni dei problemi correlati all'uso di queste funzioni.

Se si copiano e si modificano queste funzioni simili, assicurarsi di inserire gli argomenti nell'ordine corretto.

Usare lo stesso numero di righe e colonne per gli argomenti di intervallo.

L'argomento intervallo_criteri deve contenere lo stesso numero di righe e colonne dell'argomento int_somma.

Inizio pagina

Domande su funzioni specifiche?

Pubblicare una domanda nel forum della community di Excel

Suggerimenti per migliorare Excel

Per suggerimenti su come migliorare la prossima versione di Excel, vedere gli argomenti in Excel User Voice.

Vedere anche

Vedere un video su come usare le funzioni IF avanzate come somma.più.se

La funzione SOMMA.SE somma solo i valori che soddisfano un singolo criterio

La funzione SOMMA.Q somma più valori dopo avere calcolato il quadrato di ciascuno

La funzione CONTA.SE conta solo i valori che soddisfano un singolo criterio

La funzione CONTA.PIÙ.SE conta solo i valori che soddisfano più criteri

Funzione PIÙ.SE (Office 365, Excel 2016 e versioni successive)

Panoramica delle formule in Excel

Come evitare errori nelle formule

Rilevare gli errori nelle formule

Funzioni matematiche e trigonometriche

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×