SE.ERRORE (funzione SE.ERRORE)

Puoi usare la funzione se. errore per intercettare e gestire gli errori in una formula. Se. errore restituisce un valore specificato se una formula restituisce un errore. in caso contrario, restituisce il risultato della formula.

Sintassi

SE.ERRORE(valore; se_errore)

Gli argomenti della sintassi della funzione SE.ERRORE sono i seguenti:

  • valore    Obbligatorio. Argomento in cui viene verificata la presenza di un errore.

  • value_if_error    Obbligatorio. Valore da restituire se la formula restituisce un errore. Vengono valutati i seguenti tipi di errore: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME? o #NULL!.

Osservazioni

  • Se valore o value_if_error è una cella vuota, se. errore la considera come un valore stringa vuoto ("").

  • Se value è una formula in forma di matrice, se. errore restituirà una matrice di risultati per ogni cella nell'intervallo specificato in value. Vedere il secondo esempio riportato di seguito.

Esempi

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO.

Quota

Unità vendute

210

35

55

0

23

Formula

Descrizione

Risultato

=SE.ERRORE(A2/B2; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento (210 diviso 35), non trova errori e quindi restituisce i risultati della formula.

6

=SE.ERRORE(A3/B3; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento (55 diviso 0), trova un errore di divisione per 0 e quindi restituisce valore_se_errore.

Errore nel calcolo

=SE.ERRORE(A4/B4; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento ("" diviso 23), non trova errori e quindi restituisce i risultati della formula.

0

Esempio 2

Quota

Unità vendute

Rapporto

210

35

6

55

0

Errore nel calcolo

23

0

Formula

Descrizione

Risultato

=C2

Verifica la presenza di un errore nella formula nel primo argomento nel primo elemento della matrice (A2/B2 o 210 diviso 35), non trova errori e quindi restituisce il risultato della formula.

6

=C3

Verifica la presenza di un errore nella formula nel primo argomento nel secondo elemento della matrice (A3/B3 o 55 diviso 0), trova un errore di divisione per 0 e quindi restituisce valore_se_errore.

Errore nel calcolo

=C4

Verifica la presenza di un errore nella formula nel primo argomento nel terzo elemento della matrice (A4/B4 o "" diviso 23), non trova errori e quindi restituisce il risultato della formula.

0

Nota: se si ha una versione corrente di Office 365, è possibile immettere la formula nella cella superiore sinistra dell'intervallo di output, quindi premere INVIO per confermare la formula come formula in forma di matrice dinamica. In caso contrario, la formula deve essere immessa come formula di matrice legacy selezionando dapprima l'intervallo di output, inserendo la formula nella cella superiore sinistra dell'intervallo di output, quindi premere CTRL + MAIUSC + INVIO per confermarla. Excel inserisce le parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule in forma di matrice: indicazioni ed esempi.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×