Risoluzione dei problemi di ricerca in Outlook

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Scegliere lo scenario che meglio descrive il problema di ricerca di Outlook:

La ricerca di Outlook non restituisce risultati

Quando non vengono restituiti risultati mediante la ricerca di Outlook, eseguire le operazioni seguenti nell'ordine indicato:

  • In Windows 10: selezionare il pulsante Start , selezionare Impostazioni > aggiornare _AMP_ sicurezzae quindi selezionare risoluzione dei problemi. Trovare e fare clic su ricerca eindicizzazione e quindi su Esegui lo strumento di risoluzione dei problemi.

  • In Windows 8,1: da Start, cercare Impostazioni. In Impostazioniricerca per la risoluzione dei problemie seleziona risoluzione dei problemi nei risultati della ricerca. Trovare ed eseguire lo strumento di risoluzione dei problemi di ricerca e indicizzazione.

  • In Windows 7: da Start, selezionare Pannello di controlloe quindi fare clic su risoluzione dei problemi. Trovare ed eseguire lo strumento di risoluzione dei problemi di ricerca e indicizzazione.

  1. Avviare Outlook e fare clic nella casella Cerca.

  2. Selezionare Strumenti di ricerca > Stato indicizzazione nel menu Cerca.

  3. Quando viene visualizzata la finestra di dialogo stato indicizzazione, dovresti vedere

    quanto segue: Stato inDicizzazione per la ricerca in Outlook

Se Outlook non ha completato l'indicizzazione, prendere nota degli elementi rimanenti da indicizzare, attendere 5 minuti e quindi controllare di nuovo. Se il numero di elementi non è diminuito, procedere con il passaggio successivo.

  1. Avviare Outlook e fare clic nella casella Cerca.

  2. Selezionare Strumenti di ricerca > Percorsi di ricerca nel menu Cerca.

  3. Assicurarsi che tutti i file dati/archivi elencati siano selezionati.

  1. Fare clic sul menu Start di Windows e fare clic nella casella di ricerca .

  2. Digitare Services. msc e premere INVIO.

  3. Nella colonna nome trovare e fare doppio clic su ricerca per Windows.

  4. Impostare il tipo di avvio su automatico (avvio ritardato) se non è già stato fatto.

  5. Se lo stato del servizio non viene visualizzato in esecuzione, fare clic sul pulsante Start sotto di esso per avviare il servizio.

  1. Uscire da Outlook.

  2. Aprire Opzioni di indicizzazione nel Pannello di controllo di Windows.

  3. Nella finestra di dialogo Opzioni di indicizzazione assicurarsi che Microsoft Outlook sia elencato nella colonna Percorsi inclusi.

  4. Se Microsoft Outlook non è elencato, selezionare Modifica e quindi fare clic per abilitare la casella di controllo accanto a Microsoft Outlook.

  5. Fare clic su OK e quindi selezionare Chiudi.

Eseguire questa procedura per assicurarsi che le opzioni di indicizzazione siano configurate correttamente:

  1. Uscire da Outlook.

  2. Aprire Opzioni di indicizzazione nel Pannello di controllo di Windows.

  3. Nella finestra di dialogo Opzioni di indicizzazione selezionare Avanzate.

  4. Selezionare la scheda Tipi di file.

  5. Scorrere verso il basso fino a individuare msg nella colonna Estensione e selezionare tale voce.

  6. Assicurarsi che l'opzione Indicizza le proprietà e il contenuto del file sia abilitata.

  7. Fare clic su OK e quindi selezionare Chiudi.

Nota: Assicurarsi che nella colonna Descrizione filtro sia visualizzato Office Outlook MSG IFilter. In caso contrario, il servizio Windows Search non funziona correttamente oppure Microsoft Outlook non è riuscito a installare i filtri correttamente. In entrambi i casi è necessario rivolgersi al supporto tecnico Microsoft per assistenza con questo problema.

  1. Uscire da Outlook.

  2. Aprire Opzioni di indicizzazione nel Pannello di controllo di Windows.

  3. Nella finestra di dialogo Opzioni di indicizzazione selezionare Modifica, deselezionare la casella di controllo accanto a Outlook e quindi scegliere OK.

  4. Nella finestra di dialogo Opzioni di indicizzazione selezionare Avanzate.

  5. Nella finestra di dialogo Opzioni avanzate selezionare Nuovo indice.

  6. Fare clic su OK e quindi selezionare Chiudi.

Se l'indicizzazione viene completata senza includere file di dati di Outlook, contattare il supporto tecnico Microsoft e richiedere assistenza per la funzionalità Ricerca immediata di Outlook.

Se l'indicizzazione non viene completata, contattare il supporto tecnico Microsoft e richiedere assistenza per la funzionalità Desktop Search di Windows.

Eseguire questa procedura per creare un nuovo profilo e testare la funzionalità di ricerca:

  1. In Outlook selezionare File > Impostazioni account > Gestisci profili. In alternativa, è possibile uscire da Outlook e aprire Posta nel Pannello di controllo di Windows.

  2. Nella finestra di dialogo Configurazione della posta - Outlook selezionare Mostra profili e quindi selezionare Aggiungi nella scheda Generale.

  3. Nella casella Nome profilo digitare un nome per il nuovo profilo e quindi scegliere OK.

  4. Se richiesto, fornire le informazioni dell'account, come indirizzo di posta elettronica e password, quindi selezionare Avanti.

  5. Selezionare Fine. Il nome del nuovo profilo aggiunto apparirà nella scheda Generale della finestra di dialogo Posta.

  6. In All'avvio di Microsoft Outlook selezionare Richiedi un profilo da utilizzare e quindi scegliere OK.

  7. Riavviare Outlook.

  8. Nell'elenco a discesa della finestra di dialogo Scegli profilo scegliere il nome del nuovo profilo creato e fare clic su OK.

  9. Fare clic nella casella Cerca e provare a eseguire la ricerca.

Se la ricerca funziona, il problema potrebbe dipendere dal vecchio profilo. È consigliabile impostare questo profilo come nuovo profilo predefinito e trasferire le informazioni dal vecchio al nuovo profilo.

La procedura per accedere allo strumento di ripristino varia in base al sistema operativo. Scegliere dall'elenco a discesa qui sotto.

  1. Fare clic con il pulsante destro del mouse sul pulsante Start Pulsante Start di Windows in Windows 8 e Windows 10 nell'angolo in basso a sinistra e scegliere App e funzionalità dal menu a comparsa.

    Screenshot del menu Start che mostra App e funzionalità
  2. Selezionare l'applicazione di Microsoft Office da ripristinare e scegliere Modifica.

    Nota: È necessario ripristinare l'intera famiglia di prodotti di Office anche se si intende ripristinare una singola applicazione come Word o Excel. Se si dispone di un'app autonoma, cercare l'applicazione in base al nome.

  3. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, verranno visualizzate le seguenti opzioni con continuare con il ripristino. Seguire la procedura corrispondente al tipo di installazione.

    A portata di clic

    Nella finestra In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online > Ripristina in modo da eseguire un ripristino completo. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  4. Seguire le istruzioni sullo schermo per completare il processo.

  1. Fare clic con il pulsante destro del mouse sul pulsante Start Pulsante Start di Windows in Windows 8 e Windows 10 nell'angolo in basso a sinistra e scegliere Pannello di controllo dal menu a comparsa.

    Elenco di opzioni e comandi visualizzati dopo aver premuto il tasto logo Windows + X
  2. Nella visualizzazione Categoria selezionare Disinstalla un programma in Programmi.

  3. Fare clic con il pulsante destro del mouse sull'applicazione di Microsoft Office da ripristinare e scegliere Cambia dal menu a discesa.

    Nota: Se si ha una famiglia di prodotti come Office 365 Home o Office Home and Student 2013 o 2016, cercare il nome della famiglia di prodotti, anche se si vuole ripristinare solo una singola applicazione come Word o Excel. Se si ha un'applicazione autonoma come Word o Excel, cercare il nome dell'applicazione.

  4. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, eseguire la procedura seguente per il tipo di installazione di Office:

    Tipo di installazione A portata di clic:

    In In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online in modo da eseguire un ripristino completo, quindi scegliere Ripristina. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Tipo di installazione basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  5. Seguire le istruzioni sullo schermo restanti per completare il processo.

  1. Fare clic sul pulsante Start Pulsante Start di Windows 7 > Pannello di controllo.

  2. Nella visualizzazione Categoria selezionare Disinstalla un programma in Programmi.

  3. Fare clic sull'applicazione di Office da ripristinare e quindi su Cambia.

    Nota: Se si ha una famiglia di prodotti come Office 365 Home o Office Home and Student 2013 o 2016, cercare il nome della famiglia di prodotti, anche se si vuole ripristinare solo una singola applicazione come Word o Excel. Se si ha un'applicazione autonoma come Word o Excel, cercare il nome dell'applicazione.

  4. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, eseguire la procedura seguente per il tipo di installazione di Office:

    Tipo di installazione A portata di clic:

    In In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online in modo da eseguire un ripristino completo, quindi scegliere Ripristina. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Tipo di installazione basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  5. Seguire le istruzioni sullo schermo restanti per completare il processo.

  1. Fare clic su questo pulsante per la risoluzione rapida dei problemi per la disinstallazione di Office.

    Pulsante per il download di Easy Fix che indica che è disponibile una correzione automatica
  2. Per i passaggi rimanenti che mostrano come salvare e usare la correzione, selezionare il browser dall'elenco a discesa:

    1. Nella parte inferiore della finestra del browser selezionare Apri per aprire il file O15CTRRemove.diagcab.

      Selezionare Apri per aprire lo strumento per la risoluzione rapida dei problemi O15CTRRemove.diagcab

      Se il file non si apre automaticamente, scegliere Salva > Apri cartella e quindi fare doppio clic sul file (il nome dovrebbe iniziare con "O15CTRRemove") per eseguire lo strumento di risoluzione rapida dei problemi.

    2. Viene avviata la disinstallazione guidata di Microsoft Office. Selezionare Avanti e seguire le istruzioni visualizzate.

    3. Quando viene visualizzata la schermata Disinstallazione completata, seguire le istruzioni per riavviare il computer in modo da applicare le modifiche. Selezionare Avanti.

    4. Riavviare il computer e provare a reinstallare Office.

    Per reinstallare Office, Selezionare la versione da installare e seguire i passaggi riportati.

    Office 365
    Office 2019
    Office 2016
    Office 2013

    1. Nell'angolo in basso a sinistra selezionare il file o15CTRRemove e quindi nell'elenco a discesa selezionare Mostra nella cartella.

      Nell'elenco a discesa selezionare Mostra nella cartella

      Fare doppio clic sul download, o15CTRRemove, per eseguire lo strumento di risoluzione rapida dei problemi.

    2. Viene avviata la disinstallazione guidata di Microsoft Office. Selezionare Avanti e seguire le istruzioni visualizzate.

    3. Quando viene visualizzata la schermata Disinstallazione completata, seguire le istruzioni per riavviare il computer in modo da applicare le modifiche. Selezionare Avanti.

    4. Riavviare il computer e provare a reinstallare Office.

    Per reinstallare Office, Selezionare la versione da installare e seguire i passaggi riportati.

    Office 365
    Office 2019
    Office 2016
    Office 2013

    1. Scegliere Salva file e quindi OK.

      Salvare il file O15CTRRemove.diagcab in Firefox

      Nell'angolo in alto a destra della finestra del browser selezionare Mostra tutti i download. Nella raccolta selezionare Download > O15CTRRemove.diagcab e quindi selezionare l'icona della cartella. Fare doppio clic sul file O15CTRRemove.diagcab.

    2. Viene avviata la disinstallazione guidata di Microsoft Office. Selezionare Avanti e seguire le istruzioni visualizzate.

    3. Quando viene visualizzata la schermata Disinstallazione completata, seguire le istruzioni per riavviare il computer in modo da applicare le modifiche. Selezionare Avanti.

    4. Riavviare il computer e provare a reinstallare Office.

    Per reinstallare Office, Selezionare la versione da installare e seguire i passaggi riportati.

    Office 365
    Office 2019
    Office 2016
    Office 2013

Nota: Se questa procedura non è utile, provare i passaggi avanzati di questo articolo: Nessun risultato della ricerca per gli account POP, IMAP o Exchange

La ricerca di Outlook restituisce risultati incompleti

Quando si ottengono risultati incompleti con la ricerca di Outlook, eseguire le operazioni seguenti nell'ordine indicato:

Se i risultati della ricerca mancanti si trovano nella cartella Posta eliminata, è possibile aggiungere questa cartella ai risultati della ricerca:

  1. Avviare Outlook.

  2. Fare clic su Opzionifile di _GT_ e quindi selezionare Cerca.

  3. Selezionare la casella di controllo Includi messaggi dalla cartella Posta eliminata in ogni file di dati durante la ricerca in tutti gli elementi e quindi fare clic su OK.

  4. Riavviare Outlook.

È possibile aumentare le ore delle impostazioni offline dell'account di posta elettronica in modo che più o tutti i messaggi di posta elettronica vengano memorizzati nella cache localmente per l'indicizzazione. Per eseguire questa operazione:

  1. Avviare Outlook.

  2. Fare clic su File > Impostazioni account > Impostazioni account.

  3. Nella scheda posta elettronica selezionare l'account di posta elettronica e fare clic su Cambia.

  4. Trascina il messaggio di posta elettronica per il download passato: dispositivo di scorrimento fino alla quantità di tempo desiderata o all'estrema destra per tutti.

  5. Fare clic su Avantie quindi su fine. Chiudere la finestra e riavviare Outlook.

Per impostazione predefinita, Outlook visualizzerà i risultati della ricerca di 250. Puoi aumentare questa funzione per visualizzare tutti i risultati, ma la ricerca sarà più lenta. Per eseguire questa operazione:

  1. Aprire Outlook.

  2. Fare clic su Opzionifile di _GT_ e quindi selezionare Cerca.

  3. Deselezionare la casella di controllo migliora la velocità di ricerca limitando il numero dei risultati visualizzati e quindi fare clic su OK.

  4. Riavviare Outlook.

Ricerca di Outlook non riesce a trovare i messaggi meno recenti

Se non si riesce a trovare i messaggi di posta elettronica che superano i 6 mesi usando la ricerca di Outlook, eseguire le operazioni seguenti nell'ordine indicato:

Se i risultati della ricerca mancanti si trovano nella cartella Posta eliminata, è possibile aggiungere questa cartella ai risultati della ricerca:

  1. Avviare Outlook.

  2. Fare clic su Opzionifile di _GT_ e quindi selezionare Cerca.

  3. Selezionare la casella di controllo Includi messaggi dalla cartella Posta eliminata in ogni file di dati durante la ricerca in tutti gli elementi e quindi fare clic su OK.

  4. Riavviare Outlook.

È possibile aumentare le ore delle impostazioni offline dell'account di posta elettronica in modo che più o tutti i messaggi di posta elettronica vengano memorizzati nella cache localmente per l'indicizzazione. Per eseguire questa operazione:

  1. Avviare Outlook.

  2. Fare clic su File > Impostazioni account > Impostazioni account.

  3. Nella scheda posta elettronica selezionare l'account di posta elettronica e fare clic su Cambia.

  4. Trascina il messaggio di posta elettronica per il download passato: dispositivo di scorrimento fino alla quantità di tempo desiderata o all'estrema destra per tutti.

  5. Fare clic su Avantie quindi su fine. Chiudere la finestra e riavviare Outlook.

Per impostazione predefinita, Outlook visualizzerà i risultati della ricerca di 250. Puoi aumentare questa funzione per visualizzare tutti i risultati, ma la ricerca sarà più lenta. Per eseguire questa operazione:

  1. Aprire Outlook.

  2. Fare clic su Opzionifile di _GT_ e quindi selezionare Cerca.

  3. Deselezionare la casella di controllo migliora la velocità di ricerca limitando il numero dei risultati visualizzati e quindi fare clic su OK.

  4. Riavviare Outlook.

La scheda Cerca è disattivata (solo Outlook 2016)

Questo problema può verificarsi dopo l'aggiornamento a Windows 10 versione 1709 e versioni precedenti. Il problema è stato risolto in Windows 10 versioni 1803 e successive. Per risolvere il problema, eseguire questa procedura:

La procedura per accedere allo strumento di ripristino varia in base al sistema operativo. Scegliere dall'elenco a discesa qui sotto.

  1. Fare clic con il pulsante destro del mouse sul pulsante Start Pulsante Start di Windows in Windows 8 e Windows 10 nell'angolo in basso a sinistra e scegliere App e funzionalità dal menu a comparsa.

    Screenshot del menu Start che mostra App e funzionalità
  2. Selezionare l'applicazione di Microsoft Office da ripristinare e scegliere Modifica.

    Nota: È necessario ripristinare l'intera famiglia di prodotti di Office anche se si intende ripristinare una singola applicazione come Word o Excel. Se si dispone di un'app autonoma, cercare l'applicazione in base al nome.

  3. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, verranno visualizzate le seguenti opzioni con continuare con il ripristino. Seguire la procedura corrispondente al tipo di installazione.

    A portata di clic

    Nella finestra In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online > Ripristina in modo da eseguire un ripristino completo. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  4. Seguire le istruzioni sullo schermo per completare il processo.

  1. Fare clic con il pulsante destro del mouse sul pulsante Start Pulsante Start di Windows in Windows 8 e Windows 10 nell'angolo in basso a sinistra e scegliere Pannello di controllo dal menu a comparsa.

    Elenco di opzioni e comandi visualizzati dopo aver premuto il tasto logo Windows + X
  2. Nella visualizzazione Categoria selezionare Disinstalla un programma in Programmi.

  3. Fare clic con il pulsante destro del mouse sull'applicazione di Microsoft Office da ripristinare e scegliere Cambia dal menu a discesa.

    Nota: Se si ha una famiglia di prodotti come Office 365 Home o Office Home and Student 2013 o 2016, cercare il nome della famiglia di prodotti, anche se si vuole ripristinare solo una singola applicazione come Word o Excel. Se si ha un'applicazione autonoma come Word o Excel, cercare il nome dell'applicazione.

  4. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, eseguire la procedura seguente per il tipo di installazione di Office:

    Tipo di installazione A portata di clic:

    In In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online in modo da eseguire un ripristino completo, quindi scegliere Ripristina. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Tipo di installazione basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  5. Seguire le istruzioni sullo schermo restanti per completare il processo.

  1. Fare clic sul pulsante Start Pulsante Start di Windows 7 > Pannello di controllo.

  2. Nella visualizzazione Categoria selezionare Disinstalla un programma in Programmi.

  3. Fare clic sull'applicazione di Office da ripristinare e quindi su Cambia.

    Nota: Se si ha una famiglia di prodotti come Office 365 Home o Office Home and Student 2013 o 2016, cercare il nome della famiglia di prodotti, anche se si vuole ripristinare solo una singola applicazione come Word o Excel. Se si ha un'applicazione autonoma come Word o Excel, cercare il nome dell'applicazione.

  4. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, eseguire la procedura seguente per il tipo di installazione di Office:

    Tipo di installazione A portata di clic:

    In In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online in modo da eseguire un ripristino completo, quindi scegliere Ripristina. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Tipo di installazione basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  5. Seguire le istruzioni sullo schermo restanti per completare il processo.

Cassetta postale condivisa: problemi con i risultati della ricerca

Se non si ottengono risultati previsti da una ricerca in una cassetta postale condivisa o si riceve un errore, eseguire una delle operazioni seguenti:

Disabilitare la ricerca nel server come soluzione a breve termine. A questo scopo, procedere come segue:

Importante: La procedura seguente mostra come modificare il Registro di sistema. Tuttavia, la modifica non corretta del Registro di sistema può causare problemi gravi. Assicurarsi di seguire attentamente tutti i passaggi. Per una maggiore sicurezza, eseguire un backup del Registro di sistema prima di modificarlo, in modo che sia possibile ripristinarlo in caso di problemi. Per altre informazioni su come eseguire il backup e il ripristino del Registro di sistema, vedere Come eseguire il backup e il ripristino del Registro di sistema in Windows.

  1. In Windows fare clic con il pulsante destro del mouse su Start, quindi selezionare Esegui. Nella casella Apri: digitare regedit e fare clic su OK. Si aprirà l'editor del Registro di sistema.

  2. Nella finestra di dialogo Editor del registro di sistema trovare questa sottochiave nel registro di sistema e quindi fare clic su di essa:

    • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Search

  3. Fare clic su Modifica > Nuovo > Valore DWORD.

  4. Digitare DisableServerAssistedSearch per il nome del valore DWORD e quindi premere INVIO.

  5. Fare clic con il pulsante destro del mouse su DisableServerAssistedSearch e quindi scegliere modifica.

  6. Nella casella dati valore Digitare 1 per abilitare la voce del registro di sistema e quindi fare clic su OK.

  7. Chiudere l'editor del registro di sistema e quindi riavviare Windows.

Nota: Questo criterio e altre considerazioni importanti sono documentati nel Blog di ricerca.

Per eseguire una ricerca in una cassetta postale condivisa, fare clic sulla cassetta postale e usare l'ambito della cartella corrente . Si tratta di un limite di progettazione attualmente in fase di elaborazione per gli aggiornamenti futuri. Passare a questo Blog informazioni sugli ambiti di ricerca per altri dettagli sugli ambiti supportati quando.

Vedere anche

Limitare i criteri di ricerca per ottimizzare le ricerche in Outlook

Trovare un messaggio o un elemento con Ricerca immediata

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×