Riprodurre un'animazione di Adobe Macromedia Flash in una presentazione

PowerPoint per Office 365, PowerPoint 2019, PowerPoint 2016, PowerPoint 2013, PowerPoint 2010

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Se si dispone di un elemento grafico animato creato con Adobe Macromedia Flash e salvato come file Shockwave con estensione SWF, è possibile riprodurre il file in una presentazione di PowerPoint.

Aggiungere un file Flash a una presentazione in PowerPoint 2010 e versioni successive per incorporare o collegare il file in una diapositiva.

Note: 

  • Potrebbe essere alcune limitazioni quando si utilizza Flash in PowerPoint, tra cui l'impossibilità di utilizzare effetti speciali (ad esempio ombreggiature, riflessi, effetti alone, contorni sfumati, rilievi e rotazione 3D), la dissolvenza e funzionalità di taglio e la possibilità di comprimere i file per la condivisione e distribuzione più semplice.

  • La versione di PowerPoint 2010 64 bit non è compatibile con versioni a 32 bit di QuickTime o Flash. È necessario installare una versione a 64 bit di QuickTime o Flash o una versione a 32 bit di PowerPoint 2010.

Incorporare un file Flash

  1. Nella Visualizzazione normale fare clic sulla diapositiva in cui si desidera incorporare un video.

  2. Nel gruppo elementi multimediali della scheda Inserisci fare clic sulla freccia sotto Video e quindi fare clic su Video nel PC o un Video da file.

  3. Nella finestra di dialogo Inserisci Video individuare e selezionare il video che si desidera incorporare e quindi fare clic su Inserisci.

  4. Per visualizzare un'anteprima dell'animazione Flash, fare clic su Riproduci nella scheda Formato in strumenti Video.

Creare un collegamento a un file Flash

  1. Nella scheda Diapositive, in visualizzazione Normale fare clic sulla diapositiva a cui si vuole aggiungere un filmato o un'immagine GIF animata.

  2. Nel gruppo Elementi multimediali della scheda Inserisci fare clic sulla freccia sotto Video.

  3. Fare clic su Video nel PC o un Video da File, individuare e fare clic sul file che si desidera creare un collegamento a.

  4. Fare clic sulla freccia verso il basso del pulsante Inserisci e quindi su Collega a file.

    Importante: Per evitare problemi di collegamenti interrotti, è consigliabile copiare i video nella stessa cartella della presentazione e collegarsi a essi da tale percorso.

  5. Per visualizzare un'anteprima dell'animazione Flash, fare clic su Riproduci nella scheda Formato in strumenti Video.

Per aggiungere un file con estensione SWF in PowerPoint 2007, utilizzare il controllo ActiveX Shockwave Flash Object e Adobe Macromedia Flash Player. Per riprodurre il file Flash, aggiungere un controllo ActiveX alla diapositiva e il nome di un collegamento al file di anteprima.

Impostazioni di protezione di controllo ActiveX si trovano nel Centro protezione, nel punto in cui è possibile trovare le impostazioni di privacy per le applicazioni di Microsoft Office System 2007 e sicurezza. Potrebbe essere necessario regolare le impostazioni di sicurezza per consentire l'esecuzione dei controlli ActiveX. Impostazioni di ActiveX in Centro protezione si applicano a tutti i prodotti versione 2007 di Office. Ad esempio, se si modifica un'impostazione di PowerPoint, l'impostazione viene inoltre modificata per altri programmi di Office che utilizzano il Centro protezione. Per ulteriori informazioni sui controlli ActiveX e la modifica delle impostazioni, vedere abilitare o disabilitare le impostazioni di ActiveX nei file di Office.

Importante: 

  • Nel computer per poter riprodurre il file Flash in una presentazione, è necessario che sia registrato Shockwave Flash Object. Per verificare se è registrato Shockwave Flash Object, nel gruppo controlli della scheda sviluppo fare clic su Altri controlli Icona del pulsante . Se Shockwave Flash Object viene visualizzata nell'elenco dei controlli, viene registrato nel computer in uso. Se non è registrato, scaricare la versione più recente di Flash Player dal Web Adobe siti per registrare Shockwave Flash Object nel computer in uso.

  • Per garantire la corretta esecuzione di animazioni complesse, installare la versione più recente di Flash Player, anche se nel computer sono registrate versioni precedenti di Shockwave Flash Object.

Aggiungere un file Flash a una presentazione

  1. Installare Flash Player nel computer.

  2. Nella visualizzazione Normale di PowerPoint aprire la diapositiva in cui si vuole riprodurre l'animazione.

  3. Fare clic sul pulsante Microsoft Office Icona del pulsante Office e quindi scegliere Opzioni di PowerPoint.

  4. Fare clic su Impostazioni generali e quindi in Opzioni principali per l'utilizzo di PowerPoint selezionare la casella di controllo Mostra scheda Sviluppo sulla barra multifunzione e fare clic su OK.

  5. Nel gruppo Controlli della scheda Sviluppo fare clic su Altri controlli Icona del pulsante .

  6. Nell'elenco di controlli fare clic su Shockwave Flash Object, fare clic su OK e quindi trascinare il puntatore nella diapositiva per disegnare il controllo.

    Ridimensionare il controllo trascinando i quadratini di ridimensionamento.

  7. Fare clic con il pulsante destro del mouse sul controllo Shockwave Flash Object e quindi scegliere Proprietà.

  8. Nella scheda Alfabetico fare clic sulla proprietà Movie.

  9. Nella colonna del valore (la cella bianca accanto a Movie) digitare il percorso completo dell'unità, incluso il nome file, ad esempio C\:NomeFile.swf, o l'URL (Uniform Resource Locator) del file Flash da riprodurre.

  10. Per impostare opzioni specifiche di riproduzione dell'animazione, eseguire le operazioni seguenti e quindi chiudere la finestra di dialogo Proprietà:

    • Per riprodurre il file automaticamente quando viene visualizzata la diapositiva, impostare la proprietà Playing su True. Se il file Flash ha un controllo incorporato di avvio/riavvolgimento rapido, è possibile impostare la proprietà Playing su False.

    • Se non si vuole che l'animazione venga riprodotta ripetutamente, impostare la proprietà Loop su False.

Visualizzare l'anteprima di un'animazione in visualizzazione Presentazione

  • Nel gruppo Visualizzazioni presentazione della scheda Visualizzazione fare clic su Presentazione oppure premere F5.

    Per uscire dalla presentazione e tornare alla visualizzazione Normale, premere ESC.

Note: 

  • A differenza di immagini o disegni, file Flash sono sempre collegati a una presentazione in PowerPoint 2007, anziché incorporati. Quando si inserisce un file collegato, viene creato un collegamento alla posizione corrente del file. Se si sposta in un secondo momento il file in un percorso diverso, PowerPoint non è possibile trovarlo quando si desidera che il file da riprodurre. È consigliabile copiare i file Flash nella stessa cartella della presentazione prima di inserire i file di anteprima. Verrà creato un collegamento al file Flash e possibile trovare il file Flash, purché si mantenerlo nella cartella della presentazione, anche se si sposta o copia la cartella in un altro computer. Un altro modo per essere certi che i file collegati siano nella stessa cartella della presentazione consiste nell'utilizzare la caratteristica pacchetto per CD. Questa caratteristica copia tutti i file in una posizione (un CD o una cartella) con la presentazione e aggiorna automaticamente tutti i collegamenti per i file. Quando la presentazione contiene file collegati, è necessario copiare insieme alla presentazione se si prevede di eseguire la presentazione in un altro computer o inviarla tramite posta elettronica.

  • I prodotti di terze parti citati in questo articolo sono prodotti da fornitori indipendenti da Microsoft. Microsoft non riconosce alcuna garanzia, implicita o espressa, in relazione alle prestazioni o all'affidabilità di tali prodotti.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×