Registrazione di una macro

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Se in Microsoft Office Project si esegue più volte un'attività, è possibile automatizzarla tramite una macro. Una macro consiste in una serie di comandi e di funzioni memorizzati in un modulo che è possibile eseguire ogni volta che è necessario eseguire l'attività.

  1. Nella scheda Visualizza fare clic su macro e quindi fare clic su Registra Macro.

    (In Project 2007, dal menu Strumenti scegliere Macro e quindi fare clic su Registra nuova Macro.)

  2. Nella casella Nome macro digitare il nome per la macro.

    Il primo carattere del nome della macro deve essere una lettera. Gli altri caratteri possono essere lettere, numeri o caratteri di sottolineatura. Gli spazi vuoti non sono consentiti nel nome della macro, ma il carattere di sottolineatura funge da separatore tra le parole.

  3. Per poter eseguire la macro premendo un combinazione di tasti, immettere una lettera o una combinazione di tasti nella casella Tasto di scelta rapida.

    È possibile utilizzare CTRL+lettera (per le lettere minuscole) o CTRL+MAIUSC+lettera (per le lettere maiuscole), dove lettera è una qualsiasi lettera sulla tastiera, ma non un numero o un carattere speciale. Non è possibile utilizzare una combinazione di tasti già utilizzata in Microsoft Office Project.

  4. Nell'elenco Memorizza macro in fare clic sulla posizione in cui si desidera memorizzare la macro:

    • Per rendere la macro disponibile ogni volta che si utilizza Project, fare clic su File globale.

    • Per rendere la macro disponibile solo per il progetto corrente, fare clic su Questo progetto.

  5. Per includere una descrizione della macro, digitare la descrizione nella casella Descrizione.

  6. Se si seleziona una o più celle durante la registrazione di una macro, essa selezionerà la stessa colonna (campo) a ogni esecuzione, indipendentemente dalla prima cella selezionata, dato che la macro registra i riferimenti assoluti alle colonne. Se si desidera che una macro selezioni le colonne indipendentemente dalla posizione della cella attiva all'esecuzione della macro, fare clic su Relativi in Riferimenti colonna.

    Al contrario, la macro selezionerà le righe indipendentemente dalla posizione della cella attiva al momento della sua esecuzione in quanto essa registra i riferimenti relativi alle righe. Se si desidera che una macro selezioni sempre la stessa riga, indipendentemente dalla prima cella selezionata, fare clic su Assoluti (ID) in Riferimenti riga.

    Nota: Project continua a utilizzare queste impostazioni durante la registrazione delle macro finché le impostazioni non vengono modificate o fino alla chiusura del programma.

  7. Fare clic su OK e quindi eseguire le operazioni che si desidera registrare.

  8. Dopo aver completato tutte le azioni che si desidera registrare, nella scheda Visualizza fare clic su macro e quindi fare clic su Interrompi registrazione.

    (In Project 2007, dal menu Strumenti scegliere Macro e quindi fare clic su Ferma registrazione.)

Nota sulla sicurezza: Le macro possono contenere virus, quindi prestare attenzione quando le si esegue. Prendere le precauzioni descritte di seguito: eseguire un software antivirus aggiornato nel computer, impostare il livello di sicurezza delle macro su elevato, deselezionare la casella di controllo Considera attendibili tutti i modelli e i componenti aggiuntivi installati, usare le firme digitali e gestire un elenco di autori attendibili.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×