Raggruppare, copiare, spostare o allineare controlli in un foglio di lavoro

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Dopo aver aggiunto modulo e controlli ActiveX in un foglio di lavoro, si consiglia di gruppo, copiare, spostare o allineare i controlli per creare un ben progettata, UserForm descrittivo.

Per eseguire una delle procedure in questo articolo se uno o più controlli è un controllo ActiveX, è necessario prima di tutto assicurarsi che è disponibile la scheda sviluppo.

Visualizzare la scheda Sviluppo

  1. Fare clic su File > Opzioni > Personalizzazione barra multifunzione.

  2. In personalizzazione della barra multifunzione, fare clic su schede principali nell'elenco a discesa.

  3. Selezionare la casella di controllo sviluppo e quindi fare clic su OK.

Assicurarsi di essere in modalità progettazione. Nella scheda sviluppo fare clic su Modalità progettazione Icona del pulsante .

Raggruppare, separare o raggruppare di nuovo i controlli

Quando si raggruppano i controlli, si combinarli in modo da poter lavorare con loro come se si trattasse di un singolo controllo. Ad esempio, è possibile ridimensionare o spostare tutti i controlli in un gruppo in un'unica.

Nota: Non è possibile combinare nella stessa selezione gruppo controlli modulo o controlli ActiveX con oggetti di Strumenti di disegno o di Strumenti SmartArt, ad esempio forme ed elementi grafici SmartArt.

Controlli di gruppo

  1. Selezionare i controlli che si desidera raggruppare. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Fare clic con il pulsante destro del mouse sulla selezione, scegliere Gruppo e quindi Raggruppa.

Separare i controlli

  1. Selezionare il gruppo che si desidera separare. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Fare clic con il pulsante destro del mouse sulla selezione, scegliere Gruppo e quindi Separa.

    1. Per continuare la separazione, scegliere quando verrà visualizzata la finestra di messaggio.

    2. Per modificare un singolo controllo, continuare a selezionare e separare i controlli fino a rendere disponibile quello desiderato.

Raggruppare i controlli

  1. Selezionare uno dei controlli precedentemente raggruppati. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Fare clic con il pulsante destro del mouse sulla selezione, scegliere Gruppo e quindi Raggruppa di nuovo.

Nota: Non è possibile combinare nella stessa selezione gruppo controlli modulo o controlli ActiveX con oggetti di Strumenti di disegno o di Strumenti SmartArt, ad esempio forme ed elementi grafici SmartArt.

Usando i comandi Copia e Incolla

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Per creare un singolo duplicato di un controllo, fare clic suHome e quindi fare clic su Incolla Icona del pulsante Copia Icona del pulsante .

    Per rendere più duplicati, ripetere incollando fino a ottenere il numero di copie desiderato.

Tramite la tastiera e mouse

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Tenere premuto CTRL e trascinare il controllo.

    Per creare più duplicati, ripetere l'operazione di trascinamento fino a raggiungere il numero di copie desiderato.

Nota: Non è possibile combinare nella stessa selezione gruppo controlli modulo e controlli ActiveX con oggetti di Strumenti di disegno o di Strumenti SmartArt, ad esempio forme ed elementi grafici SmartArt.

Utilizzando il mouse

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Posizionarsi sul controllo finché il puntatore non assume la forma di una croce e quindi trascinare in un'altra posizione il controllo o i controlli selezionati.

Usando la tastiera

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Premere i tasti di direzione per spostare il controllo in incrementi di un singolo pixel.

Controlli e altri oggetti del disegno automaticamente tela stack in pila mentre si aggiungono. È possibile visualizzare l'ordine di impilamento controlli sovrappongano, ovvero il controllo superiore copre parzialmente i controlli di sotto di esso.

Nota: L'ordine della pila di oggetti per i controlli modulo e ActiveX è separato e distinto rispetto agli oggetti di Strumenti di disegno o di Strumenti SmartArt, ad esempio forme ed elementi grafici SmartArt.

  1. Selezionare il controllo. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Fare clic con il pulsante destro del mouse sulla selezione, scegliere Ordine e quindi eseguire una delle operazioni seguenti:

    1. Per spostare il controllo di un livello in avanti nell'ordine della pila, fare clic su Porta avanti.

    2. Per spostare il controllo nel primo livello dell'ordine della pila, fare clic su Porta in primo piano.

    3. Per spostare il controllo di un livello indietro nell'ordine della pila, fare clic su Porta indietro.

    4. Per spostare il controllo nell'ultimo livello dell'ordine della pila, fare clic su Porta in secondo piano.

Nota: Non è possibile combinare nella stessa selezione gruppo controlli modulo e controlli ActiveX con oggetti di Strumenti SmartArt, ad esempio forme ed elementi grafici SmartArt.

Allineare tutti i controlli alla griglia o sulle forme

  1. Selezionare il controllo. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Allineare tutti gli oggetti con angolo superiore sinistro di una cella, la scheda Strumenti disegno-formato, fare clic sulla freccia accanto a Allinea Icona del pulsante e quindi fare clic su Blocca sulla griglia Icona del pulsante .

    La funzionalità Blocca su funziona anche se le griglie non sono attivate. Per allineare i controlli alle griglie delle celle è inoltre possibile tenere premuto ALT mentre si sposta un controllo o un oggetto.

  3. Per allineare automaticamente i controlli con i bordi verticali e orizzontali di altre forme quando si sposta o disegnati, fare clic sulla scheda Strumenti disegno-formato, fare clic sulla freccia accanto a Allinea Icona del pulsante e quindi fare clic su Blocca sulle forme Icona del pulsante .

Allineare i controlli rispetto al margine

Importante: Durante l'allineamento, è possibile che i controlli vengano disposti in pila l'uno sopra l'altro. Verificare che i controlli siano posizionati l'uno rispetto all'altro come desiderato prima di eseguire un comando per l'allineamento.

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Per allineare i controlli, fare clic sulla scheda Strumenti disegno-formato e quindi fare clic sulla freccia accanto a Allinea Icona del pulsante . Eseguire una delle operazioni seguenti:

    1. Per allineare i controlli per il controllo di primo livello, fare clic su Allinea in alto Icona del pulsante .

    2. Per allineare i controlli dal controllo più in basso, fare clic su Allinea in basso Icona del pulsante .

    3. Per allineare i controlli per il controllo a sinistra, fare clic su Allinea a sinistra Icona del pulsante .

    4. Per allineare i controlli dal controllo più a destra, Allinea a destra Icona del pulsante .

Allineare i controlli orizzontalmente o verticalmente

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Per allineare i controlli, fare clic sulla scheda Strumenti disegno-formato, fare clic sulla freccia accanto a Allinea Icona del pulsante e quindi eseguire una delle operazioni seguenti:

    1. Per allineare i controlli in senso orizzontale in mezzo dei controlli, fare clic su Allinea al centro Icona del pulsante .

    2. Per allineare i controlli in senso verticale tramite il centro dei controlli, fare clic su Allinea al centro Icona del pulsante .

Distribuire controlli orizzontalmente o verticalmente

  1. Selezionare almeno tre controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Per distribuire i controlli, fare clic sulla scheda Strumenti disegno-formato, fare clic sulla freccia accanto a Allinea Icona del pulsante e quindi eseguire una delle operazioni seguenti:

    1. Per distribuire i controlli orizzontalmente, fare clic su Distribuisci orizzontalmente Icona del pulsante .

    2. Per distribuire i controlli in verticale, fare clic su Distribuisci verticalmente Icona del pulsante .

Per eseguire una delle procedure in questo articolo se uno o più controlli è un controllo ActiveX, è necessario prima di tutto assicurarsi che è disponibile la scheda sviluppo.

Visualizzare la scheda Sviluppo

  1. Fare clic sul pulsante Microsoft Office Icona del pulsante Office e quindi su Opzioni di Excel.

  2. Nella categoria Impostazioni generali in Opzioni principali per l'utilizzo di Excel selezionare la casella di controllo Mostra scheda Sviluppo sulla barra multifunzione, quindi scegliere OK.

Assicurarsi di essere in modalità progettazione. Nel gruppo controlli della scheda sviluppo attivare la Modalità progettazione Icona del pulsante .

Raggruppare, separare o raggruppare di nuovo i controlli

Quando si raggruppano i controlli, si combinarli in modo da poter lavorare con loro come se si trattasse di un singolo controllo. Ad esempio, è possibile ridimensionare o spostare tutti i controlli in un gruppo in un'unica.

Nota: Non è possibile combinare nella stessa selezione gruppo controlli modulo o controlli ActiveX con oggetti di Strumenti di disegno o di Strumenti SmartArt, ad esempio forme ed elementi grafici SmartArt.

Controlli di gruppo

  1. Selezionare i controlli che si desidera raggruppare. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Fare clic con il pulsante destro del mouse sulla selezione, scegliere Gruppo e quindi Raggruppa.

Separare i controlli

  1. Selezionare il gruppo che si desidera separare. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Fare clic con il pulsante destro del mouse sulla selezione, scegliere Gruppo e quindi Separa.

    1. Per continuare la separazione, scegliere quando verrà visualizzata la finestra di messaggio.

    2. Per modificare un singolo controllo, continuare a selezionare e separare i controlli fino a rendere disponibile quello desiderato.

Raggruppare i controlli

  1. Selezionare uno dei controlli precedentemente raggruppati. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Fare clic con il pulsante destro del mouse sulla selezione, scegliere Gruppo e quindi Raggruppa di nuovo.

Nota: Non è possibile combinare nella stessa selezione gruppo controlli modulo o controlli ActiveX con oggetti di Strumenti di disegno o di Strumenti SmartArt, ad esempio forme ed elementi grafici SmartArt.

Usando i comandi Copia e Incolla

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Per creare un singolo duplicato di un controllo, nella scheda Home, nel gruppo Appunti, fare clic su Copia, Icona del pulsante e quindi fare clic su Incolla Icona del pulsante .

    Per creare più duplicati, continuare a incollare fino a raggiungere il numero di copie desiderato.

Tramite la tastiera e mouse

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Tenere premuto CTRL e trascinare il controllo.

    Per creare più duplicati, ripetere l'operazione di trascinamento fino a raggiungere il numero di copie desiderato.

Nota: Non è possibile combinare nella stessa selezione gruppo controlli modulo e controlli ActiveX con oggetti di Strumenti di disegno o di Strumenti SmartArt, ad esempio forme ed elementi grafici SmartArt.

Utilizzando il mouse

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Posizionarsi sul controllo finché il puntatore non assume la forma di una croce e quindi trascinare in un'altra posizione il controllo o i controlli selezionati.

Usando la tastiera

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Premere i tasti di direzione per spostare il controllo in incrementi di un singolo pixel.

Controlli e altri oggetti del disegno automaticamente tela stack in pila mentre si aggiungono. È possibile visualizzare l'ordine di impilamento controlli sovrappongano, ovvero il controllo superiore copre parzialmente i controlli di sotto di esso.

Nota: L'ordine della pila di oggetti per i controlli modulo e ActiveX è separato e distinto rispetto agli oggetti di Strumenti di disegno o di Strumenti SmartArt, ad esempio forme ed elementi grafici SmartArt.

  1. Selezionare il controllo. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Fare clic con il pulsante destro del mouse sulla selezione, scegliere Ordine e quindi eseguire una delle operazioni seguenti:

    1. Per spostare il controllo di un livello in avanti nell'ordine della pila, fare clic su Porta avanti.

    2. Per spostare il controllo nel primo livello dell'ordine della pila, fare clic su Porta in primo piano.

    3. Per spostare il controllo di un livello indietro nell'ordine della pila, fare clic su Porta indietro.

    4. Per spostare il controllo nell'ultimo livello dell'ordine della pila, fare clic su Porta in secondo piano.

Importante: Per eseguire le procedure seguenti, è necessario aggiungere il menu del pulsante Allinea nella scheda Strumenti disegno sulla Barra di accesso rapido.

Aggiungere il menu del pulsante Allinea dalla scheda Strumenti di disegno alla barra di accesso rapido

  1. Fare clic sulla freccia accanto allabarra di accesso rapido e quindi su Altri comandi.

  2. In Scegli comandi da selezionare Tutti i comandi.

  3. Nell'elenco selezionare Allinea Icona del pulsante .

  4. Fare clic su Aggiungi e quindi su OK.

Nota: Non è possibile combinare nella stessa selezione gruppo controlli modulo e controlli ActiveX con oggetti di Strumenti SmartArt, ad esempio forme ed elementi grafici SmartArt.

Allineare tutti i controlli alla griglia o sulle forme

  • Per allineare tutti gli oggetti con angolo superiore sinistro di una cella, sulla Barra di accesso rapido fare clic sulla freccia accanto a Allinea Icona del pulsante e quindi fare clic su Blocca sulla griglia Icona del pulsante .

    La funzionalità Blocca su funziona anche se le griglie non sono attivate. Per allineare i controlli alle griglie delle celle è inoltre possibile tenere premuto ALT mentre si sposta un controllo o un oggetto.

  • Per allineare automaticamente i controlli con i bordi verticali e orizzontali di altre forme quando si sposta o disegnare, sulla Barra di accesso rapido, fare clic sulla freccia accanto a Allinea Icona del pulsante e quindi fare clic su Blocca sulle forme Icona del pulsante .

Allineare i controlli rispetto al margine

Importante: Durante l'allineamento, è possibile che i controlli vengano disposti in pila l'uno sopra l'altro. Verificare che i controlli siano posizionati l'uno rispetto all'altro come desiderato prima di eseguire un comando per l'allineamento.

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Per allineare i controlli, sulla Barra di accesso rapido fare clic sulla freccia accanto a Allinea Icona del pulsante e quindi eseguire una delle operazioni seguenti:

    1. Per allineare i controlli per il controllo di primo livello, fare clic su Allinea in alto Icona del pulsante .

    2. Per allineare i controlli dal controllo più in basso, fare clic su Allinea in basso Icona del pulsante .

    3. Per allineare i controlli per il controllo a sinistra, fare clic su Allinea a sinistra Icona del pulsante .

    4. Per allineare i controlli dal controllo più a destra, Allinea a destra Icona del pulsante .

Allineare i controlli orizzontalmente o verticalmente

  1. Selezionare i controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Per allineare i controlli, sulla Barra di accesso rapido fare clic sulla freccia accanto a Allinea Icona del pulsante e quindi eseguire una delle operazioni seguenti:

    1. Per allineare i controlli in senso orizzontale in mezzo dei controlli, fare clic su Allinea al centro Icona del pulsante .

    2. Per allineare i controlli in senso verticale tramite il centro dei controlli, fare clic su Allinea al centro Icona del pulsante .

Distribuire controlli orizzontalmente o verticalmente

  1. Selezionare almeno tre controlli. Per ulteriori informazioni, vedere Selezionare o deselezionare i controlli in un foglio di lavoro.

  2. Per distribuire i controlli, sulla Barra di accesso rapido fare clic sulla freccia accanto a Allinea Icona del pulsante e quindi eseguire una delle operazioni seguenti:

    1. Per distribuire i controlli orizzontalmente, fare clic su Distribuisci orizzontalmente Icona del pulsante .

    2. Per distribuire i controlli in verticale, fare clic su Distribuisci verticalmente Icona del pulsante .

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×