Pubblicare una versione aggiornata di un modello di modulo

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Quando si pubblica un modello di modulo che sono stati modificati, InfoPath possibile aggiornare il modello di modulo (xsn) e i moduli esistenti (file con estensione XML) basato su tale modello. Per impostazione predefinita, InfoPath sostituisce automaticamente la versione precedente del modello di modulo con la versione più recente. È possibile scegliere il metodo di aggiornamento che si preferisce per i moduli utente esistenti.

In questo articolo

Come evitare perdite di dati nei moduli utente esistenti

Pubblicare un modello di modulo aggiornato

Consentire agli utenti di scegliere se aggiornare i modelli di modulo

Come evitare perdite di dati nei moduli utente esistenti

Se è necessario aggiornare un modello di modulo esistente, è possibile modificarlo, pubblicarlo e distribuirlo agli utenti. Tuttavia, determinati tipi di modifiche potrebbero impedire l'accesso ai dati nei moduli completati basati sul modello di modulo originale.

Se si apporta modifiche a un modello di modulo che potrebbe causare la perdita di dati o errori nei moduli che hanno già compilati, verrà visualizzato un messaggio. Quando si aggiungono nuove, i campi obbligatori a un modello di modulo o quando si rinomina o rimuovere campi o gruppi dal modello di modulo, è spesso verrà visualizzato il messaggio.

Messaggio di errore indicante la possibile perdita di dati

Quando viene visualizzato questo messaggio, fare clic su e continuare con le modifiche apportate, potrebbe non essere possibile accedere ai dati nei moduli esistenti dopo la pubblicazione del modello di modulo aggiornato. In alcuni casi può trattarsi accettabile. È necessario decidere di volta in base alla situazione specifica.

Per fare in modo che è possibile accedere ai dati già raccolti dagli utenti, seguire queste linee guida quando si apportano modifiche al modello di modulo originale:

  • Non rinominare i campi esistenti e i gruppi nell'origine dati.

  • Non spostare i campi esistenti e i gruppi nell'origine dati.

  • Non eliminare i campi esistenti e i gruppi dell'origine dati. È possibile eliminare controlli dal modello di modulo senza problemi, purché si lascia il controllo campo o gruppo corrispondente nell'origine dati.

Torna all'inizio

Pubblicare un modello di modulo aggiornato

Si supponga che si prevede di apportare modifiche a un modello di modulo che è già in uso nell'organizzazione. Se queste modifiche includono la modifica origine dati sottostanti del modello di modulo, è necessario un modo per aggiornare in modo efficiente la versione pubblicata in precedenza del modello di modulo, per garantire che tutti gli utenti in uso la versione aggiornata. È inoltre possibile specificare che cosa si vuole gestire i moduli esistenti basati sul modello di modulo originale.

  1. Aprire il modello di modulo che si desidera aggiornare.

  2. Apportare le modifiche necessarie al modello di modulo.

  3. Dal menu Strumenti fare clic su Opzioni modulo.

  4. Nell'elenco categoria fare clic su controllo delle versioni.

    A questo punto, è necessario specificare ciò che si desidera gestire i moduli esistenti (file con estensione XML) compilati utilizzando il modello di modulo originale.

  5. Nell'elenco all'aggiornamento della versione in versione modello di modulo, eseguire una delle operazioni seguenti:

    • Per convertire automaticamente le versioni obsolete del modulo per la versione aggiornata, fare clic su Aggiorna automaticamente i moduli esistenti. Quando questa opzione è selezionata, InfoPath non è possibile chiedere agli utenti di aggiornare moduli esistenti. Invece l'aggiornamento viene eseguita automaticamente alla successiva apertura di un modulo di nuovo o esistente.

    • Per scrivere codice personalizzato che gestisce il processo di aggiornamento per gli utenti, fare clic su Utilizza evento personalizzato e quindi fare clic sul pulsante Modifica. È quindi possibile utilizzare l'evento OnVersionUpgrade , si verifica quando il numero di versione di un modulo di InfoPath aperto è meno il numero di versione del modello di modulo in cui si basa. Per ulteriori informazioni sull'evento OnVersionUpgrade , consultare la documentazione per sviluppatori di InfoPath.

    • Per evitare che i moduli vengono aggiornati, fare clic su non eseguire alcuna operazione (moduli esistenti non funzionino correttamente). Quando questa opzione è selezionata, gli utenti possono compilare i moduli basati sul modello di modulo aggiornato, ma potrebbe non essere possibile aprire i moduli esistenti. Se sono in grado di aprire i moduli esistenti, non sarà in grado di modificare i campi appena aggiunti.

  6. Nel menu File fare clic su pubblica e quindi seguire le istruzioni nella creazione guidata pubblicazione.

    Quando si apre una maschera in cui è basata sul modello di modulo, ricevono automaticamente la nuova versione del modello di modulo. Se si tenta di aprire i moduli che sono stati creati usando la versione precedente del modello di modulo, effettive le modifiche specificata nel passaggio 5.

Torna all'inizio

Consentire agli utenti di scegliere se aggiornare i modelli di modulo

Quando si pubblica una versione aggiornata di un modello di modulo, InfoPath sostituisce la copia del modello di modulo archiviata nel computer degli utenti con la versione più recente. Si verifica questo evento automaticamente all'apertura di un modulo basato sul modello di modulo aggiornato. Nella maggior parte dei casi, è quello che si vuole verificarsi. Tuttavia, è anche possibile visualizzare una finestra di dialogo che richiede agli utenti di aggiornare il modello di modulo quando una nuova versione diventa disponibile.

  1. Dal menu Strumenti fare clic su Opzioni modulo.

  2. Nell'elenco categoria fare clic su controllo delle versioni.

  3. In versione modello di modulo, selezionare la casella di controllo Consenti agli utenti di scegliere se eseguire l'aggiornamento a una nuova versione del modello di modulo e quindi fare clic su OK.

    Nota: Per impostazione predefinita, i dati per il valore del Registro di sistema EnableAutoUpdatePrompt sono uguale a 0 (off). Gli utenti vengono chiesto di aggiornare il modulo solo se l'amministratore di sistema ha modificato i dati per il valore EnableAutoUpdatePrompt compreso tra 0 (off) su 1 (attiva).

  4. Nel menu File fare clic su pubblica e quindi seguire le istruzioni nella creazione guidata pubblicazione.

Alla successiva apertura di una maschera in cui è basata sul modello di modulo InfoPath consente di visualizzare una finestra di dialogo che richiede all'utente di sostituire la propria copia del modello di modulo esistente con la nuova versione. L'utente può quindi decidere se per farlo. Se non viene visualizzato nella finestra di dialogo, quindi i dati per il valore EnableAutoUpdatePrompt sono 0 (off) invece di 1 (attiva).

Nota: Prima di aprire effettivamente un modulo, gli utenti possono scegliere di recuperare l'ultima versione di un modello di modulo specifico (file con estensione xsn) facendo clic sul collegamento Recupera aggiornamento di questo modulo o Recupera aggiornamenti dei moduli in questa categoria nella finestra di dialogo Compila modulo. Anche se gli utenti dispongono già la versione più recente del modello di modulo sul proprio computer, i collegamenti rimangono attivi. In questo scenario, quando un utente fa clic su uno dei collegamenti per l'aggiornamento, è sufficiente vengono salvati in InfoPath il modello di modulo più recente nel computer dell'utente nuovamente.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×