Progettare una visualizzazione ottimizzata per la stampa

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

I modelli di modulo di Microsoft Office InfoPath creati sono progettati per essere aperto e compilato online, in InfoPath o tramite un Web browser. Tuttavia, gli utenti possono decidere di stampare una copia di un modulo completato per l'archivio personale o scopo di archiviazione. Per questo motivo, è consigliabile verificare che il modello di modulo è accettabile quando viene stampato. È consigliabile, ad esempio, assicurarsi che i controlli nel modello di modulo contenute entro i margini della pagina stampata e che il testo nel modulo stampato è leggibile.

Inoltre, è possibile utilizzare il riquadro attività visualizzazioni per creare una versione speciale del modello di modulo, denominata visualizzazione per la stampa, che è progettato in particolare ai fini della stampa.

In questo articolo viene spiegato come progettare una visualizzazione per il modello di modulo e altre tecniche per la creazione di modelli di modulo di stampa.

In questo articolo

La differenza tra la stampa di un modello di modulo e una maschera

Introduzione alle visualizzazioni di stampa

Progettare una visualizzazione basata su una visualizzazione esistente

Progettare una visualizzazione di stampa specifica per Word

La differenza tra la stampa di un modello di modulo e una maschera

È possibile stampare il modello di modulo per avere un'idea generale della modalità di visualizzazione controlli e altri oggetti sulla pagina stampata o per verificare le impostazioni di stampa, ad esempio le intestazioni o piè di pagina. Quando si stampa un modello di modulo da modalità progettazione, si possono vedere alcuni elementi nel modello di modulo stampato, ad esempio pulsanti, vengono visualizzati quando si stampa un modulo basato sul modello di modulo.

Quando si stampa un modulo basato sul modello di modulo, InfoPath regolare le impostazioni per la maschera o rimuove alcuni elementi che non hanno senso in un contesto stampato. Ad esempio, il testo informativo Inserisci elemento visualizzato per impostazione predefinita in tabelle ripetute non vengono visualizzate nel modulo stampato. Non verranno pulsante controlli, voci casella di riepilogo o frecce di scorrimento, come questi elementi perdono il loro significato sulla pagina stampata.

Torna all'inizio

Introduzione alle visualizzazioni di stampa

Sebbene i modelli di modulo sono progettati per la raccolta di dati in formato elettronico, è possibile creare una visualizzazione di stampa, ovvero una visualizzazione progettata specificamente per la stampa. Questo è utile quando si desidera che gli utenti per stampare i moduli con un layout particolare o per stampare solo determinate parti del modulo.

Se il modello di modulo contiene più visualizzazioni, è possibile creare una visualizzazione di stampa per ogni visualizzazione. In alternativa, è possibile specificare un'unica visualizzazione stampa che si applica a tutte le visualizzazioni nel modello di modulo. Ad esempio, se il modello di modulo contiene tre visualizzazioni distinte, è possibile creare una visualizzazione di stampa che consolida le informazioni chiave da ognuna delle visualizzazioni in un'unica pagina stampata.

Per creare e associare una visualizzazione di stampa una visualizzazione esistente, è possibile utilizzare il collegamento Crea versione per la stampa nel riquadro attività visualizzazioni. Quando si fa clic su questo collegamento, InfoPath vengono eseguite le operazioni seguenti:

  • Crea una nuova visualizzazione vuota con lo stesso nome versione stampa, dove nome è il nome della visualizzazione in cui si basa la visualizzazione stampa.

  • Associa la visualizzazione su cui si basa la visualizzazione stampa. Questa associazione è registrata nella scheda Impostazioni di stampa della finestra di dialogo Proprietà visualizzazione. Si supponga ad esempio, creare una visualizzazione basata su una visualizzazione di approvazione nel modello di modulo. Quando gli utenti fare clic sul pulsante Stampa nella visualizzazione l'approvazione, vengono stampati tutti gli elementi presenti nella visualizzazione Stampa versione approvazione.

Dopo aver creato una visualizzazione di stampa, è possibile progettare per riflettere il modo in cui si desidera il modulo stampato. Ciò comporta in genere copiando e incollando controlli da altre visualizzazioni nel modello di modulo in visualizzazione stampa. Se necessario, è possibile sostituire alcuni controlli per gli altri controlli nella visualizzazione stampa. Ad esempio, si potrebbe sostituire una casella di riepilogo a discesa, che nasconde voci casella di riepilogo per impostazione predefinita, con una casella di riepilogo standard, che consente di visualizzare le voci per impostazione predefinita. In questo modo tutte le voci vengono visualizzate nel modulo stampato. Specificare le opzioni di stampa personalizzate per la visualizzazione di stampa nella finestra di dialogo Proprietà visualizzazione, ad esempio le intestazioni, piè di pagina e i margini di pagina.

Torna all'inizio

Progettare una visualizzazione basata su una visualizzazione esistente

Per impostazione predefinita, quando si stampa una maschera che non dispone di una visualizzazione di stampa specifica esso associata, viene stampata la visualizzazione attualmente visualizzato nel computer dell'utente. Se si crea una visualizzazione di stampa, viene stampata tale visualizzazione anziché la visualizzazione corrente. È possibile designare qualsiasi visualizzazione esistente come la stampa. La procedura seguente viene illustrato come usare una visualizzazione esistente come base per una visualizzazione di stampa.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. Nell'elenco Selezionare una visualizzazione nel riquadro attività visualizzazioni, fare clic su Visualizza per il quale si desidera creare una visualizzazione di stampa.

  3. Nel riquadro Azioni, fare clic su Crea versione stampa per questa visualizzazione.

  4. Nella finestra di dialogo Crea versione stampa digitare un nome per la visualizzazione di stampa e quindi fare clic su OK.

  5. Nel riquadro attività visualizzazioni fare doppio clic sulla visualizzazione stampa.

  6. Nella finestra di dialogo Proprietà visualizzazione, selezionare le opzioni desiderate nelle schede Impostazioni di stampa e Imposta pagina e quindi fare clic su OK. Ad esempio, si potrebbe specificare margini predefiniti per la visualizzazione stampa o aggiungere intestazioni o piè di pagina.

  7. Per passare alla visualizzazione originale, nel riquadro attività visualizzazioni, fare clic sul nome della visualizzazione nell'elenco Selezionare una visualizzazione.

  8. Per selezionare tutti gli elementi nella visualizzazione, premere CTRL + a.

  9. Per copiare la selezione negli Appunti, premere CTRL + C.

  10. Per passare alla visualizzazione stampa, nel riquadro attività visualizzazioni, fare clic sul nome della visualizzazione nell'elenco Selezionare una visualizzazione.

  11. Per incollare la selezione dalla visualizzazione originale visualizzazioni per la stampa, premere CTRL + V.

  12. Eliminare i controlli o elementi del layout non necessari oppure aggiungere altri controlli.

    Suggerimento: Per determinare rapidamente se i controlli e altri elementi grafici si adatteranno a una pagina stampata, è possibile visualizzare la Guida larghezza pagina lungo il lato destro del modello di modulo, fare clic su Guida larghezza pagina dal menu Visualizza. Guida larghezza pagina viene visualizzata come una linea verticale tratteggiata sul modello di modulo. La riga indica il margine destro della pagina stampata in cui si trova, in base alla stampante predefinita per il computer.

  13. Per aggiungere interruzioni di pagina alla visualizzazione stampa, fare clic nel punto in cui si desidera iniziare una nuova pagina e quindi fare clic su Interruzione di pagina dal menu Inserisci.

    Nota: Un'interruzione di pagina viene visualizzata come una linea tratteggiata in un modello di modulo. Se si visualizzare in anteprima il modello di modulo, non sarà visualizzata la linea tratteggiata o altre indicazioni dell'interruzione di pagina. Per vedere come l'interruzione di pagina viene influenzata dalle stampato moduli basati sul modello di modulo, fare clic su Anteprima di stampa, Icona del pulsante sulla barra degli strumenti Standard.

Torna all'inizio

Progettare una visualizzazione di stampa specifica per Word

Se si è della progettazione di moduli che conosca tecnologie XML, è possibile utilizzare la visualizzazione di stampa di aggiungere per la creazione guidata Word per creare una visualizzazione basata su Microsoft Office Word che consente di stampare i dati dei moduli direttamente da Word. In questo modo è possibile sfruttare l'intervallo di funzionalità di stampa che sono disponibili in Word. A questo scopo è necessario disporre di accesso a un file di trasformazione XSL (XSLT) esistente che consente di trasformare i dati nel modello di modulo in un formato che è adatto per la stampa da Word. Quando si stampa una maschera che contiene una visualizzazione basata su Word, i dati nel modulo verranno stampati direttamente da Word. Il file XSLT deve essere creato con Microsoft Office Word 2003 o Microsoft Office Word 2007.

Nota: Per ulteriori informazioni sulla creazione di file XSLT, fare riferimento a Microsoft Office InfoPath 2003 Software Development Kit (SDK). il SDK contiene uno strumento, denominato InfoPath Word la creazione guidata, che consente di utilizzare Word 2003 o Word 2007 per stampare i dati del modulo di InfoPath. Per individuare InfoPath 2003 SDK, vedere la sezione Vedere anche.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. Nel riquadro Azioni, nel riquadro attività visualizzazioni, fare clic su Aggiungi visualizzazione di stampa di Word.

  3. Seguire le istruzioni in Aggiungi visualizzazione stampa per Word procedura guidata specificare il file XSLT che si desidera utilizzare per la visualizzazione basata su Word.

  4. Nell'elenco Selezionare una visualizzazione, nel riquadro attività visualizzazioni, fare clic su Visualizza per il quale si desidera impostare la visualizzazione stampa basata su Word e quindi fare clic su Visualizza proprietà.

  5. Fare clic sulla scheda Impostazioni di stampa.

  6. Selezionare la visualizzazione basata su Word nell'elenco Selezionare una visualizzazione esistente per la stampa in questa visualizzazione.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×