Progettare una visualizzazione in sola lettura

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

In Microsoft Office InfoPath, è possibile creare visualizzazioni diverse dello stesso modello di modulo. Una visualizzazione è un'alternativa per presentare i dati in un modello di modulo. Durante la compilazione moduli basati sul modello di modulo di utenti possono passare tra le visualizzazioni per scegliere la quantità di dati rappresentati nel modulo. In un modello di modulo rapporto di stato, ad esempio, si potrebbe progettare una visualizzazione Riepilogo oltre a una visualizzazione dettagliata. Gli utenti possono quindi scegliere la visualizzazione preferiscono esaminare, a seconda di quali tipi di informazioni hanno bisogno.

In questo articolo viene spiegato come progettare una visualizzazione non può essere modificata dagli utenti. Viene inoltre descritto come utilizzare le regole per passare automaticamente a una visualizzazione di sola lettura di un modulo quando un utente fa clic su un pulsante della visualizzazione di lettura e scrittura.

Per saperne di più

Progettare una visualizzazione di sola lettura

Inserire un pulsante che consente di passare a una visualizzazione di lettura e scrittura e sola lettura

Inserire un pulsante che consente di attivare la visualizzazione di sola lettura dopo che gli utenti inviano il modulo

Progettare una visualizzazione in sola lettura

Visualizzazioni di sola lettura sono utili quando si desidera riepilogare i dati dei moduli per gli utenti e non si vuole vengano inavvertitamente modificato tali dati. Si supponga ad esempio, che si desidera impedire agli utenti di modificare i dati in un modulo dopo averlo inviato a un servizio Web. Quando un utente fa clic su un pulsante Invia nella maschera, è possibile configurare il modello di modulo per passare da una visualizzazione di lettura e scrittura dei dati a una visualizzazione di sola lettura. In questo modo agli utenti di visualizzare i dati siano oggetto, ma non consente di modificarlo.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. In Azioni fare clic su Aggiungi nuova visualizzazione.

  3. Nella finestra di dialogo Aggiungi visualizzazione digitare un nome per la visualizzazione e quindi fare clic su OK.

  4. Progettare la visualizzazione aggiungendo le tabelle layout e controlli.

    Suggerimento: Se si desidera basare la struttura di una nuova visualizzazione in una visualizzazione esistente, aprire la visualizzazione, premere CTRL + A per selezionare tutti gli elementi nella visualizzazione e quindi premere CTRL + C per copiare la selezione negli Appunti. Nel riquadro attività visualizzazioni, passare alla nuova visualizzazione e quindi premere CTRL + V per incollare la selezione nella nuova visualizzazione. A questo punto è possibile eliminare tutti i controlli o elementi di layout che non è necessario dalla nuova visualizzazione.

  5. Nel riquadro attività visualizzazioni, fare clic su Visualizza proprietà.

  6. Fare clic sulla scheda Generale.

  7. In impostazioni di visualizzazione, selezionare la sola casella di controllo e quindi fare clic su OK.

  8. Per verificare che la vista è di sola lettura, fare clic su Anteprima nella barra degli strumenti Standard.

  9. Nella finestra di anteprima, assicurarsi che non è possibile immettere dati nel modulo.

  10. Per tornare alla modalità progettazione, fare clic su Chiudi anteprima sulla barra degli strumenti Standard.

Torna all'inizio

Inserire un pulsante che consente di passare a una visualizzazione di lettura e scrittura e sola lettura

Visualizzazioni sono spesso progettate per funzionare con i pulsanti e le regole, che consente di automatizzare alcune operazioni in un modello di modulo in risposta a eventi o azioni avviate dall'utente compilando il modulo. Ad esempio, è possibile inserire un pulsante nel modello di modulo e quindi creare una regola per passa da una visualizzazione quando si fa clic su tale pulsante. Nell'esempio seguente la finestra di progettazione di moduli ha creato una regola nella finestra di dialogo regola che consente di passare a una visualizzazione di riepilogo di sola lettura. Questa regola viene eseguita ogni volta che gli utenti fare clic su un pulsante della maschera.

Parte della finestra di dialogo Regola

Inserire un pulsante che consente di passare tra le visualizzazioni

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. In Selezionare una visualizzazione, fare clic sulla visualizzazione di lettura e scrittura che si desidera aggiungere un pulsante.

  3. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  4. Nel modello di modulo, posizionare il cursore nel punto in cui si desidera inserire il pulsante.

  5. In Inserisci controlli fare clic su pulsante.

  6. Nel modello di modulo, fare doppio clic sul pulsante appena inserita.

  7. Fare clic sulla scheda Generale.

  8. Nella colonna azione, fare clic su regole e codice personalizzato.

  9. Nella casella etichetta digitare il testo che si desidera venga visualizzato sul pulsante.

  10. Fare clic su regole.

  11. Nella finestra di dialogo regole fare clic su Aggiungi.

  12. Nella casella nome digitare un nome per la regola.

  13. Fare clic su Aggiungi azione.

  14. Nella colonna azione, fare clic su Cambia visualizzazione.

  15. Nell'elenco visualizzazione, fare clic sulla visualizzazione che si desidera passare a e quindi fare clic su OK.

  16. Fare clic su OK per chiudere tutte le finestre di dialogo aperte.

  17. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

  18. Nella finestra di anteprima, fare clic sul pulsante.

    Consigliabile aprire la visualizzazione specificata nel passaggio 15.

  19. Per tornare alla modalità progettazione, fare clic su Chiudi anteprima sulla barra degli strumenti Standard.

  20. Per aggiungere un secondo pulsante e una regola per la visualizzazione di sola lettura, in modo che gli utenti possono tornare alla visualizzazione lettura e scrittura, aprire la visualizzazione di sola lettura e quindi ripetere i passaggi da 3 a 19.

Torna all'inizio

Inserire un pulsante che consente di attivare la visualizzazione di sola lettura dopo che gli utenti inviano il modulo

La procedura seguente viene descritto come aggiungere un pulsante al modello di modulo che visualizza una sola lettura dei dati inviati. È possibile farlo in un modulo di report di stato quando si desidera consentire agli utenti di passare da una visualizzazione predefinita per una visualizzazione di riepilogo di sola lettura dei dati del modulo.

Nota: Questa procedura è applicabile solo se il modello di modulo include un connessione dati esistente per l'invio di dati del modulo. Se non hai ancora configurato una connessione dati, è necessario farlo prima di completare questa procedura, o non è possibile utilizzare la procedura seguente. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle connessioni dati.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. In Selezionare una visualizzazione, fare clic sulla visualizzazione che si desidera inserire il pulsante Invia.

  3. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  4. Nel modello di modulo, posizionare il cursore nel punto in cui si desidera inserire il pulsante.

  5. In Inserisci controlli fare clic su pulsante.

  6. Nel modello di modulo, fare doppio clic sul pulsante appena inserita.

  7. Fare clic sulla scheda Generale.

  8. Nell'elenco azione fare clic su Invia.

  9. Se si desidera testo diverso da "Invia" come etichetta del pulsante, digitare il testo desiderato nella casella etichetta.

  10. Fare clic su Opzioni invio.

  11. Nella finestra di dialogo Opzioni invio, assicurarsi che sia selezionata la casella di controllo Consenti agli utenti di inviare il modulo.

  12. Fare clic su Esegui azione personalizzata tramite le regole e quindi fare clic su regole.

  13. Nella finestra di dialogo regole per l'invio di moduli, fare clic su Aggiungi.

  14. Nella casella nome digitare un nome per la regola e quindi fare clic su Aggiungi azione.

  15. Nella colonna azione, fare clic su Cambia visualizzazione.

  16. Nell'elenco visualizzazione, fare clic sulla visualizzazione di sola lettura che si desidera passare a e quindi fare clic su OK.

  17. Fare clic su OK per chiudere tutte le finestre di dialogo aperte.

  18. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

  19. Nella finestra di anteprima, fare clic sul pulsante utilizzato per inviare il modulo.

    Consigliabile aprire la visualizzazione di sola lettura.

  20. Per tornare alla modalità progettazione, fare clic su Chiudi anteprima sulla barra degli strumenti Standard.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×