Progettare un riquadro informazioni documento tramite InfoPath

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

In questo articolo viene spiegato come utilizzare Microsoft Office InfoPath per progettare un riquadro informazioni documento associato a documenti per Microsoft Office Word 2007, Microsoft Office Excel 2007 e Microsoft Office PowerPoint 2007.

In questo articolo

Informazioni sulle informazioni del documento

Progettare un riquadro informazioni documento

Creare o modificare un riquadro informazioni documento personalizzato per un tipo di contenuto di SharePoint

Aggiungere un riquadro informazioni documento personalizzato a un documento

Informazioni sulle informazioni del documento

Il riquadro informazioni documento, che viene visualizzata in Office Word 2007, Office Excel 2007 e Office PowerPoint 2007 documenti, consente agli utenti di visualizzare e modificare le proprietà per un singolo file o per un tipo di contenuto che viene salvato in un server document management, ad esempio un Sito area di lavoro documenti o una libreria basata su Windows SharePoint Services 3.0. Queste proprietà, noto anche come metadati, sono i dettagli di un file che descrivono o identificano. Gli utenti possono usare queste proprietà per organizzare, identificare e cercare i documenti.

Il riquadro informazioni documento è un modulo di Microsoft Office InfoPath 2007 che viene ospitato e visualizzato all'interno di un documento. Non è necessario InfoPath installato nel computer per visualizzare un riquadro informazioni documento in un documento Microsoft Office System 2007, ma è necessario Office InfoPath 2007 per progettare o personalizzare i riquadri informazioni documento. Ad esempio, se si desidera personalizzare un riquadro informazioni documento per visualizzare i dati da una risorsa esterna, ad esempio un servizio Web, è necessario utilizzare Office InfoPath 2007 per progettare il riquadro informazioni documento.

Personalizzare il riquadro informazioni documento, è possibile aggiungere logica di business, ad esempio la convalida dei dati, o aggiungere proprietà personalizzate che sono importanti per l'organizzazione. Inoltre, tramite la creazione di una parte modello per contenere campi comuni, è possibile organizzare il riutilizzo efficiente dei riquadri informazioni documento in tipi di documenti diversi versione 2007 di Office all'interno dell'organizzazione.

Torna all'inizio

Progettare un riquadro informazioni documento

Quando si progetta un riquadro informazioni documento personalizzato, è possibile utilizzare con più documenti da Office Word 2007, Office Excel 2007 e Office PowerPoint 2007 oppure è possibile progettare più informazioni del documento. Ad esempio, se alcuni documenti sono associati a un progetto specifico, è consigliabile usare campi univoci per i riquadri informazioni documento utilizzati in solo tali documenti.

Anche se l'organizzazione utilizza informazioni diverse del documento, ogni può contenere diverse proprietà comuni. Per riutilizzare facilmente le proprietà comuni durante la progettazione di un riquadro informazioni documento, valutare la possibilità di utilizzo di parti modello. Con la creazione e utilizzo di parti modello, è possibile evitare assicurarsi che i metadati chiavi per la propria organizzazione è coerente in tono, struttura e comportamento. Ad esempio, l'organizzazione può richiedere ogni riquadro informazioni documento includere un campo denominato titolo oltre autore. Progettare una parte modello che utilizza tali campi comuni, è possibile riutilizzare facilmente la parte modello in più riquadri informazioni documento.

La procedura seguente descrive come progettare un riquadro informazioni documento per l'utilizzo con i documenti versione 2007 di Office.

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. In Progetta nella finestra di dialogo Progetta modello di modulo, fare clic su Modello di modulo.

  3. Nella raccolta in base a: fare clic su vuoto e quindi fare clic su OK. In questo modo definire l'origine dati quando si progetta modello di modulo di InfoPath.

    È anche possibile basare il modello di modulo in un documento XML o Schema XML, ad esempio le proprietà del progetto Dublin Core. Inoltre, è possibile progettare il modello di modulo utilizzando un servizio Web, un database o le impostazioni in una raccolta di connessioni dati. Trovare informazioni sulla progettazione di un modello di modulo in base a un'origine dati nella sezione Vedere anche.

  4. Progettare il modello di modulo da utilizzare come un riquadro informazioni documento.

    Tramite la creazione di una parte modello per contenere campi comuni, è possibile coordinare il riutilizzo efficiente dei riquadri informazioni documento in tipi di documenti diversi versione 2007 di Office all'interno dell'organizzazione. Se si crea una parte modello e lo ha aggiunto al riquadro attività controlli, è possibile inserire la parte modello nel modello di modulo mediante la procedura seguente.

    1. Posizionare il cursore sul modello di modulo in cui si desidera inserire la parte modello.

    2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

    3. Nell'area personalizzato nell'elenco Inserisci controlli fare clic sul nome della parte modello che si desidera inserire.

      La parte modello visualizzato all'interno di un controllo sezione nel modello di modulo. È possibile riconoscere la parte modello nel modello di modulo perché le parole sezione (parte modello: nome) vengono visualizzati come etichetta della sezione in cui nome è il nome del file parte modello.

      Etichetta nel modello di modulo indicante la presenza della parte modello

  5. Rinominare la visualizzazione predefinita e le altre visualizzazioni nel modello di modulo.

    Procedura

    1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

    2. Nel riquadro attività visualizzazioni fare clic sulla visualizzazione che si desidera rinominare e quindi fare clic su Visualizza proprietà.

    3. Fare clic sulla scheda Generale.

    4. Nella casella nome visualizzazione digitare un nuovo nome per la visualizzazione.

    Nota: Anche se il modello di modulo contiene una sola visualizzazione, è necessario assegnare alla visualizzazione un nome descrittivo, ad esempio La finestra Proprietà personalizzate, perché il nome della visualizzazione verrà visualizzato nell'elenco visualizzazioni proprietà e opzioni quando viene visualizzato il riquadro informazioni documento in una documenti.

  6. Pubblicare il riquadro informazioni documento in una cartella di rete condivisa.

    Procedura

    1. Nel menu File fare clic su pubblica.

    2. Nella creazione guidata pubblicazione, fare clic su un percorso di rete e quindi fare clic su Avanti.

    3. Nella pagina successiva della procedura guidata, fare clic su Sfoglia.

    4. Passare alla cartella di rete condivisa in cui si desidera pubblicare il modello di modulo e quindi fare clic su OK.

    5. Nella pagina successiva della procedura guidata, verificare che il nome del modello maschera e percorso nella casella nome modello di modulo siano corretto e quindi fare clic su Avanti.

    6. Nella pagina successiva della procedura guidata, se si dispone di un percorso alternativo in questa cartella di rete condivisa, ad esempio un pubblico URL Uniform Resource Locator (), digitare il percorso nella casella e quindi fare clic su Avanti.

    7. Nella pagina successiva della procedura guidata, fare clic su pubblica.

      Se il modello di modulo è stato pubblicato correttamente, verrà visualizzato un messaggio di conferma nell'ultima pagina della procedura guidata.

    È anche possibile pubblicare il riquadro informazioni documento per un sito di SharePoint. Informazioni sulla pubblicazione in un sito di SharePoint, vedere la sezione Vedere anche.

Torna all'inizio

Creare o modificare un riquadro informazioni documento personalizzato per un tipo di contenuto di SharePoint

Quando si crea un tipo di contenuto in base al tipo di contenuto documento o il tipo di contenuto Dublin Core colonne, che è disponibile nei server che eseguono Microsoft Office SharePoint Server 2007, verrà creato automaticamente un riquadro informazioni documento per tenere traccia delle proprietà di SharePoint. È possibile utilizzare Office InfoPath 2007 per personalizzare questo tipo di riquadro informazioni documento nello stesso modo personalizzare qualsiasi modello di modulo di InfoPath. Ad esempio, è possibile personalizzare il riquadro informazioni documento eseguendo una o più delle operazioni seguenti:

  • Aggiungere caratteristiche, ad esempio convalida dei dati o formattazione condizionale.

  • Aggiungere una connessione dati secondaria nel riquadro informazioni documento e quindi aggiungere controlli che visualizzano dati dai campi nell'origine dati.

  • Creare una nuova visualizzazione e quindi aggiungere una parte modello che contiene i campi comuni che l'organizzazione consente di tenere traccia dei dati.

    Nota: Quando un riquadro informazioni documento è basato su uno schema di tipo di contenuto di SharePoint, non è possibile personalizzare il riquadro informazioni documento mediante l'aggiunta di campi che non fanno parte di tale schema. Per aggiungere o rimuovere campi dallo schema di tipo di contenuto, è necessario aggiungere o rimuovere colonne da un tipo di contenuto.

Creare o modificare un riquadro informazioni documento personalizzato

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. In Progetta nella finestra di dialogo Progetta modello di modulo, fare clic su Modello di modulo.

  3. Nell'elenco in base a: fare clic su XML o Schema e quindi fare clic su OK.

    Nota: Non selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser perché il riquadro informazioni documento verranno visualizzati solo come parte di un documento versione 2007 di Office, non come parte di una pagina Web.

  4. Il collegamento guidato origini dati, digitare l'URL per il server di SharePoint e quindi fare clic su Avanti.

  5. Nell'elenco Selezionare un elenco o web fare clic sul nome del tipo di contenuto che si desidera e quindi fare clic su Avanti.

  6. Fare clic su Fine.

    Apre il riquadro informazioni documento per lo schema di tipo di contenuto.

  7. Apportare le modifiche desiderate al riquadro informazioni documento e quindi salvare il modello di modulo.

    Nota: Poiché il riquadro informazioni documento è basato sullo schema di tipo di contenuto, che rappresenta l'origine dati principale per il modello di modulo, non è possibile personalizzare il riquadro informazioni documento mediante l'aggiunta di campi che non fanno parte dello schema. Per aggiungere o rimuovere campi dal riquadro informazioni documento mediante l'aggiunta di nuovi campi allo schema del tipo di contenuto, è necessario aggiungere o rimuovere colonne da un tipo di contenuto.

  8. Nel menu File fare clic su pubblica.

  9. Pubblicazione guidata fare clic su modello come un riquadro informazioni documento per un tipo di contenuto del sito di SharePoint o di un tipo di contenuto di elenco (scelta consigliata) e quindi fare clic su Avanti.

    Nota: Modello come un riquadro informazioni documento per un tipo di contenuto del sito di SharePoint o di un tipo di contenuto di elenco (scelta consigliata) viene visualizzata in questa pagina della procedura guidata solo se si è scelto XML o Schema nel passaggio 3.

  10. Nella pagina successiva della procedura guidata, fare clic su pubblica.

    Se il modello di modulo è stato pubblicato correttamente, verrà visualizzato un messaggio di conferma nell'ultima pagina della procedura guidata.

Torna all'inizio

Aggiungere un riquadro informazioni documento personalizzato a un documento

Dopo aver creato un riquadro informazioni documento personalizzato, è necessario associarlo un documento prima di poter usare. A questo scopo è necessario attivare la scheda sviluppo sulla barra multifunzione di programmi in cui si desidera utilizzare il riquadro informazioni documento. È quindi possibile specificare la posizione del riquadro informazioni documento tramite un percorso URL, UNC o URN. Inoltre, è possibile visualizzare il riquadro informazioni documento per impostazione predefinita, quando si apre il documento. È anche possibile scegliere se le proprietà personalizzate creato sono visibili per impostazione predefinita quando si apre il documento.

La procedura seguente descrive come associare un riquadro informazioni documento a un documento per Office Word 2007, Office Excel 2007 o Office PowerPoint 2007.

  1. Scegliere il Pulsante Microsoft Office icona del pulsante e quindi fare clic su Opzioni di nome programma, dove nome programma è il nome del programma che si sta utilizzando. Ad esempio, fare clic su Opzioni di Word.

  2. Nella finestra di dialogo Opzioni di nome programma, fare clic su Impostazioni generali, selezionare la casella di controllo Mostra scheda Sviluppo sulla barra multifunzione e quindi fare clic su OK.

    La barra multifunzione fa parte dell'interfaccia utente Microsoft Office Fluent.

  3. Fare clic sulla scheda sviluppo sulla barra multifunzione Office Fluent di Office e quindi fare clic su Riquadro documento.

  4. Nella finestra di dialogo Riquadro informazioni documento, in specificare un modello personalizzato (URL, UNC o URN), digitare il percorso del riquadro informazioni documento che si desidera aggiungere al documento.

  5. Per visualizzare le proprietà personalizzate per impostazione predefinita nel documento, nell'elenco visualizzato per impostazione predefinita, fare clic su Proprietà personalizzate.

  6. Per visualizzare il riquadro informazioni documento per impostazione predefinita, fare clic sulla casella di controllo Mostra sempre salvare riquadro informazioni documento nel documento aperto e iniziale.

Oltre a visualizzare o modificare proprietà nei riquadri informazioni documento in documenti per Office Word 2007, Office Excel 2007 e Office PowerPoint 2007, in Office Word 2007 gli utenti possono aggiungere proprietà dal riquadro informazioni documento di controlli di proprietà di documento stesso. Ad esempio, più istanze di un indirizzo della società possono essere aggiunti come i controlli di proprietà in un documento. Questi controlli proprietà verranno aggiornati come le informazioni nel riquadro informazioni documento viene modificate.

Ulteriori informazioni sull'aggiunta di proprietà a un documento Office Word 2007 nella sezione Vedere anche.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×