Progettare un modulo in risposta a uno stato del flusso di lavoro

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

È possibile progettare moduli di Microsoft Office InfoPath per visualizzare dati specifici corrispondente per lo stato corrente di un flusso di lavoro. Eseguire questa operazione la progettazione di un modello di modulo per usare le regole di avviare un'azione nei relativi moduli basati sullo stato del flusso di lavoro. Questo può semplificare i processi utilizzato dagli utenti per la compilazione dei moduli.

In questo articolo viene descritto come progettare un modello di modulo nota spese per visualizzare automaticamente diverse visualizzazioni del modello di modulo, a seconda lo stato di un flusso di lavoro di approvazione associato. Ad esempio, prima che viene avviato il flusso di lavoro, la maschera verrà visualizzata una visualizzazione spese contenente una tabella ripetuta in cui gli utenti possono immettere le spese. Quando lo stato del flusso di lavoro è In corso, la maschera verrà visualizzata una visualizzazione di riepilogo spese che mostra le spese totali per ogni categoria. Quando lo stato del flusso di lavoro è completata, il modulo visualizzazione sarà completato, che include dettagli sulle tempi di rimborso stimata.

Per attivare i moduli di risposta agli Stati del flusso di lavoro, è necessario eseguire attività e attività nel sito Microsoft Office SharePoint Server 2007 o Windows SharePoint Services 3.0 sito, in cui si trovano i moduli, in InfoPath. Nel sito di SharePoint è necessario creare un flusso di lavoro e un sito tipo di contenuto e in InfoPath è necessario aggiungere una connessione dati a un modello di modulo, creare una regola e pubblicare il modello di modulo.

Nota: Questo articolo viene utilizzato uno scenario di esempio in cui viene pubblicato un modello di modulo come tipo di contenuto del sito. È anche possibile pubblicare un modello di modulo in un percorso di rete condivisa o creare una nuova raccolta documenti quando si pubblica un modello di modulo in un sito di SharePoint. Ulteriori informazioni sulla pubblicazione di modelli di modulo nella sezione Vedere anche.

In questo articolo

Introduzione all'utilizzo di flussi di lavoro con moduli di InfoPath

Considerazioni sulla compatibilità

Prima di iniziare

Passaggio 1: Aggiungere un flusso di lavoro di approvazione per una raccolta

Passaggio 2: Aggiungere una connessione dati a un modello di modulo

Passaggio 3: Aggiungere una regola per un modello di modulo per visualizzare una visualizzazione specifica

Passaggio 4: Pubblicare un modello di modulo come un tipo di contenuto del sito

Passaggio 5: Aggiungere un tipo di contenuto in una raccolta documenti

Introduzione all'utilizzo di flussi di lavoro con moduli di InfoPath

Flussi di lavoro per farsi collaborare su documenti e gestire le attività di progetto mediante l'implementazione di processi aziendali specifici in documenti ed elementi in un sito Microsoft Office SharePoint Server 2007 o Windows SharePoint Services 3.0. Flussi di lavoro consentono alle organizzazioni di rispettare i processi aziendali coerenti e contribuiscono a far aumentare l'efficienza dell'organizzazione e la produttività tramite la gestione delle attività e passaggi dei processi aziendali specifici. In questo modo le persone che eseguono questi concentrare attività sul proprio lavoro anziché la gestione del flusso di lavoro.

È possibile abilitare un modulo di InfoPath visualizzare dati specifici corrispondente per lo stato corrente di un flusso di lavoro. Eseguire questa operazione la progettazione di un modello di modulo per usare le regole di avviare un'azione del modulo in base allo stato del flusso di lavoro. Questo può semplificare i processi utilizzato dagli utenti per la compilazione dei moduli. Ad esempio, è possibile abilitare un modulo visualizzare in sola lettura quando lo stato di un flusso di lavoro è completata e pertanto non devono essere modificati i dati del modulo.

Flussi di lavoro deve essere aggiunta a un elenco, una raccolta o un tipo di contenuto per renderli disponibili per l'uso nei modelli di modulo di InfoPath di SharePoint. I flussi di lavoro disponibili per un sito anche variano a seconda del tipo di sito e se sono stati creati flussi di lavoro personalizzati utilizzando Microsoft Office SharePoint Designer 2007.

Questo articolo viene utilizzato il flusso di lavoro di approvazione per illustrare come utilizzare i flussi di lavoro con i modelli di modulo di InfoPath. Il flusso di lavoro di approvazione indirizza un modulo di InfoPath che viene salvato in una raccolta di un gruppo di persone per l'approvazione. Per impostazione predefinita, il flusso di lavoro di approvazione è associato al tipo di contenuto documento ed è automaticamente disponibile nelle raccolte documenti o moduli.

Ogni flusso di lavoro è definita da stati distinti con nomi descrittivi, ad esempio In corso. I nomi per gli stati variano a seconda del tipo di flusso di lavoro. Ad esempio un flusso di lavoro di approvazione, che è disponibile nei server che eseguono Microsoft Office SharePoint Server 2007, ovvero include uno stato In corso, annullato e completato. Lo stato di un flusso di lavoro di tre stati, che è disponibile in Windows SharePoint Services 3.0, può essere definita dall'utente che aggiunge il flusso di lavoro in una raccolta o elenco, mentre altri flussi di lavoro utilizzano stati standard, ad esempio lo stato di Avanzamento In indicato in precedenza. Anche se il nome descrittivo è visibile all'utente, gli stati del flusso di lavoro sono rappresentati a livello di programmazione da valori numerici. Per progettare un modello di modulo in risposta a uno stato del flusso di lavoro specifica, è necessario conoscere il valore numerico per lo stato del flusso di lavoro che si desidera utilizzare. In questo modo InfoPath viene utilizzato il valore numerico del flusso di lavoro per avviare un'azione, ad esempio cambiare visualizzazione.

Come indicato in precedenza, è possibile attivare un modello di modulo di InfoPath visualizzare dati specifici corrispondente per lo stato corrente di un flusso di lavoro. Anche se in questo articolo viene descritto come attivare un modello di modulo nota spese visualizzare automaticamente una visualizzazione specifica in base allo stato del flusso di lavoro, è anche possibile personalizzare il flusso di lavoro mediante l'aggiunta di altre azioni. Ad esempio, invece di attivazione moduli visualizzare una visualizzazione specifica, è possibile abilitare la visualizzazione di una finestra di messaggio che mostra le istruzioni. E invece di usare un flusso di lavoro di approvazione, è possibile utilizzare il flusso di lavoro di tre stati.

Nota: Se si abilita azioni diversi da quelli descritti in questo articolo, potrebbe essere necessario eseguire alcune operazioni aggiuntive per garantire che il modello di modulo funziona correttamente con il flusso di lavoro in uso.

Torna all'inizio

Considerazioni sulla compatibilità

Se si prevede di creare un modello di modulo compatibile con browser, tenere presente che il documento sulla barra delle azioni, viene visualizzata quando la compilazione dei moduli nei documenti di Microsoft Office, compresi moduli di InfoPath, non è visibile nei modelli di modulo compatibile con browser compilati dagli utenti in un Web browser . Tuttavia, è possibile usare ancora moduli basati su browser con i flussi di lavoro. Per modificare lo stato del flusso di lavoro per tali forme, partecipanti del flusso di lavoro possono usare le impostazioni della raccolta documenti. Ulteriori informazioni sulla modifica impostazioni flusso di lavoro utilizzando i siti di SharePoint nella sezione Vedere anche.

Torna all'inizio

Prima di iniziare

Assicurarsi che le operazioni seguenti prima di eseguire le attività in questo articolo:

  • Contattare l'amministratore della farm per verificare che i flussi di lavoro di approvazione sia installato e abilitato per il sito di SharePoint che si desidera utilizzare.

  • Assicurarsi di avere almeno una struttura livello di autorizzazione del sito di SharePoint. Questo livello di autorizzazione è necessario per pubblicare un modello di modulo e creare un flusso di lavoro.

  • Creare un modello di modulo con due o più visualizzazioni e personalizzare ogni visualizzazione per visualizzare il tipo di dati appropriato per ogni stato flusso di lavoro. Ad esempio, per la visualizzazione che si desidera venga visualizzato al termine il flusso di lavoro, è possibile impostare i controlli in questa vista in sola lettura.

  • Creare una raccolta documenti o moduli e assicurarsi che la raccolta è configurata per consentire più tipi di contenuto.

Torna all'inizio

Passaggio 1: Aggiungere un flusso di lavoro di approvazione per una raccolta

Questo scenario è incentrata sul flusso di lavoro di approvazione, ma se si desidera, è possibile usare un altro tipo di flusso di lavoro. Se si usa un altro tipo di flusso di lavoro, le opzioni per il flusso di lavoro possono essere diversi da quelli descritti in questo articolo.

  1. Aprire la raccolta a cui si desidera aggiungere un flusso di lavoro.

  2. Nel menu Impostazioni, fare clic su impostazioni per il tipo di raccolta che desidera aprire.

    In una raccolta documenti, ad esempio, fare clic su Impostazioni raccolta documenti.

  3. In Autorizzazioni e gestione fare clic su Impostazioni flusso di lavoro.

  4. Fare clic su Aggiungi flusso di lavoro.

  5. Nella pagina Aggiungi un flusso di lavoro, nella sezione flusso di lavoro fare clic su approvazione.

  6. Nella sezione Nome digitare un nome univoco per il flusso di lavoro.

    1. Nella sezione Elenco attività specificare un elenco di attività da utilizzare con questo flusso di lavoro.

      Note: 

      • È possibile utilizzare l'elenco attività predefinito o è possibile crearne uno nuovo. Se si utilizza l'elenco attività predefinito, i partecipanti del flusso di lavoro saranno possibile trovare e visualizzare rapidamente le attività del flusso di lavoro tramite la visualizzazione Attività personali dell'elenco attività.

      • Se le attività del flusso di lavoro implicano informazioni sensibili o riservate che si desidera mantenere distinte dall'elenco attività generale, è necessario creare un nuovo elenco di attività.

      • Se nell'organizzazione sono numerosi flussi di lavoro o se i flussi di lavoro comporta numerose operazioni, è necessario creare un nuovo elenco di attività. In questo caso, è consigliabile creare elenchi delle attività per ogni flusso di lavoro.

  7. Nella sezione Elenco cronologia selezionare un elenco della cronologia da utilizzare con il flusso di lavoro. Nell'elenco della cronologia sono visualizzati tutti gli eventi che si verificano durante ogni istanza del flusso di lavoro.

    È possibile utilizzare l'elenco cronologia predefinito oppure è possibile crearne uno nuovo. Se nell'organizzazione sono numerosi flussi di lavoro, è possibile creare un elenco della cronologia distinta per ogni flusso di lavoro.

  8. Per consentire il flusso di lavoro per l'avvio manuale, selezionare la casella di controllo Consenti questo flusso di lavoro per l'avvio manuale da un utente autenticato con autorizzazioni Modifica elementi nella sezione Opzioni di avvio.

  9. Per richiedere ulteriori autorizzazioni per avviare il flusso di lavoro, selezionare la casella di controllo Richiedi autorizzazioni Gestione elenchi per avviare il flusso di lavoro.

  10. Specificare altre opzioni desiderate, incluso quando il flusso di lavoro per avviare e quindi fare clic su Avanti.

  11. Nella pagina Personalizza flusso di lavoro, specificare le opzioni desiderate, tra cui come le attività vengono indirizzate, il flusso di lavoro predefinita avviare valori, come completato il flusso di lavoro e quindi fare clic su OK.

    Selezionare le opzioni di tutte le sezioni seguenti. Non è necessario specificare le opzioni in ogni sezione:

    Attività flusso di lavoro

    Per

    Operazione da eseguire

    Assegnare attività a tutti i partecipanti contemporaneamente (flusso di lavoro in parallelo)

    Selezionare tutti i partecipanti contemporaneamente (in parallelo).

    Assegnare attività a un partecipante alla volta, che richiedono una partecipazione completare un'attività prima che il partecipante successivo riceva un'attività (flusso di lavoro seriale)

    Selezionare un partecipante alla volta (sequenza).

    Consentire ai partecipanti di flusso di lavoro di riassegnare le proprie attività ad altri utenti

    Selezionare la casella di controllo riassegnare l'attività a un'altra persona.

    Consenti ai partecipanti di flusso di lavoro di richiedere una modifica al documento o elemento. La modifica deve essere approvata prima del completamento dell'attività.

    Selezionare la casella di controllo richiedere una modifica prima di completare l'attività.

    Valori di avvio del flusso di lavoro predefinito

    Per

    Operazione da eseguire

    Specificare un elenco dei partecipanti per tutte le istanze del flusso di lavoro predefinito

    Digitare i nomi dei partecipanti che si desidera includere quando viene avviato il flusso di lavoro o fare clic sui responsabili approvazione e quindi selezionare utenti e gruppi dal servizio directory.

    Note: 

    • Separare i nomi con un punto e virgola.

    • Se si configura il flusso di lavoro come seriale flusso di lavoro, aggiungere i nomi dei partecipanti del flusso di lavoro nell'ordine in cui si vuole che le attività da assegnare.

    Assegnare una singola attività ai gruppi, anziché l'assegnazione di singole attività per ogni membro del gruppo

    Selezionare il assegna una sola attività per ogni gruppo immesso (non espandere i gruppi) casella di controllo.

    Consenti alle persone che avvia il flusso di lavoro per modificare o aggiungere partecipanti

    Selezionare la casella di controllo Consenti modifiche all'elenco dei partecipanti quando viene avviato il flusso di lavoro.

    Specificare un messaggio predefinito che viene visualizzato con ogni attività

    Digitare un messaggio o istruzioni nella casella di testo.

    Specificare una data di scadenza per i flussi di lavoro in parallelo

    Immettere una data in attività in scadenza il (in parallelo).

    Specificare quanto tempo partecipanti seriale flusso di lavoro sono necessario completare le attività del flusso di lavoro

    In assegnare a ogni utente seguente periodo di tempo per completare l'attività (sequenza), digitare un numero e quindi selezionare giorni o settimane come valore di incremento di tempo.

    Specificare un elenco di utenti che devono ricevere avvisi (non le assegnazioni delle attività) quando viene avviato il flusso di lavoro

    Informare gli altri utenti, digitare i nomi delle persone a cui che si desidera ricevere una notifica, oppure fare clic su CC e selezionare utenti e gruppi dal servizio directory.

    Nota: Separare i nomi con un punto e virgola.

    Completare il flusso di lavoro

    Per

    Operazione da eseguire

    Specificare che un flusso di lavoro in parallelo termina quando un numero specifico di partecipanti completata le attività

    Selezionare la casella di controllo seguente numero di attività sono state completate e quindi digitare un numero.

    Specificare che un flusso di lavoro è stata completata quando il documento o l'elemento viene rifiutato

    Selezionare la casella di controllo documento è stato rifiutato.

    Specificare che un flusso di lavoro è stata completata quando viene modificato il documento o un elemento

    Selezionare la casella di controllo documento viene modificato.

    Attività flusso di lavoro dopo il completamento

    Per

    Operazione da eseguire

    Aggiornare lo stato di approvazione per un documento o un elemento una volta completato il flusso di lavoro

    Selezionare il aggiornare lo stato di approvazione (utilizzare questo flusso di lavoro per controllare l'approvazione del contenuto) casella di controllo.

    Note: 

    • Se si utilizza il flusso di lavoro di approvazione per gestire l'approvazione del contenuto per una raccolta è selezionata la casella di controllo Avvia flusso di lavoro per approvare la pubblicazione di una versione principale di un elemento nella pagina Aggiungi un flusso di lavoro, questa casella di controllo è selezionata per impostazione predefinita.

    • Se non è stata selezionata la casella di controllo Avvia flusso di lavoro per approvare la pubblicazione di una versione principale di un elemento nella pagina Aggiungi un flusso di lavoro perché non si desidera essere flusso di lavoro di approvazione del contenuto predefinito per una raccolta del flusso di lavoro, è possibile selezionare questa casella di controllo per rendere Questo flusso di lavoro un flusso di lavoro di approvazione del contenuto secondario che è possono avviare manualmente utenti specifici.

Torna all'inizio

Passaggio 2: Aggiungere una connessione dati a un modello di modulo

La procedura seguente viene illustrato come aggiungere una connessione dati secondaria che esegue una query lo stato del flusso di lavoro del flusso di lavoro aggiunti al passaggio 1. La connessione dati secondaria fornisce i dati che consente di regole nel modulo per cambiare visualizzazione in base a stato del flusso di lavoro.

  1. In InfoPath, dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. In connessione guidata dati fare clic su Crea una nuova connessione a, fare clic su dati di ricezione e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, fare clic su raccolta o elenco SharePoint e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, digitare l'URL del sito di SharePoint.

  6. Nell'elenco Selezionare un elenco o raccolta, fare clic sul nome della raccolta documenti di cui è stato aggiunto il flusso di lavoro di approvazione nel passaggio 1 e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata, nell'elenco Selezionare i campi selezionare la casella di controllo accanto al nome del campo che corrisponda al nome del flusso di lavoro.

    Il nome del campo potrebbe non corrispondere esattamente il nome del flusso di lavoro. Se il nome del campo inizia con un carattere speciale diverso da una lettera o un carattere di sottolineatura, il nome del flusso di lavoro verrà personalizzato nell'elenco.

  8. Selezionare la casella di controllo Includi dati per il modulo attivo solo e quindi fare clic su Avanti.

  9. Deselezionare la casella di controllo memorizza una copia dei dati nel modello di modulo e quindi fare clic su Avanti.

  10. Nella pagina successiva della procedura guidata, nella casella Immettere un nome per la connessione dati, digitare un nome descrittivo per la connessione dati secondaria. Questo nome è quello visualizzato nell'elenco di origine dati nel riquadro attività origine dati.

  11. Per eseguire la query automaticamente ogni volta che viene aperto il modulo da un utente, selezionare la casella di controllo Recupera automaticamente i dati all'apertura di modulo.

  12. Nell'ultima pagina della creazione guidata fare clic su Fine.

  13. Nella finestra di dialogo Connessioni dati, fare clic su Chiudi.

Torna all'inizio

Passaggio 3: Aggiungere una regola per un modello di modulo per visualizzare una visualizzazione specifica

Quando si progetta un modello di modulo, è possibile utilizzare le regole per automaticamente visualizzare una finestra di dialogo, impostare il valore del campo, query o inviare dati del modulo a una connessione dati, cambiare visualizzazioni, o aprire o chiudere un modulo in risposta a determinati eventi e condizioni. Gli eventi possono essere la modifica di un particolare campo o gruppo in origine dati, fare clic su un pulsante, l'inserimento di una sezione ripetuta o una riga in un tabella ripetuta oppure l'apertura o l'invio di un modulo. Le condizioni possono includere calcoli, espressioni XPath e ruoli utente. Le condizioni possono includere anche se il valore di un campo è vuoto, compreso in un intervallo specificato, sarà uguale al valore di un altro campo o inizia con o contiene determinati caratteri.

In questo caso, si creerà una regola per cambiare le visualizzazioni basate sullo stato del flusso di lavoro.

  1. Dal menu Strumenti fare clic su Opzioni modulo.

  2. Nell'elenco categoria fare clic su Apri e Salva.

  3. In modalità di apertura, fare clic su regole.

  4. Nella finestra di dialogo regole per l'apertura di moduli, fare clic su Aggiungi.

  5. Nella casella nome digitare un nome per la regola.

    Ad esempio, digitare Cambia visualizzazione.

  6. Per specificare una condizione quando deve essere eseguita la regola, fare clic su Imposta condizione.

  7. In Applica regola quando questa condizione è vera, nella prima casella, fare clic su Seleziona campo o gruppo.

  8. Nell'elenco di Origine dati, fare clic sul nome dell'origine dati secondaria aggiunti nel passaggio 2 e quindi fare clic su OK.

  9. Fare clic sul nome del campo corrispondente per lo stato del flusso di lavoro.

    Potrebbe essere necessario espandere le cartelle nella finestra finché non viene visualizzato il campo desiderato.

  10. Selezionare il secondo elenco della finestra di dialogo condizioneè uguale a.

  11. Nel terzo elenco, fare clic su tipo di un numero e quindi digitare il valore corrispondente per lo stato del flusso di lavoro.

    Ad esempio, per una visualizzazione contenente una volta completata il flusso di lavoro, digitare 5.

    Valori numerici per gli stati del flusso di lavoro del flusso di lavoro di approvazione

    Stato

    Valore numerico

    In corso

    2

    Completed

    5

    Canceled

    15

    Approvate

    16

    Rifiutato

    17

    Note: 

    • I valori numerici per gli stati in altri flussi di lavoro possono essere diversi.

    • Il valore di stato del flusso di lavoro in InfoPath è di sola lettura. Questo errore indica che non è possibile creare un modello di modulo in modo che un utente può modificare manualmente lo stato del flusso di lavoro tramite l'immissione di un valore in un controllo modulo.

  12. Fare clic su OK.

  13. Nella finestra di dialogo regola fare clic su Aggiungi azione.

  14. In azione fare clic su Cambia visualizzazione.

  15. In Visualizza, fare clic sul nome della visualizzazione che si desidera visualizzare quando lo stato del flusso di lavoro corrisponde lo stato per la condizione e quindi fare clic su OK.

    Ad esempio, se si digita 2 nel passaggio 11, fare clic sul nome della visualizzazione che si desidera visualizzare quando lo stato del flusso di lavoro è uguale a In corso.

  16. Nella finestra di dialogo regola fare clic su OK.

  17. Ripetere i passaggi da 4 a 16 per creare regole aggiuntive per cambiare visualizzazione appropriate per ogni fase del flusso di lavoro.

Torna all'inizio

Passaggio 4: Pubblicare un modello di modulo come un tipo di contenuto del sito

Quando si pubblica un modello di modulo, è possibile pubblicare in una raccolta documenti o pubblica come un tipo di contenuto che può essere utilizzato in più raccolte in una raccolta siti. Perché già creata una raccolta documenti e assegnarle un flusso di lavoro, è necessario pubblicare il modello di modulo come tipo di contenuto. In un secondo momento, è possibile associare il tipo di contenuto del sito del modello di modulo per la raccolta che è stato creato.

Oltre a un modello di modulo come tipo di contenuto del sito di pubblicazione, è possibile pubblicare un modello di modulo in un percorso di rete condivisa o creare una nuova raccolta documenti quando si pubblica un modello di modulo in un sito di SharePoint. Ulteriori informazioni sulla pubblicazione di modelli di modulo nella sezione Vedere anche.

  1. Scegliere Salva dal menu File.

  2. Nella finestra di dialogo Salva con nome passare al percorso in cui si vuole salvare il modello di modulo e quindi fare clic su Salva.

  3. Per aprire il riquadro attività Controllo grafico, fare clic su Grafico dal menu Strumenti.

  4. Se sono elencati il riquadro attività Controllo grafico, correggere gli errori e quindi fare clic su Aggiorna per determinare se gli errori sono ancora presenti.

  5. Nel menu File fare clic su pubblica.

  6. Nella creazione guidata pubblicazione, fare clic su server di SharePoint con o senza InfoPath Forms Services e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata, nella casella Immettere il percorso del sito di SharePoint o InfoPath Forms Services, digitare il percorso del sito di SharePoint in cui si desidera pubblicare il modello di modulo e quindi fare clic su Avanti.

  8. Per consentire agli utenti di compilare questo modulo tramite un Web browser, nella pagina successiva della procedura guidata, selezionare la casella di controllo Abilita questo modulo per la compilazione mediante un browser.

  9. Fare clic su Tipo di contenuto del sito (avanzate) e quindi fare clic su Avanti.

  10. Nella pagina successiva della procedura guidata, fare clic su Crea un nuovo tipo di contenuto.

  11. Nell'elenco tipo di Base del contenuto in fare clic su modulo e quindi fare clic su Avanti.

  12. Nella pagina successiva della procedura guidata, digitare un nome e una descrizione per il nuovo tipo di contenuto e quindi fare clic su Avanti.

  13. Nella pagina successiva della procedura guidata, nella finestra di specificare un percorso e nome file per il modello di modulo, digitare il percorso del sito di SharePoint e quindi fare clic su Sfoglia.

  14. Nella finestra di dialogo Sfoglia passare al percorso del server in cui si desidera pubblicare il modello di modulo come un tipo di contenuto del sito e quindi nella casella Nome File digitare il nome del modello di modulo e fare clic su Salva.

  15. Fare clic su Avanti.

  16. Scegliere i campi nel modello di modulo che si desidera venga visualizzato come colonne nella visualizzazione predefinita della raccolta documenti.

    Procedura

    1. Fare clic su Aggiungi.

    2. Selezionare il campo che si desidera aggiungere come colonna nella raccolta documenti e quindi eseguire una delle operazioni seguenti:

      • Digitare un nome per la colonna nella casella nome colonna.

      • Selezionare la colonna del sito nell'elenco gruppo di colonne sito, selezionare un nome nella casella nome colonna e quindi fare clic su OK.

        Se si seleziona un campo ripetuto per visualizzare i dati nella raccolta documenti, è possibile definire come si desidera visualizzare il campo nella raccolta documenti, fare clic su un valore nell'elenco funzione. È possibile scegliere se visualizzare il primo valore nel campo, l'ultimo valore nel campo o un conteggio di tutte le occorrenze del campo o se unire tutti i valori.

    3. Fare clic su OK.

  17. Fare clic su Avanti.

  18. Nella pagina successiva della procedura guidata, verificare che le informazioni visualizzate siano corrette e quindi fare clic su pubblica.

  19. Fare clic su Chiudi e quindi verificare che il modello di modulo è un tipo di contenuto del sito di SharePoint.

    Procedura

    1. Aprire il sito di SharePoint in un Web browser.

    2. Nel menu Azioni sito nell'angolo superiore sinistro del sito fare clic su Impostazioni sito.

    3. In Impostazioni sito in raccolte fare clic su tipi di contenuto del sito.

      Il modello di modulo dovrebbe essere elencato in InfoPath i tipi di contenuto nella Raccolta di tipi di contenuto del sito.

Torna all'inizio

Passaggio 5: Aggiungere un tipo di contenuto in una raccolta documenti

Tipi di contenuto consentono alle organizzazioni di organizzare, gestire e gestire contenuto in modo più efficiente in una raccolta siti. Mediante la definizione di tipi di contenuto per tipi specifici di documenti, l'organizzazione può garantire che ognuno di questi gruppi di contenuto verrà gestito in modo più efficiente. È possibile impostare un elenco o una raccolta per contenere gli elementi di più tipi di elementi o documenti mediante l'aggiunta di tipi di contenuto all'elenco o alla raccolta.

Nota: Per aggiungere tipi di contenuto a un elenco o raccolta, è necessario almeno il livello di autorizzazione Progettazione per tale elenco o raccolta.

Prima di iniziare, verificare che la raccolta è configurata per consentire più tipi di contenuto.

Consentire più tipi di contenuto

  1. Nel menu Impostazioni, fare clic su Impostazioni raccolta documenti.

  2. In Impostazioni generali fare clic su Impostazioni avanzate.

  3. Nella sezione Tipi di contenuto selezionare per consentire più tipi di contenuto e quindi fare clic su OK.

  1. Se la raccolta o l'elenco non è già aperto, fare clic sul relativo nome sulla barra di avvio veloce.

    Nota: Se il nome dell'elenco o della raccolta non viene visualizzato, fare clic su Visualizza tutto il contenuto del sito e quindi sul nome dell'elenco o della raccolta.

  2. Nel menu Impostazioni, fare clic su Impostazioni raccolta documenti.

  3. In Tipi di contenuto fare clic su Aggiungi da tipi di contenuto del sito esistenti.

  4. Nell'elenco selezionare tipi di contenuto nella sezione Selezionare tipi di contenuto, selezionare il gruppo di tipi di contenuto del sito da cui si desidera selezionare.

  5. Nell'elenco di Tipi di contenuto del sito disponibili, fare clic sul tipo di contenuto che si desidera e quindi fare clic su Aggiungi per spostare il tipo di contenuto selezionato nell'elenco di tipi di contenuto da aggiungere.

  6. Per aggiungere altri tipi di contenuto, ripetere i passaggi 4 e 5 e quindi fare clic su OK.

A questo punto, quando si crea un nuovo modulo in questa raccolta, la visualizzazione del modulo verrà visualizzata in base a stato del flusso di lavoro.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×