Progettare un modello di modulo mediante le impostazioni in una raccolta di connessioni dati

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

In questo articolo viene illustrato come progettare un modello di modulo, basato sulle impostazioni archiviate in una raccolta di connessioni dati in un sito di Microsoft Office SharePoint Server 2007, che possono eseguire una query o inviare i dati.

In questo articolo

Panoramica

Prima di iniziare

Progettare un modello di modulo con una connessione dati di query

Progettare un modello di modulo con una connessione dati

Panoramica

Una connessione dati secondaria è qualsiasi connessione dati a un'origine dati esterna da aggiungere a un modello di modulo. La connessione dati è la differenza tra la connessione dati principale che viene creata quando si progetta modello di modulo in base a un database, servizio Web o impostazioni in una raccolta di connessioni. Aggiungere una connessione dati secondaria solo se non è possibile eseguire una query o inviare i dati mediante la connessione dati principale.

Una maschera può avere una connessione dati principale, denominata connessione dati principale e facoltativamente può contenere uno o più connessioni dati secondarie. A seconda degli obiettivi per la maschera, una connessione dati query o inviare dati del modulo a un'origine dati esterna, ad esempio un database di Microsoft SQL Server o un servizio Web.

Se si progetta vari modelli di modulo che utilizzano le connessioni dati simili, è consigliabile usando un file di connessione dati invece di creare una connessione dati a un'origine dati esterna per ogni modello di modulo. In questo modo, è necessario aggiornare un solo file di connessione dati quando le informazioni di connessione dati per un set di modelli di modulo correlati. Ad esempio, quando si spostano i modelli di modulo da una rete di test in una rete di produzione, è necessario aggiornare i dati impostazioni di connessione una sola volta nella raccolta di connessione anziché aggiornare la connessione dati di ogni modello di modulo. Quando un modulo basato su un modello di modulo che utilizza un file di connessione dati utilizza la connessione dati, la connessione dati viene aggiornata automaticamente con le nuove impostazioni.

Un file di connessione dati è un file XML con un'estensione di file XML o udcx che contiene le informazioni di connessione per una singola origine dati esterna. Il file è archiviato in una raccolta di connessioni dati in un server che esegue Microsoft Office SharePoint Server 2007. Da uno sviluppatore o per la conversione di una connessione dati in un modello di modulo esistente in un file di connessione dati facendo clic sul pulsante Converti nella finestra di dialogo Connessioni dati (menuStrumenti ), viene creato un file di connessione dati.

Vantaggi dell'utilizzo di file di connessione dati:

  • Più moduli è possono utilizzare lo stesso file di connessione dati, in modo che non è necessario per creare la stessa connessione dati da zero per ogni modello di modulo.

  • Modificare le impostazioni di connessione o posizione per un'origine dati esterna, è necessario aggiornare solo i file di connessione dati, non ogni modello di modulo.

  • File di connessione dati può contenere le informazioni di autenticazione alternativo che possono essere usate dal server durante la compilazione di un modulo tramite un Web browser.

  • Moduli basati su un modello di modulo compatibile con browser che sono compilati in un browser è possono connettersi al server in un altro dominio solo con le connessioni dati che utilizzano i file di connessione dati.

Microsoft Office InfoPath utilizza file di connessione dati che seguono il formato di file 2.0 versione universale connessione dati. Questa versione è un insieme di versione 1.0 formato di file utilizzato da Microsoft Office FrontPage e Microsoft Office Excel. InfoPath non è possibile usare i file di connessione dati nel formato di file 1.0 versione.

Quando si crea un modello di modulo che dipende dalle impostazioni in un file di connessione dati, Microsoft Office InfoPath viene creata una connessione dati in base alle impostazioni nella raccolta di connessioni dati. Se il file di connessione dati contiene le impostazioni per una connessione dati di query, viene creata principale origine dati della maschera con i campi di query, campi dati, e i gruppi che corrispondono in modo che i dati vengono archiviati in finestra dati esterni di origine che fa riferimento il impostazioni nel file di connessione dati. Campi di query contengono i dati nell'origine dati esterna utilizzata per determinare gli elementi da inviare al modulo. I risultati della query vengono inseriti in campi di dati. Per consentire agli utenti di eseguire una query nell'origine dati esterna, InfoPath aggiunge un pulsante Esegui Query al modello di modulo.

Perché la struttura di dati dei campi di query e dati deve corrispondere al modo che i dati vengono archiviati in origine dati esterna, è possibile modificare campi esistenti o gruppi nell'origine dati principale. È possibile aggiungere solo campi o gruppi al gruppo principale nell'origine dati principale.

Se si utilizza le impostazioni per una connessione dati, viene abilitato il comando Invia del menu File di moduli basati sul modello di modulo e il pulsante Invia nella barra degli strumenti Standard. In questo modo agli utenti di inviare i dati nei moduli per l'origine dati esterna.

Torna all'inizio

Prima di iniziare

Per progettare un modello di modulo che si basa sulle impostazioni in una raccolta di connessioni dati, è necessario le seguenti informazioni dall'amministratore della libreria di connessione dati o lo sviluppatore che ha creato il file di connessione dati:

  • La posizione del sito Office SharePoint Server 2007 con la raccolta di connessioni.

  • Il nome del file di connessione dati nella raccolta di connessioni dati che si desidera utilizzare.

Torna all'inizio

Progettare un modello di modulo con una connessione dati di query

Per progettare un modello di modulo basato su un file di connessione dati con le impostazioni per una connessione dati di query, è necessario eseguire le operazioni seguenti:

  1. Progettare il modello di modulo basato su file di connessione dati    In questo passaggio consente di creare l'origine dati principale per il modello di modulo con i campi appropriati e i gruppi che si basano sulle impostazioni nel file di connessione dati.

  2. Aggiungere un controllo al modello di modulo per la visualizzazione dei risultati della query    Per visualizzare i dati archiviati in campi e ai gruppi nell'origine dati principale per gli utenti, è necessario aggiungere un controllo al modello di modulo e quindi associare il controllo a un campo di query o campo dati nell'origine dati principale.

Passaggio 1: Progettare il modello di modulo in base al file di connessione dati

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. In Progetta nella finestra di dialogo Progetta modello di modulo, fare clic su Modello di modulo.

  3. Nell'elenco in base a: fare clic su Raccolta di connessioni.

  4. Se si progetta un modello di modulo compatibile con browser, selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser.

  5. Fare clic su OK.

  6. Nell'elenco sito nella connessione guidata dati, fare clic sul nome del sito sul server che esegue Office SharePoint Server 2007 che include la raccolta di connessioni dati.

    Aggiungere il sito all'elenco

    1. Fare clic su Gestisci siti.

    2. Nella finestra di dialogo Gestisci siti, fare clic su Aggiungi.

    3. Nella casella URL digitare il percorso della raccolta di connessioni dati.

    4. Nella casella nome visualizzato digitare un nome per la raccolta di connessioni dati. Questo nome verrà visualizzato nell'elenco del sito nella connessione guidata dati.

    5. Fare clic su OK.

    6. Fare clic su Chiudi.

  7. Fare clic sul nome della raccolta di connessioni dati per visualizzare un elenco di file di connessione dati, fare clic sul nome del file di connessione dati che si desidera utilizzare per la connessione dati e quindi fare clic su Avanti.

  8. Se si seleziona un file di connessione dati con le impostazioni di connessione a un servizio Web, la pagina successiva della procedura guidata potrebbe essere richiesto di specificare i valori di esempio per ogni parametro per determinare i campi o gruppi da aggiungere all'origine dati secondaria.

    Procedura

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Dettagli tecnici

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  9. Se l'origine dati esterna a cui fa riferimento nelle impostazioni restituisce un DataSet Microsoft ADO.NET, la pagina successiva della procedura guidata viene richiesto se si desidera includere tali informazioni quando gli utenti inviano i dati del modulo. Nella maggior parte dei casi, lasciare selezionata la casella di controllo Includi informazioni sulle modifiche all'invio di dati e quindi fare clic su Avanti. Se non si desidera includere le informazioni di modifica, deselezionare la casella di controllo Includi informazioni sulle modifiche all'invio di dati e quindi fare clic su Avanti.

    Dettagli tecnici

    Questa pagina della procedura guidata viene visualizzata solo se le impostazioni per un servizio Web e il file di servizio descrizione lingua WSDL (Web) indica che il servizio Web restituisce un set di dati ADO.NET.

  10. Nella pagina successiva della procedura guidata, digitare un nome per la connessione dati e quindi fare clic su Fine.

Passaggio 2: Aggiungere un controllo per visualizzare i dati nel campo

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo il modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il campo che si desidera associare il controllo.

Torna all'inizio

Progettare un modello di modulo con una connessione dati

Se il file di connessione dati contiene le impostazioni per una connessione dati, è possibile configurare il modello di modulo per consentire agli utenti di inviare i dati del modulo mediante la connessione dati. Quando si esegue questa operazione, InfoPath viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia dal menu File. È possibile configurare le opzioni di invio per il modulo nella finestra di dialogo Opzioni invio (menuStrumenti ). Le opzioni di invio vengono configurate nello stesso modo come se è progettato un modello di modulo in base a un database o un servizio Web. Sono disponibili collegamenti a ulteriori informazioni sulla progettazione di un modello di modulo basato su un database o un servizio Web nella sezione Vedere anche.

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. In Progetta nella finestra di dialogo Progetta modello di modulo, fare clic su Modello di modulo.

  3. Nell'elenco in base a: fare clic su Raccolta di connessioni.

  4. Se si progetta un modello di modulo compatibile con browser, selezionare Attiva solo caratteristiche compatibili con browser.

  5. Fare clic su OK.

  6. Nell'elenco sito nella connessione guidata dati, fare clic sul nome del sito sul server che esegue Office SharePoint Server 2007 che include la raccolta di connessione.

    Aggiungere il sito all'elenco

    1. Fare clic su Gestisci siti.

    2. Nella finestra di dialogo Gestisci siti, fare clic su Aggiungi.

    3. Nella casella URL digitare il percorso della raccolta di connessioni dati.

    4. Nella casella nome visualizzato digitare un nome per la raccolta di connessioni dati. Questo nome verrà visualizzato nell'elenco del sito nella connessione guidata dati.

    5. Fare clic su OK.

    6. Fare clic su Chiudi.

  7. Fare clic sul nome della raccolta di connessioni dati per visualizzare un elenco di file di connessione dati, fare clic sul nome del file di connessione dati che si desidera utilizzare per la connessione dati e quindi fare clic su Avanti.

  8. Se si seleziona un file di connessione dati con le impostazioni di connessione a un servizio Web, la pagina successiva della procedura guidata potrebbe essere richiesto di specificare i valori di esempio per ogni parametro per determinare il migliore campo o gruppo a cui aggiungere all'origine dati secondaria.

    Procedura

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Dettagli tecnici

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  9. Nella pagina successiva della procedura guidata, digitare un nome descrittivo per la connessione dati e quindi fare clic su Fine.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×