Progettare un modello di modulo in base a un servizio Web

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

È possibile progettare un modello di modulo che può utilizzare un servizio Web per ricevere i dati, inviare i dati, o query e inviare i dati.

In questo articolo

Panoramica

Considerazioni sulla compatibilità

Prima di iniziare

Progettare un modello di modulo con una connessione dati di query

Progettare un modello di modulo con una connessione dati

Progettare un modello di modulo con query e inviare connessioni dati

Panoramica

Una maschera può avere una connessione dati principale, denominata connessione dati principale e facoltativamente può contenere uno o più connessioni dati secondarie. A seconda degli obiettivi per la maschera, una connessione dati query o inviare dati del modulo a un'origine dati esterna, ad esempio un database di Microsoft SQL Server o un servizio Web.

Quando si progetta un modello di modulo basato su un servizio Web, è possibile scegliere di configurare il modello di modulo per consentire ai moduli basati su tale modello di modulo per ricevere i dati, inviare i dati, o inviare e ricevere i dati da e verso un servizio Web. Se si sta progettando un modello di modulo per consentire ai moduli ricevere dati da un servizio Web, Microsoft Office InfoPath viene creata una connessione dati di query come la connessione dati principale per il modulo. A seconda della connessione dati, viene creata una principale origine dati con campi di query, campi dati e gruppi che si basano sulle XML Schema del servizio Web. Campi di query contengono i dati che il servizio Web utilizza per determinare gli elementi da inviare al modulo. Quando i moduli basati sul modello di modulo utilizzano la connessione dati principale, viene creata una query utilizzando i dati nei campi di query. InfoPath quindi invia la query mediante la connessione dati di query al servizio Web. Il servizio Web restituisce i risultati della query al modulo mediante la connessione dati di query.

Perché la struttura di dati dei campi di query e dati deve corrispondere al modo che i dati vengono archiviati nel servizio Web, è possibile modificare campi esistenti o gruppi nell'origine dati principale. È possibile aggiungere solo campi o gruppi al gruppo principale nell'origine dati principale. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle origini dati.

Quando si progetta un modello di modulo per inviare dati a un servizio Web, nella connessione dati principale del modulo di InfoPath creare una connessione dati. In questo modo gli utenti inviare i dati nei moduli al servizio Web. InfoPath inoltre aggiunge un comando Invia dal menu File e abilita il pulsante Invia nella barra degli strumenti Standard del modulo. È anche possibile personalizzare le opzioni di invio per i moduli. Quando si crea la connessione dati, InfoPath determina quali parametri nel servizio Web sono disponibili per ricevere dati. In base a queste informazioni, è possibile specificare i campi che si desidera inviare al servizio Web.

Se si progetta un modello di modulo per inviare e ricevere dati a un servizio Web, viene creata una connessione dati di query e una connessione dati.

InfoPath utilizza i seguenti standard del servizio Web per comunicare con i servizi Web:

  • Simple Object Access Protocol (SOAP)    SOAP è il protocollo di comunicazione che definisce i messaggi XML che vengono utilizzati per comunicare con il servizio Web.

  • WSDL (WSDL)    WSDL è lo Schema XML standard usato per indicare la posizione, protocolli di comunicazione e interfacce a un servizio Web. InfoPath può utilizzare solo documento/letterale servizi Web di tipo.

  • Descrizione universale individuazione e integrazione (UDDI)    UDDI è il servizio directory che descrive i servizi Web offerti da un'azienda.

Torna all'inizio

Considerazioni sulla compatibilità

È possibile configurare la connessione dati in un modello di modulo compatibile con browser per consentire agli utenti di invio modificare informazioni insieme i dati del modulo a un servizio Web che accetta un DataSet Microsoft ADO.NET. Modifica informazioni comprendono le modifiche apportate ai dati archiviati in un database di un utente. Il database utilizza un servizio Web per gli utenti di connettersi al database. ADO.NET è possibile usare le informazioni di modifica per determinare la modalità di aggiornare i dati nel database. Chiedere all'amministratore del servizio Web se il servizio Web richiede informazioni sulle modifiche per aggiornare un database. In caso affermativo, è necessario progettare un modello di modulo possono essere compilati cui moduli mediante InfoPath.

Torna all'inizio

Prima di iniziare

Per progettare un modello di modulo basato su un servizio Web, è necessario le seguenti informazioni dall'amministratore del servizio Web:

  • La posizione del servizio Web.

  • Verifica che il servizio Web utilizza una codifica stile documento/letterale. InfoPath può utilizzare solo documento/letterale servizi Web di tipo.

  • Il nome dell'operazione del servizio Web che invia dati a o riceve i dati dei moduli basati sul modello di modulo.

Torna all'inizio

Progettare un modello di modulo con una connessione dati di query

Per progettare un modello di modulo con una connessione dati di query, è necessario eseguire le operazioni seguenti:

  1. Creare il modello di modulo    Quando si crea un modello di modulo che possa ricevere i dati da un servizio Web, viene creata una connessione dati principale con una connessione dati query tra una maschera in cui è basata sul modello di modulo e il servizio Web. InfoPath consente di origine dati principale del modello di modulo.

  2. Aggiungere uno o più controlli per visualizzare i risultati della query    Per consentire agli utenti di visualizzare e modificare i dati nei campi dell'origine dati principale quando viene aperto il modulo, è possibile aggiungere un controllo al modello di modulo e quindi associare il controllo a un campo nell'origine dati principale.

Passaggio 1: Creare il modello di modulo

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. In Progetta nella finestra di dialogo Progetta modello di modulo, fare clic su Modello di modulo.

  3. Nell'elenco in base a: fare clic su Servizio Web.

  4. Se si progetta un modello di modulo compatibile con browser, selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser.

  5. Fare clic su OK.

  6. Nella connessione guidata dati fare clic su dati di ricezione e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata, digitare il percorso del servizio Web e quindi fare clic su Avanti.

    Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio fornito, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  8. Nell'elenco Selezionare un'operazione, fare clic su operazione del servizio Web che restituisce i dati alla maschera e quindi fare clic su Avanti.

  9. Se la connessione guidata dati rileva un elemento sconosciuto nello schema del servizio Web, la pagina successiva della procedura guidata potrebbe essere richiesto di specificare i valori di esempio per ogni parametro per determinare i campi o gruppi da aggiungere all'origine dati principale.

    Procedura

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Dettagli tecnici

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  10. Se il servizio Web accetta le informazioni di modifica, la pagina successiva della procedura guidata viene richiesto se si desidera includere tali informazioni nei dati della query. Nella maggior parte dei casi, lasciare selezionata la casella di controllo Includi informazioni sulle modifiche all'invio di dati e quindi fare clic su Avanti. Se non si desidera includere le informazioni di modifica, deselezionare la casella di controllo Includi informazioni sulle modifiche all'invio di dati e quindi fare clic su Avanti.

    Questa casella di controllo è disattivata se si sta progettando un modello di modulo compatibile con browser.

    Dettagli tecnici

    Questa pagina della procedura guidata viene visualizzata solo se il file (WSDL, Web Services Description Language) per il servizio Web indica che il servizio Web restituisce un DataSet Microsoft ADO.NET.

  11. Nella pagina successiva della procedura guidata, digitare un nome per la connessione dati.

  12. Verificare che le informazioni nella sezione Riepilogo siano corrette e quindi fare clic su Fine.

Passaggio 2: Aggiungere uno o più controlli per visualizzare i risultati della query

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo il modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il gruppo o campo che si desidera associare il controllo.

Torna all'inizio

Progettare un modello di modulo con una connessione dati

Per progettare un modulo con una connessione dati, è necessario eseguire le operazioni seguenti:

  1. Creare il modello di modulo    Quando si crea un modello di modulo che può inviare dati a un servizio Web, viene creata una connessione dati principale con una connessione dati tra una maschera in cui è basata sul modello di modulo e il servizio Web. InfoPath consente di origine dati principale del modello di modulo.

  2. Aggiungere uno o più controlsand associarli a gruppi o campi, o impostare le proprietà del controllo per visualizzare i dati in un campo    Per consentire agli utenti di modificare i dati nei campi dell'origine dati principale, è possibile aggiungere controlli al modello di modulo e quindi associati ai campi dell'origine dati principale.

  3. Configurare le opzioni di invio    È possibile configurare i dati che si desidera inviare al servizio Web e le opzioni di invio per la maschera.

Passaggio 1: Creare il modello di modulo

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. In Progetta nella finestra di dialogo Progetta modello di modulo, fare clic su Modello di modulo.

  3. Nell'elenco in base a: fare clic su Servizio Web.

  4. Se si progetta un modello di modulo compatibile con browser, selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser.

  5. Fare clic su OK.

  6. Nella connessione guidata dati fare clic su Invia dati e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata, digitare il percorso del servizio Web in cui gli utenti verranno inviare i dati e quindi fare clic su Avanti.

    Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio fornito, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  8. Fare clic su Avanti.

  9. Nell'elenco Selezionare un'operazione, fare clic su operazione del servizio Web che utilizza i dati inviati e quindi fare clic su Avanti.

  10. Nella pagina successiva della procedura guidata, digitare un nome per la connessione dati.

  11. Verificare che le informazioni nella sezione Riepilogo siano corrette e quindi fare clic su Fine.

Passaggio 2: Aggiungere uno o più controlli e associarli a gruppi o campi

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo il modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il gruppo o campo che si desidera associare il controllo.

  4. Ripetere i passaggi 2 e 3 per tutti gli altri controlli di cui che si desidera aggiungere al modello di modulo.

Passaggio 3: Configurare le opzioni di invio

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, selezionare la connessione dati invia la connessione dati principale e quindi fare clic su Modifica.

  3. In connessione guidata dati fare due volte clic su Avanti.

  4. Nella pagina successiva della procedura guidata, eseguire una delle operazioni seguenti per selezionare i dati del modulo per inviare per ogni parametro nel servizio Web.

    Inviare i dati in un campo o gruppo

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su campo o gruppo.

    3. Fare clic su Modifica Icona del pulsante .

    4. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo o gruppo di cui si desidera inviare i dati e quindi fare clic su OK.

    5. Nella casella Includi fare clic su testo ed elementi figlio solo per inviare solo i dati in questo campo e gli elementi figlio del campo o gruppo oppure fare clic su sottostruttura XML, incluso l'elemento selezionato per inviare il nome del campo, i dati nel campo e elementi figlio nel campo o gruppo selezionato.

    Inviare tutti i dati del modulo

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    Inviare i dati come una stringa

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    3. Selezionare la casella di controllo Invia dati come una stringa.

      Nota: In genere, si seleziona questa casella di controllo per inviare i dati con firma digitale. Nella maggior parte dei casi, deselezionare questa casella di controllo.

    Dettagli tecnici sugli oggetti ADO.NET set di dati

    Se il servizio Web richiede un oggetto di set di dati ADO.NET, selezionare un nodo set di dati quando si configura la connessione dati. Se si usa un altro tipo di nodo per una connessione dati a un servizio Web che richiede un set di dati di oggetti (ADO), l'azione di invio avrà esito negativo.

  5. Fare clic su Avanti.

  6. Fare clic su Fine.

  7. Fare clic su Chiudi.

  8. Dal menu Strumenti fare clic su Opzioni invio.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella etichettaInvia Opzioni nella finestra di dialogo.

      Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  9. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      1. Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      2. Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      3. Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Progettare un modello di modulo con query e inviare connessioni dati

Per progettare un modello di modulo con una connessione dati di query e una connessione dati, è necessario eseguire le operazioni seguenti:

  1. Creare il modello di modulo    Quando si crea un modello di modulo in grado di eseguire una query e inviare dati a un servizio Web, viene creata una connessione dati principale tra il modello di modulo e il servizio Web con una connessione dati di query e una connessione dati. InfoPath consente di origine dati principale del modello di modulo.

  2. Aggiungere un controllo e associarlo a un campo per visualizzare i dati in un campo    Per consentire agli utenti di visualizzare e modificare i dati nei campi dell'origine dati principale, è possibile aggiungere controlli al modello di modulo e quindi associati ai campi dell'origine dati principale.

  3. Configurare le opzioni di invio    È possibile configurare i dati che si desidera inviare al servizio Web e le opzioni di invio per la maschera.

Passaggio 1: Creare il modello di modulo

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. In Progetta nella finestra di dialogo Progetta modulo fare clic su Modello di modulo.

  3. Nell'elenco in base a: fare clic su Servizio Web.

  4. Se si progetta un modello di modulo compatibile con browser, selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser.

  5. Fare clic su OK.

  6. In connessione guidata dati fare clic su ricezione e inviare i dati e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata, digitare il percorso del servizio Web con l'operazione che invia dati al modello di modulo e quindi fare clic su Avanti.

    Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio fornito, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  8. Nell'elenco Selezionare un'operazione, fare clic su operazione del servizio Web che restituisce i dati alla maschera e quindi fare clic su Avanti.

  9. Se la connessione guidata dati rileva un elemento sconosciuto nello schema del servizio Web, la pagina successiva della procedura guidata potrebbe essere richiesto di specificare i valori di esempio per ogni parametro per determinare i campi o gruppi da aggiungere all'origine dati principale.

    Procedura

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Dettagli tecnici

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  10. Se il servizio Web accetta le informazioni di modifica, la pagina successiva della procedura guidata viene richiesto se si desidera includere tali informazioni nei dati della query. Nella maggior parte dei casi, lasciare selezionata la casella di controllo Includi informazioni sulle modifiche all'invio di dati e fare clic su Avanti. Se non si desidera includere le informazioni di modifica, fare clic per deselezionare la casella di controllo Includi informazioni sulle modifiche all'invio di dati e quindi fare clic su Avanti.

    La casella di controllo è disattivata se si sta progettando un modello di modulo compatibile con browser.

    Dettagli tecnici

    Questa pagina della procedura guidata viene visualizzata solo se il file (WSDL, Web Services Description Language) per il servizio Web indica che il servizio Web restituisce un set di dati ADO.NET.

  11. Nella pagina successiva della procedura guidata, digitare un nome per la connessione dati di query e quindi fare clic su Avanti.

  12. Nella pagina successiva della procedura guidata, digitare il percorso del servizio Web in cui gli utenti verranno inviare i moduli e quindi fare clic su Avanti.

    Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio fornito, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  13. Nell'elenco Selezionare un'operazione, fare clic su operazione del servizio Web che utilizza i dati inviati e quindi fare clic su Avanti.

  14. Nella pagina successiva della procedura guidata, eseguire una delle operazioni seguenti per selezionare i dati del modulo per inviare per ogni parametro nel servizio Web.

    Inviare i dati in un campo o gruppo

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su campo o gruppo.

    3. Fare clic su Modifica Icona del pulsante .

    4. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo o gruppo di cui si desidera inviare i dati e quindi fare clic su OK.

    5. Nella casella Includi fare clic su testo ed elementi figlio solo per inviare solo i dati in questo campo e gli elementi figlio del campo o gruppo oppure fare clic su sottostruttura XML, incluso l'elemento selezionato per inviare il nome del campo, i dati nel campo e elementi figlio nel campo o gruppo selezionato.

    Inviare tutti i dati del modulo

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    Inviare i dati come una stringa

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    3. Selezionare la casella di controllo Invia dati come una stringa.

      In genere, si seleziona questa casella di controllo per inviare i dati con firma digitale. Nella maggior parte dei casi, deselezionare questa casella di controllo.

    Dettagli tecnici sugli oggetti ADO.NET set di dati

    Se il servizio Web richiede un oggetto di set di dati ADO.NET, selezionare un nodo set di dati quando si configura la connessione dati. Se si usa un altro tipo di nodo per una connessione dati a un servizio Web che richiede un set di dati ADO.NET, l'azione di invio avrà esito negativo.

  15. Fare clic su Avanti.

  16. Nella pagina successiva della procedura guidata, digitare un nome per la connessione dati e quindi fare clic su Fine.

Passaggio 2: Aggiungere un controllo e associare a un campo per visualizzare i dati in un campo

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo il modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il campo che si desidera associare il controllo.

Passaggio 3: Configurare le opzioni di invio

  1. Dal menu Strumenti fare clic su Opzioni invio.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella etichettaInvia Opzioni nella finestra di dialogo.

      Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  2. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×