Progettare un modello di modulo in base a un database di Microsoft SQL Server

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

È possibile progettare un modello di modulo che può utilizzare un database di Microsoft SQL Server per eseguire query sui dati o query e inviare i dati.

In questo articolo

Panoramica

Considerazioni sulla compatibilità

Prima di iniziare

Progettare il modello di modulo

Configurare le opzioni di invio

Panoramica

Una maschera può avere una connessione dati principale, denominata connessione dati principale e facoltativamente può contenere uno o più connessioni dati secondarie. A seconda degli obiettivi per la maschera, una connessione dati query o inviare dati del modulo a un'origine dati esterna, ad esempio un database di Microsoft SQL Server o un servizio Web.

Durante la progettazione di un modello di modulo basato su un database di Microsoft Office InfoPath crea una principale origine dati con gruppi che contengono i campi di query e campi dati e una connessione dati di query come la connessione dati principale per il modello di modulo. Questi campi e gruppi corrispondono in modo che i dati vengono archiviati in tabelle del database. Campi di query contengono i dati immessi da un utente per limitare i risultati della query a record che soddisfano i dati nei campi di query. Quando un modulo basato sul modello di modulo utilizza la connessione dati principale, viene creata una query utilizzando i dati nei campi di query. InfoPath quindi invia la query mediante la connessione dati di query. Il database restituisce i risultati della query al modulo mediante la connessione dati di query. Nei campi di dati, che possono essere modificati da controlli associati a questi campi vengono inseriti i risultati della query.

Perché la struttura di dati della query e i campi di dati deve corrispondere al modo che i dati vengono archiviati in database, non è possibile modificare questi campi o gruppi nell'origine dati principale. È possibile aggiungere solo campi o gruppi al gruppo principale nell'origine dati principale. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle origini dati.

Una maschera è possibile inviare dati a un database mediante connessione dati principale del modulo se il modello di modulo che si basa la maschera e il database soddisfa i requisiti seguenti:

  • Il modello di modulo è non un modello di modulo compatibile con browser    InfoPath non creerà una connessione dati nella connessione dati principale se si sta progettando un modello di modulo compatibile con browser. Per consentire agli utenti di inviare i dati in un modulo basato su un modello di modulo compatibile con browser, utilizzare un servizio Web compatibile con il database.

  • La tabella a sinistra di ogni coppia di tabelle correlate nell'origine dati principale contiene una chiave primaria    Almeno una delle relazioni per ciascuna coppia di tabelle correlate deve includere una chiave primaria della tabella a sinistra.

  • Nessuno dei campi dati nell'origine dati principale dell'archivio di maschera, un tipo di dati binari    InfoPath verrà disabilitata la connessione dati se la query include campi contenenti un tipo di dati binari, ad esempio immagini, di immagini, oggetti OLE, file allegati, il tipo di dati memo Office Access o il tipo di dati testo SQL.

Quando InfoPath consente la connessione dati, gli utenti possono inviare i dati nei campi di dati nell'origine dati principale per il database. Se InfoPath consente la connessione dati, è possibile personalizzare le opzioni di invio per i moduli basati sul modello di modulo.

Torna all'inizio

Considerazioni sulla compatibilità

Quando si progetta un modello di modulo basato su un database, disponibile l'opzione di progettazione di un modello di modulo compatibile con browser. InfoPath verrà creata una connessione dati di query come la connessione dati principale in un modello di modulo compatibile con browser. Tuttavia, modelli di modulo compatibile con browser non possono essere configurati per consentire agli utenti di inviare dati a un database. Pertanto, se si sta progettando un modello di modulo in base a un database SQL Server e si desidera che gli utenti per inviare i dati del modulo al database mediante la connessione dati principale, è possibile apportare il modello di modulo compatibile con browser.

Torna all'inizio

Prima di iniziare

Per progettare il modello di modulo in base a un database SQL Server, è necessario le seguenti informazioni all'amministratore del database:

  • Il nome del server che contiene il database che si connetterà il modello di modulo.

  • Il nome del database da utilizzare con questo modello di modulo.

  • Autenticazione necessaria per il database. Il database è possibile utilizzare l'autenticazione di Microsoft Windows o l'autenticazione di SQL Server per determinare come gli utenti possano accedere al database.

  • Il nome della tabella che contiene i dati che si desidera inviare il modulo o che riceverà i dati del modulo. Si tratta della tabella primaria. Se si intende utilizzare più di una tabella nel database, è necessario i nomi di queste altre tabelle figlio. È necessario anche i nomi dei campi della tabella figlio che sono state definite relazioni con i campi della tabella primaria.

Torna all'inizio

Progettare il modello di modulo

Per progettare un modello di modulo con una connessione dati di query, è necessario eseguire le operazioni seguenti:

  1. Creare il modello di modulo    Quando si crea un modello di modulo basato su un database, viene creata una connessione dati di query come la connessione dati principale tra il modello di modulo e il database. Questo processo crea automaticamente origine dati principale del modello di modulo.

  2. Aggiungere uno o più controlli per visualizzare i risultati della query    Per consentire agli utenti di visualizzare e modificare i dati nei campi dell'origine dati principale quando viene aperto il modulo, è possibile aggiungere un controllo al modello di modulo e quindi associare il controllo a un campo nell'origine dati principale.

Passaggio 1: Creare il modello di modulo

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. In Progetta nella finestra di dialogo Progetta modello di modulo, fare clic su modello di modulo.

  3. Nell'elenco in base a: fare clic su Database.

  4. Se si progetta un modello di modulo compatibile con browser, selezionare la casella di controllo Attiva solo caratteristiche compatibili con browser.

    Nota: La connessione guidata dati non è possibile la connessione dati in un modello di modulo compatibile con browser. Per consentire agli utenti di inviare i dati a un database da moduli basati su un modello di modulo compatibile con browser, aggiungere una connessione dati secondaria a un servizio Web compatibile con il database. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle connessioni dati secondaria.

  5. Fare clic su OK.

  6. In connessione guidata dati fare clic su Seleziona Database.

  7. Nella finestra di dialogo Seleziona origine dati fare clic su Nuova origine.

  8. Nell'elenco il tipo di origine dati si desidera connettersi, fare clic su Microsoft SQL Server e quindi fare clic su Avanti.

  9. Nella casella nome Server digitare il nome del server di database di SQL Server.

  10. In credenziali di accesso, eseguire una delle operazioni seguenti:

    • Se il database determina chi ha accesso in base alle credenziali usate in una rete Microsoft Windows, fare clic su Usa autenticazione di Windows.

    • Se il database determina chi ha accesso in base a un nome utente specificato e la password che è possibile ottenere dall'amministratore del database, fare clic su utilizza il nome utente e la Password seguenti e quindi digitare il nome utente e la password nel Nome utente e Password caselle.

  11. Fare clic su Avanti.

  12. Nella casella selezionare il database contenente i dati desiderati, fare clic sul nome del database che si desidera utilizzare, selezionare la casella di controllo Connetti a una tabella specifica, fare clic sul nome della tabella primaria e quindi fare clic su Avanti.

  13. Nella pagina successiva della procedura guidata, digitare un nome per il file che contiene le informazioni di connessione dati nella casella Nome File e quindi fare clic su Fine per salvare le impostazioni.

    Se si prevede di utilizzare altre tabelle nella connessione dati query, è possibile aggiungere altre tabelle in questa pagina della procedura guidata.

    Procedura

    1. Fare clic su Aggiungi tabella.

    2. Nella finestra di dialogo Aggiungi tabella o Query, fare clic sul nome della tabella figlio e quindi fare clic su Avanti. InfoPath tenta di impostare la visualizzazione relazioni confrontando i nomi dei campi in entrambe le tabelle. Se non si desidera utilizzare la relazione suggerita, selezionare la relazione e quindi fare clic su Rimuovi relazione. Per aggiungere una relazione, fare clic su Aggiungi relazione. Nella finestra di dialogo Aggiungi relazione, fare clic sul nome di ogni campo correlato nella rispettiva colonna e quindi fare clic su OK.

    3. Fare clic su Fine.

    4. Per aggiungere altre tabelle figlio, ripetere questi passaggi.

  14. Fare clic su Avanti.

  15. Nell'ultima pagina della procedura guidata, digitare un nome per la connessione dati principale. Questo nome verrà visualizzato nell'elenco di origine dati nel riquadro attività Origine dati.

  16. Se il modello di modulo soddisfi i requisiti di nella sezione Overview , questa pagina della procedura guidata indica che InfoPath attivata la connessione dati invia la connessione dati principale. Per modificare il nome per la connessione dati, digitare un nuovo nome nella casella appropriata. Se si vuole agli utenti di inviare che i dati del modulo a un'altra connessione dati che verranno aggiunti al modello di modulo in un secondo momento, fare clic per deselezionare la casella di controllo Consenti invio per la connessione.

    Nota: Se il modello di modulo non soddisfa i requisiti nella sezione Overview , InfoPath disabilita la connessione dati e la casella Immettere un nome per la connessione di invio e la casella di controllo Consenti invio per questa connessione sono non è disponibile (disattivato). Se InfoPath disabilita la connessione dati, la connessione dati principale per il modello di modulo avrà solo una connessione dati di query.

Passaggio 2: Aggiungere uno o più controlli per visualizzare i risultati della query

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo il modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il gruppo o campo che si desidera associare il controllo.

Torna all'inizio

Configurare le opzioni di invio

Se il modello di modulo e le tabelle selezionate nella connessione guidata dati soddisfano i requisiti nella sezione Overview , InfoPath consente di configurare il modello di modulo per inviare i dati mediante la connessione dati principale. Se si sceglie di usare questa connessione dati, InfoPath configura il modello di modulo in modo che gli utenti possono inviare i dati del modulo al database e aggiunge pulsante Invia nella barra degli strumenti Standard e il comando InviaFile menu quando gli utenti compilano il modulo. InfoPath consente di configurare anche il modello di modulo in modo che, quando gli utenti inviano i moduli, il modulo rimane aperto e verrà visualizzato un messaggio all'utente che indica se il modulo è stato inviato. È possibile modificare il testo sul pulsante Invia e il comportamento dopo l'utente invia un modulo.

  1. Dal menu Strumenti fare clic su Opzioni invio.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella etichettaInvia Opzioni nella finestra di dialogo.

      Suggerimento: Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  2. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento: Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×