Progettare un modello di modulo basato su un database di Microsoft Access

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

È possibile progettare un modello di modulo di Microsoft Office InfoPath che funziona con un database di Microsoft Office Access per ricevere i dati, oppure per eseguire query e inviare dati. È possibile progettare il modello di modulo in base a un database Microsoft Office Access 2007 (con estensione accdb format) o un database di Access salvato in una versione precedente (con estensione mdb formato).

In questo articolo

Panoramica

Considerazioni sulla compatibilità

Prima di iniziare

Progettare il modello di modulo

Configurare le opzioni di invio

Panoramica

Una maschera può avere una connessione dati principale, denominata connessione dati principale e la connessione può disporre di una o più connessioni dati secondaria. Eseguire query o inviare dati del modulo a un database di Access, è possibile usare la connessione dati principale. Utilizzare le connessioni dati secondaria per eseguire query e inviare dati a origini dati esterne, con alcune eccezioni. Ad esempio, è possibile utilizzare una connessione dati secondaria a un database di Access in modo che richieda solo il database. È possibile aggiungere una connessione dati secondaria a una maschera che invia directory dati modulo a un database di Access.

Quando si progetta un modello di modulo basato su un database di Access, InfoPath crea una principale origine dati con i gruppi che contengono i campi di query e campi dati e crea anche una connessione dati di query come la connessione dati principale per il modello di modulo. Questi campi e gruppi corrispondono in modo che i dati vengono archiviati in tabelle del database.

Campi di query contengono i dati immessi nel modulo da un utente per limitare i risultati della query a record che soddisfano i dati nei campi di query. Quando una maschera in cui è basata sul modello di modulo utilizza la connessione dati principale, viene creata una query utilizzando i dati nei campi di query. InfoPath quindi invia la query mediante la connessione dati. Il database restituisce i risultati della query al modulo mediante la connessione dati. I risultati della query vengono inseriti nei campi di dati, che possono essere modificati da controlli associati ai campi di dati del modulo.

Perché la struttura di dati della query e i campi di dati deve corrispondere al modo che i dati vengono archiviati in database, non è possibile modificare questi campi o gruppi nell'origine dati principale. È possibile aggiungere solo campi o gruppi al gruppo principale nell'origine dati principale. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle origini dati.

Una maschera è possibile inviare dati a un database mediante connessione dati principale del modulo se il modello di modulo che si basa la maschera e il database soddisfa i requisiti seguenti:

  • Il modello di modulo è non un modello di modulo compatibile con browser    InfoPath non creerà una connessione dati nella connessione dati principale se si sta progettando un modello di modulo compatibile con browser. Per consentire agli utenti di inviare i dati in un modulo basato su un modello di modulo compatibile con browser, utilizzare un servizio Web compatibile con il database.

  • La tabella a sinistra di ogni coppia di tabelle correlate nell'origine dati principale contiene una chiave primaria    Almeno una delle relazioni per ciascuna coppia di tabelle correlate deve includere una chiave primaria della tabella a sinistra.

  • Nessuno dei campi dati nell'origine dati principale dell'archivio di maschera, un tipo di dati binari    InfoPath verrà disabilitata la connessione dati se la query include campi contenenti un tipo di dati binari, ad esempio immagini, di immagini, oggetti OLE, file allegati, il tipo di dati memo Office Access o il tipo di dati testo SQL.

Quando InfoPath attiva una connessione dati, gli utenti possono inviare i dati archiviati nei campi di dati nell'origine dati principale per il database. È possibile personalizzare le opzioni di invio per i moduli basati sul modello di modulo.

Torna all'inizio

Considerazioni sulla compatibilità

Non è possibile creare un modello di modulo compatibile con browser in base a un database di Access.

Torna all'inizio

Prima di iniziare

Prima di poter correttamente progettare un modello di modulo basato su un database di Access, è necessario le seguenti informazioni sul database di Access:

  • Il nome e il percorso del database.

    Nota: Assicurarsi che il database in un percorso di rete accessibile agli utenti.

  • Il nome della tabella che riceverà inviato dati, se il modello di modulo consente agli utenti di inviare moduli a un database. Utilizzare questa tabella come tabella principale quando si configura la connessione dati.

  • Il nome della tabella che fornisce i risultati della query inviati a un database, se il modello di modulo verrà solo la query. Utilizzare questa tabella come tabella principale quando si configura la connessione dati di query.

  • I nomi delle tabelle dati da può implicare anche la tabella primaria. Nella maggior parte dei casi, tabella sono già state definite relazioni nel database. Se è necessario stabilire manualmente le relazioni tra la tabella primaria e un'altra tabella, sarà necessario i nomi dei campi correlati di entrambe le tabelle.

Torna all'inizio

Progettare il modello di modulo

Per progettare un modello di modulo con una connessione dati di query, è innanzitutto necessario creare il modello di modulo. Quando si crea un modello di modulo basato su un database, viene creata una connessione dati di query come la connessione dati principale tra il modello di modulo e il database. Questo processo crea automaticamente origine dati principale del modello di modulo.

Dopo aver creato il modello di modulo, è necessario aggiungere un controllo al modello di modulo e quindi associare il controllo a un campo nell'origine dati principale. In questo modo agli utenti di visualizzare i risultati della query nel modulo.

Passaggio 1: Creare il modello di modulo

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. Nella finestra di dialogo Progetta modello di modulo in progettare un nuovo, fare clic su Modello di modulo.

  3. Nell'elenco in base a: fare clic su Database e quindi fare clic su OK.

    Verrà avviata la connessione guidata dati

  4. Nella prima pagina della connessione guidata dati, fare clic su Seleziona Database.

  5. Nella finestra di dialogo Seleziona origine dati individuare il percorso del database.

    Nota: Se il database è archiviato in un percorso di rete, selezionare il percorso universal naming (naming convention) di tale posizione. Non visualizzare il percorso di rete tramite un'unità di rete. Se si usa un'unità di rete, gli utenti che creano moduli basati sul modello di modulo cercherà il database da un'unità di rete. Se l'utente non dispone di un'unità di rete, la maschera non troverà il database.

  6. Fare clic sul nome del database e quindi fare clic su Apri.

  7. Nella finestra di dialogo Seleziona tabella selezionare la tabella primaria o la query che si desidera utilizzare e quindi fare clic su OK.

  8. Nella pagina successiva della procedura guidata, selezionare la casella di controllo Mostra le colonne della tabella.

  9. Per impostazione predefinita, tutti i campi nella tabella verranno aggiunti all'origine dati principale del modello di modulo. Deselezionare le caselle di controllo per i campi che non si desidera includere nell'origine dati principale.

    Aggiungere altre tabelle o query che si desidera utilizzare nella connessione dati query.

    Procedura

    1. Fare clic su Aggiungi tabella.

    2. Nella finestra di dialogo Aggiungi tabella o Query, fare clic sul nome della tabella figlio e quindi fare clic su Avanti. InfoPath tenta di impostare la visualizzazione relazioni confrontando i nomi dei campi in entrambe le tabelle. Se non si desidera utilizzare la relazione suggerita, selezionare la relazione e quindi fare clic su Rimuovi relazione. Per aggiungere una relazione, fare clic su Aggiungi relazione. Nella finestra di dialogo Aggiungi relazione, fare clic sul nome di ogni campo correlato nella rispettiva colonna e quindi fare clic su OK.

    3. Fare clic su Fine.

    4. Per aggiungere altre tabelle figlio, ripetere questi passaggi.

  10. Fare clic su Avanti.

  11. Nell'ultima pagina della procedura guidata, digitare un nome per la connessione dati principale. Questo nome verrà visualizzato nell'elenco di Origine dati nel riquadro attività Origine dati.

  12. Se il modello di modulo soddisfa i requisiti nella sezione Overview , la sezione di Riepilogo in questa pagina della procedura guidata indica che InfoPath attivata la connessione dati invia la connessione dati principale.

  13. Per modificare il nome per la connessione dati, digitare un nuovo nome nella casella appropriata.

  14. Per consentire agli utenti inviare che i dati del modulo a un'altra connessione dati che verranno aggiunti al modello di modulo in un secondo momento, deselezionare la casella di controllo Consenti invio per la connessione.

    Nota: Se il modello di modulo non soddisfa i requisiti nella sezione Overview , InfoPath disabilita la connessione dati e la casella Immettere un nome per la connessione di invio e la casella di controllo Consenti invio per questa connessione sono non disponibile. Se InfoPath disabilita la connessione dati, la connessione dati principale per il modello di modulo conterrà solo una connessione dati di query.

Passaggio 2: Associare un controllo al campo

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo il modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il campo che si desidera associare il controllo.

Torna all'inizio

Configurare le opzioni di invio

Se il modello di modulo e le tabelle selezionate nella connessione guidata dati soddisfano i requisiti nella sezione Overview , InfoPath consente di configurare il modello di modulo per inviare i dati utilizzando la connessione dati principale.

Se si sceglie di utilizzare questa connessione dati, InfoPath consente di configurare il modello di modulo in modo che gli utenti possono inviare i dati del modulo al database e aggiunti anche un pulsante Invia nella barra degli strumenti Standard e un comando InviaFile menu del modulo. InfoPath consente di configurare anche il modello di modulo in modo che quando gli utenti inviano i moduli, il modulo rimane aperto e verrà visualizzato un messaggio che indica se il modulo è stato inviato. È possibile modificare il testo visualizzato sul pulsante Invia e anche modificare il comportamento di un modulo dopo l'invio.

  1. Dal menu Strumenti fare clic su Opzioni invio.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella etichettaInvia Opzioni nella finestra di dialogo.

      Suggerimento: Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  2. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento: Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×