Operatore di intersezione implicito: @

L'operatore di intersezione implicita è stato introdotto come parte dell'aggiornamento sostanziale al linguaggio delle formule di Excel per supportare matrici dinamiche. Le matrici dinamiche conferiscono a Excel capacità e funzionalità di calcolo di nuova importanza.

Lingua delle formule aggiornata

Il linguaggio delle formule aggiornato di Excel è quasi identico alla lingua precedente, ad eccezione del fatto che usa l'operatore @ per indicare il punto in cui si può verificare l'intersezione implicita, mentre la vecchia lingua è stata eseguita in modo invisibile all'utente. Di conseguenza, potresti notare che @ viene visualizzato in alcune formule quando viene aperto in matrice dinamica di Excel. È importante tenere presente che le formule continueranno a essere calcolate allo stesso modoche hanno sempre.  

Che cos'è l'intersezione implicita?

La logica di intersezione implicita riduce molti valori a un singolo valore. Excel ha eseguito questa operazione per forzare una formula a restituire un singolo valore, poiché una cella può contenere solo un singolo valore. Se la formula restituisce un singolo valore, l'intersezione implicita non ha fatto nulla (anche se tecnicamente è stato fatto in background). La logica funziona nel modo seguente:

  • Se il valore è un singolo elemento, restituire l'elemento.

  • Se il valore è un intervallo, restituirà il valore della cella nella stessa riga o colonna della formula.

  • Se il valore è una matrice, scegliere il valore superiore sinistro.

Con l'avvento delle matrici dinamiche, Excel non è più limitato a restituire singoli valori dalle formule, quindi l'intersezione implicita invisibile all'utente non è più necessaria. Quando una formula precedente potrebbe invisibilmente attivare l'intersezione implicita, la matrice dinamica abilitata in Excel Mostra dove si sarebbe verificato con @.  

Perché il simbolo @? 

Il simbolo @ è già usato nei riferimenti alle tabelle per indicare l'intersezione implicita. Prendere in considerazione la formula seguente in una tabella = [@Column1]. In questo caso, @ indica che la formula deve usare l'intersezione implicita per recuperare il valore nella stessa riga da [Column1].  

È possibile rimuovere il @? 

Spesso è possibile. Dipende da ciò che la parte della formula a destra della @ restituisce: 

  • Se viene restituito un singolo valore (il caso più comune), non verrà modificata la rimozione della @.

  • Se restituisce un intervallo o una matrice, la rimozione di @ causerà il riversamento alle celle adiacenti.

Se si rimuove un oggetto @ aggiunto automaticamente e in seguito si apre la cartella di lavoro in una versione precedente di Excel, questa verrà visualizzata come formula in forma dimatrice legacy (racchiuso tra parentesi graffe {}), operazione eseguita per garantire che la versione precedente non inneschi l'intersezione implicita.

Quando si aggiungono le formule @ alle vecchie? 

In generale, le funzioni che restituiscono intervalli o matrici a più celle avranno il prefisso @ se sono state create in una versione precedente di Excel. È importante notare che non ci sono modifiche al modo in cui la formula si comporta, ma ora puoi solo vedere l'intersezione implicita precedentemente invisibile. Le funzioni comuni che possono restituire intervalli a più celle includono indice, OFFSET e funzioni definite dall'utente (UDF).  Un'eccezione comune è se sono avvolti in una funzione che accetta una matrice o un intervallo (ad esempio somma () o media ()). 

Per altre informazioni, Vedi funzioni di Excel che restituiscono intervalli o matrici .

Esempi

Formula originale

Come si è visto in Dynamic array Excel 

Spiegazione

=SOMMA(A1:A10) 

=SOMMA(A1:A10) 

Nessun cambiamento: non è possibile eseguire un'intersezione implicita, poiché la funzione somma prevede intervalli o matrici. 

=A1+A2 

=A1+A2 

Nessun cambiamento: non si può verificare un'intersezione implicita. 

= A1: A10 

= @A1: A10 

Si verificherà l'intersezione implicita ed Excel restituirà il valore associato alla riga in cui si trova la formula.

= INDICE (A1: A10; B1) 

= @INDEX (A1: A10; B1) 

Si può verificare un'intersezione implicita. La funzione index può restituire una matrice o un intervallo quando il secondo o il terzo argomento è 0.  

= OFFSET (A1: A2,1; 1) 

= @OFFSET (A1: A2,1; 1) 

Si può verificare un'intersezione implicita. La funzione offset può restituire un intervallo di celle multiple. In questo caso, verrebbe attivata l'intersezione implicita. 

= MYUDF () 

= @MYUDF () 

Si può verificare un'intersezione implicita. Le funzioni definite dall'utente possono restituire matrici. In questo caso, la formula originale avrebbe attivato l'intersezione implicita. 

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Funzione FILTRO

Funzione MATR.CASUALE

Funzione SEQUENCE

Funzione SORT

Funzione SORTBY

Funzione UNICI

Errori #SPILL! in Excel

Matrici dinamiche e il comportamento di matrice espansa

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×