O (Funzione O)

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Usare la funzione O, cioè una delle funzioni logiche, per determinare se tutte le condizioni in un test sono VERO.

Esempio

Esempi d'uso della funzione O.

La funzione O restituisce VERO se uno degli argomenti restituisce VERO e restituisce FALSO se tutti gli argomenti restituiscono FALSO.

La funzione O viene usata comunemente per estendere la capacità di altre funzioni che eseguono test logici. La funzione SE, ad esempio, esegue un test logico e quindi restituisce un valore se il test restituisce VERO e un altro valore se il test restituisce FALSO. Usando la funzione O come argomento logical_test della funzione SE, è possibile verificare molte condizioni diverse anziché una sola.

Sintassi

O(logico1; [logico2]; ...)

Gli argomenti della sintassi della funzione O sono i seguenti:

Argomento

Descrizione

Logico1

Obbligatorio. Prima condizione da verificare che può restituire VERO o FALSO.

Logico2;...

Facoltativo. Altre condizioni che si desidera verificare che possono restituire vero o falso, fino a un massimo di 255 condizioni.

Osservazioni

  • Gli argomenti devono restituire valori logici come VERO o FALSO oppure essere in matrici o riferimenti che contengono valori logici.

  • Se una matrice o un riferimento contiene testo o celle vuote, tali valori verranno ignorati.

  • Se l'intervallo specificato non contiene valori logici o restituisce il #VALUE! .

  • È possibile usare una formula matrice O per verificare la presenza di un valore in una matrice. Per immettere una formula in forma di matrice, premere CTRL+MAIUSC+INVIO.

Esempi

Ecco alcuni esempi generali dell'uso della funzione O da sola e in combinazione con la funzione SE.

Esempi di come usare la funzione O con la funzione SE.

Formula

Descrizione

=O(A2>1,A2<100)

Visualizza VERO se A2 è maggiore di 1 O minore di 100, altrimenti visualizza FALSO.

=SE(O(A2>1,A2<100), A3, "Il valore non è compreso nell'intervallo")

Visualizza il valore nella cella A3 se è maggiore di 1 O minore di 100, altrimenti visualizza il messaggio "Il valore non è compreso nell'intervallo".

=SE(O(A2<0,A2>50),A2, "Il valore non è compreso nell'intervallo")

Visualizza il valore nella cella A2 se è minore di 0 O maggiore di 50, altrimenti viene visualizzato un messaggio.

Calcolo Commissione di vendita

Ecco uno scenario abbastanza comune in cui è necessario calcolare se gli agenti di vendita sono idonei a ricevere una commissione usando le funzioni SE e O.

Esempio d'uso di SE e O per calcolare la commissione di vendita.
  • SE(O(B14>=$B$4,C14>=$B$5);B14*$B$6,0): SE le vendite totali sono maggiori o uguali a (>=) obiettivo di vendita, O gli account sono maggiori o uguali a (>=) obiettivo dell'account, moltiplicare le vendite totali per la percentuale della commissione, altrimenti viene restituito 0.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Argomenti correlati

Video: funzioni
se avanzateimparano a usare funzioni annidate in una formula
se
funzionee
funzionenon
funzionePanoramica delle formule in Excel
come evitare che
le formule interrotte rilevino glierrori nelle formule
scelte rapide da tastiera in excel 2016 per
lescelte rapide da tastiera di excel 2016 per Mac
logico
funzioni di Excel (riferimento) funzioni di Excel(in ordine alfabetico)
funzionidi Excel (per categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×