Modificare linee, frecce o punti di connessione

Modificare linee, frecce o punti di connessione

Le opzioni di modifica e uso dei connettori sono molto flessibili. È possibile modificare lo spessore, lo stile e la curvatura della linea, controllare l'aspetto dei punti finali e delle frecce, creare connettori curvi, ad angolo retto o diritti e gestire i punti di connessione in vari modi.

Suggerimento    I comandi nel gruppo Strumenti della scheda Home modificano lo stato o la modalità di Visio, fatto che in alcuni casi può creare confusione. Usare la tastiera per passare facilmente tra gli strumenti Selezione Selezione di oggetti (premere CTRL+1) e Connettore Icona del pulsante (premere CTRL+3). Qualunque sia lo strumento in uso, ad esempio Blocco di testo o Punto di connessione, premere ESC più volte per tornare allo strumento Selezione (tranne che in Visio 2010).

Operazione da eseguire   

Creare connettori curvi, ad angolo retto o dritti

Aggiungere frecce o altre terminazioni a un connettore

Modificare lo spessore, lo stile o la curvatura di un connettore

Invertire la direzione di una freccia connettore

Modificare il percorso o intersecare connettori

Altri modi di lavorare con i punti di connessione

Vedere anche

Creare connettori curvi, ad angolo retto o dritti

È possibile modificare un connettore o modificare l'impostazione predefinita per i nuovi connettori.

Modificare un connettore

  1. Selezionare il connettore.

  2. Nel gruppo Layout della scheda Progettazione selezionare Connettori e quindi Connettore ad angolo retto, Connettore dritto o Connettore curvo.

Nota    Non è possibile aggiungere punti di connessione a connettori dritti o ad angolo retto, ma si può usare lo strumento Matita Icona del pulsante per aggiungerli ai connettori curvi. Per altre informazioni, vedere Aggiungere un punto di connessione a un connettore curvo.

Modificare l'impostazione predefinita per i nuovi connettori

  • Per rendere il connettore predefinito dritto o curvo:

    • Visio Online Piano 2, 2016, 2013    Selezionare la scheda File, quindi Stampa e Imposta pagina, selezionare la scheda Layout e percorso e quindi nell'elenco Aspetto selezionare Dritto o Curvo.

    • 2010    Selezionare la scheda File, quindi Stampa, Anteprima di stampa e Imposta pagina, selezionare la scheda Layout e percorso e quindi nell'elenco Aspetto selezionare Dritto o Curvo.

    Nota    Non è possibile impostare un connettore curvo come predefinito.

Inizio pagina

Aggiungere frecce o altre terminazioni a un connettore

È possibile aggiungere frecce, punti o altre terminazioni a un connettore.

  1. Selezionare un connettore.

  2. Eseguire una delle operazioni seguenti:

    • Visio Online Piano 2, 2016, 2013    Nel gruppo Stili forma della scheda Home selezionare Linea e quindi Opzioni linea.

    • 2010    Nel gruppo Forma della scheda Home selezionare Linea e quindi Frecce.

  3. Eseguire una delle operazioni seguenti:

    • Visio Online Piano 2, 2016, 2013    Nel riquadro Formato forma, verificare che in Linea sia selezionato Linea continua e quindi selezionare il tipo, le dimensioni o il tipo di estremità.

      Impostazioni per le estremità dei connettori
    • 2010    Selezionare Altre frecce, selezionare il tipo, le dimensioni o il tipo di estremità nella finestra Linea e quindi fare clic su OK.

      Estremità frecce

Inizio pagina

Modificare lo spessore, lo stile o la curvatura di un connettore

  1. Selezionare un connettore.

  2. Eseguire una delle operazioni seguenti:

    • Visio Online Piano 2, 2016, 2013    Nel gruppo Stili forma della scheda Home selezionare Linea e quindi Opzioni linea.

    • 2010    Nel gruppo Forma della scheda Home selezionare Linea e quindi Opzioni linea.

  3. Eseguire una delle operazioni seguenti:

    • Visio Online Piano 2, 2016, 2013    Nel riquadro Formato forma selezionare lo spessore, lo stile o la curvatura in Linea.

      Impostazioni per gli stili dei connettori
    • 2010    Nella finestra Linea selezionare lo spessore, lo stile o la curvatura e quindi fare clic su OK.

      Spessore linea e altre impostazioni

Inizio pagina

Invertire la direzione di una freccia connettore

Per cambiare la direzione di un connettore, aggiungere una nuova freccia all'estremità senza freccia e rimuovere quella esistente dall'altra estremità.

  1. Selezionare un connettore.

  2. Eseguire una delle operazioni seguenti:

    • Visio Online Piano 2, 2016, 2013    Nel gruppo Stili forma della scheda Home selezionare Linea e quindi Opzioni linea.

    • 2010    Nel gruppo Forma della scheda Home selezionare Linea e quindi Opzioni linea.

  3. Eseguire una delle operazioni seguenti:

    • Visio Online Piano 2, 2016, 2013    Nel riquadro Formato forma, in Linea, selezionare:

      • Inizio tipo freccia ed eseguire il passaggio 4.

      • Fine tipo freccia ed eseguire il passaggio 4.

      Impostazioni per invertire le frecce
    • 2010    Nella finestra Linea selezionare:

      • Inizio tipo freccia ed eseguire il passaggio 4.

      • Fine tipo freccia ed eseguire il passaggio 4.

      Frecce di inizio e fine
  4. Per aggiungere, cambiare o rimuovere una freccia all'inizio e alla fine del connettore selezionato, scegliere una freccia oppure Nessuno nel menu delle frecce.

    Selezionare uno stile di freccia oppure Nessuno nel menu Stile freccia.

Inizio pagina

Modificare il percorso o intersecare connettori

Il comportamento predefinito dei connettori è adatto alla maggior parte dei casi di utilizzo. A volte però occorre un controllo più preciso sul percorso e sull'intersezione dei connettori nel diagramma.

Suggerimento    Usare la funzionalità Zoom per vedere meglio i piccoli dettagli e usufruire di un maggior controllo: Zoom avanti (premere ALT+F6), Zoom indietro (ALT+MAIUSC+F6) e Adatta alla finestra (CTRL+MAIUSC+W).

  • Eseguire una o più delle operazioni seguenti:

    • Per connettere un connettore a un altro connettore, aggiungerlo a una forma e quindi trascinarlo sull'altro connettore.

      Connessione a un connettore
    • Per modificare il percorso di un connettore, selezionarlo e quindi trascinare un punto intermedio in una nuova posizione.

      Modifica del percorso di un connettore
    • Per modificare un connettore pixel per pixel, selezionarlo e premere MAIUSC+tasti di direzione nella direzione desiderata.

      Spostare un connettore per pixel

Nota    Per creare un diagramma ad albero, vedere Creare un diagramma ad albero.

Inizio pagina

Altri modi di lavorare con i punti di connessione

Le sezioni seguenti descrivono i vari modi per controllare i punti di connessione.

Suggerimento    Usare la funzionalità Zoom per vedere meglio i piccoli dettagli e usufruire di un maggior controllo: Zoom avanti (premere ALT+F6), Zoom indietro (ALT+MAIUSC+F6) e Adatta alla finestra (CTRL+MAIUSC+W).

Panoramica dei punti di connessione

Un punto di connessione è un punto speciale di una forma a cui è possibile associare connettori e altre forme. Quando si associa un connettore o una forma a un punto di connessione, la connessione viene mantenuta anche quando si sposta una delle forme.

I punti di connessione diventano visibili quando si cerca di connettere una forma a un'altra. I punti di connessione di una forma sono visibili quando si passa vicino alla forma con lo strumento Connettore o quando si trascina il punto finale di un connettore o di una linea vicino a una forma con punti di connessione.

Strumento Connettore vicino a un cerchio con punti di connessione

Nota    I punti di connessione non sono gli unici punti a cui è possibile associare connettori e linee. I connettori e le linee possono essere associati anche a vertici, punti di controllo e geometria della forma Per altre informazioni, vedere Finestra di dialogo Aggancia e associa.

Usare connessioni punto a punto o connessioni dinamiche

Esistono due tipi di connessione che è possibile impostare tra un connettore e una forma: connessione punto a punto o connessione dinamica. È possibile impostare uno dei due tipi di connessione su entrambe le estremità di un connettore. Se si usa Connessione automatica per connettere le forme, entrambe le estremità avranno una connessione dinamica. Se si seleziona manualmente il punto in cui un connettore è associato a una forma, è possibile specificare il tipo di connessione.

Nel diagramma seguente, la forma A ha un punto di connessione con la forma C e ogni volta che si sposta C il connettore di A rimane connesso allo stesso punto su C. Al contrario, la forma B ha una connessione dinamica con C e il connettore di B si sposta sul punto di connessione di C più vicino.

A ha una connessione punto a punto a C, ma B ha una connessione dinamica a C.

Creare una connessione punto a punto   

Una connessione punto a punto mantiene il connettore associato a uno specifico punto della forma, anche se quest'ultima viene spostata o ruotata.

  1. Trascinare un punto di connessione sulla prima forma verso un punto di connessione sulla seconda forma.

  2. Quando le forme sono connesse, i punti finali del connettore diventano verdi.

Associare un connettore a un punto specifico di una forma per fissarlo a tale punto.

Creare una connessione dinamica   

Una connessione dinamica consente di cambiare la posizione di un connettore su una forma, in modo che se la forma viene spostata o ruotata, il connettore si sposta sul punto di connessione più vicino al proprio punto di origine.

  1. Posizionare lo strumento Connettore al centro della prima forma finché non viene circondata da un riquadro verde.

  2. Tenere premuto il pulsante del mouse e trascinare al centro della seconda forma.

  3. Quando attorno alla seconda forma compare un riquadro verde, rilasciare il pulsante del mouse.

Associare un connettore a una forma per consentire lo spostamento dinamico del connettore ai punti della forma.

Aggiungere un punto di connessione a una forma

Se la forma a cui si vuole associare un connettore non ha un punto di connessione nella posizione desiderata, è facile aggiungerne uno.

  1. Selezionare la forma.

  2. Nel gruppo Strumenti della scheda Home fare clic sullo strumento Punto di connessione Icona del pulsante .

  3. Se i punti di connessione non sono visibili, nel gruppo Strumenti visivi della scheda Visualizza selezionare la casella di controllo Punti di connessione.

  4. Premere CTRL e fare clic nel punto in cui aggiungere il punto di connessione. Il nuovo punto di connessione inserito viene automaticamente selezionato.

  5. Nel gruppo Strumenti della scheda Home fare clic sullo strumento Selezione Selezione di oggetti per riprendere le normali attività di modifica.

Aggiungere un punto di connessione a un connettore curvo

Per una maggiore flessibilità quando si modifica un connettore curvo, è possibile aggiungere punti di connessione. L'operazione è possibile solo con i connettori curvi e non con quelli dritti o ad angolo retto.

  1. Selezionare il connettore curvo.

  2. Nel gruppo Strumenti della scheda Home scegliere Matita Strumento Matita nel menu a discesa degli strumenti di disegno di base.

  3. Se i punti di connessione non sono visibili, nel gruppo Strumenti visivi della scheda Visualizza selezionare la casella di controllo Punti di connessione.

  4. Premere CTRL e fare clic nel punto in cui aggiungere il punto di connessione. Il nuovo punto di connessione inserito viene automaticamente selezionato.

  5. Nel gruppo Strumenti della scheda Home fare clic sullo strumento Selezione Selezione di oggetti per riprendere le normali attività di modifica.

Spostare un punto di connessione su una forma

Se non si è soddisfatti della posizione di un punto di connessione, è possibile spostarlo.

  1. Selezionare la forma.

  2. Nel gruppo Strumenti della scheda Home selezionare lo strumento Punto di connessione Icona del pulsante .

  3. Se i punti di connessione non sono visibili, nel gruppo Strumenti visivi della scheda Visualizza selezionare la casella di controllo Punti di connessione.

  4. Premere CTRL e trascinare il punto di connessione che si vuole spostare.

  5. Nel gruppo Strumenti della scheda Home fare clic sullo strumento Selezione Selezione di oggetti per riprendere le normali attività di modifica.

Se non si riesce a spostare il punto di connessione esattamente nella posizione desiderata, provare con diverse impostazioni di aggancio. Per altre informazioni, vedere Regolare la forza della funzione Aggancia o disattivare la funzione Aggancia.

Eliminare un punto di connessione

Se un punto di connessione risulta fastidioso o inutile, è possibile eliminarlo.

  1. Selezionare la forma con un ponto di connessione da eliminare.

  2. Nel gruppo Strumenti della scheda Home fare clic sullo strumento Blocco di testo Icona del pulsante .

  3. Se non è visualizzato nessun punto di connessione, nel gruppo Strumenti visivi della scheda Visualizza selezionare la casella di controllo Punti di connessione.

  4. Fare clic sul punto di connessione da eliminare. Il punto di connessione diventa di colore magenta.

  5. Premere CANC.

  6. Nel gruppo Strumenti della scheda Home fare clic sullo strumento Selezione Selezione di oggetti per riprendere le normali attività di modifica.

Nascondere punti di connessione

Talvolta può essere utile nascondere punti di connessione per vedere meglio il diagramma.

  • Nel gruppo Strumenti visivi della scheda Visualizza deselezionare la casella di controllo Punti di connessione.

Aggiungere testo accanto a un punto di connessione

Non è possibile aggiungere direttamente testo su un punto di connessione. È però possibile aggiungere testo alla forma e spostarlo poi accanto al punto di connessione.

  1. Selezionare la forma in cui aggiungere testo e iniziare a digitare. Il testo verrà visualizzato nella forma.

  2. Selezionare il testo da spostare.

    Testo selezionato su un cerchio
  3. Posizionare il puntatore del mouse sul testo selezionato e fare clic per trascinarlo.

    Il testo selezionato viene spostato con lo strumento Selezione

    Quando si passa il mouse sul testo selezionato, Visio passa automaticamente allo strumento Selezione Selezione di oggetti .

Creare un punto di connessione verso l'interno, verso l'esterno o in entrambe le direzioni

Usare i punti di connessione verso l'interno e verso l'esterno per controllare come attirare i punti finali dei connettori sulle forme.

  1. Selezionare la forma.

  2. Nel gruppo Strumenti della scheda Home fare clic sullo strumento Punto di connessione Icona del pulsante .

  3. Se i punti di connessione non sono visibili, nel gruppo Strumenti visivi della scheda Visualizza selezionare la casella di controllo Punti di connessione.

  4. Se si vuole un punto di connessione verso l'interno, verso l'esterno oppure sia verso l'interno che l'esterno, fare clic con il pulsante destro del mouse sul punto di connessione e scegliere:

    • Verso l'interno     Nella maggior parte dei casi si usa un punto di connessione verso l'interno. Un punto di connessione di questo tipo "attira" i punti finali dei connettori, i punti di connessione verso l'esterno e quelli verso l'interno e l'esterno delle forme bidimensionali (2D).

    • Verso l'esterno     Se si vuole associare una forma 2D a un'altra forma, è necessario un punto di connessione verso l'esterno. Un punto di connessione di questo tipo è "attirato" dai punti di connessione verso l'interno.

    • Inward & Outward     Interno ed esterno Se non si sa come associare la propria forma ad altre forme, è necessario un punto di connessione verso l'interno e l'esterno.

Inizio pagina

Lavorare con i punti di connessione

Le sezioni seguenti descrivono i vari modi per controllare i punti di connessione.

Panoramica dei punti di connessione

Forma con quattro punti di connessione.

Forma con quattro punti di connessione.

Aggiungere punti di connessione

Se la forma a cui si vuole associare un connettore o un'altra forma non ha un punto di connessione nella posizione desiderata, è facile aggiungerne uno.

  1. Se i punti di connessione non sono visibili, scegliere Punti di connessione dal menu Visualizza.

  2. Selezionare la forma.

    Nota: Se non si seleziona la forma, non sarà possibile aggiungervi un punto di connessione. La forma è selezionata se è circondata da un bordo verde tratteggiato.

  3. Fare clic sullo strumento Punto di connessione Icona del pulsante .

    Se lo strumento Punto di connessione non è visibile, fare clic sulla freccia in giù accanto allo strumento Connettore Icona del pulsante e quindi fare clic sullo strumento Punto di connessione Icona del pulsante .

  4. Premere CTRL e fare clic dove si desidera aggiungere un punto di connessione.

  5. Se si desidera un punto di connessione verso l'interno, verso l'esterno oppure sia verso l'interno che l'esterno, fare clic con il pulsante destro del mouse sul punto di connessione e scegliere Verso l'interno, Verso l'esterno o Interno ed esterno.

    • Nella maggior parte dei casi si usa un punto di connessione verso l'interno. Un punto di connessione di questo tipo "attira" i punti finali dei connettori, i punti di connessione verso l'esterno e quelli verso l'interno e l'esterno delle forme bidimensionali (2D).

    • Se si vuole associare una forma 2D a un'altra forma, è necessario un punto di connessione verso l'esterno. Un punto di connessione di questo tipo è "attirato" dai punti di connessione verso l'interno.

    • Se non si sa come associare la propria forma ad altre forme, è necessario un punto di connessione verso l'interno e l'esterno.

  6. Fare clic sullo strumento Selezione Icona del puntatore per tornare alle normali attività di modifica.

Aggiungere testo accanto a un punto di connessione

Non è possibile aggiungere direttamente testo a un punto di connessione. È però possibile aggiungere testo alla forma e spostarlo poi accanto al punto di connessione.

  1. Selezionare la forma.

  2. Iniziare a digitare. Il testo verrà visualizzato nella forma.

  3. Fare clic sullo strumento Blocco di testo Icona del pulsante .

    Se lo strumento Blocco di testo non è visibile, fare clic sulla freccia in giù accanto allo strumento Testo Pulsante dello strumento Testo e quindi fare clic sullo strumento Blocco di testo Icona del pulsante .

  4. Trascinare il testo.

Suggerimento: Se la forma è dotata di un punto di controllo Immagine del punto di controllo - rombo giallo , è possibile trascinarlo per spostare rapidamente il testo della forma.

Spostare punti di connessione

Se non si è soddisfatti della posizione di un punto di connessione, è possibile spostarlo.

  1. Selezionare la forma.

    Nota: Se non si seleziona la forma, non sarà possibile spostare il punto di connessione. La forma è selezionata se è circondata da un bordo verde tratteggiato.

  2. Fare clic sullo strumento Punto di connessione Icona del pulsante .

    Se lo strumento Punto di connessione non è visibile, fare clic sulla freccia in giù accanto allo strumento Connettore Icona del pulsante e quindi fare clic sullo strumento Punto di connessione Icona del pulsante .

  3. Trascinare il punto di connessione che si vuole spostare.

    Se non sono visibili punti di connessione, scegliere Punti di connessione dal menu Visualizza.

  4. Fare clic sullo strumento Selezione Icona del puntatore per tornare alle normali attività di modifica.

Se non si riesce a spostare il punto di connessione esattamente nella posizione desiderata, provare con impostazioni di aggancio diverse:

  • Nel menu Strumenti fare clic su Aggancia e associa, quindi selezionare le opzioni desiderate nella sezione Aggancia a della scheda Generale.

Eliminare o nascondere punti di connessione

I punti di connessione a volte possono essere di intralcio. In questo caso è possibile eliminarli o nasconderli.

Per eliminare un punto di connessione su una forma

  1. Selezionare la forma.

    Nota: Se non si seleziona la forma, non è possibile eliminare il punto di connessione. La forma è selezionata se è circondata da un bordo verde tratteggiato.

  2. Fare clic sullo strumento Punto di connessione Icona del pulsante .

    Se lo strumento Punto di connessione non è visibile, fare clic sulla freccia in giù accanto allo strumento Connettore Icona del pulsante e quindi fare clic sullo strumento Punto di connessione Icona del pulsante .

  3. Fare clic sul punto di connessione da eliminare. Il punto di connessione diventa di colore magenta.

    Se non sono visibili punti di connessione, scegliere Punti di connessione dal menu Visualizza.

  4. Premere CANC.

  5. Fare clic sullo strumento Selezione Icona del puntatore per tornare alle normali attività di modifica.

Per nascondere un punto di connessione

  • Nel menu Visualizza fare clic su Punti di connessione.

Inizio pagina

Aggiungere frecce o altre terminazioni a un connettore

È possibile aggiungere elementi come frecce, punti o altre terminazioni a un connettore.

  1. Selezionare un connettore.

  2. Scegliere Linea dal menu Formato.

  3. In Terminazioni linea scegliere il tipo e la dimensione desiderati per le terminazioni di linea.

  4. Fare clic su OK.

Suggerimento: È anche possibile usare lo strumento Terminazioni linea sulla barra degli strumenti Formattazione.

Creare connettori curvi, ad angolo retto o dritti

Modificare un connettore sul diagramma

  1. Fare clic con il pulsante destro del mouse sul connettore.

  2. Scegliere Connettore ad angolo retto, Connettore dritto o Connettore curvo.

Nota    Non è possibile aggiungere punti di controllo a connettori dritti o ad angolo retto, ma si può usare lo strumento Matita Icona del pulsante per aggiungerli ai connettori curvi.

Modificare l'impostazione predefinita per i nuovi connettori

  • Per rendere il connettore predefinito dritto o curvo, scegliere Imposta pagina dal menu File, fare clic sulla scheda Layout e percorso e quindi nell'elenco Aspetto fare clic su Dritto o Curvo.

Invertire la direzione di una freccia connettore

Se si vuole cambiare la direzione di un connettore, aggiungere una nuova freccia all'estremità senza freccia e rimuovere quella esistente dall'altra estremità.

  1. Selezionare il connettore da modificare.

  2. Nel gruppo Forma della scheda Home fare clic su Linea e quindi posizionare il puntatore su Frecce per aprire il menu Frecce.

    Fare clic su Linea in Stili forma per aprire il menu e quindi fare clic su Frecce.
  3. Fare clic su Altre frecce in fondo al menu Frecce.

    Fare clic su Altre frecce in fondo al menu Frecce.

    Visio visualizza il riquadro attività Formato forma con l'opzione Linea espansa.

  4. Per aggiungere, cambiare o rimuovere una freccia all'inizio del connettore selezionato, scegliere una freccia oppure Nessuno nel menu delle frecce per Inizio tipo freccia.

    Sulla linea di connessione selezionata aggiungere, modificare o rimuovere una freccia.

    Il menu delle frecce mostra lo stile selezionato oppure Nessuno per il connettore selezionato.

    Selezionare uno stile di freccia oppure Nessuno nel menu Stile freccia.
  5. Per aggiungere, cambiare o rimuovere una freccia alla fine del connettore selezionato, scegliere una freccia oppure Nessuno nel menu delle frecce per Fine tipo freccia.

Vedere anche

Aggiungere e modificare il testo del connettore

Aggiungere connettori tra le forme

Associare o rimuovere l'associazione dei connettori

Creare un connettore personalizzato

Aggiungere o rimuovere i ponticelli di connessione

Formazione su Visio

Tutto sui connettori di Visio Desktop (blog del team di Visio)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×