Modificare il servizio Web utilizzato nella connessione dati principale del modello di modulo

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

In questo articolo

Panoramica

Prima di iniziare

Modificare la connessione dati di query

Modificare la connessione dati

Panoramica

Quando si progetta innanzitutto un modello di modulo con una connessione dati principale a un servizio Web, che si stia utilizzando un ambiente di testing nel punto in cui il servizio Web è in fase di sviluppo. Quando il servizio Web è pronto per essere distribuito, sarà necessario modificare la connessione dati principale nel modello di modulo dall'ambiente di testing al percorso del servizio Web distribuito.

Quando si modifica il servizio Web nella connessione dati principale, Microsoft Office InfoPath consente di creare un'origine dati principale con campi e gruppi che corrispondono ai XML Schema nel nuovo servizio Web. Se gli schemi nei servizi Web vecchi e nuovi sono uguali, InfoPath associa automaticamente i controlli esistenti nel modello di modulo per i campi nella nuova origine dati. Se i campi e gruppi nella nuova origine dati non corrispondono campi e ai gruppi nell'origine dati precedente, verrà rimossa l'associazione di origine dati dai controlli. InfoPath consente di rimuovere l'associazione dei controlli, è necessario rimuovere i controlli dal modello di modulo oppure associarli ad altri campi nella nuova origine dati.

A seconda di progettazione del modello di modulo, la connessione dati principale può intrattenere una connessione dati di query, una connessione dati o entrambe. Se la connessione dati principale ha una connessione dati di query e una connessione dati e percorso è stato modificato il servizio Web, è necessario modificare entrambe le connessioni.

Nota: Sono disponibili collegamenti a informazioni sulla modifica delle connessioni dati secondarie ad altre origini dati esterne nella sezione Vedere anche.

Dopo aver modificato la connessione dati principale, è necessario pubblicare e testare il modello di modulo per assicurarsi che la connessione dati al servizio Web funzioni come previsto durante la compilazione dei moduli basati sul modello di modulo. È inoltre necessario verificare per assicurarsi che i moduli esistenti basati sul modello di modulo continua a funzionare come previsto. Dopo aver completato i test, è possibile consentire agli utenti di iniziare a compilare i moduli basati sul modello di modulo. Sono disponibili collegamenti a ulteriori informazioni sulla pubblicazione di un modello di modulo nella sezione Vedere anche.

Torna all'inizio

Prima di iniziare

Prima di modificare la connessione dati principale, è necessario le seguenti informazioni dall'amministratore del servizio Web:

  • La posizione del nuovo servizio Web.

  • Verifica che il nuovo servizio Web utilizza una codifica stile documento/letterale. InfoPath può utilizzare solo documento/letterale servizi Web di tipo.

  • I nomi delle operazioni nel servizio Web che verrà utilizzato.

  • Verifica che gli schemi nei servizi Web vecchi e nuovi sono gli stessi.

Torna all'inizio

Modificare la connessione dati di query

  1. Dal menu Strumenti fare clic su Converti origine dati principale.

  2. In connessione guidata dati fare clic su Crea una nuova connessione a, fare clic su dati di ricezione e quindi fare clic su Avanti.

  3. In Selezionare il tipo di connessione dati che si desidera utilizzare per il modello di modulo, fare clic su servizio Web e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, digitare il percorso del servizio Web e quindi fare clic su Avanti.

    Nota: Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio fornito, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  5. Nell'elenco Selezionare un'operazione, fare clic su operazione del servizio Web che restituisce i dati alla maschera e quindi fare clic su Avanti.

  6. Se la connessione guidata dati rileva un elemento sconosciuto nello schema del servizio Web, la pagina successiva della procedura guidata potrebbe essere richiesto di specificare i valori di esempio per ogni parametro per determinare i campi o gruppi da aggiungere all'origine dati principale.

    Procedura

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Dettagli tecnici

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  7. Se il servizio Web accetta le informazioni di modifica, la pagina successiva della procedura guidata viene richiesto se si desidera includere tali informazioni nei dati della query. Nella maggior parte dei casi, lasciare selezionata la casella di controllo Includi informazioni sulle modifiche all'invio di dati e quindi fare clic su Avanti. Se non si desidera includere le informazioni di modifica, deselezionare la casella di controllo Includi informazioni sulle modifiche all'invio di dati e quindi fare clic su Avanti.

    Dettagli tecnici

    Questa pagina della procedura guidata viene visualizzata solo se il file (WSDL, Web Services Description Language) per il servizio Web indica che il servizio Web restituisce un DataSet Microsoft ADO.NET.

  8. Nella pagina successiva della procedura guidata, digitare un nome per la connessione dati e quindi fare clic su Fine.

  9. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

  10. Per pubblicare il modello di modulo, nel menu File fare clic su pubblica.

  11. Verificare accuratamente il modello di modulo, aprire una maschera in cui è basata sul modello di modulo e compilare i. Verificare che il modulo funzioni come previsto.

Torna all'inizio

Modificare la connessione dati

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nell'elenco connessioni dati per il modello di modulo, selezionare la connessione dati invia la connessione dati principale e quindi fare clic su Modifica.

  3. In connessione guidata dati digitare il percorso del nuovo servizio Web in cui gli utenti verranno inviare i moduli e quindi fare clic su Avanti.

    Nota: Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio fornito, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  4. Nella pagina successiva della procedura guidata, nell'elenco Selezionare un'operazione fare clic su operazione del servizio Web che utilizza i dati inviati e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata per selezionare i dati del modulo per inviare per ogni parametro nel servizio Web, eseguire una delle operazioni seguenti:

    Inviare i dati in un campo o gruppo

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su campo o gruppo.

    3. Fare clic su Modifica Icona del pulsante .

    4. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo o gruppo di cui si desidera inviare i dati e quindi fare clic su OK.

    5. Nella casella Includi fare clic su testo ed elementi figlio solo per inviare solo i dati in questo campo e gli elementi figlio del campo o gruppo oppure fare clic su sottostruttura XML, incluso l'elemento selezionato per inviare il nome del campo, i dati nel campo e elementi figlio nel campo o gruppo selezionato.

    Inviare tutti i dati del modulo

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    Inviare i dati come una stringa

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    3. Selezionare la casella di controllo Invia dati come una stringa.

      Nota: In genere, si seleziona questa casella di controllo per inviare i dati con firma digitale. Nella maggior parte dei casi, deselezionare questa casella di controllo.

    Dettagli tecnici sugli oggetti ADO.NET set di dati

    Se il servizio Web richiede un oggetto di set di dati ADO.NET, selezionare un nodo set di dati quando si configura la connessione dati. Se si usa un altro tipo di nodo per una connessione dati a un servizio Web che richiede un set di dati ADO.NET, l'azione di invio avrà esito negativo.

  6. Fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata, digitare un nome per la connessione dati e quindi fare clic su Fine.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×