Inviare i dati del modulo a un database di Microsoft Access

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

In questo articolo

Panoramica

Passaggio 1: Attivare la connessione dati per invio

Passaggio 2: Configurare le opzioni di invio

Panoramica

Quando si progetta un modello di modulo di Microsoft Office InfoPath basato su un database di Microsoft Office Access (in formato mdb) o su un database di Microsoft Office Access 2007 (in formato accdb), se vengono soddisfatte le seguenti condizioni la Connessione guidata dati crea una connessione dati per invio al database.

  • Il modello di modulo viene progettato in modo che per compilarlo sia necessario utilizzare InfoPath. Se il modulo verrà compilato utilizzando un browser, non sarà in grado di inviare dati direttamente a un database. Per configurare un modello di modulo compatibile con browser per inviare dati a un database, utilizzare una connessione dati che consenta di inviare dati a un servizio Web in grado di interagire con il database.

  • La tabella di database primaria viene utilizzata nella connessione dati principale come chiave primaria, vincolo UNIQUE o indice univoco.

  • Qualsiasi altra tabella di database utilizzata con questa connessione dati principale dispone di una semplice relazione gerarchica con la tabella di database primaria.

  • Nel database non sono presenti campi in grado di archiviare un tipo di dati binari di grandi dimensioni, ad esempio, figure, immagini, oggetti OLE, allegati di file, il tipo di dati Memo di Office Access o il tipo di dati di testo SQL.

Se il database soddisfa questi requisiti, in InfoPath viene creata la connessione dati per invio e vengono aggiunti il pulsante Invia sulla barra degli strumenti Standard e il comando Invia al menu File del modulo.

Nota : Le connessioni dati secondarie non consentono di inviare dati a un database. Se si desidera utilizzare una connessione dati per invio a un database come connessione dati secondaria, identificare un servizio Web in grado di interagire con il database, quindi aggiungere una connessione dati per invio al servizio Web.

Dopo avere attivato la connessione dati per invio, sarà possibile personalizzare le opzioni di invio per il modello di modulo come descritto di seguito.

  • Modificare il testo visualizzato sul pulsante Invia sulla barra degli strumenti Standard e il comando Invia nel menu File.

  • Modificare i tasti di scelta rapida per il pulsante Invia sulla barra degli strumenti Standard e il comando Invia nel menu File.

  • Creare messaggi personalizzati da visualizzare agli utenti quando inviano i moduli.

  • Specificare se dopo l'invio del modulo, quest'ultimo deve essere tenuto aperto o chiuso oppure se deve essere aperto un modulo vuoto.

Inizio pagina

Passaggio 1: Attivare la connessione dati per invio

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic sulla connessione dati principale e quindi su Modifica.

  3. In Connessione guidata dati fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata selezionare la casella di controllo Consenti invio per questa connessione e quindi fare clic su Fine.

Inizio pagina

Passaggio 2: Configurare le opzioni di invio

Dopo avere attivato la connessione dati per invio, in InfoPath vengono aggiunti un pulsante Invia sulla barra degli strumenti Standard e un comando Invia al menu File. Vengono inoltre configurati i moduli basati sul modello di modulo corrente in modo che dopo l'invio del modulo venga visualizzato un messaggio agli utenti in cui è indicato se l'operazione è stata completata correttamente. Per impostazione predefinita, il modulo rimane aperto in InfoPath dopo che è stato inviato. Per modificare il testo visualizzato sul pulsante Invia e il comportamento del modulo dopo che è stato inviato dall'utente, procedere come segue:

  1. Scegliere Opzioni invio dal menu Strumenti.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Suggerimento : Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare Su & v.

  2. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento : Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×