Inviare dati del modulo a una raccolta documenti

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

È possibile archiviare e organizzare tutti i moduli degli utenti in una raccolta documenti in un server che esegue Microsoft Windows SharePoint Services. Nella raccolta documenti gli utenti possono compilare i moduli basati sul modello di modulo, esportare dati da moduli completati in Microsoft Office Excel 2003 o Microsoft Office Excel 2007 o unire i dati di più moduli in un modulo.

Per consentire agli utenti di inviare moduli basati sul modello di modulo in una raccolta documenti, è possibile aggiungere una connessione dati secondaria al modello di modulo che invia i dati. Dopo aver aggiunto la connessione dati, è possibile configurare il modello di modulo per consentire agli utenti di inviare i dati del modulo alla raccolta documenti. In tal caso, Microsoft Office InfoPath viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia al menu File nella maschera. È anche possibile personalizzare le opzioni di invio del modello di modulo nei modi seguenti:

  • Modificare il testo che viene visualizzato il pulsante Invia nella barra degli strumenti Standard e il comando Invia del menu File.

  • Modificare i tasti di scelta rapida per il pulsante Invia nella barra degli strumenti Standard e il comando Invia del menu File.

  • Creare messaggi personalizzati per la visualizzazione agli utenti quando si inviano i moduli.

  • Specificare se si desidera lasciare aperta la maschera, chiudere la maschera o aprire un modulo vuoto dopo l'invio.

Aggiungere una connessione dati

  1. Dal menu Strumenti fare clic su Opzioni invio.

  2. Nella finestra di dialogo Opzioni invio, selezionare la casella di controllo Consenti agli utenti di inviare il modulo.

  3. Fare clic su Invia dati del modulo a una singola destinazione e quindi fare clic su raccolta documenti di SharePoint nell'elenco.

  4. Fare clic su Aggiungi.

  5. Nella connessione guidata dati nella finestra di raccolta documenti, digitare la posizione della raccolta documenti di SharePoint.

  6. Nella casella Nome File digitare un nome che verrà utilizzato per identificare il modulo nella raccolta documenti.

    Suggerimento: È anche possibile utilizzare una formula per assicurarsi che ogni nome di modulo sia univoco.

    Procedura

    1. Fare clic su Inserisci Formula Icona del pulsante .

    2. Nella finestra di dialogo Inserisci Formula eseguire una delle operazioni seguenti:

      • Per utilizzare un campo nella formula, fare clic su Inserisci campo o gruppo, fare clic sul campo che si desidera utilizzare nella finestra di dialogo Seleziona campo o gruppo e quindi fare clic su OK.

      • Per utilizzare una funzione nella formula, fare clic su Inserisci funzione, selezionare la funzione che si desidera utilizzare nella finestra di dialogo Inserisci funzione e quindi fare clic su OK.

        Suggerimento: Se la funzione richiede parametri, selezionare la funzione nella finestra di dialogo Inserisci funzione, fare clic su OK, quindi nella casella Formula nella finestra di dialogo Inserisci Formula, fare doppio clic sulla funzione che è stato aggiunto e fare clic su un campo o gruppo. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle funzioni.

      • Per inserire un valore o un operatore matematico nella formula, digitare il valore o il simbolo dell'operazione matematica nella casella Formula.

    Operazione

    Simbolo

    Aggiungi

    +

    Sottrarre

    -

    Moltiplicare

    *

    Dividere

    /

    • Nota: Se la formula utilizza l'operatore di divisione (/), assicurarsi che sia presente uno spazio prima e dopo l'operatore di divisione. Se l'operatore di divisione non dispone di uno spazio prima e dopo tale voce, InfoPath possono interpretare "/" come separatore per i passaggi percorso XPath anziché come un operatore di divisione.

    • Per verificare se la formula per la sintassi corretta, nella finestra di dialogo Inserisci Formula, fare clic su Verifica Formula.

      Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle formule.

  7. Per sovrascrivere moduli esistenti con lo stesso nome nella raccolta documenti, selezionare la casella di controllo Sovrascrivi se file esistente.

  8. Fare clic su Avanti.

  9. Nella pagina successiva della procedura guidata, nella casella Immettere un nome per la connessione dati digitare un nome descrittivo per questa connessione dati.

  10. Verificare che le informazioni siano corrette nella sezione Sommario e quindi fare clic su Fine.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella etichettaInvia Opzioni nella finestra di dialogo.

      Suggerimento: Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  11. Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      1. Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      2. Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento: Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      3. Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×