Inviare dati del modulo a più percorsi

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

È possibile progettare il modello di modulo in modo che gli utenti possono inviare i dati del modulo a più percorsi quando si fa clic sul pulsante Invia.

In questo articolo

Panoramica

Passaggio 1: Aggiungere le connessioni dati invia

Passaggio 2: Configurare il modello di modulo per l'invio

Panoramica

Per consentire agli utenti di inviare i dati del modulo a più percorsi, è necessario aggiungere una connessione dati secondaria al modello di modulo che invia i dati per ognuna delle posizioni in cui si desidera agli utenti di inviare il modulo. Dopo aver aggiunto tutte le connessioni dati invia, configurare il modello di modulo per consentire agli utenti di inviare i dati del modulo a più percorsi utilizzando un regola. Di conseguenza, Microsoft Office InfoPath aggiunge un pulsante Invia nella barra degli strumenti Standard e un comando Invia dal menu File quando gli utenti compilano il modulo. InfoPath invia i dati del modulo per le connessioni dati secondaria nell'ordine in cui sono elencati nella regola. Non è possibile configurare la regola per l'utilizzo di tutte le connessioni dati invia nello stesso momento.

Quando si configura il modello di modulo per consentire agli utenti di inviare i dati del modulo, è anche possibile personalizzare le opzioni di invio nei modi seguenti:

  • Modificare il testo che viene visualizzato il pulsante Invia nella barra degli strumenti Standard e il comando Invia del menu File.

  • Modificare i tasti di scelta rapida per il pulsante Invia nella barra degli strumenti Standard e il comando Invia del menu File.

  • Creare messaggi personalizzati per la visualizzazione agli utenti quando si inviano i moduli.

  • Specificare se si desidera lasciare aperta la maschera, chiudere la maschera o aprire un modulo vuoto dopo l'invio.

Torna all'inizio

Passaggio 1: Aggiungere le connessioni dati invia

Per configurare il modello di modulo per consentire agli utenti di inviare i moduli completati a più percorsi, aggiungere le necessarie presenta connessioni dati al modello di modulo. È possibile aggiungere connessioni dati nei seguenti percorsi:

  • Un servizio Web

  • Una raccolta documenti in un server che esegue Microsoft Windows SharePoint Services

  • In un messaggio di posta elettronica

    Nota: Gli utenti devono installato nel computer per inviare dati del modulo in un messaggio di posta elettronica di Microsoft Office Outlook.

Le procedure seguenti illustrano come aggiungere connessioni dati in questi percorsi di invio.

Aggiungere una connessione dati per inviare dati a un servizio Web

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. In connessione guidata dati fare clic su Crea una nuova connessione, fare clic su Invia dati e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, fare clic su a un servizio Web e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, digitare il percorso del servizio Web in cui gli utenti verranno inviare i moduli e quindi fare clic su Avanti.

    Se si desidera cercare in un servizio Web server Universal Description, individuazione e Integration (UDDI), fare clic su Cerca UDDI, immettere il server UDDI che si desidera cercare, specificare se si desidera cercare dal provider o ai servizi forniti , immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca.

  6. Nella pagina successiva della procedura guidata, nell'elenco Selezionare un'operazione fare clic su operazione del servizio Web che riceverà i dati del modulo, quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata, eseguire una delle operazioni seguenti:

    Inviare i dati in un campo o gruppo

    1. Nell'elenco parametri fare clic su un parametro di servizio Web che riceverà i dati del modulo.

    2. Nelle Opzioni del parametro, fare clic su campo o gruppo.

    3. Fare clic su Modifica Icona del pulsante .

    4. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo o gruppo di cui si desidera inviare i dati e quindi fare clic su OK.

    5. Nella casella Includi fare clic su testo ed elementi figlio solo per inviare solo il contenuto e gli elementi figlio del campo o gruppo oppure fare clic su sottostruttura XML, incluso l'elemento selezionato per inviare il contenuto e il gruppo selezionato o campo.

    Inviare tutti i dati del modulo

    1. Fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    Inviare i dati come una stringa

    1. Selezionare la casella di controllo Invia dati come una stringa.

      In genere, si seleziona questa casella di controllo per inviare i dati con firma digitale. Nella maggior parte dei casi, deselezionare questa casella di controllo.

  8. Fare clic su Avanti.

  9. Nella pagina successiva della procedura guidata, nella casella Immettere un nome per la connessione dati digitare un nome descrittivo per questa connessione dati.

  10. Verificare che le informazioni siano corrette nella sezione Sommario e quindi fare clic su Fine.

Aggiungere una connessione dati per inviare dati a una raccolta documenti

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. In connessione guidata dati fare clic su Crea una nuova connessione, fare clic su Invia dati e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, fare clic su in una raccolta documenti in un sito di SharePoint e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, nella finestra di raccolta documenti, digitare il percorso della raccolta documenti di SharePoint.

  6. Nella casella Nome File digitare un nome che verrà utilizzato per identificare il modulo nella raccolta documenti. È anche possibile utilizzare una formula per assicurarsi che ogni nome di modulo sia univoco.

    Procedura

    1. Fare clic su Inserisci Formula Icona del pulsante .

    2. Nella finestra di dialogo Inserisci Formula eseguire una delle operazioni seguenti:

      • Per utilizzare un campo nella formula, fare clic su Inserisci campo o gruppo, fare clic sul campo che si desidera utilizzare nella finestra di dialogo Seleziona campo o gruppo e quindi fare clic su OK.

      • Per utilizzare una funzione nella formula, fare clic su Inserisci funzione, selezionare la funzione che si desidera utilizzare nella finestra di dialogo Inserisci funzione e quindi fare clic su OK.

        Se la funzione richiede parametri, selezionare la funzione nella finestra di dialogo Inserisci funzione, fare clic su OK, quindi nella casella Formula nella finestra di dialogo Inserisci Formula, fare doppio clic sulla funzione che è stato aggiunto e fare clic su un campo o gruppo. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle funzioni.

      • Per inserire un valore o un operatore matematico nella formula, digitare il valore o il simbolo dell'operazione matematica nella casella Formula.

    Operazione

    Simbolo

    Aggiungi

    +

    Sottrarre

    -

    Moltiplicare

    *

    Dividere

    /

    • Nota: Se la formula utilizza l'operatore di divisione (/), assicurarsi che sia presente uno spazio prima e dopo l'operatore di divisione. Se l'operatore di divisione non dispone di uno spazio prima e dopo tale voce, InfoPath possono interpretare "/" come separatore per i passaggi percorso XPath anziché come un operatore di divisione.

    • Per verificare se la formula per la sintassi corretta, nella finestra di dialogo Inserisci Formula, fare clic su Verifica Formula.

      Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle formule.

  7. Per sovrascrivere moduli esistenti con lo stesso nome nella raccolta documenti, selezionare la casella di controllo Sovrascrivi se file esistente.

  8. Fare clic su Avanti.

  9. Nella pagina successiva della procedura guidata, nella casella Immettere un nome per la connessione dati digitare un nome descrittivo per questa connessione dati.

  10. Verificare che le informazioni siano corrette nella sezione Sommario e quindi fare clic su Fine.

Aggiungere una connessione dati che invia i dati in un messaggio di posta elettronica

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. In connessione guidata dati fare clic su Crea una nuova connessione, fare clic su Invia dati e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, fare clic su come messaggio di posta elettronica e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, digitare gli indirizzi di posta elettronica dei destinatari del messaggio, l'oggetto che si desidera venga visualizzato il messaggio e qualsiasi testo introduttivo desiderate nelle caselle appropriate e quindi fare clic su Avanti. È anche possibile utilizzare una formula in ogni casella ad eccezione della casella Introduzione.

    Procedura

    1. Fare clic su Inserisci Formula Icona del pulsante .

    2. Nella finestra di dialogo Inserisci Formula eseguire una delle operazioni seguenti:

      • Per utilizzare un campo nella formula, fare clic su Inserisci campo o gruppo, fare clic sul campo che si desidera utilizzare nella finestra di dialogo Seleziona campo o gruppo e quindi fare clic su OK.

      • Per utilizzare una funzione nella formula, fare clic su Inserisci funzione, selezionare la funzione che si desidera utilizzare nella finestra di dialogo Inserisci funzione e quindi fare clic su OK.

        Se la funzione richiede parametri, selezionare la funzione nella finestra di dialogo Inserisci funzione, fare clic su OK, quindi nella casella Formula nella finestra di dialogo Inserisci Formula, fare doppio clic sulla funzione che è stato aggiunto e fare clic su un campo o gruppo. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle funzioni.

      • Per inserire un valore o un operatore matematico nella formula, digitare il valore o il simbolo dell'operazione matematica nella casella Formula.

    Operazione

    Simbolo

    Aggiungi

    +

    Sottrarre

    -

    Moltiplicare

    *

    Dividere

    /

    • Nota: Se la formula utilizza l'operatore di divisione (/), assicurarsi che sia presente uno spazio prima e dopo l'operatore di divisione. Se l'operatore di divisione non dispone di uno spazio prima e dopo tale voce, InfoPath possono interpretare "/" come separatore per i passaggi percorso XPath anziché come un operatore di divisione.

    • Per verificare se la formula per la sintassi corretta, nella finestra di dialogo Inserisci Formula, fare clic su Verifica Formula.

      Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle formule.

  6. Nella pagina successiva della procedura guidata, eseguire una delle operazioni seguenti:

    1. Per visualizzare il modulo nel corpo del messaggio di posta elettronica, fare clic su Invia solo la visualizzazione attiva del modulo senza allegati.

    2. Per inviare i dati del modulo come allegato al messaggio di posta elettronica, fare clic su Invia i dati del modulo come allegato, selezionare la casella di controllo Connetti il modello di modulo per garantire che gli utenti possono aprire la maschera e quindi digitare un nome per il modulo in nome dell'allegato casella. È anche possibile specificare un campo o utilizzare una formula per verificare che ogni nome maschera sia univoco. Questa opzione è disponibile solo se il modello di modulo configurato per determinare automaticamente il livello di sicurezza o a livello di protezione con restrizioni o attendibilità completa.

      Procedura

      1. Fare clic su Inserisci Formula Icona del pulsante .

      2. Nella finestra di dialogo Inserisci Formula eseguire una delle operazioni seguenti:

        • Per utilizzare un campo nella formula, fare clic su Inserisci campo o gruppo, fare clic sul campo che si desidera utilizzare nella finestra di dialogo Seleziona campo o gruppo e quindi fare clic su OK.

        • Per utilizzare una funzione nella formula, fare clic su Inserisci funzione, selezionare la funzione che si desidera utilizzare nella finestra di dialogo Inserisci funzione e quindi fare clic su OK.

          Se la funzione richiede parametri, selezionare la funzione nella finestra di dialogo Inserisci funzione, fare clic su OK, quindi nella casella Formula nella finestra di dialogo Inserisci Formula, fare doppio clic sulla funzione che è stato aggiunto e fare clic su un campo o gruppo. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle funzioni.

        • Per inserire un valore o un operatore matematico nella formula, digitare il valore o il simbolo dell'operazione matematica nella casella Formula.

      Operazione

      Simbolo

      Aggiungi

      +

      Sottrarre

      -

      Moltiplicare

      *

      Dividere

      /

      • Nota: Se la formula utilizza l'operatore di divisione (/), assicurarsi che sia presente uno spazio prima e dopo l'operatore di divisione. Se l'operatore di divisione non dispone di uno spazio prima e dopo tale voce, InfoPath possono interpretare "/" come separatore per i passaggi percorso XPath anziché come un operatore di divisione.

      • Per verificare se la formula per la sintassi corretta, nella finestra di dialogo Inserisci Formula, fare clic su Verifica Formula.

        Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle formule.

      I destinatari di posta elettronica dei dati del modulo inviato come allegato saranno necessario InfoPath installato sul proprio computer aprire l'allegato.

  7. Fare clic su Avanti.

  8. Nella pagina successiva della procedura guidata, nella casella Immettere un nome per la connessione dati digitare un nome descrittivo per questa connessione dati.

  9. Verificare che le informazioni siano corrette nella sezione Sommario e quindi fare clic su Fine.

Torna all'inizio

Passaggio 2: Configurare il modello di modulo per l'invio

Dopo avere aggiunto le connessioni dati secondaria necessari per il modello di modulo, configurare il modello di modulo per consentire agli utenti di inviare i dati del modulo. Quando si esegue questa operazione, InfoPath aggiunge un comando Invia dal menu File e un pulsante Invia alla barra degli strumenti Standard quando gli utenti compilano il modulo. Configurare l'azione che si verifica quando l'utente fa clic sul pulsante Invia. In questo caso, aggiungere una regola che invia che i dati del modulo a ogni connessione dati quando l'utente fa clic sul pulsante Invia nella barra degli strumenti Standard o il comando Invia del menu File.

Nella stessa finestra di dialogo, è possibile configurare le opzioni di invio.

  1. Dal menu Strumenti fare clic su Opzioni invio.

  2. Nella finestra di dialogo Opzioni invio, selezionare la casella di controllo Consenti agli utenti di inviare il modulo.

    Quando si seleziona questa casella di controllo, InfoPath viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia dal menu File, quando gli utenti compilano il modulo.

  3. Fare clic su Esegui azione personalizzata tramite le regole e quindi fare clic su regole.

  4. Nella finestra di dialogo regole per l'invio di moduli, fare clic su Aggiungi.

  5. Fare clic su Aggiungi azione.

  6. Nella casella dell'azione, fare clic su Invia tramite una connessione dati, fare clic sulla connessione dati che si desidera utilizzare per l'invio nella casella connessione dati e quindi fare clic su OK.

  7. Ripetere i passaggi 5 e 6 per ogni connessione dati che sono stati aggiunti al modello di modulo.

  8. Dopo avere aggiunto le condizioni per tutte le connessioni dati Invia nel modello di modulo, fare clic su OK due volte.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella etichettaInvia Opzioni nella finestra di dialogo.

      Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  9. Per impedire agli utenti di utilizzare il comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×