Inserire una tabella layout

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

In questo articolo

Introduzione alle tabelle layout

Inserire una tabella layout predefinita

Inserire una tabella layout personalizzata con dimensioni specifiche

Disegnare una tabella layout personalizzata

Formattare automaticamente i controlli all'interno di una tabella layout

Introduzione alle tabelle layout

Le tabelle layout consentono di progettare modelli di modulo dall'aspetto più organizzato e professionale. Una tabella layout è un contenitore che include righe e colonne per l'organizzazione e la disposizione del contenuto del modello di modulo, inclusi i controlli, le sezioni di un modello di modulo, loghi e altri tipi di grafica.

Nell'esempio seguente una tabella layout viene utilizzata per organizzare le caselle di testo all'interno di una sezione del modello di modulo.

Sezione interna di una tabella layout in un modello di modulo

1. Questa tabella layout contiene due righe.

2. Nella seconda riga sono presenti tre colonne. La colonna centrale viene utilizzata solo per scopi di spaziatura.

In modalità progettazione i bordi della tabella layout vengono visualizzati come una griglia tratteggiata. Tale griglia non è visibile nel modulo basato sul modello di modulo durante la compilazione.

Suggerimento : Per nascondere la griglia anche in modalità progettazione, fare clic su Nascondi griglia nel menu Tabella.

Nel riquadro attività Layout è disponibile una raccolta di tabelle layout preconfigurate che è possibile inserire nel modello di modulo e modificare in base alle specifiche esigenze. Ad esempio, fare clic su Tabella con tre colonne per inserire rapidamente nel modello di modulo una tabella vuota composta da una riga e tre colonne. Se si desidera aggiungere un'ulteriore riga alla tabella, fare clic in una cella della tabella nel modello di modulo e quindi selezionare Aggiungi riga nel riquadro attività Layout.

Se si preferisce creare una propria tabella layout, è possibile inserire una tabella layout personalizzata composta da un numero specifico di righe e colonne. È inoltre possibile disegnare una tabella layout personalizzata, un'alternativa utile per creare layout più complessi. Ad esempio, è possibile creare una tabella layout contenente celle di altezza diversa o un numero variabile di colonne per ogni riga.

Inizio pagina

Inserire una tabella layout predefinita

  1. Nel modello di modulo, posizionare il cursore nel punto in cui si desidera inserire la tabella layout.

  2. Scegliere Layout dal menu Formato.

  3. Nell'elenco Inserisci tabelle layout del riquadro attività Layout fare clic sul tipo di tabella layout desiderato.

  4. Per aggiungere ulteriori righe e colonne alla tabella, fare clic in una cella della tabella nel modello di modulo e quindi selezionare le opzioni desiderate nell'elenco Unisci e dividi celle.

    Suggerimento : Per eliminare righe, colonne o l'intera tabella, fare clic con il pulsante destro del mouse in qualsiasi punto della tabella, scegliere Elimina e quindi fare clic sull'opzione desiderata.

Inizio pagina

Inserire una tabella layout personalizzata con dimensioni specifiche

  1. Nel modello di modulo, posizionare il cursore nel punto in cui si desidera inserire la tabella layout.

  2. Fare clic su Inserisci nella barra degli strumenti Tabelle e quindi fare clic su Tabella layout.

  3. Nella finestra di dialogo Inserisci tabella immettere il numero di righe e colonne desiderato per la tabella.

Inizio pagina

Disegnare una tabella layout personalizzata

  1. Nel modello di modulo posizionare il cursore nel punto in cui si desidera disegnare la tabella layout.

  2. Fare clic su Disegna tabella nella barra degli strumenti Tabelle.

    Il puntatore assume la forma di una matita.

  3. Per definire i bordi esterni della tabella, disegnare un rettangolo nel modello di modulo. Disegnare quindi i bordi delle colonne e delle righe all'interno di tale rettangolo.

    Disegnare una tabella

  4. Per cancellare una linea o un blocco di righe, fare clic su Gomma Icona del pulsante sulla barra degli strumenti tabelle, quindi fare clic e trascinare la gomma lungo la riga che si desidera cancellare.

Inizio pagina

Formattare automaticamente i controlli all'interno di una tabella layout

È possibile utilizzare il riquadro attività controlli o il riquadro attività Origine dati per inserire i controlli nel modello di modulo. Se si utilizza il riquadro attività Origine dati per inserire i controlli, è possibile utilizzare un collegamento che consente di inserire istantaneamente i controlli e le etichette corrispondenti all'interno di una tabella layout in una sezione. Il collegamento funziona meglio durante la progettazione di un modello di modulo basato su un database, servizio Web o altra origine dati esterna e si desidera inserire un gruppo non ripetuto dall'origine dati. Controlli, ad esempio le sezioni e le sezioni facoltative sono associati ai gruppi non ripetuti.

Nell'immagine seguente viene illustrata la selezione di un gruppo employee nel riquadro attività Origine dati e del comando Controlli nella tabella layout nel menu di scelta rapida.

Aggiunta di controlli mediante il comando Controlli nella tabella layout

1. Quando si fa clic sulla freccia accanto al gruppo employee, viene visualizzato un menu con opzioni per l'inserimento di controlli. Per inserire controlli in una tabella layout, fare clic su Controlli nella tabella layout nel menu.

2. Ogni campo del gruppo employee viene rappresentato chiaramente da un controllo e da una corrispondente etichetta nel modello di modulo. Le etichette dei controlli derivano dai nomi di campo o gruppo nell'origine dati.

  1. Se il riquadro attività Origine dati non è visibile, fare clic su Origine dati dal menu Visualizza.

  2. Nel riquadro attività Origine dati selezionare un gruppo non ripetuto contenente uno o più campi.

    Nota : Se si seleziona per errore un gruppo ripetuto, nel menu di scelta rapida verrà visualizzato un insieme diverso di comandi.

  3. Fare clic con il pulsante destro del mouse sul gruppo e quindi scegliere Controlli nella tabella layout dal menu di scelta rapida.

    In Microsoft Office InfoPath viene inserita all'istante una tabella layout nel modello di modulo, contenente i controlli e le etichette per ogni campo del gruppo selezionato. Il tipo di controllo da aggiungere viene determinato automaticamente in base al tipo di dati del campo o del gruppo. Ad esempio, se nei singoli campi di un gruppo viene utilizzato il tipo di dati Testo (stringa), in InfoPath vengono aggiunti controlli casella di testo nelle celle della tabella.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×