Inserire automaticamente il testo

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

In Word è possibile inserire automaticamente il testo con i blocchi di testo preformattato della raccolta di glossario oppure con parole, frasi o frasi che Word completa automaticamente dopo aver digitato solo pochi caratteri.

Nota: Se si cercano informazioni sulle impostazioni di formattazione automatica, ad esempio il formato automatico di trattini e trattini, frazioni, collegamenti ipertestuali, virgolette e elenchi puntati o numerati, vedere configurare o disattivare la formattazione automatica del testo.

Le voci di glossario vengono archiviate come blocchi predefiniti. Per creare una nuova voce, utilizzare la finestra di dialogo Crea nuovo blocco predefinito.

  1. Nel documento selezionare il testo che si desidera aggiungere alla raccolta delle voci di glossario.

  2. Nel gruppo Testo della scheda Inserisci fare clic su Parti rapide, scegliere Glossario e quindi fare clic su Salva selezione nella raccolta voci di glossario

  3. Compilare le informazioni richieste nella finestra di dialogo Crea nuovo blocco predefinito: La maggior parte dei valori predefiniti non deve essere modificata, ma aggiungendo un nome univoco e una descrizione il glossario risulterà più facile da usare.

    Finestra di dialogo Crea nuovo blocco predefinito

    • Nome    Digitare un nome univoco per il blocco predefinito del glossario.

    • Raccolta    Selezionare la raccolta Glossario.

    • Categoria    Selezionare la categoria Generale o crearne una nuova.

    • Descrizione    Digitare una descrizione per il blocco predefinito.

    • Salva in    Fare clic sul nome del modello nell'elenco a discesa. Ad esempio, fare clic su Normal.

      È necessario che il modello sia aperto, affinché il relativo nome sia disponibile in questo elenco.

    • Opzioni    Scegliere una delle opzioni seguenti:

      • Selezionare Inserisci contenuto nella relativa pagina per posizionare il blocco predefinito in una pagina distinta, separata dal resto del contenuto con interruzioni di pagina.

      • Selezionare Inserisci contenuto nel relativo paragrafo per posizionare il contenuto nel relativo paragrafo, anche se il cursore dell'utente si trova all'interno di un paragrafo.

      • Selezionare Inserisci solo contenuto per tutto il resto del contenuto.

Inizio pagina

  1. Nella scheda Inserisci fare clic su Parti rapide e quindi scegliere Glossario.

  2. Fare clic sulla voce che si desidera aggiungere.

Aggiungendo le voci di testo nella finestra di dialogo Correzione automatica, è possibile configurare Word in modo da completare automaticamente una parola, una frase o una frase dopo aver digitato solo pochi caratteri.

  1. Selezionare il testo da inserire automaticamente.

  2. Fare clic sulla scheda File.

  3. Fare clic su Opzioni.

  4. Fare clic su Strumenti di correzione.

  5. Fare clic su Opzioni correzione automatica e quindi sulla scheda Correzione automatica.

    finestra di dialogo correzione automatica

  6. Selezionare la casella di controllo Sostituisci il testo durante la digitazione, se non è già selezionata.

  7. Nella casella Sostituisci digitare i caratteri che si desidera usare per il testo automatico. Il testo selezionato nel documento dovrebbe essere visualizzato sotto Con.

L'Elenco correzione automatica è globalmente valido per tutte le applicazioni di Office che supportano questa caratteristica. L'aggiunta o l'eliminazione di una parola dall'elenco in un'applicazione, avrà quindi effetto anche sulle altre applicazioni di Office.

Nota: L'elenco Correzione automatica in Word è limitato a un totale di circa 64.000 voci.

Inizio pagina

Durante la digitazione nel documento, il testo nella colonna sinistra dell'elenco Correzione automatica, in Sostituisci, viene sostituito automaticamente con il testo nella colonna destra, in with.

Inizio pagina

Vedere anche

Configurare o disattivare la formattazione automatica del testo

Scegliere le opzioni di correzione automatica per la correzione delle maiuscole, il controllo ortografia e i simboli

  1. Nella scheda Inserisci fare clic su Parti rapide e quindi scegliere Glossario.

  2. Fare clic sulla voce che si desidera aggiungere.

In Word 2010 le voci di glossario vengono archiviate come blocchi predefiniti. Per creare una nuova voce, usare la finestra di dialogo Crea nuovo blocco predefinito.

  1. Nel documento di Word selezionare il testo che si desidera aggiungere alla raccolta di voci di glossario.

  2. Nel gruppo Testo della scheda Inserisci fare clic su Parti rapide, scegliere Glossario e quindi fare clic su Salva selezione nella raccolta voci di glossario

  3. Compilare le informazioni richieste nella finestra di dialogo Crea nuovo blocco predefinito:

    • Nome    Digitare un nome univoco per il blocco predefinito del glossario.

    • Raccolta    Selezionare la raccolta Glossario.

    • Categoria    Selezionare la categoria Generale o crearne una nuova.

    • Descrizione    Digitare una descrizione per il blocco predefinito.

    • Salva in    Fare clic sul nome del modello nell'elenco a discesa. Ad esempio, fare clic su Normal.

      È necessario che il modello sia aperto, affinché il relativo nome sia disponibile in questo elenco.

    • Opzioni    Scegliere una delle opzioni seguenti:

      • Selezionare Inserisci contenuto nella relativa pagina per posizionare il blocco predefinito in una pagina distinta con interruzioni di pagina prima e dopo il blocco.

      • Selezionare Inserisci contenuto nel relativo paragrafo per posizionare il contenuto nel relativo paragrafo, anche se il cursore dell'utente si trova all'interno di un paragrafo.

      • Selezionare Inserisci solo contenuto per tutto il resto del contenuto.

Inizio pagina

Se sono state usate voci di glossario in Microsoft Office Word 2003, è possibile eseguirne manualmente la migrazione in Word 2010. Le voci di glossario create in Word 2007 vengono migrate automaticamente.

  1. Passare al file Normal11. dot eseguendo una delle operazioni seguenti:

  2. Se il computer è in uso in Windows 7    Aprire Esplora risorse e passare a C:\Utenti\nome name\AppData\Roaming\Microsoft\Templates.

    Nota: Se la cartella AppData non è visibile in Esplora risorse, fare clic su organizza, fare clic su Opzioni cartella e ricerca, fare clic sulla scheda Visualizza e quindi su Mostra file, cartelle e unità nascoste. Chiudere e riaprire Windows Explorer.

  3. Se il computer è in uso in Windows Vista    Aprire Esplora risorse e passare a C:\Utenti\nome name\AppData\Roaming\Microsoft\Templates.

    Nota: Se la cartella AppData non è visibile in Esplora risorse, fare clic su organizza, fare clic su Opzioni cartella e ricerca, fare clic sulla scheda Visualizza e quindi su Mostra file, cartelle e unità nascoste. Chiudere e riaprire Windows Explorer.

  4. Se il computer è in uso in Windows XP    Aprire Esplora risorse e quindi passare a C:\Documents and Settings\nome Utente\dati Applicazioni\microsoft\modelli.

    Nota: Se la cartella dati applicazione non è visibile in Esplora risorse, fare clic sul menustrumenti, fare clic su Opzioni cartella, fare clic sulla scheda Visualizza e quindi su Mostra file e cartelle nascosti. Chiudere e riaprire Windows Explorer.

  5. Fare clic con il pulsante destro del mouse su Normal11. dot e quindi scegliere Apri.

  6. Fare clic sulla scheda File.

  7. Fare clic su Salva con nome.

  8. Nella finestra di dialogo Salva con nome passare al percorso corretto:

  9. Se il computer è in uso in Windows 7    C:\Utenti\nome name\AppData\Roaming\Microsoft\Word\Startup

  10. Se il computer è in uso in Windows Vista    C:\Utenti\nome name\AppData\Roaming\Microsoft\Word\Startup

  11. Se il computer è in uso in Windows XP    C:\Documents and Settings\nome Utente\dati Applicazioni\microsoft\word\startup

    Nota: Potrebbe essere necessario creare la cartella di avvio facendo clic su nuova cartella.

  12. Nella casella nome file Digitare Glossario.

  13. Nell'elenco tipo Salva con nome fare clic su modello di Word con attivazione macro.

  14. Fare clic su Salva.

    Se richiesto, fare clic su OK.

  15. Uscire da Word.

Inizio pagina

Per aggiungere voci di testo inserite automaticamente quando si digita un set di caratteri specifico, è necessario usare la finestra di dialogo Correzione automatica.

  1. Fare clic sulla schedaFile.

  2. Fare clic su Opzioni.

  3. Fare clic su Strumenti di correzione.

  4. Fare clic su Opzioni correzione automatica e quindi sulla scheda Correzione automatica.

  5. Selezionare la casella di controllo Sostituisci il testo durante la digitazione, se non è già selezionata.

  6. Nella casella Sostituisci digitare i caratteri che si desidera utilizzare per il testo automatico.

Il testo selezionato nel documento sarà visualizzato nella casella Con.

Nota: L'elenco Correzione automatica in Word è limitato a un totale di circa 64.000 voci.

Inizio pagina

In Microsoft Office Word 2007 è possibile aggiungere voci di glossario nella raccolta Glossario.

In alternativa, se si vuole aggiungere testo automaticamente quando si digita un numero di caratteri, è possibile aggiungere voci di testo nella finestra di dialogo Correzione automatica.

Per aggiungere il glossario dalla raccolta, è necessario aggiungere la raccolta alla barra di accesso rapido. Dopo averlo aggiunto, è possibile creare nuove voci ed è possibile eseguire la migrazione delle voci da Word 2003 alla raccolta.

  1. Fare clic sul pulsante Microsoft Office icona del pulsante e quindi su Opzioni di Word.

  2. Fai clic su Personalizza.

  3. Nell'elenco in Scegli comandi da fare clic su tutti i comandi.

  4. Scorrere l'elenco dei comandi finché non viene visualizzato AutoText.

  5. Fare clic su Glossario e quindi su Aggiungi.

Il pulsante Glossario ora viene visualizzato nella barra di accesso rapido. Fare clic su glossario per scegliere una raccolta di voci di glossario.

Inizio pagina

  1. Nel documento di Word selezionare il testo che si desidera aggiungere alla raccolta di voci di glossario.

  2. Sulla barra di accesso rapido fare clic su Glossario e quindi su Salva selezione in raccolta Glossario.

  3. Compilare le informazioni richieste nella finestra di dialogo Crea nuovo blocco predefinito:

    • Nome     Digitare un nome univoco per il blocco predefinito.

    • Raccolta     Selezionare la raccolta in cui si vuole visualizzare il blocco predefinito.

    • Categoria     Selezionare una categoria, come Generale o Predefinita, oppure crearne una nuova.

    • Descrizione     Digitare una descrizione per il blocco predefinito.

    • Salva in     Fare clic sul nome del modello nell'elenco a discesa.

    • È necessario che il modello sia aperto, affinché il relativo nome sia disponibile in questo elenco.

    • Opzioni     Scegliere una delle opzioni seguenti:

      • Selezionare Inserisci contenuto nella relativa pagina per posizionare il blocco predefinito in una pagina distinta con interruzioni di pagina prima e dopo il blocco.

      • Selezionare Inserisci contenuto nel relativo paragrafo per posizionare il contenuto nel relativo paragrafo, anche se il cursore dell'utente si trova all'interno di un paragrafo.

      • Selezionare Inserisci solo contenuto per tutto il resto del contenuto.

Per informazioni sull'uso della raccolta blocchi predefiniti per la creazione e la gestione delle voci di glossario, vedere usare le parti rapide e il glossario in Word.

Se sono state usate voci di glossario in Microsoft Office Word 2003, è possibile eseguirne manualmente la migrazione in Word 2007.

  1. Copiare il file Normal11. dot nella cartella dei blocchi predefiniti del documento eseguendo una delle operazioni seguenti:

    • Se il computer è in uso in Windows Vista     Aprire Esplora risorse e quindi copiare il modello Normal11. dot da C:\Utenti\nome name\AppData\Roaming\Microsoft\Templates ai blocchi predefiniti di C:\Utenti\nome name\AppData\Roaming\Microsoft\Document.

    • Se il computer è in uso in Windows XP     Aprire Esplora risorse e quindi copiare il modello Normal11. dot da C:\Documents and Settings\nome Utente\dati Applicazioni\microsoft\modelli in C:\Documents and Settings\nome utente\Dati Data\Microsoft\Document Building Blocks.

  2. In Office Word 2007 aprire il modello Normal11. dot.

  3. Salvare il file come Glossario. dotx.

    Quando richiesto, fare clic su continua.

    1. Fare clic sul pulsante Microsoft Office icona del pulsante e quindi su Converti.

Quando richiesto, fare clic su OK.

Il file viene potenziato nel nuovo formato di file.

  1. Nel gruppo testo della scheda Inserisci fare clic su parti rapide e quindi su raccolta blocchi predefiniti.

  2. In Organizer blocchi predefiniti selezionare una voce di glossario, fare clic su modifica proprietà e quindi selezionare la raccolta appropriata nell'elenco raccolta.

  3. Nell'elenco Salva in fare clic su Normal. dotm e quindi fare clic su OK.

  4. Ripetere la procedura per ogni voce di glossario che si vuole usare in Office Word 2007.

Per aggiungere voci di testo inserite automaticamente quando si digita un set di caratteri specifico, è necessario usare la finestra di dialogo Correzione automatica.

  1. In Word 2007, documento, selezionare il testo che si desidera aggiungere automaticamente.

  2. Fare clic sul pulsante Microsoft Office icona del pulsante e quindi su Opzioni di Word.

  3. Fare clic su Strumenti di correzione.

  4. Fare clic su Opzioni correzione automatica e quindi sulla scheda correzione automatica.

  5. Selezionare la casella di controllo Sostituisci il testo durante la digitazione, se non è già selezionata.

  6. Nella casella Sostituisci digitare i caratteri che si desidera utilizzare per il testo automatico.

    Il testo selezionato nel documento sarà visualizzato nella casella Con.

Nota: L'elenco Correzione automatica in Word è limitato a un totale di circa 64.000 voci.

Inizio pagina

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×