INDICE (funzione INDICE)

La funzione INDICE restituisce un valore o il riferimento a un valore da una tabella o un intervallo.

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

La funzione INDICE può essere usata in due modi:

  • Se si vuole restituire il valore di una cella o di una matrice di celle specificata, vedere Matrice.

  • Se si vuole restituire un riferimento alle celle specificate, vedere Riferimento.

Matrice

Descrizione

Restituisce il valore di un elemento in una tabella o in una matrice, selezionato dagli indici di numero di riga e colonna.

Usare la forma per matrice se il primo argomento della funzione INDICE è una costante di matrice.

Sintassi

INDICE(matrice; riga; [col])

La forma matrice della funzione indice contiene gli argomenti seguenti:

  • matrice    Obbligatorio. Intervallo di celle o costante di matrice.

    • Se matrice contiene solo una riga o colonna, l'argomento riga o col corrispondente è facoltativo.

    • Se matrice contiene più di una riga e più di una colonna e solo riga o col viene usato, INDEX restituisce una matrice dell'intera riga o colonna in matrice.

  • riga    Obbligatorio. Seleziona la riga nella matrice da cui restituire un valore. Se riga viene omesso, col è obbligatorio.

  • col    Facoltativo. Seleziona la colonna nella matrice da cui restituire un valore. Se col viene omesso, riga è obbligatorio.

Osservazioni

  • Se vengono usati entrambi gli argomenti riga e col, INDEX restituisce il valore nella cella all'intersezione di riga e col.

  • riga e col devono puntare a una cella all'interno di una matrice; in caso contrario, INDEX restituisce un #REF. .

  • Se si imposta riga o col su 0 (zero), INDEX restituirà rispettivamente la matrice di valori per l'intera colonna o riga. Per usare i valori restituiti come matrice, immettere la funzione indice come formula in forma di matrice.

    Nota: Se si ha una versione corrente di Office 365, è possibile immettere la formula nella cella superiore sinistra dell'intervallo di output, quindi premere invio per confermare la formula come formula in forma di matrice dinamica. In caso contrario, la formula deve essere immessa come formula di matrice legacy selezionando dapprima l'intervallo di output, inserendo la formula nella cella superiore sinistra dell'intervallo di output, quindi premere CTRL + MAIUSC + INVIO per confermarla. Excel inserisce le parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule in forma di matrice: indicazioni ed esempi.

Esempi

Esempio 1

In questi esempi la funzione INDICE viene utilizzata per trovare il valore nella cella di intersezione dove si incontrano una riga e una colonna.

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO.

Dati

Dati

Mele

Limoni

Banane

Pere

Formula

Descrizione

Risultato

=INDICE(A2:B3;2;2)

Valore all'intersezione della seconda riga e della seconda colonna nell'intervallo A2:B3.

Pere

=INDICE(A2:B3;2;1)

Valore all'intersezione della seconda riga e della prima colonna nell'intervallo A2:B3.

Banane

Esempio 2

In questo esempio si utilizza la funzione INDICE in una formula in forma di matrice per trovare i valori in due celle specificate in una matrice 2x2.  

Nota: Se si ha una versione corrente di Office 365, è possibile immettere la formula nella cella superiore sinistra dell'intervallo di output, quindi premere invio per confermare la formula come formula in forma di matrice dinamica. In caso contrario, la formula deve essere immessa come formula di matrice legacy selezionando prima di tutto due celle vuote, immettere la formula nella cella superiore sinistra dell'intervallo di output, quindi premere CTRL + MAIUSC + INVIO per confermarla. Excel inserisce le parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule in forma di matrice: indicazioni ed esempi.

Formula

Descrizione

Risultato

=INDICE({1;2;3;4};0;2)

Valore trovato nella prima riga, seconda colonna della matrice. La matrice contiene 1 e 2 nella prima riga e 3 e 4 nella seconda riga.

2

Valore trovato nella seconda riga, seconda colonna della matrice (matrice identica a quella dell'esempio precedente).

4

Inizio pagina


Modulo di riferimento

Descrizione

Restituisce il riferimento della cella all'intersezione di una particolare riga e colonna. Se il riferimento è costituito da selezioni non adiacenti, è possibile selezionare la selezione in cui cercare.

Sintassi

INDICE(rif; riga; [col]; [area])

Il modulo di riferimento della funzione indice contiene gli argomenti seguenti:

  • riferimento    Obbligatorio. Riferimento a uno o più intervalli di celle.

    • Se si immette un intervallo non adiacente per il riferimento, racchiudere il riferimento tra parentesi.

    • Se ogni area di riferimento contiene solo una riga o una colonna, l'argomento riga o col, rispettivamente, è facoltativo. Ad esempio, per un riferimento a una singola riga, utilizzare INDICE(rif;;col).

  • riga    Obbligatorio. Numero della riga in rif dal quale si desidera restituire un riferimento.

  • col    Facoltativo. Numero della colonna in rif dal quale si desidera restituire un riferimento.

  • area    Facoltativo. Seleziona un intervallo in riferimento da cui restituire l'intersezione di riga e col. La prima area selezionata o immessa viene contrassegnata dal numero 1, la seconda dal numero 2 e così via. Se area viene omesso, INDEX utilizzerà l'area 1.  Le aree elencate qui devono essere tutte nello stesso foglio.  Se si specificano aree che non si trovano nello stesso foglio, verrà generato un errore #VALORE!.  Se occorre usare intervalli che si trovano in fogli diversi, è consigliabile usare il formato di matrice della funzione INDICE e usare un'altra funzione per calcolare l'intervallo che costituisce la matrice.  Ad esempio, si potrebbe usare la funzione SCEGLI per calcolare l'intervallo che verrà usato.

Ad esempio, se il riferimento descrive le celle (a1: B4, D1: E4, G1: H4), area 1 è l'intervallo a1: B4, area 2 è l'intervallo D1: E4 e area 3 è l'intervallo G1: H4.

Osservazioni

  • Dopo il riferimento e area hanno selezionato un determinato intervallo, riga e col selezionare una cella specifica: riga 1 è la prima riga dell'intervallo, col 1 è la prima colonna e così via. Il riferimento restituito da INDEX è l'intersezione di riga e col.

  • Se si imposta riga o col su 0 (zero), INDEX restituirà rispettivamente il riferimento per l'intera colonna o riga.

  • riga, col e area devono puntare a una cella all'interno di riferimento; in caso contrario, INDEX restituisce un #REF. . Se riga e col vengono omessi, INDEX restituisce l'area in riferimento specificata da area.

  • Il risultato della funzione INDICE è un riferimento e viene interpretato come tale dalle altre formule. A seconda della formula, il valore restituito da INDICE può essere utilizzato come riferimento o come valore. Ad esempio, la formula CELLA("larghezza";INDICE(A1:B2;1;2)) è uguale a CELLA("larghezza";B1). La funzione CELLA utilizza il valore restituito da INDICE come riferimento di cella. D'altro lato, una formula come 2*INDICE(A1:B2;1;2) traduce il valore restituito da INDICE nel numero della cella B1.

Esempi

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO.

Frutta

Prezzo

Numero

Mele

€ 0,69

40

Banane

€ 0,34

38

Limoni

€ 0,55

15

Arance

€ 0,25

25

Pere

€ 0,59

40

Mandorle

€ 2,80

10

Anacardi

€ 3,55

16

Arachidi

€ 1,25

20

Noci

€ 1,75

12

Formula

Descrizione

Risultato

=INDICE(A2:C6; 2; 3)

L'intersezione della seconda riga e della terza colonna nell'intervallo A2:C6, ossia il contenuto della cella C3.

38

=INDICE((A1:C6; A8:C11); 2; 2; 2)

L'intersezione della seconda riga e della seconda colonna nella seconda area di A8:C11, ossia il contenuto della cella B9.

1,25

=SOMMA(INDICE(A1:C11; 0; 3; 1))

La somma della terza colonna nella prima area dell'intervallo A1:C11, ossia la somma di C1:C11.

216

=SOMMA(B2:INDICE(A2:C6; 5; 2))

La somma dell'intervallo che ha inizio in B2 e termina all'intersezione della quinta riga e della seconda colonna dell'intervallo A2:A6, ossia la somma di B2:B6.

2,42

Inizio pagina

Vedere anche

CERCA.VERT

CONFRONTA

INDIRETTO (funzione INDIRETTO)

Formule in forma di matrice: indicazioni ed esempi

Funzioni di ricerca e di riferimento (riferimento)

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×