Importare o copiare l'elenco di completamento automatico in un altro computer

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

L'elenco completamento automatico è una caratteristica che vengono visualizzati i suggerimenti per i nomi e indirizzi di posta elettronica quando si inizia a digitarli. Questi suggerimenti sono possibili corrispondenze da un elenco di nomi e indirizzi di posta elettronica dai messaggi di posta elettronica inviati.

Elenco di completamento automatico

Il metodo per copiare l'elenco di completamento automatico da un computer a altro dipende dal tipo di account di posta elettronica è stato aggiunto a Outlook. Se si dispone di un account Office 365, account di Exchange Server o un account IMAP (è il tipo più comune di altri account di posta elettronica), l'elenco completamento automatico verrà archiviato come file nascosto in un File di dati di Outlook. Per istruzioni, vedere copiare l'elenco di completamento automatico .

Se si dispone di un account POP3 (meno comuni, ma spesso usati per i provider di posta elettronica di terze parti come Comcast, Earthlink e Verizon), l'elenco di completamento automatico verrà archiviato in un file archiviato nel computer in uso. Vedere Copia e importare un file nk2.

Se non si conosce il tipo di account si dispone, selezionare File > Impostazioni Account > Impostazioni Account. È possibile trovare il tipo di account.

Copiare l'elenco di completamento automatico

Passaggio 1: Esportare il messaggio di cassette postali di completamento automatico

  1. Uscire da Outlook e quindi chiudere Outlook Web Access o Outlook Web App (OWA) in tutte le workstation connessi alla cassetta postale.

  2. Scaricare e installare MFCMAPI http://mfcmapi.codeplex.com.

  3. Eseguire mfcmapi.exe.

  4. Nel menu sessione fare clic su accesso.

  5. Se viene richiesto per un profilo, selezionare il nome del profilo desiderato e quindi fare clic su OK.

  6. Nel riquadro in alto, individuare la riga che corrisponde alla propria cassetta postale e quindi fare doppio clic su esso.

  7. Nel riquadro di spostamento sinistro, espandere Contenitore principale e quindi espandere Parte superiore dell'archivio informazioni o IPM_SUBTREE.

  8. Pulsante destro del mouse sulla cartella posta in arrivo e quindi fare clic su Apri tabella contenuto associato. Questa azione verrà visualizzata una nuova finestra MFCMAPI contenente diverse proprietà.

  9. Nella colonna oggetto rapida l'elemento con l'oggetto IPM. Configuration.Autocomplete e quindi fare clic su Esporta messaggio. Questa azione apre la finestra Salva messaggio al File.

  10. Nell'elenco a discesa selezionare il file MSG (UNICODE) e quindi fare clic su OK.

  11. Selezionare un percorso della cartella in cui si desidera salvare il messaggio e quindi fare clic su Salva. Prendere nota del percorso.

Passaggio 2: Importare il messaggio di cassette postali di completamento automatico

  1. Uscire da Outlook e quindi chiudere Outlook Web Access o Outlook Web App (OWA) in tutte le workstation connessi alla cassetta postale.

  2. Scaricare e installare MFCMAPI http://mfcmapi.codeplex.com.

  3. Eseguire mfcmapi.exe.

  4. Nel menu sessione fare clic su accesso.

  5. Se viene richiesto per un profilo, selezionare il nome del profilo desiderato e quindi fare clic su OK.

  6. Nel riquadro in alto, individuare la riga che corrisponde alla propria cassetta postale e quindi fare doppio clic su esso.

  7. Nel riquadro di spostamento sinistro, espandere Contenitore principale e quindi espandere Parte superiore dell'archivio informazioni o IPM_SUBTREE.

  8. Pulsante destro del mouse sulla cartella posta in arrivo e quindi fare clic su Apri tabella contenuto associato. Questa azione verrà visualizzata una nuova finestra MFCMAPI contenente diverse proprietà.

  9. Per evitare le voci duplicate, è necessario eliminare il messaggio di completamento automatico esistente.

    Nota: Prima di eliminare il IPM. Messaggio Configuration.Autocomplete, è necessario esportare il messaggio utilizzando la procedura descritta nella sezione "Come esportare la cache di completamento automatico".

    Per eliminare il messaggio di completamento automatico esistente, procedere come segue:

    1. Nella colonna oggetto individuare l'elemento con l'oggetto IPM. Configuration.Autocomplete.

    2. Pulsante destro del mouse sull'elemento e quindi fare clic su Elimina messaggio. Verrà aperta la finestra Elimina elemento.

    3. Nell'elenco a discesa selezionare l'eliminazione permanente (Elimina per il mantenimento degli elementi eliminati se supportato) e quindi fare clic su OK.

  10. Nel menu cartella, fare clic su Importa e quindi fare clic su da MSG.

  11. Individuare il file con estensione msg creato nel passaggio 11 della "Esporta il messaggio di completamento automatico della cassetta postale" sopra e quindi fare clic su OK.

  12. Nella finestra Carico MSG che viene visualizzato, selezionare Carica messaggio nella cartella corrente nell'elenco stile carica e quindi fare clic su OK.

Le informazioni di completamento automatico vengono importate dal IPM. Configuration.Autocomplete_ <codici esadecimali> con estensione msg, in cui il segnaposto <codici esadecimali> rappresenta una lunga stringa di numeri e lettere.

Coy e importare un file nk2

Passaggio 1: Copiare il file di completamento automatico dal vecchio computer

  1. Perché la cartella predefinita è nascosto, usare il comando %APPDATA%\Microsoft\Outlook nel Windows casella di ricerca (o, passare al C:\Users\username\AppData\Roaming\Microsoft\Outlook) è il modo più semplice per aprire la cartella.

  2. Nella cartella di Outlook, individuare il file di elenco di completamento automatico (. nk2).

    Nota: Per impostazione predefinita, le estensioni di file sono nascoste di Windows. Per modificare l'impostazione vengono visualizzate le estensioni di file, nella finestra Esplora dal menu Strumenti (in Windows 7 o Windows Vista, premere il tasto ALT per visualizzare il menu Strumenti ), fare clic su Opzioni cartella. Nella scheda Visualizza selezionare o deselezionare la casella di controllo Nascondi le estensioni per i tipi di file conosciuti.

  3. Copiare il file nel nuovo computer. Il file è piccolo e può essere inserito in un supporto rimovibile, ad esempio una memory stick USB.

Passaggio 2: Copiare il file di completamento automatico nel nuovo computer

  1. Nel nuovo computer nel Pannello di controllo, fare clic o doppio clic su posta.

    Posta elettronica viene visualizzata in un'altra posizione del Pannello di controllo in base alla versione del sistema operativo Microsoft Windows, la visualizzazione del Pannello di controllo è selezionata, e se è installata una versione di Outlook 2010 o il sistema operativo 32 o 64 bit.

    Il modo più semplice per individuare Posta elettronica consiste nell'aprire il Pannello di controllo in Windows e quindi digitare Posta elettronica nella casella Cerca nella parte superiore della finestra. Nel Pannello di controllo in Windows XP digitare Posta elettronica nella casella Indirizzo.

    Nota: L'icona Posta elettronica viene visualizzata dopo il primo avvio di Outlook.

  2. Fare clic su Mostra profili.

  3. Prendere nota del nome del profilo. È necessario modificare il nome del file nk2 in modo che corrisponda al nome in un secondo momento.

  4. Copiare il file nk2 nel nuovo computer la cartella in Outlook vengono salvate configurazioni. Perché la cartella predefinita è nascosto, usare il comando %APPDATA%\Microsoft\Outlook nel Windows casella di ricerca (o, passare al C:\Users\username\AppData\Roaming\Microsoft\Outlook) è il modo più semplice per aprire la cartella.

  5. Dopo il file è ricevere nella cartella, pulsante destro del mouse sul file, fare clic su Rinomina e modificare il nome in modo che corrispondano il nome del profilo che erano presenti nel passaggio 3.

Passaggio 3: Importare l'elenco di completamento automatico

A questo punto si è pronti avviare Outlook e importare il file, ma è necessario avviare Outlook con un comando copia unico speciale.

  • Digitare outlook /importnk2 nella finestra di Windows Search e quindi premere INVIO.

L'elenco di completamento automatico dovrebbe ora essere le voci da altri computer quando si scrive un messaggio e iniziare a digitare nelle caselle a, Cc o Ccn.

Torna all'inizio

In Outlook 2007, è possibile copiare i nomi e indirizzi di posta elettronica nell'elenco di completamento automatico da un computer a altro. Ad esempio, se si esegue l'aggiornamento a un nuovo computer e non si desidera annullare tutte le informazioni archiviate nell'elenco di completamento automatico, è possibile copiare i nomi e indirizzi di posta elettronica dal vecchio al nuovo computer.

Importante: È necessario uscire Microsoft Outlook prima di iniziare la procedura seguente. I nomi verranno inclusi nell'elenco di completamento automatico quando si riavvia Outlook.

Copiare il file di completamento automatico dal vecchio computer

  1. Nel vecchio computer, passare a unità: \user\AppData\Local\Microsoft\Outlook.

    Nota: A seconda delle impostazioni di file, questa cartella potrebbe essere nascosta.

  2. Pulsante destro del mouse name.nk2 profilo e quindi fare clic su Copia.

    Suggerimento: È possibile copiare il file su supporti rimovibili, ad esempio memory stick USB media e quindi copiare il file nel percorso corretto nel nuovo computer. Oppure è possibile allegare il file a un messaggio di posta elettronica e inviare il messaggio a se stessi. Nel nuovo computer, aprire l'allegato in Outlook e quindi salvarlo nel percorso corretto.

  3. Nel computer in cui si desidera inserire l'elenco di completamento automatico, fare clic nell'unità: \user\AppData\Local\Microsoft\Outlook e quindi fare clic su Incolla per salvare name.nk2 profilo.

  4. Se il nome del profilo utente Outlook è diverso nel computer in cui si sposti file nk2, è necessario rinominare il file con il nome del profilo utente di Outlook in uso nel nuovo computer dopo aver copiato i file nella cartella corretta. Ad esempio, se si sposta Kim Akers.nk2 dal computer originale con un nome profilo utente di Outlook di Kim Akers e copiare il file Kim Akers.nk2 nel nuovo computer, è necessario rinominare il file con il nome del profilo Outlook utilizzato nel nuovo computer.

  5. Quando viene richiesto di sostituire il file esistente, fare clic su .

  6. Aprire Outlook per visualizzare le modifiche apportate all'elenco di completamento automatico.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×