Funzione VALORECAMPO

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

È possibile usare la funzione VALORECAMPO per recuperare i dati del campo dai tipi di dati collegati, come Azioni o Geografia. Sono disponibili metodi più semplici per scrivere formule che fanno riferimento ai tipi di dati, quindi la funzione VALORECAMPO deve essere usata principalmente per la creazione di calcoli condizionali basati sui tipi di dati collegati.

Nota: 12 giugno 2018: Questa funzione è una caratteristica beta e disponibile solo per una parte di Office gli utenti interni al momento. Si continuerà ad ottimizzare questa funzionalità nei mesi successivi. Quando è pronto, sarà disponibile per tutti gli utenti interni Office e gli abbonati a Office 365.

Dettagli tecnici

Sintassi

=VALORECAMPO(valore, nome_campo)

Gli argomenti della sintassi della funzione VALORECAMPO sono i seguenti:

  • valore: l'indirizzo della cella, la colonna della tabella o l'intervallo denominato che contiene un tipo di dati collegato. 

  • nome_campo: il nome o i nomi dei campi da estrarre dal tipo di dati collegati

Descrizione

  • La funzione VALORECAMPO restituisce tutti i campi corrispondenti dal tipo di dati collegato specificato nell'argomento valore.

  • La funzione VALORECAMPO appartiene alla famiglia di funzioni Ricerca e riferimento.

Esempi

Nell'esempio di base seguente la formula =VALORECAMPO(A2,"Prezzo") estrae il campo Prezzo dal tipo di dati Azioni per JM Smucker Co

Recuperare un prezzo delle azioni aziendali con =VALORECAMPO(A2,"Prezzo") .

L'esempio seguente è un esempio tipico della funzione VALORECAMPO. Qui la funzione SE.ERRORE viene usata per controllare gli errori. Se non c'è il nome di una società nella cella A2, la formula VALORECAMPO restituisce un errore. In questo caso non vogliamo visualizzare niente (""). Se invece questo nome esiste, vogliamo recuperare il prezzo dal tipo di dati nella cella A2 con =SE.ERRORE(VALORECAMPO($A2,B$1),"").

Recuperare un prezzo delle azioni aziendali e ignorare gli errori con =SE.ERRORE(VALORECAMPO($A2,B$1),"")

La funzione VALORECAMPO consente di fare riferimento a celle del foglio di lavoro per l'argomento nome_campo, quindi la formula precedente fa riferimento alla cella B1 per il prezzo invece di richiedere l'immissione manuale di "Prezzo" nella formula. 

Osservazioni

Se si prova a recuperare i dati da un campo del tipo di dati inesistente, la funzione VALORECAMPO restituisce l'errore #CAMPO!. Ad esempio, potrebbe essere stato immesso "Prezzi" al posto del nome effettivo del tipo di dati, ovvero "Prezzo". Verificare la formula per verificare che il nome campo sia valido. Per visualizzare un elenco di nomi campo per un record, selezionare la cella per il record e premere CTRL+MAIUSC+F2.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Vedere anche

Tipi di dati Azioni e Geografia

Come scrivere formule con riferimento ai tipi di dati

Errore #CAMPO!

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×